#opnfv-functest: Functest weekly meeting August 16th

Meeting started by morgan_orange at 08:00:12 UTC (full logs).

Meeting summary

  1. call roll (morgan_orange, 08:00:16)
    1. Morgan (morgan_orange, 08:00:19)
    2. Viktor Tikkanen (viktor_t, 08:00:26)
    3. Juha Kosonen (juhak, 08:00:42)
    4. Luke Hinds (lhinds, 08:00:48)

  2. Action point follow-up (morgan_orange, 08:01:01)
    1. AP morgan_orange check with Domino project: sync done, tests run but skipped on joid (domaino waiting method to get IP) (morgan_orange, 08:01:09)
    2. AP morgan_orange reference this page from Brahamaputra page only: done (morgan_orange, 08:01:15)
    3. AP morgan_orange for Coloradao put the URl to swagger: done (morgan_orange, 08:01:31)
    4. AP morgan_orange contact bryan_att to sync on this issue: done copper ok on joid still issue on apex - JIRA updated (morgan_orange, 08:01:37)
    5. AP all formalize the condition for tempest smoke suite case exclusion (may initiate a wiki page for that) - not done but question valid as several scenarios no fully OK and exlusion list for onos submitted as a patch (morgan_orange, 08:01:47)
    6. ACTION: morgan_orange viktor_t create a wiki page to explain how to justify case exclusion for Tempest (morgan_orange, 08:02:12)
    7. AP morgan_orange ask for x2 on storage capability for the testresult VM: done (morgan_orange, 08:02:20)
    8. AP morgan_orange see if we should buy (OPNFV has money..) an elasticsearch licence: done elascrtic search cloud licence to be purchased (morgan_orange, 08:02:26)
    9. AP morgan_orange contact onos-sfc to discuss this option: mail sent, no feedback received yet (morgan_orange, 08:02:33)
    10. AP SerenaFeng contact Doctor team to support integration: done tests run manually, troubleshooting in progress on doctor side (morgan_orange, 08:02:40)
    11. AP CG_Nokia organize webex to discuss remaining topic on documentation: done (morgan_orange, 08:02:47)
    12. AP morgan_orange contact releng team to see if we could have weekly run on Sunday to give a chance to vIMS, Tempest full and Rally full: done but no chance due to resource management, long duration tests can be run on Community labs (morgan_orange, 08:03:00)
    13. AP morgan_orange initiate mail for bitergia related to test results: ne feedback in the elasticsearch thread (morgan_orange, 08:03:07)
    14. AP morgan_orange invite hongbo to present Dovetail update to Functest team: will be done during the test weekly meeting (morgan_orange, 08:03:17)
    15. CG_Nokia (CG_Nokia, 08:03:23)
    16. AP all brainstorm on intern proposals: I sent some proposals mail to CENGN => dedicated topic after (morgan_orange, 08:03:43)
    17. Jun Li (MatthewLi, 08:03:44)
    18. Juha Haapavirta (JuhaHaapa, 08:03:47)

  3. Feature projects integration status (morgan_orange, 08:04:39)
    1. integration of feature projects on track (morgan_orange, 08:04:52)
    2. new scenario with moon, multisites, (morgan_orange, 08:05:06)
    3. parser added also to testcases.yaml (morgan_orange, 08:05:14)
    4. http://testresults.opnfv.org/reporting/functest/release/master/index-status-joid.html (morgan_orange, 08:05:29)
    5. scenarios still seen as red/failed in reporting page because criteria are strict (internal + feature) and must be Ok at least 4 times in a raw (morgan_orange, 08:10:10)
    6. we got end of last week our first blue balls in Jenkins (morgan_orange, 08:10:23)
    7. some scenarios should be green before the end of the week (morgan_orange, 08:10:41)
    8. note that feature projects are also part of the scenario score, so if a feature project is part of all scenarios for an installer, it may prevent the scenario to be green (morgan_orange, 08:11:17)
    9. it is possible to exclude feature projects from score calculation (morgan_orange, 08:11:33)
    10. Documentation for colorado (morgan_orange, 08:15:19)
    11. user guide review in progress (wait for Cedric final review on ODL section) (morgan_orange, 08:15:43)
    12. merge will be done afterwards, and feature projects will be contacted to provide the URL of their own user guide as reference (morgan_orange, 08:16:07)
    13. ACTION: morgan_orange merge userguide patch + call feature proejct to complete user guide with their own reference (morgan_orange, 08:16:27)
    14. config guide in progress (morgan_orange, 08:16:35)
    15. config guide shall be ready this week (morgan_orange, 08:17:30)
    16. ACTION: all review config guide (morgan_orange, 08:19:28)
    17. https://gerrit.opnfv.org/gerrit/#/c/18479/ (morgan_orange, 08:19:39)
    18. release note to be initiated thsi week to start capturing the status of the scenarios (morgan_orange, 08:20:08)
    19. patch in progros to exclude Tempest cases from onos scenario (morgan_orange, 08:20:52)
    20. https://gerrit.opnfv.org/gerrit/#/c/18645/ (morgan_orange, 08:20:56)
    21. issue could be the non support of medata service (to be confirmed) (morgan_orange, 08:22:30)
    22. documentation user/config/dev guide target => end of this week, release note for the release date 2 days (morgan_orange, 08:23:21)
    23. Colorado scenarios (morgan_orange, 08:23:32)
    24. first scenarios Ok with compass, fuel and joid (morgan_orange, 08:23:50)
    25. some issues with some feature projects + some tempest/rally issues on some scenarios (morgan_orange, 08:24:20)
    26. globla improvement regarding Tempest (untill last week there were no 0 error, it is no more the case now) (morgan_orange, 08:24:44)
    27. but still some with heat on rally (morgan_orange, 08:26:17)
    28. improvement on apex (due to patch after great analysis doe by michael) but still issue on rally (heat) (morgan_orange, 08:28:16)
    29. ACTION: morgan_orange see why json rally result files are not pushed anymore to artifact (morgan_orange, 08:29:07)
    30. ACTION: juhak see json locally on lf-pod1 to troubleshoot rally issue with apex scenario (morgan_orange, 08:29:34)
    31. regarding dashboard, LF foundation accepted to purcharsed an elastic search licence. I think it is a cloud licence, so the Data will be pushed from test results to this cloud (morgan_orange, 08:30:50)
    32. ACTION: morgan_orange SerenaFeng sync with Juraj and peopel dealing with ElasticSearch licence (morgan_orange, 08:33:13)
    33. first lxd and multisite tests run (new scenario) (morgan_orange, 08:34:00)
    34. multisite OK (morgan_orange, 08:34:16)
    35. https://build.opnfv.org/ci/view/functest/job/functest-fuel-virtual-suite-master/lastSuccessfulBuild/console (morgan_orange, 08:34:18)
    36. https://git.opnfv.org/cgit/functest/tree/testcases/features/doctor.py (morgan_orange, 08:35:55)
    37. ACTION: SerenaFeng morgan_orange add report flag to avoid meaningless results or 500 because source is not referenced (morgan_orange, 08:39:33)
    38. https://build.opnfv.org/ci/view/functest/job/functest-fuel-baremetal-daily-master/343/console (SerenaFeng, 08:40:25)
    39. ACTION: create rules for D release to decide to which category a case belong to (morgan_orange, 08:45:25)

  4. Date for Functest Branching Colorado (morgan_orange, 08:48:58)
    1. Functest will branch/tag Colorado on the 19th 13UTC (morgan_orange, 08:54:17)

  5. Security (morgan_orange, 08:55:05)
    1. main issues fixed, JIRA will be updated (morgan_orange, 08:56:45)
    2. Security repo will be used (instead of sub dire in Functest) (morgan_orange, 08:57:01)
    3. ACTION: lhinds modify exec_test to point to security repo (morgan_orange, 08:57:14)
    4. ACTION: morgan_orange re-enable security_scan when ready (morgan_orange, 08:58:11)
    5. security scean on apex for Colorado, other installer for D release (morgan_orange, 08:59:07)
    6. check artifact management to be sure that security reporting pages are propelery pushed to artifact (morgan_orange, 08:59:27)

  6. intern project proposals (morgan_orange, 08:59:51)
    1. https://wiki.opnfv.org/display/DEV/Intern-projects-page (morgan_orange, 09:00:09)
    2. proposals made by mail (morgan_orange, 09:00:16)
    3. mainly new simple VNF test cases (can reused the onos list of elementary VNF for inspiration) (morgan_orange, 09:00:45)

  7. Resources for Plugfest/Meetup (morgan_orange, 09:01:49)
    1. search functest rrepresentative for plugfest (registration already open, especially for company aiming to send hardware) (morgan_orange, 09:03:59)
    2. for the next meetup, my suggestion will be to do it either in barcelona (during the OpenStack summit) or in France (beginning of October) (morgan_orange, 09:04:37)

  8. AoB (morgan_orange, 09:06:26)


Meeting ended at 09:07:39 UTC (full logs).

Action items

  1. morgan_orange viktor_t create a wiki page to explain how to justify case exclusion for Tempest
  2. morgan_orange merge userguide patch + call feature proejct to complete user guide with their own reference
  3. all review config guide
  4. morgan_orange see why json rally result files are not pushed anymore to artifact
  5. juhak see json locally on lf-pod1 to troubleshoot rally issue with apex scenario
  6. morgan_orange SerenaFeng sync with Juraj and peopel dealing with ElasticSearch licence
  7. SerenaFeng morgan_orange add report flag to avoid meaningless results or 500 because source is not referenced
  8. create rules for D release to decide to which category a case belong to
  9. lhinds modify exec_test to point to security repo
  10. morgan_orange re-enable security_scan when ready


Action items, by person

  1. juhak
    1. juhak see json locally on lf-pod1 to troubleshoot rally issue with apex scenario
  2. lhinds
    1. lhinds modify exec_test to point to security repo
  3. morgan_orange
    1. morgan_orange viktor_t create a wiki page to explain how to justify case exclusion for Tempest
    2. morgan_orange merge userguide patch + call feature proejct to complete user guide with their own reference
    3. morgan_orange see why json rally result files are not pushed anymore to artifact
    4. morgan_orange SerenaFeng sync with Juraj and peopel dealing with ElasticSearch licence
    5. SerenaFeng morgan_orange add report flag to avoid meaningless results or 500 because source is not referenced
    6. morgan_orange re-enable security_scan when ready
  4. SerenaFeng
    1. morgan_orange SerenaFeng sync with Juraj and peopel dealing with ElasticSearch licence
    2. SerenaFeng morgan_orange add report flag to avoid meaningless results or 500 because source is not referenced
  5. viktor_t
    1. morgan_orange viktor_t create a wiki page to explain how to justify case exclusion for Tempest
  6. UNASSIGNED
    1. all review config guide
    2. create rules for D release to decide to which category a case belong to


People present (lines said)

  1. morgan_orange (167)
  2. SerenaFeng (27)
  3. lhinds (15)
  4. juhak (8)
  5. May-meimei (7)
  6. JuhaHaapa (5)
  7. viktor_t (5)
  8. collabot (4)
  9. fdegir (3)
  10. MatthewLi (1)
  11. CG_Nokia (1)


Generated by MeetBot 0.1.4.