#opnfv-functest: Functest weekly meeting october 10th

Meeting started by morgan_orange at 08:01:05 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 08:01:09)
    1. Morgan Richomme (morgan_orange, 08:01:14)
    2. Helen Yao (HelenYao, 08:01:23)
    3. Juha Kosonen (juhak, 08:01:24)
    4. Jose Lausuch (jose_lausuch, 08:01:35)
    5. agenda for Today: https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange, 08:02:02)
    6. SerenaFeng (SerenaFeng, 08:02:05)
    7. hideyasu_ool (hideyasu_ool, 08:02:21)
    8. meimei (May-meimei, 08:02:22)

  2. action point follow-up (morgan_orange, 08:03:22)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-functest/2016/opnfv-functest.2016-10-04-07.59.html (morgan_orange, 08:03:35)
    2. AP1: jose_lausuch morgan_orange plan finalization of Colorado postmortem during OpenStack Summit (morgan_orange, 08:03:50)
    3. no update, meeting planed during the OpenStack Summit Wednesday 9-12h (morgan_orange, 08:03:58)
    4. ACTION: jose_lausuch morgan_orange plan finalization of Colorado postmortem during OpenStack Summit (morgan_orange, 08:04:04)
    5. ACTION: AP2: morgan_orange jose_lausuch initiate presentation with proposals for the - and -- alreday referenced (morgan_orange, 08:04:10)
    6. see AP1... (morgan_orange, 08:04:15)
    7. ACTION: morgan_orange jose_lausuch initiate presentation with proposals for the - and -- already referenced (morgan_orange, 08:04:25)
    8. AP3: morgan_orange refactor Danube page to reflect the introduction of a scenario table in the API (morgan_orange, 08:04:32)
    9. done (morgan_orange, 08:04:38)
    10. https://wiki.opnfv.org/display/functest/Functest+Danube (morgan_orange, 08:04:43)
    11. AP4: morgan_orange ask feature projects already integrated in Functest for feedback on a possible evolution considering Feature project as an object (morgan_orange, 08:04:51)
    12. mail sent, no feedback received so far (morgan_orange, 08:04:56)
    13. AP5: all review CI evolution (morgan_orange, 08:05:03)
    14. we will see in the next section (morgan_orange, 08:05:09)

  3. PTL election (morgan_orange, 08:06:12)
    1. let's formalize the vote for our new PTL (morgan_orange, 08:06:25)
    2. I received mandate from Zhanghaoyu, lixiaoguang, Lanqinglong and Valentin (morgan_orange, 08:07:32)
    3. VOTE: Voted on ": Vote for Jose as PTL?" Results are, Yes: 5 (morgan_orange, 08:10:22)
    4. ACTION: morgan_orange modify Info in repo + inform TSC (morgan_orange, 08:11:01)

  4. Colorado post mortem (morgan_orange, 08:12:52)
    1. still time to report your concerns/criticisms/remarks...as said in action points, Jose and myself will plan some formal presentation to tackle the - and -- points (morgan_orange, 08:13:30)
    2. https://etherpad.opnfv.org/p/Colorado-Testing-postmortem (morgan_orange, 08:13:41)

  5. CI Evolution / adaptation in Functest (morgan_orange, 08:14:27)
    1. https://wiki.opnfv.org/display/INF/CI+Evolution (morgan_orange, 08:15:11)
    2. discussion on unit testing (morgan_orange, 08:17:57)
    3. in Danube Functest unit tests must be run on each commit to stabilize Functest code (morgan_orange, 08:18:11)
    4. new dev must be provided with associated unit tests (morgan_orange, 08:18:28)
    5. ACTION: morgan_orange see how to trigger unit testing on commit on master (morgan_orange, 08:21:52)
    6. morgan_orange suggests a new mechanism for test and scenario promotion in line with CI evolution (morgan_orange, 08:36:29)
    7. changes to be planned - reallocation trustIndicator + new APi methods on scenario (morgan_orange, 08:36:49)
    8. ACTION: SerenaFeng jose_lausuch review proposal (morgan_orange, 08:36:57)

  6. evolution of docker (morgan_orange, 08:37:53)
    1. our docker is becoming fat (morgan_orange, 08:39:14)
    2. we need to create several dockers not just one (e.g. vIMS, feature,..) (morgan_orange, 08:39:39)
    3. discussion 1 docker per feature versus 1 docker for all feature tests (morgan_orange, 08:40:44)
    4. question on the scalability and the maintenance/versioning of all the docker if we go for 1 docker / feature tests (morgan_orange, 08:41:17)
    5. https://git.opnfv.org/cgit/functest/tree/ci/testcases.yaml (jose_lausuch, 08:41:19)
    6. currently 11 feature projects declared in Functest config (morgan_orange, 08:41:57)
    7. and it may only grow... (morgan_orange, 08:42:13)
    8. ACTION: jose_lausuch identify which packages are instaleed in the docker build process and for what reason (jose_lausuch, 08:43:39)
    9. ACTION: HelenYao SerenaFeng jose_lausuch study impact on a massive dockerization of feature (morgan_orange, 08:44:00)
    10. ACTION: morgan_orange create a JIRA_epic on docker topic (morgan_orange, 08:44:29)

  7. Global class (morgan_orange, 08:44:36)
    1. https://gerrit.opnfv.org/gerrit/#/c/22921/6 (morgan_orange, 08:45:01)
    2. https://jira.opnfv.org/browse/FUNCTEST-353 (morgan_orange, 08:45:30)
    3. everybody seems happy to create some organization into the chaos of featur test integration (morgan_orange, 08:47:51)

  8. internship (morgan_orange, 08:50:57)
    1. https://wiki.opnfv.org/display/DEV/Intern-projects-page (morgan_orange, 08:51:38)
    2. 2 candidates for https://wiki.opnfv.org/display/DEV/Intern+Project%3A+Functest+unit+tests (morgan_orange, 08:52:11)

  9. AoB (morgan_orange, 08:55:43)
    1. Barcelona Functest meeting planned on Wednesday 9-13h (morgan_orange, 08:56:16)
    2. disucssion on adapater done in releng (morgan_orange, 08:56:47)
    3. https://gerrit.opnfv.org/gerrit/#/c/22599/ (morgan_orange, 08:56:49)
    4. Installer Adapters is a library to get information about the deployment and get the ips of the nodes, ssh, scp, etc https://gerrit.opnfv.org/gerrit/#/c/22599/ (jose_lausuch, 08:57:02)
    5. ACTION: morgan_orange ask for functest gerrit alias (morgan_orange, 08:58:59)
    6. https://wiki.opnfv.org/display/DEV/Contribution+Guidelines (morgan_orange, 08:59:33)
    7. ACTION: morgan_orange check copyright stuff with Ray (morgan_orange, 09:05:29)
    8. ACTION: jose_lausuch: ollivier morgan_orange SerenaFeng final decision on patch https://gerrit.opnfv.org/gerrit/#/c/22487/ (morgan_orange, 09:09:20)


Meeting ended at 09:12:49 UTC (full logs).

Action items

  1. jose_lausuch morgan_orange plan finalization of Colorado postmortem during OpenStack Summit
  2. AP2: morgan_orange jose_lausuch initiate presentation with proposals for the - and -- alreday referenced
  3. morgan_orange jose_lausuch initiate presentation with proposals for the - and -- already referenced
  4. morgan_orange modify Info in repo + inform TSC
  5. morgan_orange see how to trigger unit testing on commit on master
  6. SerenaFeng jose_lausuch review proposal
  7. jose_lausuch identify which packages are instaleed in the docker build process and for what reason
  8. HelenYao SerenaFeng jose_lausuch study impact on a massive dockerization of feature
  9. morgan_orange create a JIRA_epic on docker topic
  10. morgan_orange ask for functest gerrit alias
  11. morgan_orange check copyright stuff with Ray
  12. jose_lausuch: ollivier morgan_orange SerenaFeng final decision on patch https://gerrit.opnfv.org/gerrit/#/c/22487/


Action items, by person

  1. HelenYao
    1. HelenYao SerenaFeng jose_lausuch study impact on a massive dockerization of feature
  2. jose_lausuch
    1. jose_lausuch morgan_orange plan finalization of Colorado postmortem during OpenStack Summit
    2. AP2: morgan_orange jose_lausuch initiate presentation with proposals for the - and -- alreday referenced
    3. morgan_orange jose_lausuch initiate presentation with proposals for the - and -- already referenced
    4. SerenaFeng jose_lausuch review proposal
    5. jose_lausuch identify which packages are instaleed in the docker build process and for what reason
    6. HelenYao SerenaFeng jose_lausuch study impact on a massive dockerization of feature
    7. jose_lausuch: ollivier morgan_orange SerenaFeng final decision on patch https://gerrit.opnfv.org/gerrit/#/c/22487/
  3. morgan_orange
    1. jose_lausuch morgan_orange plan finalization of Colorado postmortem during OpenStack Summit
    2. AP2: morgan_orange jose_lausuch initiate presentation with proposals for the - and -- alreday referenced
    3. morgan_orange jose_lausuch initiate presentation with proposals for the - and -- already referenced
    4. morgan_orange modify Info in repo + inform TSC
    5. morgan_orange see how to trigger unit testing on commit on master
    6. morgan_orange create a JIRA_epic on docker topic
    7. morgan_orange ask for functest gerrit alias
    8. morgan_orange check copyright stuff with Ray
    9. jose_lausuch: ollivier morgan_orange SerenaFeng final decision on patch https://gerrit.opnfv.org/gerrit/#/c/22487/
  4. ollivier
    1. jose_lausuch: ollivier morgan_orange SerenaFeng final decision on patch https://gerrit.opnfv.org/gerrit/#/c/22487/
  5. SerenaFeng
    1. SerenaFeng jose_lausuch review proposal
    2. HelenYao SerenaFeng jose_lausuch study impact on a massive dockerization of feature
    3. jose_lausuch: ollivier morgan_orange SerenaFeng final decision on patch https://gerrit.opnfv.org/gerrit/#/c/22487/


People present (lines said)

  1. morgan_orange (187)
  2. jose_lausuch (122)
  3. ollivier (30)
  4. SerenaFeng (28)
  5. HelenYao (16)
  6. collabot (10)
  7. juhak (4)
  8. May-meimei (4)
  9. hideyasu_ool (2)
  10. leo_wang (1)
  11. viktor_t (1)


Generated by MeetBot 0.1.4.