08:00:53 <jose_lausuch> #startmeeting Functest weekly meeting october 18th
08:00:53 <collabot`> Meeting started Tue Oct 18 08:00:53 2016 UTC.  The chair is jose_lausuch. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:53 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:53 <collabot`> The meeting name has been set to 'functest_weekly_meeting_october_18th'
08:01:11 <jose_lausuch> #topic role call
08:01:17 <CristinaPauna> #info Cristina Pauna (ENEA)
08:01:22 <lhinds> #info Luke Hinds
08:01:25 <juhak> #info Juha Kosonen
08:01:27 <morgan_orange> #info Morgan Richomme
08:01:27 <hideyasu> #info Hideyasu_ool
08:01:34 <SerenaFeng> #info SerenaFeng
08:01:50 <HelenYao> #info HelenYao
08:02:36 <jose_lausuch> #info agenda for today here: https://wiki.opnfv.org/display/functest/Functest+Meeting#FunctestMeeting-18/10(8UTC)
08:02:46 <jose_lausuch> #info previous minutes: http://ircbot.wl.linuxfoundation.org/meetings/opnfv-functest/2016/opnfv-functest.2016-10-11-08.01.html
08:02:52 <jose_lausuch> #info Jose Lausuch
08:03:15 <jose_lausuch> #topic Action point follow-up
08:03:33 <jose_lausuch> #info initiate presentation with proposals for the - and -- alreday referenced. Not ready yet.
08:03:52 <jose_lausuch> morgan_orange: we still need to work onthat
08:03:57 <jose_lausuch> we have this week left :)
08:04:15 <morgan_orange> jose_lausuch: yep, I will initiate something this afternoon and tomorrow
08:04:16 <jose_lausuch> #action: morgan_orange jose_lausuch initiate presentation with proposals for the - and -- alreday referenced
08:04:25 <jose_lausuch> let's sync on that
08:04:49 <jose_lausuch> #info morgan_orange modify Info in repo + inform TSC. Done.
08:04:55 <jose_lausuch> right?
08:04:58 <morgan_orange> yes
08:05:11 <jose_lausuch> #info morgan_orange see how to trigger unit testing on commit on master
08:05:14 <jose_lausuch> status?
08:05:28 <morgan_orange> #info I think we can use storperf as best practice
08:05:37 <morgan_orange> #link https://build.opnfv.org/ci/view/storperf/job/storperf-verify-master/81/testReport/
08:06:01 <morgan_orange> #info creation of a dedicated tests dir submitted: https://gerrit.opnfv.org/gerrit/#/c/23233/
08:06:06 <jose_lausuch> ok, that sounds and looks good
08:06:19 <morgan_orange> #info with an illustration with unit test for CLI (I let utilities for the internship)
08:06:35 <morgan_orange> #info I will submit a patch in releng to follow stroperf view to trigger unittests
08:06:39 <jose_lausuch> I'll have a look later
08:06:44 <jose_lausuch> ok
08:07:05 <jose_lausuch> #info SerenaFeng jose_lausuch review proposal from morgan_orange.
08:07:15 <jose_lausuch> well, everyone is welcome to review it
08:07:23 <jose_lausuch> I already sent comments
08:07:42 <jose_lausuch> it was a nice reading yesterday evening during a flight :)
08:07:50 <SerenaFeng> https://gerrit.opnfv.org/gerrit/#/c/23233/ this submit?
08:08:29 <jose_lausuch> #info I sent some comments to the email thread but I agree on the idea exposed in the presentation
08:08:40 <jose_lausuch> SerenaFeng: needs merge
08:08:40 <morgan_orange> i think it was the ppt proposal on impact on CI evolution on tests
08:08:47 <jose_lausuch> yes
08:08:58 <jose_lausuch> you huge slides :)
08:09:07 <SerenaFeng> Ok, please give me a link?
08:09:12 <jose_lausuch> it took a while to get all the small boxes
08:09:22 <jose_lausuch> SerenaFeng: it was sent by email last week
08:09:34 <SerenaFeng> ok, maybe I ignore it
08:09:35 <morgan_orange> SerenaFeng: I put it on the wiki and give you the link
08:09:45 <SerenaFeng> I will find and review it
08:10:22 <jose_lausuch> #action SerenaFeng and others review CI proposal from Morgan
08:10:38 <jose_lausuch> #info jose_lausuch identify which packages are installed in the docker build process and for what reason. Done. https://wiki.opnfv.org/display/functest/Docker+images+slicing
08:10:40 <morgan_orange> jose_lausuch: just saw your feedback, i will have a look
08:10:58 <jose_lausuch> morgan_orange: ok, not much, I agree with everything
08:11:11 <jose_lausuch> #info HelenYao SerenaFeng jose_lausuch study impact on a massive dockerization of feature.
08:11:22 <jose_lausuch> #info Ongoing. Some important impacts detected. https://wiki.opnfv.org/display/functest/Docker+images+slicing
08:11:33 <jose_lausuch> we will have a section later to discuss a bit
08:11:55 <jose_lausuch> #info morgan_orange create a JIRA_epic on docker topic
08:11:57 <jose_lausuch> ?
08:12:32 <jose_lausuch> morgan_orange: I think it is created,right?
08:12:46 <morgan_orange> jose_lausuch: yes
08:12:47 <HelenYao> morgan_orange: I looked at your slide and the whole process seems great. it may need to collabrate closely with docker slicing to make each other aligned
08:13:08 <jose_lausuch> #info Done https://jira.opnfv.org/browse/FUNCTEST-509
08:13:40 <jose_lausuch> HelenYao: sure, it has to be correlated
08:14:00 <jose_lausuch> HelenYao: feel free to provide you comments in the email thread
08:14:10 <morgan_orange> SerenaFeng: https://wiki.opnfv.org/display/testing/Testing+Danube+discussions
08:14:13 <HelenYao> jose_lausuch: sure
08:14:13 <jose_lausuch> we will discuss it again next week I guess
08:14:29 <jose_lausuch> #info morgan_orange ask for functest gerrit alias. Done. We have alias for contributors and commiters
08:14:32 <morgan_orange> I think I will move from the ppt to the wiki after barcelona
08:15:02 <jose_lausuch> https://gerrit.opnfv.org/gerrit/#/groups/self
08:15:16 <jose_lausuch> oops someone deleted the functest-contributors group!
08:16:03 <jose_lausuch> I'll create later again
08:16:12 <HelenYao> the group is there
08:16:18 <HelenYao> i can see my name in the group
08:16:20 <jose_lausuch> sorry
08:16:23 <jose_lausuch> #link https://gerrit.opnfv.org/gerrit/#/admin/groups/
08:16:30 <jose_lausuch> it is not there
08:16:55 <jose_lausuch> do you see it?
08:17:05 <HelenYao> yes
08:17:12 <HelenYao> CLA Accepted - Individual
08:17:12 <HelenYao> functest-contributors
08:17:15 <jose_lausuch> ah ok, I know what happens
08:17:27 <HelenYao> functest-contributors  is not visible to all
08:17:32 <jose_lausuch> I removed myself from the group and I can't longer seee it
08:17:34 <jose_lausuch> haha
08:17:39 <HelenYao> oops
08:17:44 <jose_lausuch> can you add me? do you have rights?
08:17:50 <HelenYao> let me try
08:18:03 <HelenYao> done
08:18:08 <jose_lausuch> thanks
08:18:16 <morgan_orange> same for me, I can see functest-committers but not contributors
08:18:21 <jose_lausuch> I'll include the commiters also to that group
08:18:21 <SerenaFeng> only the people in the group can see it?
08:18:26 <jose_lausuch> yes
08:18:27 <SerenaFeng> me too
08:18:50 <jose_lausuch> morgan_orange: you should be able to see it
08:18:52 <SerenaFeng> only in functest-committers group
08:19:00 <HelenYao> there is only five people in the contributors group
08:19:08 <jose_lausuch> ok
08:19:15 <jose_lausuch> I'll do  it later
08:19:16 <morgan_orange> back
08:19:16 <jose_lausuch> #info morgan_orange check copyright stuff with Ray.
08:19:22 <HelenYao> Colum Gaynor
08:19:22 <HelenYao> colum.gaynor@nokia.com
08:19:22 <HelenYao> David Blaisonneau
08:19:22 <HelenYao> david.blaisonneau@orange.com
08:19:22 <HelenYao> Helen Yao
08:19:22 <HelenYao> yaohelan@huawei.com
08:19:22 <HelenYao> Jose Lausuch
08:19:23 <HelenYao> jose.lausuch@ericsson.com
08:19:23 <HelenYao> Juha Haapavirta
08:19:24 <HelenYao> juha.haapavirta@nokia.com
08:19:28 <HelenYao> the whole list
08:20:04 <morgan_orange> ok let's fix it offline, we have more people..
08:20:20 <jose_lausuch> #info I checked with Ray and we should include the license header in all the files
08:20:34 <morgan_orange> #info disucssion in progress between Ray and Cedric
08:20:58 <jose_lausuch> #info jose_lausuch: ollivier morgan_orange SerenaFeng final decision on patch https://gerrit.opnfv.org/gerrit/#/c/22487/
08:21:26 <jose_lausuch> I would like to merge today all pending patches
08:21:33 <jose_lausuch> we have too many dependencies alreaduy
08:22:01 <jose_lausuch> can we discuss later about this patch as well?
08:22:27 <jose_lausuch> let;s move to the first topic, its getting late :)
08:22:33 <jose_lausuch> a lot of actions
08:22:34 <SerenaFeng> ok
08:22:36 <jose_lausuch> #topic JIRA best practices
08:22:38 <SerenaFeng> discuss it later
08:22:57 <jose_lausuch> I'd like to share my view about JIRA and gerrit management
08:23:06 <jose_lausuch> #info Recommendation is to create an EPIC for a bug story or activity and create tasks within that epic.
08:23:29 <jose_lausuch> #info The tasks must be broken down so that it doesn't require a tremendous amount of work. Something that be achieved in a couple of days.
08:23:46 <jose_lausuch> #info a JIRA Task does not correspond to 1 commit. 1 task can be completed with 1 or more commits. The idea is not to create JIRA tasks for small changes.
08:24:14 <jose_lausuch> #info If sometimes, the change is obvious, it might not include a JIRA reference at all. It is not a mandatory, just optional.
08:24:34 <jose_lausuch> #info However, for important changes, we must have JIRA epic/tasks created for it.
08:24:45 <jose_lausuch> Do you agree? Shall we vote on this?
08:24:49 <SerenaFeng> agree
08:24:54 <HelenYao> I came across a page about JIRA mgmt which is quite useful and it was created by jose_lausuch this Apr.
08:25:04 <jose_lausuch> yes
08:25:06 <HelenYao> https://wiki.opnfv.org/display/functest/JIRA+management
08:25:28 <HelenYao> i agree on the new points here
08:25:36 <jose_lausuch> #info https://wiki.opnfv.org/display/functest/JIRA+management
08:25:42 <HelenYao> we many consolidate all into the page
08:25:46 <HelenYao> many = may
08:25:49 <jose_lausuch> #action jose_lausuch include new points in that wiki
08:25:59 <morgan_orange> #agreed
08:26:03 <hideyasu> agree
08:26:09 <SerenaFeng> we can create some usual epic for usual tasks
08:26:20 <SerenaFeng> such as a code refactor epic
08:26:37 <HelenYao> will we go thru all the epics of D release sometime?
08:26:37 <SerenaFeng> or else theses have no epic to relate to
08:26:41 <jose_lausuch> but a code refactor could be related to anything
08:26:55 <jose_lausuch> HelenYao: after Barcelona
08:27:03 <jose_lausuch> once we have all clear
08:27:20 <HelenYao> sounds good
08:27:21 <jose_lausuch> we also need to know available resources, people , ...
08:27:44 <SerenaFeng> anyway we are refactoring the framework, let's see after that
08:27:49 <jose_lausuch> SerenaFeng: if its a test api refactor, we could have an epic for it
08:27:55 <jose_lausuch> ya
08:28:04 <jose_lausuch> maybe, we should have framework refactor
08:28:14 <jose_lausuch> I'll think about it
08:28:17 <SerenaFeng> I think we have one
08:28:26 <jose_lausuch> but we should have everything clear after barcelona
08:28:26 <morgan_orange> yes..
08:28:28 <HelenYao> one small point to add about task, the description should be of enough information so that the one w/o background info can understand the task
08:28:36 <jose_lausuch> who is gonna work on what
08:28:44 <SerenaFeng> https://jira.opnfv.org/browse/FUNCTEST-332
08:29:02 <jose_lausuch> SerenaFeng: yes, thanks
08:29:14 <SerenaFeng> I think this one is used to the framework refactor
08:29:21 <jose_lausuch> HelenYao: yes, description is important
08:29:21 <SerenaFeng> we just need to rename it
08:29:35 <morgan_orange> After Barcelona, we should be able to allocate people to tasks and start the sprints...
08:29:52 <morgan_orange> and see what we will be able to achieve and what will be for E, F, ..
08:30:09 <jose_lausuch> we also have interns :)
08:30:10 <morgan_orange> need to plan a JIRA funny session
08:30:24 <morgan_orange> aka as "triage"
08:30:33 <jose_lausuch> yes
08:30:51 <jose_lausuch> it sounds more "release management"
08:30:59 <jose_lausuch> ok, next topic
08:31:08 <jose_lausuch> #info Testcase class refactoring
08:31:32 <morgan_orange> #link https://gerrit.opnfv.org/gerrit/#/c/22921/
08:31:39 <jose_lausuch> cedric is not here.... mmmm
08:31:47 <jose_lausuch> shall we postpone this?
08:31:59 <morgan_orange> #info with illustration on odl test
08:32:05 <jose_lausuch> #info Cedric proposed a way to converge all the test cases created in functest.
08:32:18 <jose_lausuch> #info this will help consolidating the framework being more robust and structured.
08:32:26 <morgan_orange> I think we just need to agree and maybe start allocating adaptation for the existing cases
08:32:38 <jose_lausuch> I'd like to have a short discussion about if we change the current test cases to adopt this
08:32:39 <jose_lausuch> yes
08:32:51 <jose_lausuch> #info all the new test cases should be implemented the same way
08:32:52 <morgan_orange> #info refactoring is usefull to manage feature project in a consistent way by imposing methods
08:32:59 <jose_lausuch> its a good exercise
08:33:20 <morgan_orange> yes
08:33:39 <jose_lausuch> would it make sense for example to adapt vping ort tempest to this classes?
08:33:43 <morgan_orange> and fortunately the number of cases is finite..
08:34:06 <morgan_orange> I think so, I do not think it is so difficult
08:34:18 <jose_lausuch> ok
08:34:38 <morgan_orange> and it is easier to do it now than later...
08:34:45 <HelenYao> yeah, agreed
08:34:48 <jose_lausuch> also the feature test cases (promise, doctor, ..)
08:34:55 <jose_lausuch> SerenaFeng: ?
08:35:01 <SerenaFeng> agreed
08:35:03 <jose_lausuch> you refactored vping
08:35:06 <SerenaFeng> ok
08:35:07 <morgan_orange> will be hard for me before Barcelona, but you can action me for some cases
08:35:11 <jose_lausuch> new refactor :)
08:35:22 <morgan_orange> there is no rush, we can do it progressively
08:35:27 <SerenaFeng> refactor it before Barcelona?
08:35:29 <jose_lausuch> morgan_orange: no need to have it before barcelona
08:35:30 <morgan_orange> but for any new case, we should do it
08:35:36 <morgan_orange> vRouter for example is a good example :)
08:35:44 <morgan_orange> of vEPC
08:35:50 <HelenYao> i'd like to be part of refactoring
08:35:59 <jose_lausuch> #info agree on refactor the existing test cases to thenew Testcase class
08:36:05 <morgan_orange> moreover this refactoring is a good way to jump into the project
08:36:15 <jose_lausuch> HelenYao: ok, thanks
08:36:44 <jose_lausuch> yes
08:36:53 <jose_lausuch> its a bit of work, but not complex
08:37:02 <jose_lausuch> ok, good
08:37:16 <SerenaFeng> Yes
08:37:17 <jose_lausuch> we will distribute the tasks sonn
08:37:20 <jose_lausuch> #topic Colorado 2.0: what do we have to do (release notes, doc, ...)
08:37:24 <jose_lausuch> soon*
08:37:31 <jose_lausuch> morgan_orange ?
08:37:42 <jose_lausuch> I think we need to update the release notes and let render the documentation for C2.0
08:37:45 <morgan_orange> I should admit I did not attend the release meeting recently...
08:37:54 <morgan_orange> I do not think we have new features
08:37:59 <morgan_orange> but the scenarios changes a little bit
08:38:04 <morgan_orange> scores changes
08:38:07 <jose_lausuch> yes
08:38:08 <morgan_orange> and onos is back in Apex
08:38:31 <morgan_orange> so as far as I can see, only work => new release note
08:38:34 <jose_lausuch> we need to update the release notes before the release
08:38:34 <morgan_orange> other docs OK
08:38:42 <jose_lausuch> and have a snapshot of the scoring
08:38:48 <morgan_orange> we may check also the JIRA related to Colorado 1
08:39:27 <jose_lausuch> #action morgan_orange jose_lausuch review scenario changes for the release notes, and check jira
08:39:54 <morgan_orange> #info release date Colroado 2.0:  doc and test complete 24/10
08:39:56 <jose_lausuch> #action jose_lausuch tag stable branch next week
08:40:06 <morgan_orange> #info release date COlorado 2.0: 27/10
08:40:11 <morgan_orange> we will be in barcelona...
08:40:16 <jose_lausuch> yes
08:40:27 <jose_lausuch> maybe we can spend 10 minutes on that
08:40:50 <morgan_orange> looks like evening tasks....not sure we could visit the Sagrada Familia
08:41:01 <morgan_orange> let's say 1h...
08:41:05 <jose_lausuch> :)
08:41:06 <jose_lausuch> ok
08:41:14 <jose_lausuch> I visited it last year
08:41:22 <morgan_orange> I do not think there are new features
08:41:26 <HelenYao> a side question, when will u arrive in Barcelona
08:41:27 <jose_lausuch> nope
08:41:28 <morgan_orange> just new scenarios
08:41:35 <morgan_orange> Monday evening for me
08:41:42 <jose_lausuch> ok, let's jump 1 topic
08:41:43 <jose_lausuch> #topic OpenStack summit
08:41:50 <morgan_orange> good transition
08:41:50 <jose_lausuch> who will be there?
08:41:59 <SerenaFeng> +1
08:42:01 <morgan_orange> +1
08:42:02 <HelenYao> +1
08:42:06 <juhak> +1
08:42:07 <morgan_orange> Cedric +1
08:42:10 <morgan_orange> David +1
08:42:13 <HelenYao> I will be there on Oct.23
08:42:19 <morgan_orange> Valentin still do not know
08:42:29 <HelenYao> Sagrada Familia is my target visit
08:42:31 <jose_lausuch> #info people in Barcelona: SerenaFeng morgan_orange HelenYao juhak Cedric David jose_lausuch (Valentin)
08:42:47 <jose_lausuch> when is planned our meetup?
08:42:57 <morgan_orange> HelenYao: if you have time do not miss other Gaudi building
08:43:01 <jose_lausuch> morgan_orange:  can you link the wiki?
08:43:24 <HelenYao> morgan_orange: i did a rough search, Gaudi is everywhere in Barcelona
08:43:25 <jose_lausuch> you should visit the gothic block
08:43:45 <morgan_orange> #link https://wiki.opnfv.org/display/EVNT/OPNFV+at+OpenStack-Barcelona
08:43:53 <jose_lausuch> and the Born area
08:44:01 <morgan_orange> #info Functest Meetup planned on Wednesday morning 9-13h
08:44:01 <HelenYao> jose_lausuch: u may drop us a tour guide for reference :)
08:44:15 <jose_lausuch> HelenYao: maybe, but we might get lost :p
08:44:26 <jose_lausuch> I've been there only twice
08:44:48 <HelenYao> better than me. i've been there 0
08:44:59 <jose_lausuch> #info Functest meeting planned for Wednesday 26th , 9:00-13:00
08:45:14 <morgan_orange> HelenYao: if you have time to prepare your travel, you may watch https://en.wikipedia.org/wiki/L%27Auberge_Espagnole, it happens in Barcelona and it is funny ..
08:45:28 <jose_lausuch> nice movie :)
08:45:40 <HelenYao> morgan_orange: i will check it out, thx
08:46:21 <jose_lausuch> #info discussion with Bitergia about testing dashboard on Thursday at 14:00-1:00
08:46:37 <morgan_orange> we may plan a Functest social within one of the several OpenStack socials....
08:46:45 <jose_lausuch> yes
08:46:57 <morgan_orange> #undo
08:47:04 <jose_lausuch> ok, let's move on
08:47:07 <morgan_orange> #info  discussion with Bitergia about testing dashboard on Thursday at 14:00-16:00
08:47:17 <jose_lausuch> oops sorry :)
08:47:19 <jose_lausuch> thanks
08:47:22 <jose_lausuch> #topic Docker discussion
08:47:28 <morgan_orange> the idea of the meetup is to have a good view for task allocation
08:47:33 <jose_lausuch> yes
08:47:43 <jose_lausuch> I hope its enough time...
08:47:43 <morgan_orange> and be reasonable on what we can achieve..
08:47:52 <jose_lausuch> release is in march
08:47:57 <morgan_orange> it is on Wednesday, I leave on Friday afternoon
08:48:09 <morgan_orange> we may have additional slots if needed
08:48:12 <jose_lausuch> I leve thursday evening
08:48:21 <jose_lausuch> leave*
08:48:25 <jose_lausuch> #info Proposal for slicing our docker image: https://wiki.opnfv.org/display/functest/Docker+images+slicing
08:48:26 <HelenYao> I leave on Sat.
08:48:28 <SerenaFeng> I leave on Sunday evening
08:48:37 <jose_lausuch> #info the idea is to have 1 image for Functest core testcases, 1 for feature feature, 1 for sdn controllers, 1 per each vnf (vIMS, vRouter, ...)
08:48:47 <jose_lausuch> #info in the comments section there are already some proposals about how to orchestrate all the containers from a central one
08:48:56 <jose_lausuch> #info However, this change increases the complexity of the Docker containers management in CI ==> is it worth it?
08:49:09 <morgan_orange> do we need 1 for sdn, are they not part of the core?
08:49:11 <jose_lausuch> SerenaFeng:  HelenYao I tested yesterday the docker api
08:49:15 <morgan_orange> 1 for features and 1 per vnf
08:49:28 <jose_lausuch> well
08:49:31 <morgan_orange> the multiplication of dockers will lead to complexity
08:49:38 <jose_lausuch> we could consider sdn core yes
08:49:43 <morgan_orange> the idea is "just" to keep the size under control, no?
08:49:43 <jose_lausuch> I dont mind
08:49:49 <jose_lausuch> yes
08:49:58 <morgan_orange> in the CI evolution, I suggets to merged smoke and sdn
08:50:06 <morgan_orange> sdn tests take 5 minutes
08:50:11 <jose_lausuch> HelenYao proposed initially 1 image / feature test
08:50:14 <morgan_orange> and are part of the core tests for a scenario
08:50:43 <morgan_orange> it depends of the feature but sometimes it is a bit overkill
08:50:47 <jose_lausuch> shall we start with minimum?
08:50:53 <morgan_orange> it depends if we want to have a systematicall approach
08:51:09 <HelenYao> there is one benefit about 1 image/feature, we can monitor the code change of the feature and rebuild the image accordingly
08:51:12 <SerenaFeng> I think we can merge sdn to core, since there's no much extra sdn to be added now
08:51:34 <SerenaFeng> still keep one image for all features
08:51:37 <jose_lausuch> 1 core(functest+odl), 1(feature tests), 1(vims), 1(vnfX),..
08:51:38 <morgan_orange> sometimes some features are very light...
08:51:55 <SerenaFeng> jose_lausuch agree
08:52:06 <morgan_orange> jose_lausuch: agree too (at least in first steps)
08:52:14 <SerenaFeng> sdn is not only odl, onos as well right?
08:52:18 <jose_lausuch> yes
08:52:23 <SerenaFeng> ok, agree
08:52:25 <morgan_orange> sdn = odl, onos
08:52:34 <jose_lausuch> #info agreed 1 core(functest+odl), 1(feature tests), 1(vims), 1(vnfX),..
08:52:52 <jose_lausuch> #undo
08:52:52 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2cdeb90>
08:52:54 <HelenYao> agreed
08:52:58 <morgan_orange> #agreed
08:53:05 <jose_lausuch> #info agreed 1 core(functest+sdn), 1(feature tests), 1(vims), 1(vnfX),..
08:53:23 <jose_lausuch> about the api
08:53:39 <jose_lausuch> we need to do a small change on all CI pods
08:53:52 <jose_lausuch> its easy, but someone has to do it
08:54:10 <jose_lausuch> someone with the CI keys to all pods...
08:54:16 <jose_lausuch> or each lab owner...
08:54:37 <jose_lausuch> we need to put a requirement in pharos
08:54:53 <SerenaFeng> can we we provide the script, let the lab owner do it for us?
08:54:56 <jose_lausuch> it also increases a bit the complexity for the end users
08:55:02 <jose_lausuch> yes
08:55:14 <HelenYao> we can put the script into the code
08:55:14 <jose_lausuch> but the way you described is not for all OS'
08:55:28 <HelenYao> i have been thinking about the script
08:55:28 <jose_lausuch> we need to investigate at least ubuntu/redhat
08:55:40 <SerenaFeng> and centos?
08:55:41 <jose_lausuch> and need sudo rights
08:55:47 <SerenaFeng> yes
08:55:51 <jose_lausuch> which we normally have
08:55:59 <jose_lausuch> centos should be the same as redhat
08:56:05 <HelenYao> I can work out the script for centos/ubuntu/redhat
08:56:33 <jose_lausuch> #action HelenYao prepare script to update jumphost with the needed docker daemon flags
08:56:36 <HelenYao> is there any other os that needs to be supported?
08:56:36 <jose_lausuch> thanks
08:56:46 <jose_lausuch> for now that should be fine
08:56:57 <jose_lausuch> I can test it on LF labs
08:57:03 <jose_lausuch> and some ericsson labs
08:57:13 <jose_lausuch> ok, running out of time
08:57:21 <jose_lausuch> #topic Internships
08:57:27 <jose_lausuch> #info we performed a first interview and have another one this week.
08:57:32 <HelenYao> jose_lausuch: good. I will contact u once it is ready
08:57:38 <jose_lausuch> HelenYao: ok
08:57:42 <jose_lausuch> 3 possible candidates for intern projects in Functest.
08:57:50 <jose_lausuch> It seems our topics are attractive :)
08:58:17 <SerenaFeng> yes
08:58:31 <jose_lausuch> #info Added a new internship projet to implement security groups https://wiki.opnfv.org/display/DEV/Intern-projects-page
08:58:32 <morgan_orange> and it seems that it is internship time in India :)
08:58:56 <jose_lausuch> we have an interview this week as well
08:59:19 <jose_lausuch> #topic AoB
08:59:20 <HelenYao> all the candidates are in India?
08:59:30 <jose_lausuch> HelenYao: for now yes \
08:59:52 <HelenYao> is there any plan for enforcing python style?
08:59:53 <jose_lausuch> thats why its internship time there it seems
08:59:54 <jose_lausuch> :)
09:00:04 <HelenYao> other projects are leveraging flake8
09:00:06 <SerenaFeng> I'd like to change the name of result_collection_api to testapi, is that ok?
09:00:07 <jose_lausuch> enforcing python style?
09:00:16 <SerenaFeng> since we always use testapi now
09:00:25 <morgan_orange> SerenaFeng: yes
09:00:28 <jose_lausuch> SerenaFeng: no objections from my side
09:00:37 <HelenYao> i ran flake8 against functest and all passed which shows we have good coding habit
09:00:45 <jose_lausuch> yes
09:00:57 <jose_lausuch> we have a gerrit gate in Functest for flake8
09:01:07 <jose_lausuch> not in all opnfv repos
09:01:14 <jose_lausuch> but  we requested it
09:01:16 <HelenYao> where is the gate?
09:01:27 <jose_lausuch> triggered in Jenkins
09:01:34 <HelenYao> i did a search in the functest code and did not see any flake8 check
09:01:35 <jose_lausuch> for each commit
09:01:44 <jose_lausuch> its a CI thing
09:01:51 <jose_lausuch> common for all opnfv repos
09:02:03 <HelenYao> see. i will check it out
09:02:43 <jose_lausuch> ok
09:02:58 <jose_lausuch> HelenYao: look here https://gerrit.opnfv.org/gerrit/#/c/23225/
09:03:18 <jose_lausuch> jenkins gives -1 if flake8 gate is not passed
09:03:19 <jose_lausuch> ok
09:03:20 <morgan_orange> https://git.opnfv.org/cgit/releng/tree/jjb/releng-macros.yaml
09:03:27 <jose_lausuch> thanks everyone
09:03:32 <morgan_orange> thanks jose_lausuch
09:03:40 <jose_lausuch> have a nice week
09:03:42 <HelenYao> thx jose_lausuch
09:03:43 <morgan_orange> HelenYao:  what do you see for additional rules?
09:03:45 <jose_lausuch> #endmeeting