#opnfv-functest: Functest weekly meeting November 7th 2016

Meeting started by jose_lausuch at 08:01:42 UTC (full logs).

Meeting summary

  1. role call (jose_lausuch, 08:01:50)
    1. Jose Lausuch (jose_lausuch, 08:02:24)
    2. Helen Yao (HelenYao, 08:02:41)
    3. Morgan Richomme (morgan_orange, 08:02:45)
    4. Bertrand Souville (bertys__, 08:02:57)
    5. Juha Kosonen (juhak, 08:03:10)
    6. agenda for today here: https://wiki.opnfv.org/display/functest/Functest+Meeting#FunctestMeeting-08/11(8UTC) (jose_lausuch, 08:03:13)
    7. previous minutes: http://ircbot.wl.linuxfoundation.org/meetings/opnfv-functest/2016/opnfv-functest.2016-10-18-08.00.html (jose_lausuch, 08:03:19)

  2. OpenStack summit recap (jose_lausuch, 08:04:57)
    1. we had productive meeting during the summit where many contributors from Functest were present (jose_lausuch, 08:05:08)
    2. participants: Morgan, Cedric, Juha K., Serena, Helen, Steve and myself (jose_lausuch, 08:05:23)
    3. SerenaFeng (SerenaFeng, 08:05:34)
    4. presentation that I used to follow the agenda points https://docs.google.com/presentation/d/15SzJ4NmhrxoVx5LfZ4hPYsDifKoNCLmVA7-oK4abyzw/edit?usp=sharing (jose_lausuch, 08:05:39)
    5. rohitsakala (rohitsakala, 08:05:43)
    6. we covered the main topics that we want to work for Danube: Framework refactor, CI evolution, Docker slicing and integration of SNAPS (which can be renamed). We missed some other smaller tasks, but they are for sure as important as these. (jose_lausuch, 08:06:08)
    7. there was another important session with Bitergia (Jesus) about integration of our results in their Dashboard. (jose_lausuch, 08:06:25)
    8. sync with bitergia, we showed what we did so far (morgan_orange, 08:07:21)
    9. we described our different data sets (functest, yardstick) (morgan_orange, 08:07:36)
    10. bitergia proposed several scenarios to help us (morgan_orange, 08:07:49)
    11. initiated a discussion at TSC on priority for Danube (jose_lausuch, 08:10:18)

  3. Internships announcements (jose_lausuch, 08:11:32)
    1. we will have for sure 3 interns in Functest for Danube release. 1 is still pending. (jose_lausuch, 08:11:53)
    2. paper work is still ongoing, but they will be able to start soon. (jose_lausuch, 08:12:08)
    3. Ashish Kumar will work on Unit tests with Helen as mentor (jose_lausuch, 08:12:43)
    4. https://wiki.opnfv.org/display/DEV/Intern+Project%3A+Functest+unit+tests (jose_lausuch, 08:12:51)
    5. Rohit Sakala will work on the test api project with Serena as mentor (jose_lausuch, 08:13:04)
    6. https://wiki.opnfv.org/display/DEV/Intern+Project%3A+testapi+evolution (jose_lausuch, 08:13:20)
    7. Girish Sukhatankar will work on the security groups test case mentored by David (jose_lausuch, 08:13:55)
    8. https://wiki.opnfv.org/display/DEV/Intern+Project%3A+Security+groups+test+case+in+Functest (jose_lausuch, 08:14:01)
    9. ACTION: Jose: clean up and make clearer our JIRA backlog, and send an email to all. Postpone topic for next week (jose_lausuch, 08:20:10)
    10. 3rd intern is on security group / Mentor: David_Orange (morgan_orange, 08:21:10)

  4. libraries and dependencies installed in Functest image (jose_lausuch, 08:22:08)
    1. We are having problems in CI due to failed Docker builds (jose_lausuch, 08:22:32)
    2. I have detected the problem and created this JIRA to keep the track (jose_lausuch, 08:22:40)
    3. things like pip install requirements try to install the same python modules but with different versions, specially the openstack clients (jose_lausuch, 08:22:48)
    4. this causes a loss of control over what we are installing (jose_lausuch, 08:23:04)
    5. for example, the problem of the image build in CI is kingbird requirements "RUN cd ${repos_dir}/kingbird && pip install -e ." (jose_lausuch, 08:23:13)
    6. we MUST be aware of what we install in the image. (jose_lausuch, 08:23:20)
    7. we should install the openstack clients that belong to the same openstack release, and not use random versions without any special reason. (jose_lausuch, 08:23:37)
    8. my proposal: centralize all the requirements installed by any project to a central requirements file and remove all the others (this will also save some lines in the Dockerfile) (jose_lausuch, 08:23:54)
    9. ACTION: HelenYao check what are the versions of the OS python clients related to a stable version of OS (starting with Mitaka) (jose_lausuch, 08:27:53)
    10. ACTION: HelenYao detect with lines in the Dockerfile are altering the OS python clients (i.e. tempest, rally, kingbird, ) (jose_lausuch, 08:29:23)

  5. Docker follow-up discussion and possible decision (jose_lausuch, 08:35:33)
    1. I created this patch to show how we could slice the image in the different categories https://gerrit.opnfv.org/gerrit/#/c/23729/ (jose_lausuch, 08:35:53)
    2. https://wiki.opnfv.org/display/functest/Docker+images+slicing (jose_lausuch, 08:36:56)
    3. https://thepasteb.in/p/Q1hBnqPB4RjS8 (HelenYao, 08:37:40)
    4. ACTION: morgan_orange contact valentin regarding hardcoded ruby version that triggers warning (morgan_orange, 08:39:00)
    5. ACTION: HelenYao SerenaFeng morgan_orange and all check docker slicing proposal and provide comments (jose_lausuch, 08:42:15)
    6. ACTION: jose_lausuch complete the slide with the "+" and the "-" about the docker slicing impacts (jose_lausuch, 08:43:44)

  6. Unit tests (repo structure/logger issues) (jose_lausuch, 08:47:11)
    1. introduction of unit tests done in CI (morgan_orange, 08:47:32)
    2. https://build.opnfv.org/ci/view/functest/job/functest-verify-master/ (morgan_orange, 08:47:52)
    3. only ODL test today but system working locally and in Jenkins including coverage (morgan_orange, 08:48:12)
    4. however coverage is limited to the first tests we have (we clearly should extend) and I had to twist the config to make it work (morgan_orange, 08:48:42)
    5. 2 main issues (morgan_orange, 08:48:46)
    6. only applied for master branch (jose_lausuch, 08:49:03)
    7. 1 the repo structure: all our code is at the root level => issue with modules (morgan_orange, 08:49:09)
    8. we need to create a functest subdirectory in our repo to be sure that we will always have the same structure (morgan_orange, 08:49:35)
    9. 2 in some of our util class, we use the logger that logs in harcoded file (morgan_orange, 08:50:28)
    10. decission on creating functest root dir and move all the tests and tools inside (jose_lausuch, 08:54:54)
    11. https://github.com/openstack/rally (jose_lausuch, 09:00:30)
    12. https://github.com/openstack/rally/tree/master/tests (jose_lausuch, 09:00:44)
    13. https://github.com/openstack/tempest (morgan_orange, 09:01:11)
    14. https://github.com/openstack/tempest/tree/master/tempest (morgan_orange, 09:01:47)
    15. agree to rename testcases (jose_lausuch, 09:03:49)
    16. ACTION: morgan_orange propose a patch with the new dir structure as initiated by email 1) Create /functest 2) create /functest/tests/unit (jose_lausuch, 09:05:57)
    17. ACTION: jose_lausuch follow up discussion on dir structure and naming (jose_lausuch, 09:10:59)
    18. ACTION: jose_lausuch move bitergia discussion for next weekly (jose_lausuch, 09:13:29)


Meeting ended at 09:13:33 UTC (full logs).

Action items

  1. Jose: clean up and make clearer our JIRA backlog, and send an email to all. Postpone topic for next week
  2. HelenYao check what are the versions of the OS python clients related to a stable version of OS (starting with Mitaka)
  3. HelenYao detect with lines in the Dockerfile are altering the OS python clients (i.e. tempest, rally, kingbird, )
  4. morgan_orange contact valentin regarding hardcoded ruby version that triggers warning
  5. HelenYao SerenaFeng morgan_orange and all check docker slicing proposal and provide comments
  6. jose_lausuch complete the slide with the "+" and the "-" about the docker slicing impacts
  7. morgan_orange propose a patch with the new dir structure as initiated by email 1) Create /functest 2) create /functest/tests/unit
  8. jose_lausuch follow up discussion on dir structure and naming
  9. jose_lausuch move bitergia discussion for next weekly


Action items, by person

  1. HelenYao
    1. HelenYao check what are the versions of the OS python clients related to a stable version of OS (starting with Mitaka)
    2. HelenYao detect with lines in the Dockerfile are altering the OS python clients (i.e. tempest, rally, kingbird, )
    3. HelenYao SerenaFeng morgan_orange and all check docker slicing proposal and provide comments
  2. jose_lausuch
    1. jose_lausuch complete the slide with the "+" and the "-" about the docker slicing impacts
    2. jose_lausuch follow up discussion on dir structure and naming
    3. jose_lausuch move bitergia discussion for next weekly
  3. morgan_orange
    1. morgan_orange contact valentin regarding hardcoded ruby version that triggers warning
    2. HelenYao SerenaFeng morgan_orange and all check docker slicing proposal and provide comments
    3. morgan_orange propose a patch with the new dir structure as initiated by email 1) Create /functest 2) create /functest/tests/unit
  4. SerenaFeng
    1. HelenYao SerenaFeng morgan_orange and all check docker slicing proposal and provide comments


People present (lines said)

  1. jose_lausuch (191)
  2. morgan_orange (82)
  3. HelenYao (49)
  4. SerenaFeng (28)
  5. ollivier (5)
  6. collabot` (5)
  7. rohitsakala (4)
  8. bertys__ (4)
  9. juhak (2)
  10. OPNFV-Gerrit-Bot (2)
  11. pma (1)
  12. David_Orange (1)


Generated by MeetBot 0.1.4.