#opnfv-functest: Functest weekly meeting November 29th

Meeting started by jose_lausuch at 08:02:26 UTC (full logs).

Meeting summary

    1. agenda for today here: https://wiki.opnfv.org/display/functest/Functest+Meeting#FunctestMeeting-29/11(8UTC) (jose_lausuch, 08:02:50)
    2. previous minutes: http://ircbot.wl.linuxfoundation.org/meetings/opnfv-functest/2016/opnfv-functest.2016-11-22-08.00.html (jose_lausuch, 08:02:50)

  1. role call (jose_lausuch, 08:02:56)
    1. Morgan Richomme (morgan_orange, 08:03:35)
    2. rohitsakala (rohitsakala, 08:03:40)
    3. Helen Yao (HelenYao, 08:03:40)
    4. SerenaFeng (SerenaFeng, 08:03:42)

  2. Action point follow-up (jose_lausuch, 08:04:52)
    1. AP: HelenYao jose_lausuch SerenaFeng check if things could work with docker compose (jose_lausuch, 08:04:57)
    2. not done, considering postponing it to E-river if no further solutions found soon. (jose_lausuch, 08:06:19)
    3. AP: HelenYao jose_lausuch continue Alpine study (jose_lausuch, 08:06:25)
    4. ACTION: HelenYao jose_lausuch continue investigation in Alpine (jose_lausuch, 08:07:54)
    5. AP: submit a patch with a new directory "openstack" functest/utils/openstack/ to put all the new utils. DONE (jose_lausuch, 08:08:09)
    6. AP: all review vping refactor and merge https://gerrit.opnfv.org/gerrit/#/c/24541/ . DONE (jose_lausuch, 08:08:20)
    7. AP: fix Domino test case in CI (jose_lausuch, 08:08:27)
    8. done (morgan_orange, 08:08:39)

  3. Feature project integration requests (Milestone2) (jose_lausuch, 08:09:00)
    1. Request from new feature projects: NetReady, Opera, Orchestra, Movie, Scalator, Ipv6, Barometer (jose_lausuch, 08:11:16)
    2. NetReady: a simple ping test case using Gluon API (jose_lausuch, 08:11:23)
    3. Opera: Clarwater vIMS deployment using Open-O instead of Cloudify (jose_lausuch, 08:11:32)
    4. Orchestra: not much info about the test plans. (jose_lausuch, 08:11:48)
    5. ACTION: morgan_orange create VNF onboarding abstraction class (jose_lausuch, 08:12:17)
    6. Escalator: test case for installer Daisy4NFV (jose_lausuch, 08:12:26)
    7. IPv6: Run entire functest suite but making use of the IPv6 endpoints. Maybe nothing extra to do here. Scenarios that will implement IPv6: apex/os-nosdn-nofeature-ha/noha, apex/os-odl_l2-nofeature-ha/noha (jose_lausuch, 08:12:43)
    8. Barometer: test collecting information from the compute nodes to validate the metrics/timestamps generated by Ceilometer. Supported scenarios: fuel/os-nosdn-kvm_ovs-ha/noha, fuel/os-nosdn-kvm_ovs_dpdk-ha/noha (jose_lausuch, 08:13:27)
    9. Existing feature projects that will add new tests: SFC, SDNVPN (jose_lausuch, 08:13:44)
    10. OAI test case + security group tests (internship) - (but considered as internal Functest case) (morgan_orange, 08:15:13)
    11. + healthcheck SNAPS (morgan_orange, 08:15:51)

  4. Framework re-factor status (jose_lausuch, 08:16:29)
    1. Discussion ongoing about what the tests should return (0 or !0) when the test fails. (jose_lausuch, 08:16:43)
    2. AGREED: (HelenYao, 08:29:20)
    3. ACTION: morgan_orange see with releng if we can customize the jenkins color to distinguish an error due to execution framework from an error due to the tests (morgan_orange, 08:29:23)
    4. AGREED: (morgan_orange, 08:29:36)
    5. Agreement on pushing results to DB when the execution is ok (test can FAIL/PASS) but not pushing when there is an execution error (jose_lausuch, 08:29:43)
    6. AGREED: (SerenaFeng, 08:30:00)
    7. Agreement on removing SKIP state (morgan_orange, 08:30:16)
    8. Agreement on exclude SKIP state (affeected scripts: domino, sdnvpn) (jose_lausuch, 08:30:21)
    9. Question: should the tests return 0 if the code execution is correct but the test failed? (jose_lausuch, 08:31:43)
    10. https://wiki.opnfv.org/download/attachments/8685677/sfc-example.JPG?version=3&modificationDate=1479914953000&api=v2 (jose_lausuch, 08:45:26)
    11. ACTION: Cedric, propose a patch for TestCaseBase (jose_lausuch, 08:48:39)

  5. Unified way to provide constants and env variables (jose_lausuch, 08:49:06)
    1. https://git.opnfv.org/releng/tree/modules/opnfv/utils/constants.py (morgan_orange, 08:51:41)
    2. idea about seperating things like node_name with things in config_functest.yaml (jose_lausuch, 08:53:36)
    3. differenciate between configuration parameteres and environment variables (jose_lausuch, 08:54:20)
    4. ACTION: SerenaFeng propose a patch about this topic (jose_lausuch, 08:57:20)

  6. Update Swagger framework + associated documentation using swagger2markup (jose_lausuch, 08:57:38)
    1. https://docs.google.com/document/d/1jWwVZ1ZpKgKcOS_zSz2KzX1nwg4BXxzBxcwkesl7krw/edit?usp=sharing (rohitsakala, 08:58:29)
    2. https://docs.google.com/document/d/1jWwVZ1ZpKgKcOS_zSz2KzX1nwg4BXxzBxcwkesl7krw/edit?usp=sharing (jose_lausuch, 08:58:47)
    3. http://swagger2markup.github.io/spring-swagger2markup-demo/1.1.0/ (jose_lausuch, 09:00:35)
    4. no need to upgrade swagger-ui for now, as we are using v1.2 and there're tools that support it (jose_lausuch, 09:01:52)
    5. https://usercontent.irccloud-cdn.com/file/WBMjul3s/script.sh (SerenaFeng, 09:04:20)
    6. proposal to use swagger-codegen (jose_lausuch, 09:05:04)
    7. AGREED: use of swagger-codegen (morgan_orange, 09:06:11)
    8. ACTION: morgan_orange grant access to rohitsakala to testresults.opnfv.org (morgan_orange, 09:12:59)

  7. PlugFest§Hackfest (morgan_orange, 09:14:11)
    1. Jose will attend... (morgan_orange, 09:14:18)
    2. Juha and Jose will attend the event (jose_lausuch, 09:14:18)
    3. We will prepare a Functest demo. (jose_lausuch, 09:14:33)
    4. need support to set up a Database to store local results and possible Dashboard (jose_lausuch, 09:15:00)
    5. https://wiki.opnfv.org/display/EVNT/Co-located+Plugfest-Hackfest+Planning+Page (jose_lausuch, 09:15:10)
    6. Test Community Common Goals and Priorities by Trevor and me (jose_lausuch, 09:15:35)
    7. Functest versus Dovetail (morgan_orange, 09:16:19)
    8. Trevor Initiated some etherpads:https://etherpad.opnfv.org/p/yardstickcvp, https://etherpad.opnfv.org/p/vsperfcvp (morgan_orange, 09:16:33)

  8. AoB (morgan_orange, 09:17:27)
    1. work on landing page + data model to be initiated next week (with jack and Rex) (morgan_orange, 09:17:54)
    2. I proposed https://gerrit.opnfv.org/gerrit/#/c/25059/ about newton support, your feedback is appreciated (HelenYao, 09:18:33)


Meeting ended at 09:20:51 UTC (full logs).

Action items

  1. HelenYao jose_lausuch continue investigation in Alpine
  2. morgan_orange create VNF onboarding abstraction class
  3. morgan_orange see with releng if we can customize the jenkins color to distinguish an error due to execution framework from an error due to the tests
  4. Cedric, propose a patch for TestCaseBase
  5. SerenaFeng propose a patch about this topic
  6. morgan_orange grant access to rohitsakala to testresults.opnfv.org


Action items, by person

  1. HelenYao
    1. HelenYao jose_lausuch continue investigation in Alpine
  2. jose_lausuch
    1. HelenYao jose_lausuch continue investigation in Alpine
  3. morgan_orange
    1. morgan_orange create VNF onboarding abstraction class
    2. morgan_orange see with releng if we can customize the jenkins color to distinguish an error due to execution framework from an error due to the tests
    3. morgan_orange grant access to rohitsakala to testresults.opnfv.org
  4. rohitsakala
    1. morgan_orange grant access to rohitsakala to testresults.opnfv.org
  5. SerenaFeng
    1. SerenaFeng propose a patch about this topic


People present (lines said)

  1. jose_lausuch (167)
  2. morgan_orange (93)
  3. SerenaFeng (61)
  4. HelenYao (34)
  5. rohitsakala (20)
  6. collabot` (6)
  7. OPNFV-Gerrit-Bot (3)


Generated by MeetBot 0.1.4.