08:00:22 <jose_lausuch> #startmeeting Functest weekly meeting January 17th 2017
08:00:22 <collabot> Meeting started Tue Jan 17 08:00:22 2017 UTC.  The chair is jose_lausuch. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:22 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:22 <collabot> The meeting name has been set to 'functest_weekly_meeting_january_17th_2017'
08:00:32 <jose_lausuch> Good morning/afternoon
08:00:53 <jose_lausuch> #topic role call
08:00:59 <jose_lausuch> #info Jose Lausuch
08:01:17 <jose_lausuch> #chair morgan_orange
08:01:17 <collabot> Current chairs: jose_lausuch morgan_orange
08:01:19 <HelenYao> #info Helen Yao
08:01:29 <LindaWang> #info Linda Wang
08:01:44 <juhak> #info Juha Kosonen
08:01:50 <jvidal> #info Juan Vidal
08:02:07 <morgan_orange> #info Morgan Richomme
08:02:30 <rohitsakala> #info rohitsakala
08:03:07 <jose_lausuch> #topic Troubleshooting status
08:03:13 <jose_lausuch> let´s go installer by installer
08:03:19 <jose_lausuch> #info APEX
08:03:24 <jose_lausuch> #info Apex jobs: https://build.opnfv.org/ci/job/apex-daily-master/
08:03:31 <jose_lausuch> #info Deployments seem stable (blue)
08:03:47 <jose_lausuch> #info healthcheck, vPing, rally_smoke, connection_check and api_check are 100% ok.
08:03:58 <jose_lausuch> #info 1 error in Tempest. Copper and Doctor fail.
08:04:07 <jose_lausuch> I talked to Tim Rozet
08:04:13 <jose_lausuch> and there was a problem with the ODL port
08:04:30 <jose_lausuch> and he proposed this patch https://gerrit.opnfv.org/gerrit/#/c/26983/
08:05:24 <morgan_orange> APEX runs = only nosdn-nofeature and odl_l3
08:05:28 <jose_lausuch> anything you want to add about apex?
08:05:33 <jose_lausuch> yep
08:05:46 <morgan_orange> odl tests are OK in odl scenarios
08:05:52 <morgan_orange> what is the problem with odl port?
08:06:02 <jose_lausuch> I think they changed it
08:06:06 <jose_lausuch> so now its 8081
08:06:06 <morgan_orange> ok
08:06:09 <jose_lausuch> not 8181
08:06:16 <jose_lausuch> robot tests were failing
08:06:45 <morgan_orange> as far as I remember Cedric discussed this config issue long time ago
08:06:54 <morgan_orange> an installer is using an env variable
08:07:04 <jose_lausuch> for the ip
08:07:05 <morgan_orange> for others it is default port
08:07:08 <morgan_orange> but ok
08:07:09 <jose_lausuch> the ports are hardcoded
08:07:37 <morgan_orange> not always..depends of the installers...
08:07:51 <morgan_orange> good point for genesis...
08:08:18 <morgan_orange> I see 9 failures in Tempest
08:08:25 <morgan_orange> on odl_l3 scenario
08:09:14 <morgan_orange> do we know the openstack version used by apex
08:09:15 <jose_lausuch> https://git.opnfv.org/functest/tree/functest/opnfv_tests/sdn/odl/odl.py#n150
08:09:15 <jose_lausuch> fuel also uses another port
08:09:15 <jose_lausuch> which is fine
08:09:15 <jose_lausuch> no one is obliged to use a default port
08:09:15 <jose_lausuch> but maybe we could put it in a conf file or something
08:09:15 <jose_lausuch> not in the code
08:09:16 <jose_lausuch> ok
08:09:23 <jose_lausuch> ah really?
08:09:24 <jose_lausuch> ok
08:09:31 <jose_lausuch> I saw yesterday 1 failure in nosdn
08:09:32 <jose_lausuch> ok
08:09:47 <jose_lausuch> #info 9 tempest failures in odl_l3 scenario
08:10:05 <jose_lausuch> i think odl_l3 scenarios have been quite unstable during colorado as well
08:10:22 <morgan_orange> for odl if the env variables are properly set os.environ['SDN_CONTROLLER_IP'] os.environ['SDN_CONTROLLER'] it is fine...
08:10:41 <jose_lausuch> yep
08:10:48 <morgan_orange> arg no ok odlwebport is hardcoded
08:10:49 <HelenYao> I only see only failure for tempest for odl_l3 https://build.opnfv.org/ci/job/functest-apex-apex-daily-master-daily-master/371/console
08:11:02 <HelenYao> tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.test_network_basic_ops [202.057694s] ... FAILED
08:11:09 <jose_lausuch> right
08:11:13 <morgan_orange> ok I had a look at https://build.opnfv.org/ci/job/functest-apex-apex-daily-master-daily-master/369
08:11:15 <jose_lausuch> where did you see 9 morgan_orange_
08:11:15 <jose_lausuch> ?
08:11:28 <morgan_orange> maybe the odl fix...
08:11:43 <jose_lausuch> could be
08:12:00 <morgan_orange> so 1 error to investigate on tempest
08:12:04 <morgan_orange> + errors on feature projects
08:12:14 <jose_lausuch> #info we think after the odl port fix, tempest have reduced to 1 error only, as in nosdn scenarios
08:12:16 <morgan_orange> we should maybe contact dopctor and copper to report feedback
08:12:27 <morgan_orange> and investigate on Tempest
08:12:31 <morgan_orange> with apex team
08:12:40 <jose_lausuch> #action jose_lausuch contact Copper PTL to see what happens with Copper test case
08:12:51 <jose_lausuch> #action jose_lausuch contact Doctor PTL for Doctor test case
08:13:16 <morgan_orange> #info all SNAPS smoke tests are OK with apex
08:13:32 <morgan_orange> juhak: could you have a look at the Tempest error?
08:13:55 <juhak> morgan_orange: yes that's ok
08:14:15 <jose_lausuch> its always the same: tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.test_network_basic_ops
08:14:35 <jose_lausuch> #info tempest error log: http://artifacts.opnfv.org/logs/functest/lf-pod1/2017-01-13_10-55-38/tempest/tempest.log
08:14:43 <morgan_orange> yep it is not the first time...
08:14:51 <jose_lausuch> nop
08:14:57 <juhak> I'll take a look
08:14:57 <jose_lausuch> ok, lets move to the next installer
08:15:00 <morgan_orange> #action juhak troubleshoot on Apex error
08:15:01 <jose_lausuch> #info COMPASS
08:15:12 <morgan_orange> and we are sure that apex is in newton?
08:15:24 <HelenYao> apex is not in newton
08:15:27 <jose_lausuch> I tihkn so
08:15:33 <jose_lausuch> but using keystone v2 I thionk
08:15:35 <jose_lausuch> no?
08:15:41 <morgan_orange> hehe.. not clear to me
08:15:49 <HelenYao> https://wiki.opnfv.org/display/SWREL/Keystone+API+Usage+per+Installer+in+Danube
08:15:52 <jose_lausuch> I will talk to Tim Rozet
08:15:59 <morgan_orange> we probably should had that at the beginning of the test
08:16:02 <HelenYao> in this table, apex will not support v3
08:16:05 <jose_lausuch> v3 doesnt mean newton
08:16:08 <HelenYao> ok
08:16:12 <jose_lausuch> keystone v3 is just the version
08:16:17 <jose_lausuch> I tihkn they deploy Newton with v2
08:16:39 <jose_lausuch> #action talk to trozet about openstack version vs keystone version. Can we use v3 as all the others?
08:16:39 <HelenYao> exactly. i was wrong
08:16:49 <jose_lausuch> maybe it is not verified and its not in their plans
08:17:22 <jose_lausuch> morgan_orange: to have what?
08:17:22 <morgan_orange> #info get a snaphsot of teh versions of the main component before doing tests could be useful (for further versions..)
08:18:00 <jose_lausuch> well, not at the beginning but everytime openstack_utils is called, there is a message that says so, but yes, it would be good to have it at the beginning
08:18:10 <HelenYao> I think functest is able to run the mainstream version of all component clients
08:18:59 <morgan_orange> in the functest.log, I cannot see any mention of newton
08:19:01 <HelenYao> by version, it can be clientversion, api_version
08:19:11 <jose_lausuch> not newton no, I mean v3
08:19:13 <morgan_orange> or odl version
08:19:20 <jose_lausuch> we could include that
08:19:30 <jose_lausuch> it's not so difficult
08:19:39 <jose_lausuch> I'm working on it :)
08:19:42 <morgan_orange> yep my comment is (and it is not for functest only) it would be interesting to know precisely the version of the components of the SUT
08:19:42 <jose_lausuch> what about compass?
08:19:43 <HelenYao> the log will prompt about the api_version that is set in the env
08:19:50 <morgan_orange> yes let's move to compass
08:20:09 <HelenYao> 2017-01-16 22:00:39,343 - openstack_utils - INFO - OS_IDENTITY_API_VERSION is set in env as '3'
08:20:12 <jose_lausuch> #info deployments are not 100% stable (mixture of red and blue balls) https://build.opnfv.org/ci/job/compass-deploy-baremetal-daily-master/
08:20:33 <jose_lausuch> #info Rally_sanity fails in keystone scenario. 10 failures in tempest
08:20:37 <jose_lausuch> #info rest of the test cases are ok.
08:20:49 <HelenYao> the compass is mainly failing b/c of the rally keystone and request
08:21:05 <HelenYao> https://gerrit.opnfv.org/gerrit/#/c/27015/
08:21:15 <HelenYao> I finished the upgrading to new rally
08:21:29 <morgan_orange> HelenYao: Functest but it does not explain that deployments do not seem stabilized yet
08:21:39 <jose_lausuch> #info filed a fix for keystone problems (also with other installers) https://gerrit.opnfv.org/gerrit/#/c/27015/
08:21:46 <HelenYao> the request failure is blocked by https://gerrit.opnfv.org/gerrit/#/c/27039/
08:22:36 <HelenYao> morgan_orange: sorry, I did not follow ur point
08:22:40 <SerenaFeng> and will the patch affect other installers, as just discussed, v3 is not supported by APEX
08:22:58 <HelenYao> the patch is able to support both v2 and v3
08:23:13 <morgan_orange> HelenYao: Jose mentioned that compass deployments are not always blue. When they are OK, then we have issue in Functest due to Rally as you mentioned.
08:23:25 <morgan_orange> but they are for the moment not always OK
08:24:51 <jose_lausuch> #action review all https://gerrit.opnfv.org/gerrit/#/c/27015/
08:24:57 <jose_lausuch> if possible merge today
08:25:02 <jose_lausuch> and see results in Jenkins tomorrow
08:25:22 <morgan_orange> it is me or gerrit is very slow this morning?
08:25:24 <HelenYao> I think the link to compass is wrong. It seems to be https://build.opnfv.org/ci/view/functest/job/functest-compass-baremetal-daily-master/
08:25:27 <jose_lausuch> HelenYao: why do you clone the latest rally?
08:25:33 <HelenYao> all of the latest build failed
08:25:33 <jose_lausuch> we would like to control the versios
08:25:35 <jose_lausuch> versions
08:25:51 <HelenYao> the rally is going to release 0.8.0
08:25:57 <jose_lausuch> latest is not a good idea
08:25:58 <HelenYao> all current dev is under master
08:26:00 <jose_lausuch> latest can be unstable
08:26:11 <HelenYao> the new release is totally different from 0.7.0
08:26:22 <HelenYao> we are in the middle of the old release and new features
08:26:26 <jose_lausuch> when is 0.8.0 planned?
08:26:39 <HelenYao> some features are incapable of backward compability
08:26:40 <morgan_orange> HelenYao: https://build.opnfv.org/ci/job/compass-deploy-baremetal-daily-master/ (the deployment) and https://build.opnfv.org/ci/view/functest/job/functest-compass-baremetal-daily-master/ (functest after teh deployment)
08:27:03 <HelenYao> 0.8.0 will be released in this month.
08:27:16 <HelenYao> the keystone v3 is only supported by the new feature
08:27:36 <jose_lausuch> ok
08:27:38 <jose_lausuch> I see
08:27:41 <HelenYao> that's the reason why I am using master. once 0.8.0 is released, we will get rally from 0.8.0
08:27:50 <jose_lausuch> but as soon 0.8.0 is out, we should tag it again
08:27:54 <HelenYao> sure
08:27:56 <jose_lausuch> ok
08:27:57 <morgan_orange> ok for me
08:28:22 <jose_lausuch> anything else for compass?
08:28:32 <morgan_orange> do we know if only apex will not use keystone v3
08:28:38 <SerenaFeng> I am just afaid master will not always work
08:29:02 <morgan_orange> shall we put rally as unblocking until this is fixed
08:29:10 <jose_lausuch> SerenaFeng: yes, but now stable tag doesnt work either :)
08:29:12 <HelenYao> Rally is about to freeze the release
08:29:15 <morgan_orange> to give a chance to the other tests (even if we know that rally will fail)
08:29:32 <jose_lausuch> well, i think we can give it a shot with latest master
08:29:38 <jose_lausuch> the patch from helen
08:29:40 <SerenaFeng> morgan_orange agree
08:29:45 <jose_lausuch> if we see problems, we block it
08:29:50 <HelenYao> yeah, give it a shot in other installers before the rally is released. per my experience, the rally is not that instable
08:30:51 <jose_lausuch> ok
08:31:12 <jose_lausuch> next installer?
08:31:20 <SerenaFeng> the main problem
08:31:40 <SerenaFeng> should we follow the reason why the deployment of campass failed?
08:31:50 <jose_lausuch> sure, go ahead
08:32:46 <jose_lausuch> SerenaFeng?
08:32:50 <morgan_orange> 6 compass deployment OK on the last 17 attempts
08:32:57 <morgan_orange> but I think it is a compass issue
08:33:05 <SerenaFeng> I think we need to contack compass team to troubleshooting it
08:33:08 <morgan_orange> then wen deployment is OK, it is up to use to investigate
08:33:22 <jose_lausuch> yes, we can't solve it here :)
08:33:41 <jose_lausuch> #action SerenaFeng get an status update about Compass deployment problems
08:33:48 <jose_lausuch> ok
08:33:49 <jose_lausuch> #info JOID
08:33:58 <jose_lausuch> #info the deployments don´t look stable in CI https://build.opnfv.org/ci/job/joid-deploy-baremetal-daily-master/
08:33:59 <SerenaFeng> I think it should be better we assign to Helen
08:34:11 <jose_lausuch> ok
08:34:19 <morgan_orange> #info no joid deployment since 25/12
08:34:21 <HelenYao> I will work on it
08:34:25 <jose_lausuch> #action HelenYao get an status update about Compass deployment problems
08:34:35 <jose_lausuch> #info last Functest run was in December 28...
08:34:37 <morgan_orange> #info joid deployed on Intel pods...Intel pods no more available
08:34:44 <jose_lausuch> that's bad...
08:34:52 <morgan_orange> #info joid pod available on Huawei but installation not available
08:35:06 <jose_lausuch> #action jose_lausuch talk to jmorgan1 about intel pods status
08:35:29 <morgan_orange> #action morgan_orange contact narinder to get visibility...would be hard to troubleshoot if no run before the end of january
08:35:38 <jose_lausuch> yes..
08:35:48 <jose_lausuch> this outage is dangerous
08:35:51 <jose_lausuch> for the release
08:35:55 <morgan_orange> maybe issue to raise at release meeting
08:36:02 <morgan_orange> we have milestones
08:36:02 <jose_lausuch> I will
08:36:13 <morgan_orange> it seem that one cannot be completed here
08:36:32 <morgan_orange> what if milestones are no met in time (installer integration ready)
08:36:36 <morgan_orange> question for David
08:36:47 <morgan_orange> #info fuel
08:36:55 <jose_lausuch> ok
08:36:57 <morgan_orange> #link https://build.opnfv.org/ci/job/compass-deploy-baremetal-daily-master/
08:36:59 <jose_lausuch> I have some info here
08:37:03 <jose_lausuch> #info Fuel Deploy jobs: https://build.opnfv.org/ci/job/fuel-deploy-baremetal-daily-master/
08:37:07 <jose_lausuch> compass?
08:37:09 <jose_lausuch> :)
08:37:12 <morgan_orange> oops
08:37:14 <morgan_orange> bad tab
08:37:23 <jose_lausuch> #undo
08:37:23 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24a31d0>
08:37:26 <jose_lausuch> #undo
08:37:26 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x24a3dd0>
08:37:29 <jose_lausuch> #info Fuel Deploy jobs: https://build.opnfv.org/ci/job/fuel-deploy-baremetal-daily-master/
08:37:58 <jose_lausuch> #info despite the red balls in the past days, Functest is executed and surprisingly some tests are ok.
08:38:07 <jose_lausuch> #undo
08:38:07 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1d152d0>
08:38:15 <jose_lausuch> irc://irc.freenode.net:6667/#info despite the red balls in the past days in the deploy jobs, Functest is executed and surprisingly some tests are ok.
08:38:17 <jose_lausuch> shit
08:38:21 <jose_lausuch> irc://irc.freenode.net:6667/#info despite the red balls in the past days in the deploy jobs, Functest is executed and surprisingly some tests are ok.
08:38:25 <jose_lausuch> sorry :D
08:38:48 <jose_lausuch> it seems that there is a wrong return value. I can see that it says "deployment is done" at the end of this job for example: https://build.opnfv.org/ci/job/fuel-deploy-baremetal-daily-master/1532/console
08:38:52 <jose_lausuch> anyway
08:39:02 <jose_lausuch> what matters to us
08:39:02 <jose_lausuch> #info Functest jobs: https://build.opnfv.org/ci/view/functest/job/functest-fuel-baremetal-daily-master/
08:39:15 <jose_lausuch> #info vPing and Tempest are 100% ok.
08:39:28 <jose_lausuch> #info Connection Check test case fails. Keystone in Rally also gives an error.
08:39:40 <morgan_orange> we may note that 164 tests are run
08:39:51 <morgan_orange> the basic ops (faile don apex) is nto run on fuelk
08:39:56 <jose_lausuch> I guess rally fails due to the same problem as compass
08:40:05 <jose_lausuch> why not?
08:41:11 <HelenYao> the count of tempest test case varies per blacklist
08:41:14 <morgan_orange> good question....https://git.opnfv.org/functest/tree/functest/opnfv_tests/openstack/tempest/custom_tests/blacklist.txt
08:41:25 <morgan_orange> it is explicitely excluded
08:41:39 <SerenaFeng> I see Deployment failed in deployment console, will it affect rally?
08:42:11 <HelenYao> I hope to see the log of request
08:42:16 <jose_lausuch> oh interesting
08:42:42 <jose_lausuch> we have to check the status of that bug and re-enable that test case
08:42:43 <HelenYao> for keystone, I would say the current rally does not support v3
08:43:07 <jose_lausuch> #info rally fails the keystone scenario due to lack of v3 support in 0.7.0
08:43:28 <morgan_orange> could also expain the errors on rally/request
08:43:33 <jose_lausuch> SerenaFeng: the deployment is completed and succesfful, but I dont know it returns -1
08:43:40 <morgan_orange> but the jobs exited due to an error on SNAPS
08:43:45 <jose_lausuch> there must be some wrong check at the end
08:43:57 <jose_lausuch> yes
08:43:57 <SerenaFeng> ok
08:44:00 <jose_lausuch> right
08:44:11 <jose_lausuch> keystoneauth1.exceptions.http.NotFound: The resource could not be found. (HTTP 404)
08:44:20 <jose_lausuch> HelenYao: can you contact Steven about this error?
08:44:21 <morgan_orange> it was reported to Steve but he has no access to a fuel env to test
08:44:26 <jose_lausuch> ok
08:44:27 <jose_lausuch> I have
08:44:29 <jose_lausuch> I can do it
08:44:34 <morgan_orange> jose_lausuch:  I think I already reported the bug to him
08:44:42 <jose_lausuch> I set up the server on friday
08:44:45 <jose_lausuch> and I could try
08:44:46 <morgan_orange> but he answered he has not the nev to test
08:44:52 <jose_lausuch> ok, thanks
08:45:05 <HelenYao> morgan_orange: ok. I will talk to steve
08:45:09 <morgan_orange> that is why I sent a mail to try to identify which env we have for such issues
08:45:16 <jose_lausuch> #action jose_lausuch test connection_check on a fuel env
08:45:35 <jose_lausuch> thats the next topic
08:45:42 <jose_lausuch> let's move
08:45:42 <morgan_orange> and it is a real bug - the case could be fail but we should not exit
08:45:54 <morgan_orange> we have a 5th installer..
08:45:57 <morgan_orange> haven't we
08:45:59 <jose_lausuch> yes, we should continue if its not a blocking test
08:46:04 <jose_lausuch> daisy?
08:46:17 <morgan_orange> yep any news?
08:46:22 <jose_lausuch> #info Daisy
08:46:28 <jose_lausuch> #info no functest runs so far
08:46:38 <SerenaFeng> yes
08:46:47 <jose_lausuch> I provided information to the team, about how to integrate functest jobs, the needed things in fetch_creds and so on
08:46:49 <jose_lausuch> but nothing so far
08:46:52 <SerenaFeng> I think they are working on the integration work
08:46:59 <jose_lausuch> yes
08:47:03 <jose_lausuch> that was last week
08:47:14 <morgan_orange> we may also notice that fuel, compass and joid are consistent (job naming)
08:47:15 <jose_lausuch> I explained more or less all the steps they need to run functest in CI
08:47:20 <morgan_orange> it will be great if daisy could be
08:47:23 <jose_lausuch> but so far I see only deployments
08:47:32 <SerenaFeng> yes
08:47:37 <morgan_orange> https://build.opnfv.org/ci/job/daisy-deploy-baremetal-daily-master
08:47:40 <SerenaFeng> the deployment is not stable yet
08:47:52 <jose_lausuch> that link doesnt work for me
08:47:53 <morgan_orange> and of course if apex could also make some effort to be consistent it would be great...
08:47:57 <morgan_orange> neither for me
08:48:09 <jose_lausuch> I think fdegir tried already :)
08:48:16 <morgan_orange> I know...
08:48:49 <morgan_orange> 3 installers did it...it does not look impossible to do
08:48:51 <jose_lausuch> ok, in the same direction, let´s see who can work with what
08:48:53 <jose_lausuch> #topic Lab availability
08:48:54 <morgan_orange> and it is easier for us
08:49:20 <jose_lausuch> I have a fuel environment where I can login that belongs to sdnvpn team (including myself)
08:49:31 <jose_lausuch> it´s a virtual deployment, but it should be fine
08:49:42 <jose_lausuch> #info jose_lausuch troubleshoot functest-fuel issues
08:49:54 <jose_lausuch> who can work on apex? juhak ?
08:50:19 <juhak> I can check apex issues
08:50:31 <morgan_orange> #info morgan_orange: compass/colorado (Orange Paris), fuel/colorado (Orange Paris), joid/Danube? (when available on Orange Lannion) and access to LF pod1 and LF POD2 shall still be OK (but not used for a long time and troubleshooting on CI pod is not easy...)
08:50:31 <jose_lausuch> do you have hw to test on?
08:51:11 <juhak> yes
08:51:24 <jose_lausuch> ok perfect
08:51:29 <jose_lausuch> what about the others?
08:51:34 <morgan_orange> #info juhak apex/ (Nokia pod)
08:51:34 <juhak> but our apex env Colorado...
08:51:35 <jose_lausuch> do you have testbeds?
08:51:42 <morgan_orange> #undo
08:51:42 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a69550>
08:51:45 <jose_lausuch> we should be testing latest apex
08:51:48 <jose_lausuch> latest everything
08:52:08 <morgan_orange> #info juhak apex/colorado (Nokia pod)
08:52:31 <jose_lausuch> do you have a chance to test latest deployments ?
08:52:33 <morgan_orange> not always easy, In Paris some teams are using to perform tests on a "stable" version
08:52:49 <juhak> at this moment can update to latest
08:52:52 <morgan_orange> so no plan to upgrade to Danube candidate...
08:52:57 <jose_lausuch> ok
08:53:06 <juhak> others are testing w/ Colodaro
08:53:28 <jose_lausuch> ok
08:53:36 <jose_lausuch> HelenYao: SerenaFeng do you have testbeds?
08:53:36 <morgan_orange> it is logical that community pods deal with stable version (i.e.colorado...)
08:53:42 <jose_lausuch> who works on compass?
08:53:49 <morgan_orange> but we need community pod with danube candidate version for troubleshooting
08:53:53 <HelenYao> I have compass mitaka and newton
08:53:59 <jose_lausuch> ok
08:54:17 <jose_lausuch> for joid, I guess we have to wait for intel pods?
08:54:21 <morgan_orange> #info HelenYao compass/colorado and compass/danube (Huawei pod)
08:54:35 <morgan_orange> jose_lausuch: yes and we will use one of the Orange POD
08:54:47 <jose_lausuch> ok good
08:54:47 <SerenaFeng> our apex deploy failed for now
08:55:11 <jose_lausuch> so we are set, everyone has some hardware to test stuff on
08:55:42 <morgan_orange> and daisy?
08:55:44 <SerenaFeng> can we troubleshoot it on virtual apex pod?
08:55:54 <morgan_orange> SerenaFeng: yes I think so
08:55:58 <SerenaFeng> we have virtual apex pod
08:56:20 <jose_lausuch> if you create an infra ticket, I could set up a pod with both installers, apex and fuel
08:56:28 <jose_lausuch> using latest builds
08:56:35 <jose_lausuch> and troubleshoot at least these 2 installers there
08:56:48 <jose_lausuch> centos as op.system
08:57:00 <jose_lausuch> virtual deployments
08:57:14 <SerenaFeng> ok, assign the task to me, I will try to troubleshoot it
08:57:52 <jose_lausuch> well, the task is for all :)
08:58:02 <SerenaFeng> ok
08:58:04 <jose_lausuch> I will give access to the few of us that work on it
08:58:07 <jose_lausuch> ok
08:58:09 <jose_lausuch> before we finish
08:58:17 <jose_lausuch> #topic Gerrit gate
08:58:29 <SerenaFeng> for daisy, I will follow their progress
08:58:32 <morgan_orange> maybe we need 1 virtual pod for functest for apex and fuel
08:58:53 <jose_lausuch> Nikolas proposed me to use the same apex deployment as he does for the ODL-pipeline based on snapshots
08:58:54 <morgan_orange> I can create an infra ticket
08:59:02 <jose_lausuch> it takes 5 minutes to deploy
08:59:06 <jose_lausuch> ok, thanks
08:59:42 <jose_lausuch> we could use that and have a verify job (20min max) that runs maybe prepare_env and 1 test case (healthechk?)
08:59:47 <jose_lausuch> would you like to have something like that?
09:00:06 <morgan_orange> Am I wrong or is it already in place on apex?
09:00:23 <jose_lausuch> it is
09:00:31 <jose_lausuch> for apex verify jobs
09:00:33 <morgan_orange> I would suggest prepare env + healtcheck + a vPing
09:00:36 <jose_lausuch> but not for functest verify jobs :)
09:00:40 <jose_lausuch> ok
09:00:46 <jose_lausuch> agree
09:00:57 <jose_lausuch> it has to be something not depending on the installer of course
09:01:07 <morgan_orange> the prepare env is then maybe a bit heavy for what we want to do
09:01:09 <jose_lausuch> because we will use apex snapshots
09:01:20 <morgan_orange> we could have something lighter...no need to install rally/tempest, clone all the repos...
09:01:22 <jose_lausuch> it takes 10 seconds
09:01:28 <jose_lausuch> but the challenge is
09:01:36 <jose_lausuch> to build a docker container and put the patch changes in there
09:02:23 <morgan_orange> hmm if you run the git review -D <id of the patch> in the docker
09:02:32 <jose_lausuch> yes
09:02:39 <jose_lausuch> so we need to do some hacking around :)
09:02:39 <HelenYao> we can deploy the container by volume mapping
09:02:43 <morgan_orange> yes
09:02:47 <SerenaFeng> git review is not support for now
09:02:47 <jose_lausuch> thats also another idea
09:02:48 <HelenYao> then reinstall the functest
09:03:03 <jose_lausuch> so 2 setps
09:03:04 <jose_lausuch> steps
09:03:13 <jose_lausuch> docker volume including the local patch
09:03:19 <jose_lausuch> and reinstall functest
09:03:30 <morgan_orange> sounds good
09:03:36 <jose_lausuch> this would be pulling the latest container, without building it again
09:03:40 <jose_lausuch> right?
09:04:01 <HelenYao> the docker latest image should be pulled from time to time to embrace the latest change of other project
09:04:15 <jose_lausuch> we can include the pull in the job
09:04:16 <HelenYao> otherwise, it will cause problem as other projects are submitting code
09:04:28 <HelenYao> the pulling takes time
09:04:53 <jose_lausuch> yes
09:04:55 <HelenYao> if we want to make the verification quick enough, we can pull the image periodically
09:04:57 <jose_lausuch> we are out of time :(
09:05:17 <jose_lausuch> but periodically doesnt mean it will have the latest at the gate time
09:05:23 <jose_lausuch> I think we can pull with cache
09:05:28 <jose_lausuch> and it takes shorter
09:05:50 <SerenaFeng> if only healthcheck and vping
09:05:53 <HelenYao> yep, let's make it happen first then think about how to improve it
09:06:00 <SerenaFeng> we don't need the latest docker
09:06:17 <SerenaFeng> functest will be substituted with local version
09:06:25 <jose_lausuch> good point
09:06:28 <SerenaFeng> it will be the latest
09:06:44 <jose_lausuch> right
09:06:49 <SerenaFeng> so periodically pull will satisfied
09:06:54 <jose_lausuch> ok, let's think about that in gerrit itself :)
09:07:06 <jose_lausuch> thanks
09:07:08 <jose_lausuch> anything else?
09:07:38 <SerenaFeng> https://gerrit.opnfv.org/gerrit/#/c/26499/
09:07:57 <SerenaFeng> patch, I already decouple it with functest change, I think we can merge this one first,
09:08:03 <jose_lausuch> ok
09:08:11 <HelenYao> https://gerrit.opnfv.org/gerrit/#/c/26695/
09:08:17 <SerenaFeng> it will not affect others
09:08:51 <HelenYao> about the logging config, could you help to decide what is the next step for the patch?
09:09:20 <jose_lausuch> I plan to do reviews today
09:09:42 <jose_lausuch> sorry if I'm slow, it´s being very busy these days
09:10:14 <jose_lausuch> #endmeeting