#opnfv-functest: Functest weekly meeting February 28th 2017

Meeting started by jose_lausuch at 08:00:43 UTC (full logs).

Meeting summary

  1. role call (jose_lausuch, 08:00:52)
    1. Jose Lausuch (jose_lausuch, 08:00:56)
    2. Morgan Richomme (morgan_orange, 08:00:58)
    3. Cristina Pauna (Enea) (CristinaPauna, 08:01:07)
    4. hideyasu (ool) (hideyasu, 08:01:15)
    5. SerenaFeng (SerenaFeng, 08:01:17)
    6. Helen Yao (HelenYao, 08:01:24)
    7. Linda Wang (LindaWang, 08:01:27)
    8. agenda for today https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange, 08:03:10)

  2. Action point follow-up (jose_lausuch, 08:03:17)
    1. AP jose_lausuch: contact Luke to see if we can reduce output -> Not needed. after using feature_base in security_scan test, all the output is in the log file, not on the console. (jose_lausuch, 08:03:25)
    2. action jose_lausuch create a wikipage for logging best practicies for Functest. (jose_lausuch, 08:03:39)
    3. AP ollivier add a wiki page about review best practices (jose_lausuch, 08:03:47)
    4. ACTION: ollivier add a wiki page about review best practices (jose_lausuch, 08:04:04)
    5. AP morgan_orange fix hyperlink to jenkins on the dashboard. DONE (jose_lausuch, 08:04:14)
    6. work on tempest stopper https://jira.opnfv.org/browse/FUNCTEST-725. DONE (jose_lausuch, 08:04:29)
    7. morgan_orange add api_check and conenction_check in reporting. DONE (jose_lausuch, 08:04:54)
    8. morgan_orange see why huawei-pod12 is stil not seen as a CI POD. (jose_lausuch, 08:05:06)
    9. DONE (jose_lausuch, 08:05:43)

  3. New Tempest test cases added (jose_lausuch, 08:06:08)
    1. Tempest Defcore test enabled for nosdn-nofeature-ha scenarios: https://gerrit.opnfv.org/gerrit/#/c/29247/ (jose_lausuch, 08:06:20)
    2. more information about DefCore/RefStack: https://refstack.openstack.org/#/guidelines (jose_lausuch, 08:06:35)
    3. visible on reporting page => http://testresults.opnfv.org/reporting/functest/release/master/index-status-compass.html (morgan_orange, 08:06:39)
    4. there will be a collaboration between OPNFV and OpenStack to establish a reference NFV list of tests. Extend this list and find the gaps. (jose_lausuch, 08:06:57)
    5. Added Custom Tempest test case: https://gerrit.opnfv.org/gerrit/#/c/29249/ (jose_lausuch, 08:07:30)
    6. The user will be able to use that txt with the desired list of test cases to be run. (jose_lausuch, 08:07:37)
    7. ACTION: jose_lausuch update documentation for: removed healthcheck, added tempest tests (jose_lausuch, 08:07:59)
    8. ACTION: contact Refstack PTL to see why only 104 / 244 tests are run (jose_lausuch, 08:10:01)
    9. Refactoring status (jose_lausuch, 08:11:46)
    10. last test case to be updated ONOS --> https://gerrit.opnfv.org/gerrit/#/c/29403/ (jose_lausuch, 08:11:52)
    11. https://gerrit.opnfv.org/gerrit/#/c/29431/ (jose_lausuch, 08:14:23)
    12. https://gerrit.opnfv.org/gerrit/#/c/28609/ (jose_lausuch, 08:16:14)

  4. status (morgan_orange, 08:19:07)
    1. Apex status (morgan_orange, 08:19:12)
    2. http://testresults.opnfv.org/reporting/functest/release/master/index-status-apex.html (jose_lausuch, 08:19:23)
    3. tests failing on all scenarios: doctor, security_scan (jose_lausuch, 08:19:42)
    4. tests failing on all apex scenarios: doctor, security_scan (jose_lausuch, 08:23:36)
    5. and Tempest smoke (morgan_orange, 08:23:51)
    6. SNAPS_Smoke fails only on gluon scenario --> Netready PTL already contacted Steven, troubleshooting at the moment (jose_lausuch, 08:23:53)
    7. https://jira.opnfv.org/browse/FUNCTEST-732 (morgan_orange, 08:24:56)
    8. ACTION: LindaWang troubleshoot securtiy_scan issue (morgan_orange, 08:27:11)
    9. ACTION: morgan_orange create a patch to exclude Doctor temporarily + add Doctor team in review (morgan_orange, 08:29:13)
    10. ACTION: re-enable promise on the dashboard (jose_lausuch, 08:30:14)

  5. Compass status (jose_lausuch, 08:31:22)
    1. https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/458/console (morgan_orange, 08:31:35)
    2. compass nosdn and odl_l2 scenarios are passing all the criteria (jose_lausuch, 08:33:36)
    3. some problems with multisite being addressed, juha looked into that. (jose_lausuch, 08:33:57)

  6. Fuel (jose_lausuch, 08:35:23)
    1. Parser problems in fuel has been fixed by parser team (morgan_orange, 08:37:16)
    2. problems with ovs-dpdk barometer deployments due to the healthcheck (dhcp) (jose_lausuch, 08:37:59)
    3. fuel some issues with SNAPS (morgan_orange, 08:39:36)

  7. JOID status (jose_lausuch, 08:40:02)
    1. SNAPs fails on all scenarios (jose_lausuch, 08:40:15)
    2. tempest smoke fails on lxd (jose_lausuch, 08:40:37)
    3. ACTION: morgan_orange sync joid / Steve/ Narinder for SNAPS errors on joid scenarios (morgan_orange, 08:40:52)

  8. AoB (jose_lausuch, 08:43:22)
    1. orchestra_ims integration in progress.... seems there are timeout issue but should be OK (morgan_orange, 08:44:11)
    2. TestAPI evolution internship is officially over (morgan_orange, 08:44:20)
    3. The cloudify_ims works fine if the keystone_url is in v2 by default (morgan_orange, 08:48:03)
    4. ARM close on merging https://gerrit.opnfv.org/gerrit/#/c/28945 which upstreams all the custom configs we use for running functest on arm (morgan_orange, 08:48:26)
    5. vrouter tested vrouter on my Lab's enviroment(fuel) using nosdn-nofeature (morgan_orange, 08:48:39)
    6. working on https://jira.opnfv.org/browse/ARMBAND-222 to adapt snaps tests for ARM (CristinaPauna, 08:49:14)
    7. ACTION: jose_lausuch ask for a pod for weekly loops (jose_lausuch, 08:54:03)
    8. fd tests alrso under integration (morgan_orange, 08:54:32)


Meeting ended at 09:02:26 UTC (full logs).

Action items

  1. ollivier add a wiki page about review best practices
  2. jose_lausuch update documentation for: removed healthcheck, added tempest tests
  3. contact Refstack PTL to see why only 104 / 244 tests are run
  4. LindaWang troubleshoot securtiy_scan issue
  5. morgan_orange create a patch to exclude Doctor temporarily + add Doctor team in review
  6. re-enable promise on the dashboard
  7. morgan_orange sync joid / Steve/ Narinder for SNAPS errors on joid scenarios
  8. jose_lausuch ask for a pod for weekly loops


Action items, by person

  1. jose_lausuch
    1. jose_lausuch update documentation for: removed healthcheck, added tempest tests
    2. jose_lausuch ask for a pod for weekly loops
  2. LindaWang
    1. LindaWang troubleshoot securtiy_scan issue
  3. morgan_orange
    1. morgan_orange create a patch to exclude Doctor temporarily + add Doctor team in review
    2. morgan_orange sync joid / Steve/ Narinder for SNAPS errors on joid scenarios
  4. UNASSIGNED
    1. ollivier add a wiki page about review best practices
    2. contact Refstack PTL to see why only 104 / 244 tests are run
    3. re-enable promise on the dashboard


People present (lines said)

  1. jose_lausuch (175)
  2. morgan_orange (110)
  3. SerenaFeng (17)
  4. HelenYao (13)
  5. LindaWang (9)
  6. CristinaPauna (6)
  7. collabot` (6)
  8. hideyasu (4)
  9. boucherv (3)
  10. OPNFV-Gerrit-Bot (2)


Generated by MeetBot 0.1.4.