#opnfv-functest: Functest weekly meeting March 7th

Meeting started by morgan_orange1 at 08:00:27 UTC (full logs).

Meeting summary

  1. call role (morgan_orange1, 08:00:33)
    1. morgan Richomme (morgan_orange1, 08:00:38)
    2. Juha Kosonen (juhak, 08:00:55)
    3. Hideyasu Hayashi (hideyasu, 08:01:11)
    4. Linda Wang (LindaWang, 08:01:21)
    5. agenda for today https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange1, 08:01:24)
    6. Cristina Pauna (Enea) (CristinaPauna, 08:01:41)

  2. action points follow up (morgan_orange1, 08:02:20)
    1. AP1: ollivier add a wiki page about review best practices (morgan_orange1, 08:02:40)
    2. not started (but not the priority regarding the release) (morgan_orange1, 08:03:00)
    3. ACTION: ollivier add a wiki page about review best practices (morgan_orange1, 08:03:10)
    4. AP2: jose_lausuch update documentation for: removed healthcheck, added tempest tests (morgan_orange1, 08:03:19)
    5. done, patch submitted and structure agreed with other test projects (morgan_orange1, 08:03:26)
    6. AP3: contact Refstack PTL to see why only 104 / 244 tests are run (morgan_orange1, 08:03:35)
    7. done: seems negative tests are not executed (morgan_orange1, 08:03:41)
    8. shuya(ool) (shuya_ool, 08:03:43)
    9. work on using refstack client rather than starting tempest suite from Tempest/rally to be done (morgan_orange1, 08:03:47)
    10. AP4: LindaWang troubleshoot securtiy_scan issue (morgan_orange1, 08:03:54)
    11. done, see next topic discussion (morgan_orange1, 08:04:00)
    12. AP5: morgan_orange create a patch to exclude Doctor temporarily + add Doctor team in review (morgan_orange1, 08:04:20)
    13. done, patch will be abandonned - first Doctor run OK on fuel (morgan_orange1, 08:04:26)
    14. AP6: re-enable promise on the dashboard (morgan_orange1, 08:04:34)
    15. done (morgan_orange1, 08:04:42)
    16. AP7: morgan_orange sync joid / Steve/ Narinder for SNAPS errors on joid scenarios (morgan_orange1, 08:04:50)
    17. partially done, os-nosdn-nofeature scenario is now fine, still bug in odl and open questions on lxd scenarios / SNAPS (see next sections) (morgan_orange1, 08:04:55)
    18. AP8: jose_lausuch ask for a pod for weekly loops (morgan_orange1, 08:05:02)
    19. done....see next topic (morgan_orange1, 08:05:10)

  3. Security scanning: testbase versus feature base for python based feature projects (morgan_orange1, 08:06:36)
    1. https://gerrit.opnfv.org/gerrit/#/c/29703/ (morgan_orange1, 08:07:55)
    2. security scanning patch will fix security scan problem on apex results. However it reintroduced a python => bash => python we tried to exclude (morgan_orange1, 08:11:25)
    3. https://git.opnfv.org/functest/tree/functest/opnfv_tests/features/sdnvpn.py (morgan_orange1, 08:15:07)
    4. https://git.opnfv.org/functest/tree/functest/opnfv_tests/features/odl_sfc.py (morgan_orange1, 08:15:18)
    5. https://gerrit.opnfv.org/gerrit/#/c/29703/2/functest/opnfv_tests/features/security_scan.py (ollivier, 08:17:00)
    6. ACTION: morgan_orange ollivier clarify python way for feature projects inhering feature based - see impact on sfc, sdnvpn (morgan_orange1, 08:20:00)

  4. Weekly jobs (vrouter, orchestra_ims, cloudify_ims) (morgan_orange1, 08:20:19)
    1. first weekly job created on fuel/os-nosdn-nofeature-ha scenario (morgan_orange1, 08:20:34)
    2. it is now possible to launch manually a weekly job , mainly to test the VNF (morgan_orange1, 08:20:53)
    3. https://build.opnfv.org/ci/job/functest-fuel-baremetal-weekly-master/ (morgan_orange1, 08:21:07)
    4. first attempt => problem in cloudify_ims preventing vrouter and orchestra_ims to be run (morgan_orange1, 08:21:28)
    5. orchestra torubleshooting done on virtual server, but it seems that issues may be due to resources shortage on virtual env, tests need to be done on baremetal to confirm (morgan_orange1, 08:23:38)
    6. weekly runs can be triggered manually though jenkins interface (today one installer/1 scenario) (morgan_orange1, 08:25:33)
    7. https://gerrit.opnfv.org/gerrit/#/c/28609/, jose do it in this patch (SerenaFeng, 08:25:48)
    8. https://jira.opnfv.org/browse/FUNCTEST-750 (hideyasu, 08:26:23)
    9. issue found on vrouter, patch will be submitted today (morgan_orange1, 08:26:38)
    10. https://jira.opnfv.org/browse/FUNCTEST-750 (morgan_orange1, 08:26:45)

  5. Troubleshooting status (morgan_orange1, 08:27:18)
    1. mail sent yesterday (morgan_orange1, 08:27:29)
    2. ACTION: morgan_orange => share the mail with scenario owners (any alias?) (morgan_orange1, 08:27:38)
    3. bug fix provided for Doctor, successfully tested on fuel (morgan_orange1, 08:27:45)
    4. status apex (morgan_orange1, 08:27:49)
    5. http://testresults.opnfv.org/reporting/functest/release/master/index-status-apex.html (morgan_orange1, 08:27:54)
    6. new run this morning (48h without CI run (morgan_orange1, 08:28:00)
    7. Jun Li (MatthewLi, 08:28:26)
    8. security scanning: we know how to solve but discussion to solve it properly ...(see previous topic that needs follwo up by mail) (morgan_orange1, 08:28:41)
    9. considering Doctor/Security scanning OK => 1 scenario OK for Danube nosdn-nofeature-ha (morgan_orange1, 08:28:48)
    10. main issues: Tempest_smoke (odl_l3, bgpvpn), SNAPS (gluon), vping_ssh (bgpvpn) (morgan_orange1, 08:28:56)
    11. bgpvpn vping_ssh pb could be linked to last ODL version? (see Manuel's mail) (morgan_orange1, 08:29:17)
    12. fds scenario in CI but failing SNAPS so not see in the reporting page (SNAPS patch provided to supported huge page) (morgan_orange1, 08:29:24)
    13. ACTION: juhak : give feedback on tempest_smoke error for apex scenario (morgan_orange1, 08:29:43)
    14. status compass (morgan_orange1, 08:29:53)
    15. http://testresults.opnfv.org/reporting/functest/release/master/index-status-compass.html (morgan_orange1, 08:29:59)
    16. 2 scenarios OK for release: nosdn-nofeature-ha and odl_l2-nofeature-ha (morgan_orange1, 08:30:05)
    17. main issues: tempest_smoke & rally_sanity (odl_l3), ODL (odl_l3), vping_ssh (ocl) (morgan_orange1, 08:30:12)
    18. ACTION: juhak have a look at tempest&rally issue on odl_l3 scenario (compass) (morgan_orange1, 08:30:28)
    19. ACTION: ollivier see what is wrong on odl_l3 scenario (morgan_orange1, 08:30:36)
    20. status fuel (morgan_orange1, 08:30:44)
    21. http://testresults.opnfv.org/reporting/functest/release/master/index-status-fuel.html (morgan_orange1, 08:30:52)
    22. 6 scenarios ~ OK for Release (Doctor exluded until we got the number of iterations): nosdn-ov__kvm_dpdk_noha, nosdn-ovs (ha and noha), nosdn_nofeature (ha and noha) (morgan_orange1, 08:31:07)
    23. CI crash when launching barometer suite (morgan_orange1, 08:31:13)
    24. issues vping_ssh (SFC), Tempest (odl_l3, odl_l2n bgpvpn), rally_sanity (kvm), SNAPS (kvm), bgpvpn (bgpvpn) (morgan_orange1, 08:31:19)
    25. ACTION: juhak have a look at tempest&rally issues on odl & kvm scenarios (fuel) (morgan_orange1, 08:31:58)
    26. status joid (morgan_orange1, 08:32:04)
    27. http://testresults.opnfv.org/reporting/functest/release/master/index-status-joid.html (morgan_orange1, 08:32:10)
    28. 2 scenarios OK (without considering Doctor now) for Danube nosdn-nofeature (ha and noha) (morgan_orange1, 08:32:16)
    29. main issues: vping_ssh (odl), rally_sanity (lxd), SNAPS (lxd) (morgan_orange1, 08:32:22)
    30. k8 scenarios no tested => rto be done in E (morgan_orange1, 08:32:28)
    31. ACTION: juhak see rally_sanity issue on lxd scenario (joid) (morgan_orange1, 08:32:43)
    32. ACTION: steve and morgan_orange, see if SNAPS smoke is compatible with lxd (probably not...) if not exclude it (morgan_orange1, 08:34:21)
    33. please note that a new testcase has been introduced on os-nosdn-nofeature-ha scenario called tempest devcore, it corresponds to the work mentioned by Jose last year (working with Openstack on ref NFV suite) (morgan_orange1, 08:36:02)

  6. Danube branching (morgan_orange1, 08:36:52)
    1. ACTION: morgan_orange create Danube branch March 10th 2PM CET (morgan_orange1, 08:39:28)
    2. ACTION: morgan_orange adapt reporting to include Danube version (morgan_orange1, 08:39:42)

  7. Multisite (morgan_orange1, 08:41:00)
    1. last run 27/2 (morgan_orange1, 08:41:26)
    2. https://build.opnfv.org/ci/view/functest/job/functest-compass-virtual-daily-master/1219/console (morgan_orange1, 08:41:28)
    3. multisite case was failing (morgan_orange1, 08:41:44)
    4. multisite tempest cases could be executed successfully manually (morgan_orange1, 08:43:08)
    5. ACTION: juhak troubleshooting multisite (morgan_orange1, 08:43:26)
    6. https://build.opnfv.org/ci/job/multisite-kingbird-virtual-daily-master/ (morgan_orange1, 08:44:09)
    7. last attempt (morgan_orange1, 08:45:01)
    8. https://build.opnfv.org/ci/job/functest-fuel-virtual-suite-master/271/console (morgan_orange1, 08:45:02)

  8. JIRA (morgan_orange1, 08:48:34)
    1. I started cleaning the JIRAs (morgan_orange1, 08:48:52)
    2. ACTION: all close the JIRA that are fixed to clarify (morgan_orange1, 08:49:14)
    3. if task cannot be done for Danube, move them to E (morgan_orange1, 08:49:30)
    4. JIRA shall reflect some reality... (morgan_orange1, 08:49:52)
    5. it includes the JIRAs we created for the internships (morgan_orange1, 08:50:48)
    6. current status: 29 open issues + 62 in the backlogs that are still tagged Danube (morgan_orange1, 08:51:57)
    7. ACTION: morgan_orange clean JIRA for Danube (morgan_orange1, 08:52:47)

  9. AoB (morgan_orange1, 08:52:59)
    1. ACTION: SerenaFeng check testapi fixed are included on testresults.opnfv.org, if not apply them and maybe enable automatic mechanism now.. (morgan_orange1, 09:00:01)
    2. tomorrow Test weekly meeting (APAC slot): with a presentation of Kumar work on VNF catalogue. Feel free to join (morgan_orange1, 09:00:36)


Meeting ended at 09:01:47 UTC (full logs).

Action items

  1. ollivier add a wiki page about review best practices
  2. morgan_orange ollivier clarify python way for feature projects inhering feature based - see impact on sfc, sdnvpn
  3. morgan_orange => share the mail with scenario owners (any alias?)
  4. juhak : give feedback on tempest_smoke error for apex scenario
  5. juhak have a look at tempest&rally issue on odl_l3 scenario (compass)
  6. ollivier see what is wrong on odl_l3 scenario
  7. juhak have a look at tempest&rally issues on odl & kvm scenarios (fuel)
  8. juhak see rally_sanity issue on lxd scenario (joid)
  9. steve and morgan_orange, see if SNAPS smoke is compatible with lxd (probably not...) if not exclude it
  10. morgan_orange create Danube branch March 10th 2PM CET
  11. morgan_orange adapt reporting to include Danube version
  12. juhak troubleshooting multisite
  13. all close the JIRA that are fixed to clarify
  14. morgan_orange clean JIRA for Danube
  15. SerenaFeng check testapi fixed are included on testresults.opnfv.org, if not apply them and maybe enable automatic mechanism now..


Action items, by person

  1. juhak
    1. juhak : give feedback on tempest_smoke error for apex scenario
    2. juhak have a look at tempest&rally issue on odl_l3 scenario (compass)
    3. juhak have a look at tempest&rally issues on odl & kvm scenarios (fuel)
    4. juhak see rally_sanity issue on lxd scenario (joid)
    5. juhak troubleshooting multisite
  2. ollivier
    1. ollivier add a wiki page about review best practices
    2. morgan_orange ollivier clarify python way for feature projects inhering feature based - see impact on sfc, sdnvpn
    3. ollivier see what is wrong on odl_l3 scenario
  3. SerenaFeng
    1. SerenaFeng check testapi fixed are included on testresults.opnfv.org, if not apply them and maybe enable automatic mechanism now..
  4. UNASSIGNED
    1. morgan_orange => share the mail with scenario owners (any alias?)
    2. steve and morgan_orange, see if SNAPS smoke is compatible with lxd (probably not...) if not exclude it
    3. morgan_orange create Danube branch March 10th 2PM CET
    4. morgan_orange adapt reporting to include Danube version
    5. all close the JIRA that are fixed to clarify
    6. morgan_orange clean JIRA for Danube


People present (lines said)

  1. morgan_orange1 (165)
  2. joehuang__ (14)
  3. ollivier (9)
  4. LindaWang (8)
  5. MatthewLi (6)
  6. juhak (5)
  7. SerenaFeng (4)
  8. collabot` (4)
  9. hideyasu (4)
  10. shuya_ool (1)
  11. CristinaPauna (1)


Generated by MeetBot 0.1.4.