#opnfv-functest: Functest weekly meeting March 28th 2017

Meeting started by jose_lausuch at 08:00:21 UTC (full logs).

Meeting summary

  1. role call (jose_lausuch, 08:00:30)
    1. Morgan Richomme (morgan_orange, 08:00:37)
    2. Jose Lausuch (jose_lausuch, 08:00:42)
    3. Juha Kosonen (juhak, 08:01:21)
    4. Linda Wang (LindaWang1, 08:01:42)
    5. Helen Yao (HelenYao, 08:01:59)
    6. Valentin Boucher (boucherv, 08:02:06)

  2. Action point follow-up (jose_lausuch, 08:03:58)
    1. AP ollivier add a wiki page about review best practices. DONE https://wiki.opnfv.org/display/functest/Review+checkpoints (jose_lausuch, 08:04:03)
    2. ACTION: everyone to agree on Cedric's proposal: https://wiki.opnfv.org/display/functest/Review+checkpoints (jose_lausuch, 08:04:29)
    3. morgan_orange jose_lausuch prepare release note. To be finised this week (before release) (jose_lausuch, 08:04:44)
    4. jose_lausuch exclude tempest_defcore (we can keep the code as it can be usefull to have a second launcher in case) but not execute it. DONE by morgan https://gerrit.opnfv.org/gerrit/#/c/30735/ (jose_lausuch, 08:04:54)
    5. LindaWang contact juraj to indicate to update functest docker or at least to change the refstack criteria. (jose_lausuch, 08:05:04)
    6. Cédric Ollivier (ollivier, 08:05:43)
    7. HelenYao ollivier jose_lausuch morgan_orange juhak LindaWang boucherv take care for your danube 1.0 JIRA. EMAIL sent and topic added (jose_lausuch, 08:06:35)
    8. morgan_orange update the figures of the guides. DONE (jose_lausuch, 08:06:44)
    9. jose_lausuch check on bgpvpn status. ONGOING. Problems are being addressed. Need to see if sdnvpn will target 1.0 or 2.0 (jose_lausuch, 08:07:02)
    10. LindaWang set Refstack criteria to 100%. DONE (jose_lausuch, 08:07:16)
    11. morgan_orange jose_lausuch prepare short summary and share with Functest contributors before the 27th (jose_lausuch, 08:07:24)
    12. ACTION: morgan_orange jose_lausuch prepare short summary "presentation on Functest (introduction/vision) + framework evolution and interface with third party to be initiated" and share with Functest contributors (jose_lausuch, 08:07:32)
    13. Jun Li (MatthewLi, 08:07:36)
    14. SerenaFeng (SerenaFeng, 08:07:57)
    15. Cristina Pauna (CristinaPauna, 08:09:43)

  3. Danube status (jose_lausuch, 08:10:08)
    1. APEX (jose_lausuch, 08:10:30)
    2. scenarios that are getting stable and getting 100%: nosdn-nofeature, odl_l3-nofeature, nosdn-kvm (jose_lausuch, 08:10:53)
    3. scenarios that have problems with tempest_smoke: gluon, old_l3-fdio, odl-bgpvpn (jose_lausuch, 08:11:02)
    4. scenarios that don't pass healtcheck: nosdn-fdio (jose_lausuch, 08:11:11)
    5. patch for gluon and bgpvpn to exclude a vping_ssh in apex (jose_lausuch, 08:12:22)
    6. ACTION: jose_lausuch update release note with referenced bug for vping (gluon, bgpvpn) (morgan_orange, 08:12:44)
    7. COMPASS (jose_lausuch, 08:13:30)
    8. scenarios that are are fully working: nosdn-nofeature, nosdn-openo (jose_lausuch, 08:13:35)
    9. scenarios that have problems with tempest_smoke: odl_l3-nofeature, odl_l2-nofeature (jose_lausuch, 08:13:39)
    10. scenarios that don't pass healtcheck: ocl-nofeature (jose_lausuch, 08:13:42)
    11. ocl is libery and it isn't supported by compass long time ago (jose_lausuch, 08:17:01)
    12. ACTION: morgan_orange find compas/ocl scenario owner and asks for teh status (morgan_orange, 08:18:21)
    13. FUEL (jose_lausuch, 08:18:38)
    14. scenarios that are are fully working: nosdn-nofeature, nosdn-ovs, nosdn-kvm, odl_l2-nofeature, odl_l3-nofeature-noha (jose_lausuch, 08:18:55)
    15. scenarios that have problems with features: sfc, bgpvpn (jose_lausuch, 08:19:01)
    16. scenarios that don't pass healtcheck: nosdn-kvm_ovs_dpdk_bar, nosdn-kvm_ovs_dpdk (jose_lausuch, 08:19:12)
    17. fully working os-nosdn-kvm_ovs_dpdk-noha (morgan_orange, 08:19:45)
    18. excluded server_basic_ops from OLD scenarios in fuel. Bug reported upstream. --> to be included in the release notes (jose_lausuch, 08:22:12)
    19. JOID (jose_lausuch, 08:22:25)
    20. scenarios that are are fully working: nosdn-nofeature (jose_lausuch, 08:22:30)
    21. scenarios that have problems: nosdn-lxd (jose_lausuch, 08:22:33)
    22. scenarios that don't pass healtcheck: odl_l2-nofeature (jose_lausuch, 08:22:37)
    23. there was a discussion about excluding functest for k8 scenarios (Functest doesn't support container based deployments yet) (jose_lausuch, 08:23:12)

  4. JIRA review (jose_lausuch, 08:25:42)
    1. https://jira.opnfv.org/browse/FUNCTEST-762?jql=project%20%3D%20FUNCTEST%20AND%20issuetype%20in%20(Bug%2C%20Task)%20AND%20status%20%3D%20Open%20AND%20fixVersion%20%3D%20%22Danube%201.0%22 (jose_lausuch, 08:25:46)
    2. ACTION: ALL: check JIRA issues and try to finish them or postpone them to Danube2.0 or Euphrates when makes sense (jose_lausuch, 08:26:17)
    3. https://jira.opnfv.org/browse/FUNCTEST-762 must be clean soon (ollivier, 08:27:25)
    4. https://jira.opnfv.org/browse/FUNCTEST-616 (morgan_orange, 08:29:00)
    5. https://jira.opnfv.org/browse/FUNCTEST-614 (morgan_orange, 08:29:07)
    6. https://jira.opnfv.org/browse/RELENG-185 (SerenaFeng, 08:30:49)
    7. https://gerrit.opnfv.org/gerrit/#/c/26501/ (SerenaFeng, 08:31:17)
    8. ACTION: morgan_orange propose https://jira.opnfv.org/browse/RELENG-185 to the APAC group test WG (jose_lausuch, 08:33:52)
    9. ACTION: jose_lausuch propose demo for the hackfest about the available tooling in releng (jose_lausuch, 08:37:48)

  5. OPNFV summit proposals (jose_lausuch, 08:39:36)
    1. the CFP deadline has been extended to 4/10 (2 weeks more) (jose_lausuch, 08:39:40)
    2. https://etherpad.opnfv.org/p/TestCommunitySummit (jose_lausuch, 08:39:45)
    3. TOPIC: Design Session / Morgan (panel) (jose_lausuch, 08:40:06)
    4. TOPIC: hands on testing / Design Summit / tutorial / Jose (jose_lausuch, 08:40:12)
    5. TOPIC: Upstream and Xcollaboration (refstack, odl-netvirt) / Jose (jose_lausuch, 08:40:20)
    6. TOPIC: challenge / micro service approach how to consumme API /Design summit / Morgan (jose_lausuch, 08:40:24)
    7. TOPIC: Testing and CI gating / Design Summit / Nikolas (jose_lausuch, 08:40:27)
    8. TOPIC: TestAPI Enhancement / Design Summit (jose_lausuch, 08:41:16)
    9. TOPIC: VNF catalogue (jose_lausuch, 08:42:20)
    10. ACTION: propose a new talk about abstractions / best practices / common libraries / ... (jose_lausuch, 08:43:12)

  6. Review checkpoints (jose_lausuch, 08:43:42)
    1. Cedric initiated https://wiki.opnfv.org/display/functest/Review+checkpoints (jose_lausuch, 08:43:45)
    2. ACTION: SerenaFeng rename feature_base to feature (SerenaFeng, 08:45:35)
    3. ACTION: morgan_orange propose a vote for https://wiki.opnfv.org/display/functest/Review+checkpoints next week (jose_lausuch, 08:47:13)
    4. ollivier will propose pylint gating for commits, replacing the existing flake8 check (jose_lausuch, 08:47:45)

  7. IMS abstraction (jose_lausuch, 08:48:27)
    1. https://www.pylint.org/ (jose_lausuch, 08:49:17)
    2. https://gerrit.opnfv.org/gerrit/#/c/30681/17/functest/opnfv_tests/vnf/ims/opera_ims.py (HelenYao, 08:57:12)

  8. AoB (jose_lausuch, 08:59:53)
    1. Updated the Euphrates page: https://wiki.opnfv.org/display/functest/Functest+Euphrates+page (jose_lausuch, 09:00:48)


Meeting ended at 09:04:22 UTC (full logs).

Action items

  1. everyone to agree on Cedric's proposal: https://wiki.opnfv.org/display/functest/Review+checkpoints
  2. morgan_orange jose_lausuch prepare short summary "presentation on Functest (introduction/vision) + framework evolution and interface with third party to be initiated" and share with Functest contributors
  3. jose_lausuch update release note with referenced bug for vping (gluon, bgpvpn)
  4. morgan_orange find compas/ocl scenario owner and asks for teh status
  5. ALL: check JIRA issues and try to finish them or postpone them to Danube2.0 or Euphrates when makes sense
  6. morgan_orange propose https://jira.opnfv.org/browse/RELENG-185 to the APAC group test WG
  7. jose_lausuch propose demo for the hackfest about the available tooling in releng
  8. propose a new talk about abstractions / best practices / common libraries / ...
  9. SerenaFeng rename feature_base to feature
  10. morgan_orange propose a vote for https://wiki.opnfv.org/display/functest/Review+checkpoints next week


Action items, by person

  1. jose_lausuch
    1. morgan_orange jose_lausuch prepare short summary "presentation on Functest (introduction/vision) + framework evolution and interface with third party to be initiated" and share with Functest contributors
    2. jose_lausuch update release note with referenced bug for vping (gluon, bgpvpn)
    3. jose_lausuch propose demo for the hackfest about the available tooling in releng
  2. morgan_orange
    1. morgan_orange jose_lausuch prepare short summary "presentation on Functest (introduction/vision) + framework evolution and interface with third party to be initiated" and share with Functest contributors
    2. morgan_orange find compas/ocl scenario owner and asks for teh status
    3. morgan_orange propose https://jira.opnfv.org/browse/RELENG-185 to the APAC group test WG
    4. morgan_orange propose a vote for https://wiki.opnfv.org/display/functest/Review+checkpoints next week
  3. SerenaFeng
    1. SerenaFeng rename feature_base to feature
  4. UNASSIGNED
    1. everyone to agree on Cedric's proposal: https://wiki.opnfv.org/display/functest/Review+checkpoints
    2. ALL: check JIRA issues and try to finish them or postpone them to Danube2.0 or Euphrates when makes sense
    3. propose a new talk about abstractions / best practices / common libraries / ...


People present (lines said)

  1. jose_lausuch (190)
  2. morgan_orange (82)
  3. SerenaFeng (33)
  4. ollivier (30)
  5. HelenYao (20)
  6. LindaWang1 (7)
  7. collabot (6)
  8. OPNFV-Gerrit-Bot (5)
  9. juhak (2)
  10. boucherv (2)
  11. shuya_ool (1)
  12. MatthewLi (1)
  13. CristinaPauna (1)


Generated by MeetBot 0.1.4.