08:00:08 <morgan_orange1> #startmeeting Functest weekly meeting April 4th
08:00:08 <collabot`> Meeting started Tue Apr  4 08:00:08 2017 UTC.  The chair is morgan_orange1. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:08 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:08 <collabot`> The meeting name has been set to 'functest_weekly_meeting_april_4th'
08:00:13 <morgan_orange1> #topic call role
08:00:19 <morgan_orange1> #info Morgan Richomme
08:01:13 <morgan_orange1> #info Jose is at ONS (so hopefully sleeping now it is  AM local time)
08:01:22 <morgan_orange1> #link https://pbs.twimg.com/media/C8gh7ecUAAAMV9T.jpg:large
08:02:08 <morgan_orange1> If I am alone, it will be short :)...post Release side effect...
08:02:35 <boucherv> #info Valentin Boucher
08:02:58 <morgan_orange1> boucherv:  ça compte pas..si on est que tous les 2 je vais prendre mon thé... :)
08:03:33 <morgan_orange1> quorum not reached, I will anyway put the action point follow up topic
08:03:43 <morgan_orange1> #topic action points follow-up
08:03:51 <morgan_orange1> #info AP1: everyone to agree on Cedric's proposal: https://wiki.opnfv.org/display/functest/Review+checkpoints
08:04:08 <morgan_orange1> #info done (at least me and Jose)
08:04:12 <ollivier> #info Cédric
08:04:17 <morgan_orange1> #info AP2: morgan_orange jose_lausuch prepare short summary "presentation on Functest (introduction/vision) + framework evolution and interface with third party to be initiated" and share with Functest contributors
08:04:26 <ollivier> morgan_orange1: we could add a section about voting rules
08:04:26 <Shuya> #info Shuya
08:04:28 <morgan_orange1> #info work initiated by ollivier... :) a section had been added on teh abstraction class in the developer guide but a deeper discussion needed during the plugfest
08:04:52 <morgan_orange1> #action jose_lausuch plan a slot for this topic during the Hackfest in Paris
08:05:04 <morgan_orange1> #info AP3: jose_lausuch update release note with referenced bug for vping (gluon, bgpvpn)
08:05:09 <morgan_orange1> #info done
08:05:19 <morgan_orange1> #info AP4: morgan_orange find compas/ocl scenario owner and asks for the status
08:05:26 <morgan_orange1> #info mail sent (Artur taylot for ocl/joid, chigang ocl/compass and Stuart Mackie for Juniper - note ovno project created a long time ago did even not branch this time causing CI errors...) wait for feedback.
08:05:36 <morgan_orange1> #info AP5: ALL: check JIRA issues and try to finish them or postpone them to Danube2.0 or Euphrates when makes sense
08:05:43 <morgan_orange1> #info done, Jose sent a mail to indicate that Functest was clean
08:05:50 <morgan_orange1> #info even if JIRAs are probably one of the worst indicator (code is more trustable), it is important to keep it clean .....
08:05:56 <morgan_orange1> #info shall we create guideline for JIRA as we have for review?
08:06:03 <morgan_orange1> #info could make sense to try to be consistant, for the moment we have Jira for bug corrections, tasks, feature implementations, sometimes small, sometimes big, sometime several JIRAs for the same task.
08:06:05 <ollivier> Sure.
08:06:17 <morgan_orange1> what is your view? do you have any pressure to write JIRA (evidence for managmement of the activity?)
08:06:28 <ollivier> Code first
08:06:56 <ollivier> gerrit is the key point for activities
08:07:16 <morgan_orange1> as the quorum is limited today, it will be hard to have a discussion but I will take the action point to create such page
08:07:37 <morgan_orange1> #action morgan initiate page for Jira best practices in Functest
08:07:44 <morgan_orange1> #info AP6: morgan_orange propose https://jira.opnfv.org/browse/RELENG-185 to the APAC group test WG
08:07:56 <morgan_orange1> #info done
08:08:01 <morgan_orange1> #action SerenaFeng plans a short slide deck for the meeting planned on the 12th (could be reused for the plugfest)
08:08:07 <morgan_orange1> #info AP7: jose_lausuch propose demo for the hackfest about the available tooling in releng
08:08:14 <morgan_orange1> #info due to Release/ONS I assume it is not done yet
08:08:20 <morgan_orange1> #action jose_lausuch propose demo for the hackfest about the available tooling in releng
08:08:27 <morgan_orange1> #info AP8: propose a new talk about abstractions / best practices / common libraries / ...
08:08:31 <morgan_orange1> #info ???
08:08:49 <ollivier> AP8 could be moderated
08:08:52 <morgan_orange1> did anyone intiate anything on this topic
08:09:17 <ollivier> some abstractions are wrong and coverage is partial
08:09:18 <morgan_orange1> I assume it was for a panel during design summit..
08:10:10 <morgan_orange1> a good topic for the plugfest as well
08:10:20 <morgan_orange1> #info AP9: SerenaFeng rename feature_base to feature
08:10:24 <morgan_orange1> #info done
08:10:32 <morgan_orange1> #info AP10: morgan_orange propose a vote for https://wiki.opnfv.org/display/functest/Review+checkpoints next week
08:10:43 <morgan_orange1> #info I think that due to ONS, the quorum is not reached
08:11:01 <morgan_orange1> I planned the statement : "Do you validate (and then engage to follow and evangelize to third parties integrating stuff in Functest) the Functest review rules described in https://wiki.opnfv.org/display/functest/Review+checkpoints? (+1, 0, -1)"
08:11:06 <morgan_orange1> but we need more cores..
08:11:20 <morgan_orange1> so I suggest to postpone it until quorum is reached
08:11:29 <ollivier> We have to respect our rules before forwarding :)
08:12:07 <morgan_orange1> yes that is why I put "engage to follow and evangelize"
08:12:47 <ollivier> ok. then agree
08:13:33 <morgan_orange1> As the audience is low, I will go quickly on the different topics
08:13:39 <morgan_orange1> #topic Danube status
08:13:54 <morgan_orange1> #info release on the 31th of March
08:14:12 <morgan_orange1> #info functest release note updated, note that we validated less scenarios than in Colorado
08:14:24 <morgan_orange1> #info I initiated a postmortem as usual
08:14:32 <morgan_orange1> #link https://etherpad.opnfv.org/p/FunctestDanubePostMortem
08:14:44 <morgan_orange1> #info we will discuss it during the plugfest
08:15:03 <morgan_orange1> #info Jose sent a mail to thanks all the contributors, I associate myself to the the greetings
08:15:39 <morgan_orange1> #action all complete Functest postmortem (what was ++, +, - or --)
08:15:59 <morgan_orange1> #topic Feature project unit test / interface management
08:16:39 <morgan_orange1> #info ollivier started to review the way we are deailing with feature project and especially unit testing (uncovered in Danube)
08:16:58 <morgan_orange1> #info conencted to the topic on how we should manage feature project, what are our expectations in term of quality,...
08:17:22 <morgan_orange1> #link https://gerrit.opnfv.org/gerrit/#/q/status:open+project:functest+branch:master+topic:cover_features
08:17:50 <morgan_orange1> #info several dependencies mixed..will be funny to merge...
08:18:03 <ollivier> no issue at att
08:18:05 <ollivier> at all
08:18:33 <morgan_orange1> there is no stuff with 2 refstack patchs?
08:18:37 <morgan_orange1> #undo
08:18:37 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2460a90>
08:19:55 <morgan_orange1> #info several unit tests skipped (though decorator) because of pending issues (JIRA indicated in the decorator)
08:20:06 <ollivier> sure. But it's quite simple to fix. My main concern is about update my patch you have commented
08:20:42 <morgan_orange1> https://gerrit.opnfv.org/gerrit/#/c/32083/
08:20:58 <morgan_orange1> yes
08:21:04 <morgan_orange1> so we shoudl merge quickly...
08:21:05 <ollivier> Yes. I'am taking your comment into account
08:21:28 <morgan_orange1> I am pretty sure, most of teh contributors will sleep several days (usual way after a release)
08:21:46 <morgan_orange1> but as there are lots of files...it could be painful to maintain
08:21:58 <morgan_orange1> we can action Jose, I think there are already some +2
08:23:28 <morgan_orange1> #action jose_lausuch review https://gerrit.opnfv.org/gerrit/#/c/32083/ and associate patches (32083 impacting all the feature projects..need to be merged to avoid too many rebasing)
08:24:02 <morgan_orange1> ollivier: you want to add somethign on this topic?
08:25:14 <morgan_orange1> #topic review Functest Euphrates page / discussion priorities
08:25:23 <morgan_orange1> #info connected with postmortem
08:25:33 <morgan_orange1> #info preparation for the plugfest
08:25:34 <morgan_orange1> #link https://wiki.opnfv.org/display/functest/Functest+Euphrates+page
08:25:49 <morgan_orange1> #info we should discuss the priorities and the tasks for next release
08:25:55 <morgan_orange1> need a bigger forum
08:26:06 <morgan_orange1> #action ALL review Functest Euphrates page
08:26:09 <boucherv> We can add a topic on VNF in the CI
08:26:42 <morgan_orange1> boucherv: in the postmortem I put a -- on scenario promotion and weekly job => it can be converted into soemthing in the Euphrates pages
08:27:05 <boucherv> morgan_orange1: Yes, Ok
08:27:30 <morgan_orange1> #info boucherv suggest adding a topic on VNF in CI (only 1 weekly job on fuel /master created ) => either scenario promotion or more weekly jobs to be created if we want to give feedback to VNF providers
08:27:31 <OPNFV-Gerrit-Bot> Cedric Ollivier proposed functest: Add case_name as constructor arg  https://gerrit.opnfv.org/gerrit/32083
08:27:52 <morgan_orange1> #topic reporting scenario status using the test API
08:28:13 <morgan_orange1> #info today we build reporting page by calling teh API. the scenario score is hosted in a txt file locally
08:28:28 <morgan_orange1> #info we made an evolution of teh test API and create a sceanrio object
08:28:36 <morgan_orange1> #info for scenario promotion we need to use them
08:28:51 <morgan_orange1> #info at the end of a CI loop we should use the APi to update the scenario scoring
08:29:16 <morgan_orange1> #link http://testresults.opnfv.org/test/api/v1/scenarios?name=os-fake-ha
08:29:45 <morgan_orange1> #info the scenario object will contains: scenario owner / score / custom test lists...
08:30:21 <morgan_orange1> we are not so many so calling for volunteer does not make really sense :)
08:30:40 <morgan_orange1> #info to be discussed during the plugfest - Danube 2.0 is planned for May
08:30:58 <morgan_orange1> #info this mechanism could be put in place in // with existing one (transition during danube)
08:31:11 <morgan_orange1> #info using scenario backend will be also useful for the gloabl test landing page
08:31:23 <morgan_orange1> #action morgan_orange1 organize a discussion during the plugfest
08:31:26 <morgan_orange1> #topic AoB
08:31:35 <morgan_orange1> any topic you would like to discuss
08:32:00 <morgan_orange1> Shuya: I assume you are working in okinawa Lab, rught?
08:32:17 <Shuya> you are right
08:32:38 <morgan_orange1> do you know if hideyashi will submit a talk on vyos_vrouter testing for the Summit?
08:33:22 <morgan_orange1> welcome by the way :)
08:33:53 <Shuya> yes. He submited cfp last week.
08:33:59 <morgan_orange1> ok great
08:34:20 <morgan_orange1> will you attend the plugfest?
08:35:11 <morgan_orange1> ollivier: boucherv do you want to add something...
08:35:19 <morgan_orange1> if not I suggest to close the meeting now...
08:35:32 <Shuya> sorry. I not attend the plugfest.
08:35:36 <ollivier> #agree
08:35:44 <boucherv> #agree too
08:35:50 <Shuya> #agree too
08:35:59 <morgan_orange1> Shuya: it is along way from Okinawa to paris. Maybe a chance to meet in Beijing
08:36:01 <morgan_orange1> Ok
08:36:05 <morgan_orange1> so have a good week
08:36:11 <morgan_orange1> congratulations for Danube 1.0
08:36:16 <morgan_orange1> show must go on...
08:36:22 <morgan_orange1> #endmeeting