#opnfv-functest: Functest weekly meeting May 16th 2017

Meeting started by jose_lausuch at 08:00:13 UTC (full logs).

Meeting summary

  1. role call (jose_lausuch, 08:00:51)
    1. Cédric (ollivier, 08:00:56)
    2. Morgan (morgan_orange, 08:00:58)
    3. Jose Lausuch (jose_lausuch, 08:01:02)
    4. agenda for today: https://wiki.opnfv.org/display/functest/Functest+Meeting#FunctestMeeting-16/05(8UTC) (jose_lausuch, 08:01:38)
    5. Shuya(OOL) (Shuya_ool, 08:01:43)
    6. Juha Kosonen (juhak, 08:02:13)
    7. SerenaFeng (SerenaFeng, 08:02:20)

  2. Action point follow-up (jose_lausuch, 08:03:36)
    1. AP: HelenYao sync with jack Chan for internal API (jose_lausuch, 08:03:46)
    2. ACTION: HelenYao sync with jack Chan for internal API (jose_lausuch, 08:04:20)
    3. AP: https://www.surveymonkey.com/r/7ZNPMMR (jose_lausuch, 08:04:24)
    4. survey closed. (jose_lausuch, 08:04:27)
    5. AP Anual Awards: https://wiki.opnfv.org/display/DEV/2017+Annual+Award+Nominations (jose_lausuch, 08:04:47)

  3. Decission on onos and onos_sfc (jose_lausuch, 08:05:33)
    1. Linda Wang (LindaWang, 08:05:35)
    2. Some comments in JIRA: https://jira.opnfv.org/browse/FUNCTEST-820 (jose_lausuch, 08:05:38)
    3. LindaWang want will follow up with Huawei team to see if onos_sfc will be part of Euphrates or not (jose_lausuch, 08:10:23)

  4. Progress on framework (morgan_orange, 08:23:41)
    1. lots of changes provided by Cedric (morgan_orange, 08:24:02)
    2. run_tests also under refactoring (morgan_orange, 08:24:18)
    3. Testcases.yaml to provide a flag "enabled" for each test case (jose_lausuch, 08:24:20)
    4. AGREED: automate MS2 for the feature test integration using this future flag (morgan_orange, 08:24:43)
    5. the plan is to disable all the feature tests and the MS2 criteria will be that the feature PTLs should enable if they plan to have the tests in CI (jose_lausuch, 08:24:53)
    6. ACTION: jose_lausuch work on the 'enabled' flag patcvh (jose_lausuch, 08:25:06)
    7. each feature project will have to propose a patch to (re) enable its test suite (morgan_orange, 08:25:24)
    8. along with the declaration in the DB (if not done yet) (jose_lausuch, 08:25:38)
    9. src ollivier refactoring of testcase and feature OK (morgan_orange, 08:27:36)
    10. still work on vnf (sic) (morgan_orange, 08:27:49)
    11. ACTION: morgan_orange valentin review vnf accoring to framework changes (morgan_orange, 08:28:27)
    12. create Jenkins job for api doc (ollivier, 08:29:35)
    13. to publish framework prez' (ollivier, 08:31:22)
    14. ACTION: to publish framework prez' (ollivier, 08:32:19)
    15. ACTION: morgan_orange update test case description with new catalog description field (morgan_orange, 08:32:47)
    16. ACTION: to create a Jenkins job for api doc (ollivier, 08:35:49)
    17. create a tag in MASTER branch when Functest meets the Dovetail requirements (jose_lausuch, 08:46:23)
    18. tag name to be decided (jose_lausuch, 08:46:30)

  5. Status on Kumar VNF's catalogue (jose_lausuch, 08:50:50)
    1. https://gerrit.opnfv.org/gerrit/#/q/status:open+project:functest+branch:stable/danube+topic:backport_refstack (ollivier, 08:50:52)
    2. Kumar made a demo during the plugfest (morgan_orange, 08:52:02)
    3. https://wiki.opnfv.org/display/DEV/VNF+Catalogue (morgan_orange, 08:52:17)
    4. he will be in Beijing for the Summit (morgan_orange, 08:52:45)
    5. LF suggest to extend the internship 1 month (morgan_orange, 08:52:57)
    6. his work shoudl be included in sample_vnf project (morgan_orange, 08:53:16)
    7. the link for the demo (morgan_orange, 08:53:23)
    8. http://ec2-34-210-8-241.us-west-2.compute.amazonaws.com:3000/ (morgan_orange, 08:53:34)
    9. ACTION: morgan_orange move from amazon hosting to opnfv resources (morgan_orange, 08:53:47)

  6. New internship proposals (morgan_orange, 08:54:32)
    1. https://wiki.opnfv.org/display/DEV/2017+Intern+Projects (jose_lausuch, 08:54:39)
    2. new proposals created on our admin pages (morgan_orange, 08:54:41)
    3. https://wiki.opnfv.org/display/functest/Functest+admin (morgan_orange, 08:55:02)
    4. proposals: vCDN, vPing evolution, VNF/Juju, Automation of performance test post processing, integration of InSpec (security) , integration of upstream K8 test suites, (morgan_orange, 08:55:57)

  7. AoB (jose_lausuch, 09:00:51)
    1. ACTION: morgan_orange contact Dave (Urschatz) to see if container suite could be done with functest/cengn mentor (morgan_orange, 09:00:59)


Meeting ended at 09:03:14 UTC (full logs).

Action items

  1. HelenYao sync with jack Chan for internal API
  2. jose_lausuch work on the 'enabled' flag patcvh
  3. morgan_orange valentin review vnf accoring to framework changes
  4. to publish framework prez'
  5. morgan_orange update test case description with new catalog description field
  6. to create a Jenkins job for api doc
  7. morgan_orange move from amazon hosting to opnfv resources
  8. morgan_orange contact Dave (Urschatz) to see if container suite could be done with functest/cengn mentor


Action items, by person

  1. jose_lausuch
    1. jose_lausuch work on the 'enabled' flag patcvh
  2. morgan_orange
    1. morgan_orange valentin review vnf accoring to framework changes
    2. morgan_orange update test case description with new catalog description field
    3. morgan_orange move from amazon hosting to opnfv resources
    4. morgan_orange contact Dave (Urschatz) to see if container suite could be done with functest/cengn mentor
  3. UNASSIGNED
    1. HelenYao sync with jack Chan for internal API
    2. to publish framework prez'
    3. to create a Jenkins job for api doc


People present (lines said)

  1. jose_lausuch (184)
  2. morgan_orange (106)
  3. ollivier (33)
  4. SerenaFeng (18)
  5. collabot (6)
  6. LindaWang (5)
  7. juhak (1)
  8. Shuya_ool (1)


Generated by MeetBot 0.1.4.