#opnfv-functest: Functest weekly meeting July 11th 2017

Meeting started by jose_lausuch at 08:01:20 UTC (full logs).

Meeting summary

  1. role call (jose_lausuch, 08:01:24)
    1. Jose Lausuch (jose_lausuch, 08:01:34)
    2. Morgan (morgan_orange, 08:01:34)
    3. agenda for today: https://wiki.opnfv.org/display/functest/Functest+5.+Meeting#Functest5.Meeting-11/07(8UTC) (jose_lausuch, 08:02:13)
    4. Valentin Boucher (boucherv, 08:02:26)

  2. Action Point follow-up (jose_lausuch, 08:05:01)
    1. Linda Wang (LindaWang, 08:05:38)
    2. Cédric (ollivier, 08:05:44)
    3. AP ollivier create a wiki and list all the remaining issues that prevent us from fully using Alpine (jose_lausuch, 08:05:47)
    4. wiki created with instructions how to run the new containers https://wiki.opnfv.org/display/functest/Running+new+Functest+containers (jose_lausuch, 08:05:51)
    5. AP ollivier publish Alpine Dockerfile in /docker/alpine/Dockerfile (jose_lausuch, 08:06:04)
    6. DONE. Testing and feedback in progress (jose_lausuch, 08:06:08)
    7. AP ollivier check tempest version to be used to run against Ocata. (jose_lausuch, 08:06:14)
    8. DONE. According to upper constraints, it should be 14.0.0 (jose_lausuch, 08:06:21)

  3. Alpine testing status (jose_lausuch, 08:06:52)
    1. https://gerrit.opnfv.org/gerrit/#/c/36963/12 ? (jose_lausuch, 08:07:46)
    2. last errors (snaps / refstack) are not related to Alpine (morgan_orange, 08:08:11)
    3. investigation in progress on snaps and refstack side (morgan_orange, 08:08:33)
    4. fixed bug in ansible test case https://gerrit.opnfv.org/gerrit/#/c/37137/ (jose_lausuch, 08:09:48)
    5. ACTION: ollivier docker alpine image automatic build (jose_lausuch, 08:11:43)
    6. ACTION: jose_lausuch ask Steven to promote news snaps committer (morgan_orange, 08:11:59)
    7. ACTION: jose_lausuch sync with opnfv helpdesk for automatic builds from opnfv github mirror (jose_lausuch, 08:12:52)
    8. new docker repos needed: functest-core, functest-smoke, functest-features, functest-components, functest-vnfs (jose_lausuch, 08:17:38)
    9. functest-healthcheck (jose_lausuch, 08:18:19)
    10. https://gerrit.opnfv.org/gerrit/#/c/36963/ (ollivier, 08:18:22)
    11. 1 docker repo per tier (jose_lausuch, 08:18:28)
    12. ACTION: jose_lausuch request a virtual deployment job for alpine testing (jose_lausuch, 08:22:17)
    13. ACTION: jose_lausuch review all the enabled feature test if they perform any package installation (jose_lausuch, 08:27:39)

  4. Add images in Functest (jose_lausuch, 08:30:11)
    1. https://wiki.opnfv.org/display/functest/Running+new+Functest+containers (ollivier, 08:31:29)
    2. agreed to remove add_images.sh, container images shouldn't embed images (jose_lausuch, 08:34:59)
    3. add arguments in download_images.sh for different containers/images (jose_lausuch, 08:35:17)
    4. add md5sum to comply with ONFV security audit (jose_lausuch, 08:35:33)
    5. ACTION: jose_lausuch propose a patch without add_images.sh (jose_lausuch, 08:36:52)

  5. Enabling cloudify_ims (and vnf) in daily (morgan_orange, 08:40:35)
    1. config done (morgan_orange, 08:40:49)
    2. wait for master CI run going beyond smoke tests... (morgan_orange, 08:41:08)
    3. vims enabled in daily jobs https://gerrit.opnfv.org/gerrit/#/c/36869/ (jose_lausuch, 08:41:24)
    4. contact with other people working on VNF onboarding tests (orchestra_ims juju_epc) => should be ready to start working on their integration on a community lab (morgan_orange, 08:42:02)
    5. ACTION: LindaWang check with Compass team about opera_ims status due to ONAP changes (jose_lausuch, 08:44:05)

  6. Logger (Valentin) (morgan_orange, 08:44:36)
    1. there has been a discussion by email about having a user-friendly console output for testcases (jose_lausuch, 08:44:59)
    2. currently, we mute all the output on screen while a testcase is running, and to see the logs you must go to the functest.log or others (jose_lausuch, 08:45:32)
    3. question is: how difficult is to implement a flag in runtest.py to enable that output? does it make sense? is it useful for our users? (jose_lausuch, 08:46:03)
    4. this is fine for CI or short test when done manually but it may be misleady for long tests (everything seems frozen) (morgan_orange, 08:46:21)
    5. ACTION: jose_lausuch propose a way to hack logging.ini in prepare_env according to env variable (jose_lausuch, 08:55:32)

  7. Rest API (jose_lausuch, 08:58:57)
    1. restart needed this morning - the statbility issue reported by Serena is not fixed (morgan_orange, 08:59:57)
    2. simple restart is enough but I have a doubt on the version currently running as paginations per cases is no more there (morgan_orange, 09:00:19)
    3. ACTION: serena-zte morgan_orange jose_lausuch sync on test API issues (morgan_orange, 09:00:42)
    4. sync meeting with Bitergia on thursday (jose_lausuch, 09:04:07)


Meeting ended at 09:07:00 UTC (full logs).

Action items

  1. ollivier docker alpine image automatic build
  2. jose_lausuch ask Steven to promote news snaps committer
  3. jose_lausuch sync with opnfv helpdesk for automatic builds from opnfv github mirror
  4. jose_lausuch request a virtual deployment job for alpine testing
  5. jose_lausuch review all the enabled feature test if they perform any package installation
  6. jose_lausuch propose a patch without add_images.sh
  7. LindaWang check with Compass team about opera_ims status due to ONAP changes
  8. jose_lausuch propose a way to hack logging.ini in prepare_env according to env variable
  9. serena-zte morgan_orange jose_lausuch sync on test API issues


Action items, by person

  1. jose_lausuch
    1. jose_lausuch ask Steven to promote news snaps committer
    2. jose_lausuch sync with opnfv helpdesk for automatic builds from opnfv github mirror
    3. jose_lausuch request a virtual deployment job for alpine testing
    4. jose_lausuch review all the enabled feature test if they perform any package installation
    5. jose_lausuch propose a patch without add_images.sh
    6. jose_lausuch propose a way to hack logging.ini in prepare_env according to env variable
    7. serena-zte morgan_orange jose_lausuch sync on test API issues
  2. LindaWang
    1. LindaWang check with Compass team about opera_ims status due to ONAP changes
  3. morgan_orange
    1. serena-zte morgan_orange jose_lausuch sync on test API issues
  4. ollivier
    1. ollivier docker alpine image automatic build


People present (lines said)

  1. jose_lausuch (144)
  2. ollivier (80)
  3. morgan_orange (50)
  4. LindaWang (15)
  5. boucherv (10)
  6. collabot` (7)
  7. OPNFV-Gerrit-Bot (5)
  8. Martin_nokia (1)
  9. mbuil (1)


Generated by MeetBot 0.1.4.