08:00:36 <jose_lausuch> #startmeeting Functest weekly meeting July 18th 2017
08:00:36 <collabot> Meeting started Tue Jul 18 08:00:36 2017 UTC.  The chair is jose_lausuch. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:36 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:36 <collabot> The meeting name has been set to 'functest_weekly_meeting_july_18th_2017'
08:00:41 <jose_lausuch> jlinkes: starting a meeting now :)
08:00:44 <jose_lausuch> #topic role call
08:00:47 <jose_lausuch> #info Jose Lausuch
08:00:50 <jose_lausuch> #info agenda for today: https://wiki.opnfv.org/display/functest/Functest+5.+Meeting#Functest5.Meeting-17/07(8UTC)
08:01:17 <LindaWang> #info Linda Wang
08:01:43 <depo> #info Delia Popescu (ENEA)
08:04:00 <jose_lausuch> serena-zte: ?
08:04:07 <jose_lausuch> we are few today
08:04:23 <serena-zte> #info SerenaFeng
08:04:55 <jose_lausuch> #topic Action Point follow up
08:05:03 <jose_lausuch> #info AP: ollivier docker alpine image automatic build. DONE: https://gerrit.opnfv.org/gerrit/#/c/37215/
08:05:09 <jose_lausuch> #info AP: jose_lausuch ask Steven to promote news snaps committer. DONE. Linda and Cedric can become committers in SNAPS after CI is properly setup for the project (a few weeks).
08:05:16 <jose_lausuch> #info AP: jose_lausuch sync with opnfv helpdesk for automatic builds from opnfv github mirror.
08:05:20 <jose_lausuch> #info We already have the docker repos created in Dockerhub, but still waiting for the automatic build from opnfv github.
08:05:22 <jose_lausuch> more information later
08:05:46 <jose_lausuch> #info AP: jose_lausuch request a virtual deployment job for alpine testing
08:05:50 <jose_lausuch> #info I created a virtual server connected to Jenkins for our Alpine testing. https://build.opnfv.org/ci/computer/ericsson-virtual-pod1bl01/
08:05:57 <jose_lausuch> I tried to run a Fuel deployment
08:06:02 <jose_lausuch> ongoing https://build.opnfv.org/ci/job/fuel-deploy-virtual-daily-danube/1143/console
08:06:26 <jose_lausuch> we still need to create jenkins jobs and a different prepare env in jenkins for alpine containers
08:06:49 <jose_lausuch> #action prepare jenkins job to run alpine containers on ericsson-virtual-pod1bl01
08:07:05 <jose_lausuch> but good progress :)
08:07:13 <jose_lausuch> #info AP: jose_lausuch review all the enabled feature test if they perform any package installation
08:07:16 <jose_lausuch> #info Some fixes in Domino https://gerrit.opnfv.org/gerrit/#/c/37385/
08:07:27 <jose_lausuch> #info Still doing some adaptations in Parser. https://gerrit.opnfv.org/gerrit/#/c/37625/
08:07:48 <jose_lausuch> #info ONOS under investigation https://gerrit.opnfv.org/gerrit/#/c/37607/
08:07:57 <jose_lausuch> #info AP: jose_lausuch propose a patch without add_images.sh
08:08:00 <jose_lausuch> #info DONE: https://gerrit.opnfv.org/gerrit/#/c/37373/
08:08:04 <jose_lausuch> #info AP: LindaWang check with Compass team about opera_ims status due to ONAP changes
08:08:06 <jose_lausuch> LindaWang: ?
08:08:08 <LindaWang> Lots of stuff needs to be developed from the side of ONAP.
08:08:13 <LindaWang> And currently, ONAP has no plan to be released in E release.
08:08:20 <LindaWang> After the scenario onap is ready, the testcase opera_ims needs to be updated for sure.
08:08:24 <LindaWang> But no one has decided to take care of this testcase in Functest yet.
08:08:42 <jose_lausuch> #info currently, ONAP has no plan to be released in E release.
08:08:51 <jose_lausuch> #info but the scenario onap is ready, the testcase opera_ims needs to be updated
08:08:56 <jose_lausuch> ok...
08:09:08 <jose_lausuch> seems that there won't be much action in this area
08:09:14 <jose_lausuch> at least in this release
08:09:16 <LindaWang> yes
08:09:19 <jose_lausuch> ok
08:09:19 <jose_lausuch> thanks
08:09:27 <jose_lausuch> #info AP: jose_lausuch propose a way to hack logging.ini in prepare_env according to env variable
08:09:35 <jose_lausuch> #info 2 proposals: 1) https://gerrit.opnfv.org/gerrit/#/c/37263/   2) https://gerrit.opnfv.org/gerrit/#/c/37287/
08:09:38 <jose_lausuch> #info Waiting for feedback. Valenting and Serena prefer option 2)
08:10:01 <jose_lausuch> #info AP: serena-zte morgan_orange jose_lausuch sync on test API issues
08:10:02 <jose_lausuch> serena-zte: ?
08:10:20 <serena-zte> I am testing the stability
08:10:45 <serena-zte> update to 17.03.1-ce
08:10:58 <serena-zte> test it 100 times
08:11:11 <serena-zte> no crash for now
08:11:25 <jose_lausuch> ok
08:11:35 <serena-zte> I don't whether it is because rohit's new patch solve it for good
08:11:57 <jose_lausuch> #info serena-zte testing the stability and seems ok now with the update to 17.03.1-ce
08:11:59 <jose_lausuch> sounds good
08:12:15 <serena-zte> I will continue testing hope we can solve it for good
08:12:16 <jose_lausuch> it's better we have this problems now than 1 month before the  E release :)
08:12:40 <serena-zte> yeah
08:13:01 <jose_lausuch> ok
08:13:01 <jose_lausuch> great
08:13:04 <jose_lausuch> first topic
08:13:04 <jose_lausuch> #topic Alpine testing status
08:13:17 <jose_lausuch> the whole Orange crew is on vacation...
08:13:20 <jose_lausuch> but there we go
08:13:28 <jose_lausuch> maybe we have some good progress before they come back :)
08:13:29 <jose_lausuch> #info Functest docker repositories created in Dockerhub: https://hub.docker.com/u/opnfv/dashboard/?page=2
08:13:34 <jose_lausuch> #info functest-core functest-healthcheck functest-smoke functest-features functest-components functest-vnf
08:14:06 <LindaWang> 404 page not found
08:14:29 <jose_lausuch> oops
08:14:31 <jose_lausuch> wait
08:14:51 <jose_lausuch> https://hub.docker.com/u/opnfv/?page=2
08:14:52 <jose_lausuch> better?
08:14:55 <jose_lausuch> #info https://hub.docker.com/u/opnfv/?page=2
08:15:05 <LindaWang> Fine
08:15:10 <LindaWang> Thanks
08:15:40 <jose_lausuch> #info I connected an Ericsson free server to jenkins with CentOS https://build.opnfv.org/ci/computer/ericsson-virtual-pod1bl01/
08:15:53 <jose_lausuch> #info currently doing some tests with Fuel, but we can use any installer in principle
08:15:58 <jose_lausuch> #link https://build.opnfv.org/ci/job/fuel-deploy-virtual-daily-danube/1143/console
08:16:19 <jose_lausuch> #info the idea is to use this server for our Alpine testing
08:16:54 <jose_lausuch> #action jose_lausuch create a jenkins job that triggers a deployment + testing on this server with Alpine containers. Healthcheck+smoke for the momment
08:16:59 <serena-zte> when you say fuel, you mean the original fuel or mcp?
08:17:06 <jose_lausuch> I'm using Fuel stable/danube
08:17:11 <jose_lausuch> which deploys fine in CI
08:17:17 <jose_lausuch> we can switch to whatever
08:17:28 <jose_lausuch> but since I have more experience with Fuel ... I tried it with it
08:17:39 <serena-zte> Okey, got it
08:17:49 <jose_lausuch> and Fuel danube had the most blue dots in jenkins
08:17:56 <jose_lausuch> but as said, we can change that later
08:18:02 <jose_lausuch> it's triggered manually anyway
08:18:06 <jose_lausuch> for testing
08:18:12 <jose_lausuch> we can automate it of course
08:18:22 <jose_lausuch> after every patch merge in Functest for example
08:19:08 <jose_lausuch> I think its getting in a good shape :)
08:19:18 <jose_lausuch> and cedric will be happy to see his stuff tested in jenkins
08:20:09 <LindaWang> IS there a need to test alpine based image in compass? If a free pod is provided.
08:21:30 <LindaWang> Now functest tests  run quite well in compass master (nosdn-nofeature) in CI.
08:21:35 <jose_lausuch> LindaWang: if Huawei or someone can provide a free server, we can of course do that
08:22:04 <LindaWang> It seems that https is not supported by cloudify_ims yet.
08:22:24 <jose_lausuch> aha
08:22:26 <LindaWang> I will check with our lab manager
08:22:49 <jose_lausuch> #action Linda check for a free baremetal server to connect it to jenkins for Alpine testing in Compass
08:22:57 <jose_lausuch> it would be great
08:23:01 <jose_lausuch> so we can have more than 1 job
08:23:07 <LindaWang> Baremetal?
08:23:12 <jose_lausuch> yes
08:23:15 <jose_lausuch> 1 server
08:23:19 <LindaWang> Is virtual ok?
08:23:19 <jose_lausuch> for virtual deployments
08:23:23 <LindaWang> ok
08:23:25 <LindaWang> fine
08:23:46 <jose_lausuch> good
08:24:02 <jose_lausuch> we don't have more topics in the agenda
08:24:08 <jose_lausuch> would you like to talk about something ?
08:24:10 <jose_lausuch> we have time...
08:24:26 <LindaWang> Could anybody available help review the restapi patch?
08:24:39 <serena-zte> about that
08:24:42 <LindaWang> Comments are welcome
08:24:51 <jose_lausuch> #action all review Functest API proposal https://gerrit.opnfv.org/gerrit/#/c/36703/
08:24:54 <serena-zte> I suggest to add swagger specification for the first time
08:25:03 <LindaWang> Why?
08:25:05 <serena-zte> we will do it anyay
08:25:11 <serena-zte> we need to do it anyway
08:25:36 <jose_lausuch> you mean in the same patch?
08:25:36 <serena-zte> since you provide api impl, it would be better to tell people how to use it, what the interfaces look like
08:25:41 <serena-zte> yes
08:25:55 <jose_lausuch> shouldn't we split the work?
08:26:01 <jose_lausuch> otherwise the patch will be too big
08:26:02 <jose_lausuch> to review
08:26:21 <LindaWang> The patch  is already a bit large
08:26:24 <serena-zte> then I would suggest to impl it interface by interface
08:27:16 <serena-zte> another patch also ok since the patch is already submitted
08:27:28 <jose_lausuch> ya
08:27:32 <jose_lausuch> it would mean a lot of changes again
08:27:41 <jose_lausuch> and Linda has been doing this proposal for a while
08:27:51 <serena-zte> but swagger should be provided together
08:27:54 <jose_lausuch> but agree, we should have the specification for sure
08:28:04 <jose_lausuch> LindaWang: can you do that on top of this patch?
08:28:06 <serena-zte> it is difficult to manage the interface usage manually
08:28:10 <jose_lausuch> I mean, in another one dependent on this?
08:28:32 <jose_lausuch> serena-zte: you have some experience with it, could you help LindaWang about the specification?
08:28:34 <LindaWang> I feel it is a large workload if I add swagger for the first time
08:28:36 <jose_lausuch> (I have no clue) :)
08:28:50 <LindaWang> Fine
08:29:22 <serena-zte> Sure, LindaWang ping me on irc
08:29:28 <jose_lausuch> thank you
08:29:32 <LindaWang> serena-zte: Thanks:)
08:29:43 <jose_lausuch> #info create swagger specification on top of this proposal
08:29:44 <serena-zte> and flask_swagger is provided, you can leverage it directly
08:29:55 <serena-zte> I already give the link in my comment
08:29:59 <jose_lausuch> by the way, https://gerrit.opnfv.org/gerrit/#/c/36703/13/functest/api/__init__.py    is __init__.py meant to contain code???
08:30:22 <LindaWang> yes
08:30:37 <jose_lausuch> I thought __init__.py files are supposed to be emtpy
08:30:43 <jose_lausuch> they just define that there is a module
08:30:43 <serena-zte> I think it depends on the structure
08:30:47 <serena-zte> not exactly
08:31:04 <serena-zte> sometime it is used to accomodate some information too
08:31:14 <jose_lausuch> I've only seen headers :)
08:31:15 <jose_lausuch> but ok
08:31:17 <jose_lausuch> if you say so
08:31:21 <jose_lausuch> never implemented an api...
08:31:23 <jose_lausuch> so ok
08:31:29 <jose_lausuch> :)
08:31:37 <jose_lausuch> LindaWang: I'll review it today
08:31:52 <LindaWang> Finally , thanks
08:32:01 <jose_lausuch> and you got a +1 from jenkins
08:32:14 <serena-zte> but usually it is empty
08:32:33 <jose_lausuch> ok
08:32:58 <jose_lausuch> but does it make sense in this case?
08:33:04 <jose_lausuch> to be full of code?
08:33:53 <serena-zte> https://github.com/openstack/nova/blob/master/nova/__init__.py
08:34:05 <serena-zte> nova also fill something in __init__.py
08:34:14 <jose_lausuch> but not a full implementation of a class
08:34:42 <serena-zte> yes
08:34:51 <serena-zte> full impl of a class I never see it also
08:35:05 <LindaWang> https://github.com/openstack/nova/blob/master/nova/network/__init__.py
08:35:07 <serena-zte> it should be some import or environ relevant work
08:35:29 <jose_lausuch> would it make sense to move it to a new file?
08:35:44 <serena-zte> it shouldn't be very heavy in my opinion
08:36:14 <jose_lausuch> LindaWang: ?
08:36:52 <LindaWang> Not so heavy
08:36:57 <serena-zte> The majority opinion seems to be that __init__.py files should be very thin to avoid violating the "explicit is better than implicit" philosophy.
08:37:14 <LindaWang> jose_lausuch: But if you insist on that, i will change it to new file
08:37:25 <jose_lausuch> I'm not an expert
08:37:36 <jose_lausuch> but I think best practices is to keep that file thin
08:37:45 <LindaWang> It is thin
08:38:25 <jose_lausuch> https://stackoverflow.com/questions/448271/what-is-init-py-for
08:38:30 <jose_lausuch> but not thin enough
08:38:35 <jose_lausuch> it contains 2 classes
08:38:37 <jose_lausuch> small, but 2 classes
08:39:05 <LindaWang> https://github.com/openstack/neutron/blob/master/neutron/quota/__init__.py
08:39:36 <serena-zte> I cannot open gerrit now
08:39:44 <jose_lausuch> The __init__.py files are required to make Python treat the directories as containing packages; this is done to prevent directories with a common name, such as string, from unintentionally hiding valid modules that occur later on the module search path. In the simplest case, __init__.py can just be an empty file, but it can also execute initialization code for the package or set the __all__ variable, described later.
08:40:06 <jose_lausuch> oh
08:40:25 <jose_lausuch> LindaWang: you just destroyed my best practices :D
08:40:55 <LindaWang> Sorry, I just learned it from upstream project
08:40:58 <LindaWang> :)
08:40:59 <jose_lausuch> I just looked it up in the documentation https://docs.python.org/3/tutorial/modules.html#packages
08:41:27 <jose_lausuch> The __init__.py file is usually empty, but can be used to export selected portions of the package under more convenient name, hold convenience functions, etc. Given the example above, the contents of the init module can be accessed as
08:41:29 <jose_lausuch> https://pythontips.com/2013/07/28/what-is-__init__-py/
08:41:47 <jose_lausuch> serena-zte: what is your preference then?
08:41:48 <serena-zte> as regards to class, in my opinion it should be put in a specific file, to make it better structured
08:41:50 <jose_lausuch> new file or init?
08:41:57 <jose_lausuch> I think the same
08:42:32 <LindaWang> It is up to your idea, jose_lausuch and serena-zte
08:43:02 <serena-zte> it should be splitted to model(data model), handlers/controllers
08:43:07 <jose_lausuch> then, let's create a new file for that :)
08:43:14 <LindaWang> :(
08:43:32 <LindaWang> Fine....
08:43:41 <jose_lausuch> not a big deal I think
08:44:08 <LindaWang> So why do you ask for that?
08:44:21 <jose_lausuch> I mean its not a big deal to create a new file with that
08:44:29 <LindaWang> Aha
08:44:43 <jose_lausuch> all our __init__.py files in Functest are empty, let's also follow the same guidelines
08:44:56 <LindaWang> ok
08:45:06 <jose_lausuch> thanks
08:45:12 <jose_lausuch> other things ?
08:45:21 <jose_lausuch> oterhwise we can close the meeting
08:45:23 <serena-zte> internship?
08:45:27 <jose_lausuch> ah yes!
08:45:34 <serena-zte> when will we submit our proposal?
08:45:44 <jose_lausuch> I tried to talk to Ray
08:45:47 <jose_lausuch> but didnt get answer
08:45:50 <jose_lausuch> I'll try again today
08:45:58 <jose_lausuch> and I will post the internship if its ok
08:46:07 <jose_lausuch> can you provide the link to the wiki again please?
08:46:30 <jose_lausuch> Title: Add Web portal to TestAPI
08:46:51 <jose_lausuch> #action propose internship "Add Web portal to TestAPI" https://wiki.opnfv.org/display/functest/Internship+proposals
08:47:05 <serena-zte> #link https://wiki.opnfv.org/display/functest/Internship+proposals
08:47:14 <jose_lausuch> #undo
08:47:14 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x31dd410>
08:47:17 <jose_lausuch> #link https://wiki.opnfv.org/display/functest/Internship+proposals#Internshipproposals-Title:AddWebportaltoTestAPI
08:47:22 <jose_lausuch> that one, right?
08:47:30 <jose_lausuch> oops, I deleted your link
08:47:53 <serena-zte> it is ok, you have provided
08:47:55 <jose_lausuch> ok
08:48:03 <jose_lausuch> will you mentor?
08:48:04 <jose_lausuch> I help
08:48:20 <serena-zte> yes, you/morgan/me
08:48:45 <serena-zte> all mentors, I guess some details need to discussed among us
08:48:55 <jose_lausuch> yes
08:49:28 <jose_lausuch> ok
08:49:32 <jose_lausuch> let's see if I get answer today
08:49:35 <jose_lausuch> thanks for the reminder
08:49:48 <jose_lausuch> what else?
08:49:59 <serena-zte> and btw
08:50:17 <serena-zte> please help review dovetail relevant patch in testapi
08:50:23 <jose_lausuch> which one
08:50:44 <serena-zte> https://gerrit.opnfv.org/gerrit/#/c/37053/
08:50:57 <serena-zte> Leo is working on my last comment
08:51:13 <jose_lausuch> it's a huge patch as well
08:51:18 <jose_lausuch> let's see what I can do today :)
08:51:37 <serena-zte> yes, he merge upload file with role thing
08:51:52 <jose_lausuch> ok
08:51:59 <jose_lausuch> it's interenesting
08:52:01 <jose_lausuch> what roles do we have?
08:52:05 <serena-zte> they say it is in a hurry, want to be used in dovetail first version
08:52:51 <serena-zte> actually I don't know how they will use it
08:52:58 <jose_lausuch> ok
08:53:01 <jose_lausuch> I'll take a look
08:53:03 <serena-zte> all role is default one 'owner'
08:53:18 <serena-zte> they say they will change database directly to all 'admin' user
08:53:44 <jose_lausuch> ok
08:53:45 <serena-zte> all -> add
08:54:40 <jose_lausuch> good
08:54:42 <jose_lausuch> anything else?
08:55:23 <serena-zte> nope from my side
08:55:33 <jose_lausuch> LindaWang: ?
08:55:52 <LindaWang> no
08:55:55 <jose_lausuch> ok
08:55:57 <jose_lausuch> thank you
08:55:59 <jose_lausuch> have a good day
08:56:02 <jose_lausuch> #endmeeting