08:01:09 <jose_lausuch> #startmeeting Functest weekly meeting 26 Sep. 2017
08:01:09 <collabot> Meeting started Tue Sep 26 08:01:09 2017 UTC.  The chair is jose_lausuch. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:09 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:09 <collabot> The meeting name has been set to 'functest_weekly_meeting_26_sep__2017'
08:01:13 <jose_lausuch> #info Jose Lausuch
08:01:33 <jose_lausuch> #undo
08:01:33 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x3071a90>
08:01:38 <jose_lausuch> #topic role call
08:01:42 <jose_lausuch> #info Jose Lausuch
08:01:48 <LindaWang> #info Linda Wang
08:03:21 <jose_lausuch> anyone else?
08:03:36 <LindaWang> juhak:  is here too
08:03:40 <juhak> #info Juha Kosonen
08:04:22 <jose_lausuch> serena-zte: are you there?
08:04:49 <jose_lausuch> depo: ?
08:05:01 <jose_lausuch> CristinaPauna: ?
08:06:08 <CristinaPauna> hei
08:06:14 <CristinaPauna> sorry I was a bit late
08:06:30 <CristinaPauna> #info Cristina Pauna
08:06:40 <jose_lausuch> np :)
08:06:57 <jose_lausuch> it will probably be a quick meeting today
08:07:00 <depo> #info Delia Popescu
08:07:18 <jose_lausuch> the Orange colleagues can't attend today
08:07:22 <jose_lausuch> #topic action points follow up
08:07:30 <jose_lausuch> #info AP morgan_orange prepare scenario summary
08:07:34 <jose_lausuch> #info Done and sent to Release manager.
08:07:39 <jose_lausuch> #info AP morgan_orange prepare sync on status feature project integration.
08:07:44 <jose_lausuch> #info Done: https://wiki.opnfv.org/display/functest/Functest+feature+integration+status
08:07:51 <jose_lausuch> #info APĀ  depo update patches to create the containers with the same image name but different tag
08:08:02 <jose_lausuch> status of this?
08:09:42 <depo> work in progress
08:09:54 <jose_lausuch> #info Work in progress
08:09:59 <jose_lausuch> #info AP Delia look also into the possibility of using manifests not to duplicate images or create new tags
08:10:22 <depo> pending the patch until we have automated build for aarch alpine containers too
08:10:41 <depo> sent an email on manifests
08:10:53 <depo> the conclusion was not to use it yet
08:10:53 <jose_lausuch> today?
08:11:00 <depo> no, l;ast weak
08:11:07 <depo> last week
08:11:32 <jose_lausuch> hmmm ok, didn't see it...
08:11:37 <depo> we'll go with the storperf approach, but with multijob for jjb
08:11:47 <jose_lausuch> which pending patch? can you paste it here? so we accelerate the review
08:11:49 <depo> I can resend it to you
08:11:54 <jose_lausuch> ok, thanks
08:12:26 <depo> patch is not finished yet
08:12:32 <jose_lausuch> ok
08:12:50 <depo> we're focusong on the release with ubuntu containers, fixing the last failning tests
08:13:03 <jose_lausuch> #info pending the patch until we have automated build for aarch alpine containers too
08:13:10 <jose_lausuch> #info we'll go with the storperf approach, but with multijob for jjb
08:13:11 <depo> alpine will most likely go in 5.1 for aarch64
08:13:16 <jose_lausuch> ok
08:13:18 <jose_lausuch> thanks
08:13:26 <jose_lausuch> #info alpine will most likely go in 5.1 for aarch64
08:13:36 <jose_lausuch> thanks for the info
08:13:41 <jose_lausuch> #topic Internships status
08:13:47 <jose_lausuch> #info One intern selected for the Web Portal for Test API
08:13:48 <depo> thanks for the support
08:13:58 <jose_lausuch> hopefully starting on October
08:14:15 <jose_lausuch> #info Interviews still ongoing for the Kubernetes testing project, there are a few candidates
08:14:44 <jose_lausuch> #info we probably need to close the security groups intern project as it is outdated
08:14:57 <jose_lausuch> #action jose_lausuch send emails to applicants
08:15:08 <LindaWang> any internship I could help with?
08:16:00 <jose_lausuch> yes
08:16:08 <jose_lausuch> #info there are few proposals in Functest still https://wiki.opnfv.org/display/functest/Internship+proposals
08:16:47 <jose_lausuch> LindaWang: would you like to be a mentor for the Kubernetes project?
08:17:01 <LindaWang> yes, i would like to try
08:17:32 <jose_lausuch> ok, that's great, let's talk later offline :)
08:18:01 <jose_lausuch> nothing else to share regarding internships, will do another update next week
08:18:03 <jose_lausuch> #topic Euphrates Status
08:18:13 <jose_lausuch> #info Functest suite is now working and based on Alpine containers.
08:18:18 <jose_lausuch> #info Example Compass: https://build.opnfv.org/ci/job/functest-compass-virtual-suite-master/1386/
08:18:24 <jose_lausuch> #info Example Apex: https://build.opnfv.org/ci/job/functest-apex-virtual-suite-master/283/
08:18:42 <LindaWang> Still a small bug when running vping_ssh:
08:18:45 <jose_lausuch> I posted a patch with some bugs, thanks LindaWang for correcting them
08:18:50 <LindaWang> https://build.opnfv.org/ci/job/functest-compass-virtual-suite-master/1388/console
08:19:13 <LindaWang> i will fix it soon.
08:19:17 <jose_lausuch> ok
08:19:42 <jose_lausuch> run_tests: error: argument -t/--test: expected one argument
08:20:14 <jose_lausuch> is that due to https://gerrit.opnfv.org/gerrit/#/c/43099/1/jjb/functest/functest-alpine.sh ?
08:21:08 <LindaWang> cmd_opt='prepare_env start && run_tests -r -t $test_name', maybe "" should be used
08:21:31 <jose_lausuch> yes
08:21:44 <jose_lausuch> when using variables, double quotes should be used
08:21:50 <LindaWang> yes
08:22:00 <jose_lausuch> good catch
08:22:05 <jose_lausuch> again, my fault :)
08:22:19 <jose_lausuch> and fast copy-paste
08:22:38 <jose_lausuch> let me fix that at least
08:22:57 <LindaWang> sure
08:23:11 <jose_lausuch> #info Promise disabled for most of the installers, only enabled in JOID: https://gerrit.opnfv.org/gerrit/#/c/43011/
08:23:16 <jose_lausuch> #info current plan for Promise is to deprecate the current shim-layer based Promise implementation and switch to Blazar project instead, however, there are no plans to update the test cases in E release.
08:24:29 <jose_lausuch> anyone with comments about euphrates?
08:24:45 <jose_lausuch> LindaWang: do you want to info the docker problem?
08:24:54 <jose_lausuch> of multiple docker builds
08:24:58 <LindaWang> docker images build in E?
08:25:45 <LindaWang> all these docker image building are triggered in parallel.
08:26:33 <LindaWang> So we ccan not make sure functest-core is built before other images.
08:27:01 <jose_lausuch> yes
08:27:22 <LindaWang> another issue: with more and more docker image building job, it is easy to timeout
08:27:57 <jose_lausuch> it was ok before, with only sporadic docker builds
08:28:02 <jose_lausuch> but now we are including all the alpine images
08:28:09 <jose_lausuch> we need a more efficient way to build images
08:28:13 <serena-zte> Sorry for the late, regarding to docker build, I have another question
08:28:17 <jose_lausuch> an email was sent yesterday by Mark
08:28:21 <LindaWang> yes
08:28:24 <jose_lausuch> we can also discuss it there, I will try to answer
08:28:36 <jose_lausuch> serena-zte: np, what question?
08:28:45 <serena-zte> since we only demo Functest repo, if the code in the feature project changed, such as parser
08:29:07 <serena-zte> the image will not be built, until Functest repo change
08:30:08 <serena-zte> and the feature project is installed during docker build, so the new changes will not be included
08:30:26 <jose_lausuch> serena-zte: that is absolutely right :)
08:30:40 <jose_lausuch> but that has been like this before
08:30:54 <jose_lausuch> but since we are merging code everyday.. it's not a major problem
08:31:02 <jose_lausuch> but you are right
08:31:09 <serena-zte> currently it's ok
08:31:22 <serena-zte> but once Functest is stable, it will be a problem
08:31:31 <jose_lausuch> we can change this behavior, but if we trigger a build everytime any repo we integrate has a change, we probably overload the system with builds
08:31:33 <serena-zte> imp, we should take this into consideration
08:31:37 <jose_lausuch> yes
08:31:45 <serena-zte> yes
08:31:50 <jose_lausuch> we first need to fix the concurrency problem
08:32:45 <serena-zte> ok,
08:33:21 <serena-zte> about this we need to study docker build mechanism in docker hub, to see if they can be processed in serial
08:35:20 <jose_lausuch> I proposed that some time ago and it was rejected
08:35:36 <jose_lausuch> the community wants to use our own servers and scripts
08:35:43 <jose_lausuch> so we have 100% control of what we need
08:36:29 <LindaWang> But why is it still updated? https://hub.docker.com/r/opnfv/functest-healthcheck/builds/
08:36:46 <jose_lausuch> it's optional
08:36:53 <jose_lausuch> people can use the dockerhub mechanisms
08:37:03 <jose_lausuch> but in general, opnfv servers should be use
08:37:16 <jose_lausuch> we could do our builds in dockerhub if we want
08:37:27 <jose_lausuch> but then we need to disable it from opnnfv-docker.sh
08:37:32 <LindaWang> functest-core is will be built first via docker hub mechanism?
08:38:09 <jose_lausuch> also the others https://hub.docker.com/r/opnfv/functest-smoke/~/settings/automated-builds/
08:38:10 <LindaWang> Compass team build their several images by docker hub.
08:38:33 <jose_lausuch> shall we build things in dockerhub and stop opnfv-docker.sh ?
08:38:38 <LindaWang> 404 page not found.
08:38:39 <jose_lausuch> I'm fine with it
08:38:44 <jose_lausuch> https://hub.docker.com/r/opnfv/functest-smoke/builds/
08:38:46 <LindaWang> me too.
08:39:35 <serena-zte> if it can meet with our requirements, such as build functest-core first, I am also fine with it
08:39:41 <jose_lausuch> by the way, in all the cases, we are using master images in functest-alpine.sh
08:39:53 <jose_lausuch> we don't specify a tag in alpine job
08:39:57 <jose_lausuch> I can fix that
08:40:05 <LindaWang> Could you send an email to our team members to discuss it?  jose_lausuch
08:40:22 <jose_lausuch> #action jose_lausuch add euphrates support in functest-alpine.sh
08:40:28 <jose_lausuch> LindaWang: yes
08:41:43 <jose_lausuch> ok
08:41:47 <jose_lausuch> anything else on this topic?
08:42:22 <serena-zte> nope
08:42:30 <LindaWang> Maybe you could remove ericsson-virtual-pod1bl01 for alpine testing e
08:42:35 <LindaWang> https://git.opnfv.org/releng/tree/jjb/functest/functest-daily-jobs.yml#n193
08:42:48 <jose_lausuch> yes, it's not used any more
08:43:05 <jose_lausuch> not so important though
08:43:25 <jose_lausuch> #action remove ericsson-virtual-pod1bl01 from functest alpine pods
08:43:55 <jose_lausuch> #topic AoB
08:44:01 <jose_lausuch> #info Docker image danube.3.0 is missing.
08:44:08 <jose_lausuch> for some reason it's not there
08:44:15 <jose_lausuch> #action jose_lausuch build it again and push it
08:44:23 <LindaWang> jose_lausuch:  thanks
08:44:27 <jose_lausuch> anything else ?
08:44:31 <LindaWang> no
08:44:33 <jose_lausuch> otherwise, we can close now
08:46:11 <jose_lausuch> ok
08:46:13 <jose_lausuch> thanks everyone
08:46:16 <jose_lausuch> #endmeeting