08:01:18 <jose_lausuch> #startmeeting Functest weekly meeting 17 Oct. 2017
08:01:18 <collabot> Meeting started Tue Oct 17 08:01:18 2017 UTC.  The chair is jose_lausuch. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:18 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:18 <collabot> The meeting name has been set to 'functest_weekly_meeting_17_oct__2017'
08:01:25 <jose_lausuch> #info Agenda https://wiki.opnfv.org/display/functest/Functest+5.+Meeting#Functest5.Meeting-17/10(8UTC)
08:01:30 <jose_lausuch> #topic role call
08:01:34 <jose_lausuch> #info Jose Lausuch
08:01:46 <morgan_orange> #info Morgan Richomme
08:02:17 <LindaWang> #info Linda Wang
08:02:24 <CristinaPauna> #info Cristina Pauna
08:04:39 <jose_lausuch> #chair morgan_orange
08:04:39 <collabot> Current chairs: jose_lausuch morgan_orange
08:04:43 <jose_lausuch> 
08:04:43 <jose_lausuch> #topic action points follow up
08:04:56 <jose_lausuch> #info AP morgan_orange contact Daisy team to get details on metadata management
08:05:00 <depo> #info Delia Popescu
08:05:22 <morgan_orange> #info first contact established, mail shared this morning
08:05:51 <jose_lausuch> ok
08:05:59 <jose_lausuch> #info AP  xudan bring topic of custom testcases.yaml to Dovetail team
08:06:05 <jose_lausuch> xudan: are you there?
08:06:10 <xudan> yes
08:06:25 <jose_lausuch> did you talk to Dovetail team about the tempest custom?
08:06:34 <xudan> Last week Dovetail meeting we have discussed this.
08:06:53 <jose_lausuch> what is the outcome of the discussion?
08:07:14 <xudan> But we haven't choose a plan for this. (use Functest containers or maintain our container)
08:07:37 <jose_lausuch> #info xudan brought the topic to last week Dovetail´s meeting and the team hasn't chosen a plan for it (use Functest containers or maintain our container)
08:07:43 <xudan> Our team will discuss it futher
08:07:49 <jose_lausuch> I thought the discussion was about the custom testcases.yaml
08:07:59 <jose_lausuch> #info The team will discuss further
08:08:15 <xudan> Thanks for the help.
08:08:17 <jose_lausuch> xudan: I don't understand that
08:08:29 <jose_lausuch> I thought Dovetail container was running Functest container
08:08:32 <jose_lausuch> is that right?
08:08:37 <xudan> Yes.
08:09:53 <jose_lausuch> but then
08:10:05 <jose_lausuch> you will use Functest containers anyway
08:10:25 <jose_lausuch> when you said "use Functest containers or maintain our container"
08:11:02 <jose_lausuch> the idea is to use Alpine containers as the Ubuntu will be removed once Arm jobs work on Alpine
08:11:30 <jose_lausuch> removed = stop maintaining and building new images
08:11:37 <xudan> morgan suggested in the email that everyone can maintain their own alpine container.
08:12:25 <xudan> I think it's a good way for us if we want to run multiple test cases
08:12:27 <jose_lausuch> yes, let's make clear that is the alpine method
08:12:40 <jose_lausuch> so you could create functest-dovetail or dovetail-functest
08:12:46 <jose_lausuch> in your docker repo
08:12:57 <jose_lausuch> based on functest-core
08:12:59 <xudan> Yes. We only consider Alpine ones.
08:13:00 <jose_lausuch> for example
08:13:02 <jose_lausuch> ok
08:13:03 <jose_lausuch> thanks
08:13:18 <xudan> thanks.
08:13:29 <jose_lausuch> xudan: let us know when you start doing that job and we will help if you need
08:13:45 <xudan> sure. Thanks
08:13:45 <jose_lausuch> #info Release status
08:13:52 <jose_lausuch> #info The Euphrates release 5.0 is this Friday
08:14:02 <jose_lausuch> #info action jose_lausuch finish release notes
08:14:53 <jose_lausuch> #info small problem with scoring on the dashboard for Arm jobs (not top priority)
08:15:05 <morgan_orange> #info I have a fix for that, just testing now
08:15:12 <jose_lausuch> great
08:15:22 <LindaWang> Compass: The issue of segfault about rally on Compass has been fixed by Cedric, and The two volume urlmismatch issue (https issue) has been fixed too.
08:15:26 <jose_lausuch> what about the idea of including arch type in the DB next release?
08:15:28 <morgan_orange> the issue is due to the fact that arm is not a field in the results
08:15:45 <jose_lausuch> LindaWang: can you info that ?
08:15:53 <morgan_orange> so we need to consider the build_tag and make some seach to know what is aarch64 what is x86
08:16:01 <LindaWang> #info Compass: The issue of segfault about rally on Compass has been fixed by Cedric, and The two volume urlmismatch issue (https issue) has been fixed too.
08:16:05 <morgan_orange> if we had an additional constraints (as scenario, installer)
08:16:09 <morgan_orange> it will be more simple
08:16:11 <jose_lausuch> yes
08:16:23 <jose_lausuch> is it something to add to testcases.yaml?
08:16:30 <ollivier> no
08:17:44 <jose_lausuch> ok, at least we should push that info to the DB along with the results
08:17:45 <ollivier> It"s already too complex. I would prefer arm64 to override the default config.
08:18:34 <jose_lausuch> ollivier: ok, no problem
08:18:40 <jose_lausuch> can we agree on adding that field to the DB ?
08:18:43 <jose_lausuch> after Euphrates?
08:19:33 <jose_lausuch> morgan_orange: ?
08:19:54 <morgan_orange> yep DB is enough
08:20:31 <jose_lausuch> #info Add field "architecture" in the DB for each test result
08:20:38 <jose_lausuch> CristinaPauna: what is the desired options?
08:20:46 <CristinaPauna> ollivier, morgan_orange: does this need any action from us?
08:20:49 <jose_lausuch> arm64, aarch64, ?
08:21:03 <CristinaPauna> I would say aarc64
08:21:11 <CristinaPauna> aarch64*
08:21:30 <jose_lausuch> ok
08:21:41 <jose_lausuch> no worries, we can add that with the help of Serena
08:21:48 <morgan_orange> action on test API + minor change  when pushing the results
08:21:48 <jose_lausuch> but we need to re-adapt the jobs maybe
08:21:49 <CristinaPauna> ok, thanks
08:21:59 <jose_lausuch> and add that env variable
08:22:01 <jose_lausuch> not a big deal
08:22:05 <CristinaPauna> :)
08:22:26 <jose_lausuch> in the beginning we can set a default value and then adapt the jobs to push the right value
08:23:02 <CristinaPauna> sounds good
08:23:12 <jose_lausuch> regarding this release
08:23:26 <jose_lausuch> morgan_orange: I don't see a big improvement of the scenarios in 2 weeks…
08:23:36 <jose_lausuch> just some things have improved, but in general it looks similar
08:23:51 <ollivier> compass results should be better
08:24:03 <LindaWang> ollivier: yes
08:24:06 <jose_lausuch> they look better yes
08:24:24 <LindaWang> ollivier: Thanks a lot about rally issue
08:24:28 <jose_lausuch> but the dashboard still shows rally smoke failing
08:24:35 <jose_lausuch> will it become sunny with more iterations?
08:24:41 <morgan_orange> LindaWang: ollivier the rally issue seem very tricky
08:24:44 <morgan_orange> you can summarize?
08:24:47 <LindaWang> jose_lausuch: Because ceilometer has not been integrated on compass
08:24:59 <LindaWang> Tianwei is now working on that
08:25:13 <jose_lausuch> ok
08:25:33 <jose_lausuch> something maybe for the release notes
08:26:02 <jose_lausuch> there are still some scenarios that don't pass healhcheck
08:26:17 <ollivier> morgan_orange: We are hacking OPNFV constraints to update requests. We (Linda and I) must go to much details before pushing the bugs to right community (requests or OpenSTack)
08:26:26 <jose_lausuch> #info Compass has improved results in 2 weeks
08:27:03 <jose_lausuch> #info Ceilometer is not integrated on Compass yet, Tianwei is now working on that
08:27:08 <ollivier> morgan_orange: I should be an OpenStack bug and that's the main action of the week.
08:27:28 <jose_lausuch> #info Daisy has 2 scenarios almost 100% success
08:27:58 <morgan_orange> #info all IMS VNF tests OK on Daisy
08:28:15 <jose_lausuch> yes
08:29:25 <jose_lausuch> #info Fuel results looks better now, but SNAPS test case failing in all scenarios
08:29:37 <jose_lausuch> CristinaPauna: depo: is that what you fixed in snaps repo?
08:29:40 <jose_lausuch> the ansible stuff?
08:29:47 <CristinaPauna> yes
08:29:59 <CristinaPauna> in the latest run the snaps suite passed
08:30:23 <jose_lausuch> ok, it's not reflected on the Dashboard yet...
08:30:29 <CristinaPauna> https://build.opnfv.org/ci/view/functest/job/functest-fuel-armband-baremetal-arm-daily-euphrates/29/consoleFull
08:30:33 <jose_lausuch> CristinaPauna: when was the first PASS ?
08:30:44 <CristinaPauna> on arm, earlier today
08:30:47 <jose_lausuch> ok, thanks
08:30:51 <CristinaPauna> on x86 I didn't check
08:30:57 <CristinaPauna> but I expect the same result
08:31:10 <jose_lausuch> ok, probably we will have sun in 2 days
08:31:15 <jose_lausuch> yes
08:31:18 <CristinaPauna> I expect to
08:31:19 <jose_lausuch> if the root cause is the same
08:31:23 <CristinaPauna> it is
08:31:38 <jose_lausuch> however, rally smoe fails on nosdn-nofeature as well
08:31:42 <jose_lausuch> on fuel arm
08:32:07 <CristinaPauna> yes, I don't expect we will fix that in time for E5.0. it's a live migration issue
08:32:11 <CristinaPauna> and more complicated to fix
08:32:32 <jose_lausuch> ok
08:33:04 <jose_lausuch> #info Issues with life migration on ha scenarios of Fuel-aarch64, won't be on time for E5.0
08:33:26 <jose_lausuch> CristinaPauna: can you paste the link to the snaps fix?
08:34:12 <CristinaPauna> https://gerrit.opnfv.org/gerrit/#/c/45235/
08:34:26 <jose_lausuch> #info Snaps smoke expected to pass 100% on Fuel jobs after this patch https://gerrit.opnfv.org/gerrit/#/c/45235/
08:34:28 <jose_lausuch> thanks
08:34:54 <jose_lausuch> joid…
08:35:43 <jose_lausuch> #info no scenario passing Functest on joid, only noha passes healcheck
08:36:53 <jose_lausuch> #info some scenarios have improved in 2 weeks for Apex, but still a lot of failures
08:36:59 <morgan_orange> test done on ocl scenario by stuart, but no feedback since we provided test manual procedure
08:37:17 <jose_lausuch> yes
08:37:59 <jose_lausuch> any other comments about the results?
08:38:38 <LindaWang> live migration tests should be blacklisted on noha scenario, but what about migration?
08:39:14 <jose_lausuch> but noha scenarios still have 2 compute nodes, right?
08:39:21 <LindaWang> I mean NovaServers.boot_and_migrate_server
08:39:57 <LindaWang> Does it testcase NovaServers.boot_and_migrate_server  refer to "cold migration"?
08:40:07 <jose_lausuch> LindaWang: rally smoke passes on os-nosdn-nofeature-noha for apex
08:40:33 <LindaWang> OK, maybe I will check that.
08:40:49 <LindaWang> NovaServers.boot_and_migrate_server failed on Compass noha
08:41:11 <jose_lausuch> ok, to be investigated then
08:41:22 <jose_lausuch> but I though that as long as you have more than 1 compute.. the test should pass
08:42:11 <LindaWang> Compass noha has only one compute node
08:42:29 <jose_lausuch> ok
08:42:40 <jose_lausuch> I though Pharos specification for OPNFV was 1 controller, 2 computes
08:42:51 <jose_lausuch> but maybe we should revisit that
08:43:10 <jose_lausuch> let's move on
08:43:24 <jose_lausuch> #topic	Fraser release: organization / main targets /..
08:43:37 <jose_lausuch> #info we need a release plan for Fraser, wiki started https://wiki.opnfv.org/display/functest/6.+Fraser
08:43:48 <jose_lausuch> ollivier and LindaWang you are key here :)
08:44:17 <ollivier> A wiki page has already been initiated.
08:44:18 <LindaWang> :) more responsibilities then
08:44:47 <morgan_orange> yep, unfortunatly I will not work on the Canadian river... it is also my last weekly meeting. I will be around for any question but I will progressivly disappear from the radar scope...
08:44:47 <jose_lausuch> I think the gating is very important
08:45:09 <jose_lausuch> morgan_orange: that's a pity…
08:45:10 <ollivier> https://wiki.opnfv.org/display/functest/Functional+testing+gating
08:45:20 <LindaWang> agree:Functional testing gating is good and important
08:45:29 <jose_lausuch> #info important topic for Fraser: Functest gating https://wiki.opnfv.org/display/functest/Functional+testing+gating
08:45:47 <morgan_orange> jose_lausuch: that's life :)
08:45:49 <jose_lausuch> morgan_orange: you are always invited to this meeting of course
08:46:12 <LindaWang> morgan_orange: Where are you going?
08:46:32 <morgan_orange> I will work on ONAP and try to reuse as much as possible what we did..
08:46:54 <LindaWang> will you still work in France?
08:46:58 <LindaWang> morgan_orange:
08:47:30 <morgan_orange> LindaWang: yes I will still be in the same office, no change
08:47:50 <morgan_orange> regarding the gating, I sent a mail to mailing list
08:47:51 <LindaWang> That is no good, no big pity then. Enjoy your new work
08:47:55 <morgan_orange> regarding xci / functest
08:48:06 <LindaWang> That is no good -> That is good ;
08:48:11 <morgan_orange> :)
08:48:55 <jose_lausuch> morgan_orange: regarding xci functest?
08:49:02 <jose_lausuch> you can info the tests you did
08:49:04 <jose_lausuch> it's interesting
08:49:06 <morgan_orange> i mentioned the problems I found - most of them linked to volume management but xci is a little bit idfferent from installers (noceph, linuxbridge, ..)
08:49:26 <morgan_orange> maybe i should put them in a wiki page for F
08:49:30 <morgan_orange> you can action me for that
08:49:33 <jose_lausuch> good idea
08:49:54 <morgan_orange> I am waiting for confirmation from xci / virtual pods but as far as I understood, there is no test running in CI yet
08:49:54 <jose_lausuch> #action write a wikipage about the outcome of Functest testing on XCI
08:50:06 <jose_lausuch> as Fatih said, not yet
08:50:08 <morgan_orange> neither for gating or as daily jobs
08:50:27 <jose_lausuch> but I think that will start soon
08:50:37 <morgan_orange> so for F i think it is key
08:51:00 <jose_lausuch> yes, and it is mentioned in the wiki from ollivier
08:51:01 <morgan_orange> I would also suggest still some framework refactoring in order to be able to keep on using it for k8S or ONAP
08:51:13 <morgan_orange> for the moment we are OpenStack dependen due to Tempest/Rally
08:51:25 <morgan_orange> we may imagine to split the framework and teh tests
08:51:30 <jose_lausuch> morgan_orange: yes, feel free to add items to https://wiki.opnfv.org/display/functest/6.+Fraser
08:51:32 <morgan_orange> core will be VIM agnostic
08:51:57 <ollivier> Yes i's already part of my plan.
08:52:18 <jose_lausuch> I imagine some sort of new container functest-k8 or something like that, we will see
08:52:33 <jose_lausuch> and maybe remove prepare_env
08:52:38 <jose_lausuch> and install rally only when it is needed
08:53:43 <LindaWang> agree:  install rally when running it.
08:53:53 <LindaWang> I guess Cedric has planed to do it
08:53:57 <jose_lausuch> doesn't make sense to install it on functest-vnf for example
08:54:04 <LindaWang> And I'd like to help
08:54:09 <ollivier> LindaWang: It breaks offline test.
08:54:24 <LindaWang> no
08:54:24 <ollivier> LindaWang: yes.
08:54:37 <LindaWang> prepare_env is alread offline enabled
08:54:45 <LindaWang> prepare_env is already offline enabled
08:55:41 <ollivier> prepare_env can be simply removed. I was answering install rally. In fact you meant the right container. :) Not in runtime.
08:55:54 <LindaWang> For the step of "install_rally" in prepare_env, online is not necessary.
08:55:56 <LindaWang> yes
08:56:28 <LindaWang> what does the right container mean?
08:56:39 <ollivier> functest-smoke.
08:56:48 <LindaWang> Aha, yes
08:57:04 <jose_lausuch> ok
08:57:13 <jose_lausuch> we can discuss this further and start working on it
08:57:18 <jose_lausuch> #topic AoB
08:57:25 <jose_lausuch> any other thing you want to discuss?
08:58:16 <LindaWang> no from my side.
08:58:37 <morgan_orange> maybe Fraser could be a good occasion to see if new contributors would not be itnerested to join..
08:58:52 <morgan_orange> there is always renewal but fresh blood is needed
08:59:06 <jose_lausuch> maybe we can make a call for contributors
08:59:13 <jose_lausuch> I can send an email to the mailing list
08:59:37 <morgan_orange> I planned to ask for the revookation of my +2 right after the release to be fair. I think the +2 must reflect the reality of the work. I would feel ilegitimate to +2 if I cannot really work on the topics anymore
09:00:07 <morgan_orange> but a critical mass of committer is needed to avoid blocking points
09:00:18 <jose_lausuch> that's up to you, I think we don't have any problem you keep +2 for some time after all your work
09:00:34 <ollivier> Your vision could have helped anyway.
09:00:45 <jose_lausuch> exactly
09:00:47 <LindaWang> agree
09:01:04 <morgan_orange> we will see, there is no rush anyway
09:01:05 <jose_lausuch> let's thank Morgan all the work he has done in Functest
09:01:21 <morgan_orange> thanks to you. I will miss you
09:01:45 <LindaWang> morgan_orange:  Thanks and Miss you
09:01:47 <morgan_orange> OPNFV is a family community..it is not always easy as in any familly...but we can talk
09:01:49 <ollivier> It's sure as you and Valentin stopped, we don't reach the quota if we look at voting stats during E release.
09:02:13 <jose_lausuch> I hope your next tasks at ONAP bring you the same excitement as in Functest :)
09:02:22 <LindaWang> morgan_orange: What about the reporting work ?
09:02:50 <jose_lausuch> ollivier: yes, in case someone of us is on vacation or travelling or whatever, it will be difficult to merge things fast
09:02:53 <morgan_orange> LindaWang: I think I can discuss with jack, but he and also Mark knoes it well. Rohit also did all the automation part
09:03:27 <LindaWang> morgan_orange: Oh, got it.
09:03:37 <jose_lausuch> let's end meeting
09:03:43 <jose_lausuch> thanks everyone
09:03:44 <morgan_orange> and  I will not far anyway..
09:03:46 <morgan_orange> thanks
09:03:47 <jose_lausuch> and specially to Morgan
09:03:52 <jose_lausuch> #endmeeting