08:00:27 <jose_lausuch> #startmeeting Functest weekly meeting 31 Oct. 2017
08:00:27 <collabot> Meeting started Tue Oct 31 08:00:27 2017 UTC.  The chair is jose_lausuch. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:27 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:27 <collabot> The meeting name has been set to 'functest_weekly_meeting_31_oct__2017'
08:00:33 <jose_lausuch> #info Agenda https://wiki.opnfv.org/display/functest/Functest+5.+Meeting#Functest5.Meeting-31/10(8UTC)
08:00:36 <jose_lausuch> #topic role call
08:00:42 <jose_lausuch> #info Jose Lausuch
08:00:49 <juhak> #info Juha Kosonen
08:01:37 <LindaWang> #info Linda Wang
08:03:14 <jose_lausuch> #info Rally version issue
08:03:17 <jose_lausuch> #undo
08:03:17 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2deed10>
08:03:20 <jose_lausuch> #topic Rally version issue
08:03:40 <LindaWang> Rally has been updated to stable/0.10
08:03:45 <jose_lausuch> #info described in  https://jira.opnfv.org/browse/PROMISE-88 - os-faults module is missing IN PROGRESS  ==> Select Rally 0.9.1 for Functest E and Rally stable/0.10 for Functest Master?
08:03:54 <ollivier> yes
08:03:55 <jose_lausuch> I think the patch has been merged, right?
08:03:55 <LindaWang> But some issues have raised:
08:03:58 <LindaWang> yes
08:04:05 <LindaWang> https://jira.opnfv.org/browse/FUNCTEST-883
08:04:10 <jose_lausuch> LindaWang: use #info
08:04:16 <LindaWang> I describe the issues here
08:04:21 <jose_lausuch> #link https://jira.opnfv.org/browse/FUNCTEST-883
08:04:34 <LindaWang> #info https://jira.opnfv.org/browse/FUNCTEST-883 https://jira.opnfv.org/browse/FUNCTEST-883
08:04:59 <LindaWang> #undo
08:05:01 <jose_lausuch> these issues are due to the uplift to 1.10?
08:05:22 <LindaWang> yes, rally stable 0.10
08:05:45 <jose_lausuch> so, there are some obsolete scenarios for nova it seems
08:06:02 <jose_lausuch> #info patch to remove obsolete Nova scenarios https://gerrit.opnfv.org/gerrit/#/c/46459/1
08:06:08 <LindaWang> i  also asked Rally PTL to help with the keyError creds when getting deployment
08:06:27 <LindaWang> juhak: I got some trouble when adding new scenarios
08:06:56 <jose_lausuch> #link https://build.opnfv.org/ci/view/functest/job/functest-fuel-virtual-daily-master/2294/console
08:06:57 <LindaWang> juhak: Which scenarios should be included in rally_sanity and which be in rally_full? Some new scenarios about glance, nova, neutron and cinder should been added
08:07:01 <juhak> LindaWang: we can take a look after the meeting?
08:07:26 <LindaWang> juhak: sure. Could you help with the new scenarios added.
08:07:33 <juhak> yes
08:07:38 <LindaWang> juhak: thanks
08:07:56 <jose_lausuch> so, basically 3 issues
08:08:19 <jose_lausuch> shall I action you on this?
08:08:27 <LindaWang> sure. me and juhak
08:08:50 <jose_lausuch> #action juhak LindaWang Try to fix rally 0.10 issues defined in https://jira.opnfv.org/browse/FUNCTEST-883
08:09:27 <jose_lausuch> #action juhak LindaWang add new scenarios from stable/0.10
08:09:53 <jose_lausuch> ok
08:09:56 <jose_lausuch> anything else about rally?
08:10:16 <LindaWang> no
08:10:36 <LindaWang> the good news is xrally will provide some tests about k8s soon
08:10:37 <jose_lausuch> serena-zte: ping
08:10:43 <serena-zte> pong
08:10:57 <jose_lausuch> LindaWang: that's great, we could include them for k8 scenarios
08:11:24 <jose_lausuch> serena-zte: ok, just to verify you are in the meeting, as you didn't info your name :)
08:11:27 <LindaWang> but i do not know when it can be released
08:11:37 <serena-zte> almost forget :(
08:11:42 <jose_lausuch> well, we expect to have k8 tests soon
08:11:48 <jose_lausuch> which is good too
08:11:51 <serena-zte> that's great
08:12:10 <jose_lausuch> #topic Docker image build process
08:12:48 <jose_lausuch> #info there is a patch from Delia that implements Alpine builds in Releng https://gerrit.opnfv.org/gerrit/#/c/46111/
08:13:05 <jose_lausuch> that uses manifests to build aarch64 as well
08:13:19 <jose_lausuch> ollivier: will you review it when you have time?
08:13:50 <jose_lausuch> it also solves the image dependency
08:13:54 <jose_lausuch> so functest-core will be built first
08:13:57 <jose_lausuch> and the rest in parallel
08:14:29 <ollivier> jose_lausuch: sure. I must check it.
08:14:59 <jose_lausuch> good, thanks, cause I'm not so familiar with those manifests
08:15:08 <ollivier> jose_lausuch: but regarding that, I wasn't supposed to do that at the beginning.
08:15:09 <jose_lausuch> CristinaPauna: is Delia here?
08:15:23 <jose_lausuch> what do you mean?
08:17:09 <ollivier> jose_lausuch: I was not in charge of updating the jjobs part during E release. I have built parallel builds via Docker to allows sharing. Nothing against releng.
08:18:02 <jose_lausuch> ollivier: that's fine, you gave the idea of these manifests
08:18:24 <jose_lausuch> I also wanted to help but didn't have the time
08:18:42 <jose_lausuch> ok
08:18:49 <jose_lausuch> let's assume this works soon
08:19:00 <ollivier> jose_lausuch: it's quite strange to read that I'm quite inactive on that topic.
08:19:22 <jose_lausuch> what do we do with the image builds when a patch is merged in SNAPS for example?
08:19:35 <LindaWang> I do not agree docker image built should be triggered when dependency code changes, escecially for SNAPS
08:19:46 <ollivier> LindaWang: sure we can't.
08:19:49 <LindaWang> Because in some cases, it will not work if only dependency code changes are involved in image built.
08:19:54 <LindaWang> And also some codes in Functest should also be changed too.
08:20:36 <jose_lausuch> can you explain why exactly?
08:20:55 <jose_lausuch> what is the problem of building functest-core and the rest when snaps merges something?
08:21:00 <LindaWang> Just take bgpvpn for example
08:21:05 <jose_lausuch> yes
08:21:09 <jose_lausuch> that's different
08:21:14 <jose_lausuch> that affects only functest-features
08:22:30 <LindaWang> Then we will lose the control of functest-features.
08:22:34 <LindaWang> Hard to debug
08:22:48 <jose_lausuch> why?
08:22:52 <serena-zte> why?
08:23:24 <ollivier> Please read the email thread. We will trigger the built one after the others.
08:23:56 <jose_lausuch> let me explain the concern from the community first, and see how we can solve it
08:23:56 <ollivier> And Functest depend much more on OpenStack librairies that OPNFV project.
08:24:10 <ollivier> SDNVPN  was late.
08:24:23 <jose_lausuch> I am not talking about being late
08:24:30 <jose_lausuch> let's take the Fraser release
08:24:34 <jose_lausuch> folks in feature projects do a change and merge it
08:24:47 <jose_lausuch> they won't see the change in CI if we don't build an image
08:25:00 <ollivier> You're mixing functional testing and OPNFV gating.
08:25:05 <jose_lausuch> maybe because we didn't merge anything and didn't trigger the build
08:25:13 <serena-zte> if dependency code is changed, we don't build the image, how to test the change works or not?
08:25:40 <jose_lausuch> my concern is about continuous development in the release process
08:25:45 <ollivier> In fact, we do build instead a dedicated container per project change.
08:26:09 <jose_lausuch> I didn't get that
08:26:12 <serena-zte> I think the main concern is that if we build every time the dependency code change, the image will be built too frequent
08:26:17 <ollivier> The current containers are fine. For E release, it would have been simpler if all Functest committers have the same rights.
08:26:42 <ollivier> You're mixing functional testing and OPNFV gating. The target for Fraser is clear
08:26:46 <jose_lausuch> yes, I agree with serena-zte. that's the other drawback
08:27:08 <jose_lausuch> what is the target for Fraser? :)
08:27:20 <LindaWang> When docker image built is ready in Releng, we could trigger any job manually.
08:27:30 <serena-zte> manually?
08:27:32 <serena-zte> why?
08:27:34 <ollivier> E?? Everything is written in xtesting.
08:28:27 <ollivier> https://wiki.opnfv.org/display/functest/Functional+testing+gating
08:29:18 <jose_lausuch> why shall we be doing manual builds?
08:29:57 <LindaWang> jose_lausuch: You mean SNAPS or Feature projects?
08:29:57 <ollivier> For a special case eg when Functest is frozen (just before the release), we could have triggered the build manually
08:30:53 <jose_lausuch> I mean feature projects
08:31:04 <jose_lausuch> not before the release
08:31:04 <jose_lausuch> now
08:31:06 <jose_lausuch> Fraser
08:31:06 <ollivier> The current process is fine. For one special case, Linda could have triggered it if she were allowed too. It's better to built the Functest on notifications
08:32:11 <jose_lausuch> people also ask if it is ok to for example trigger an automated build per day? without any merge?
08:33:14 <ollivier> I have already explained my point.
08:34:28 <jose_lausuch> I wasn't talking about functest gating
08:34:32 <jose_lausuch> please elaborate
08:35:13 <jose_lausuch> I got this questions several times: "can you build the images? we have merged a patch and we would like to see it in CI.. "
08:35:35 <ollivier> I sent 2 emails yesterday morning. I think notifications are better. More if we implement real functestional testing.
08:35:37 <jose_lausuch> what should we do? manually build?
08:35:46 <jose_lausuch> notifications = mail ?
08:35:51 <ollivier> ??
08:36:03 <jose_lausuch> what do you mean by notifications
08:36:18 <ollivier> git merge as it's the current process.
08:36:24 <jose_lausuch> yes
08:36:29 <jose_lausuch> but that's for Functest repo
08:36:32 <jose_lausuch> what about the others?
08:37:26 <jose_lausuch> LindaWang and you are saying that we shouldn't build the images when features merge stuff
08:37:28 <ollivier> I have answered it twice. I think all project changes should trigger a container built on purpose to validate their changes.
08:37:48 <ollivier> jose_lausuch: again. We depend much more on OpenSTack than on OPNFV.
08:38:04 <jose_lausuch> ok, can you elaborate that?
08:38:38 <ollivier> we can see that by building a container and check the dependencies installed.
08:38:52 <LindaWang> Yes, Functional testing gating for feature projects should be applied first.
08:39:08 <ollivier> It would be more important to rebuild our container when OpenStack requirements are updated.
08:39:33 <jose_lausuch> ok, I agree to that
08:39:40 <jose_lausuch> but let's say the feature projects don't have that gating in place
08:39:47 <jose_lausuch> it will be difficult to implement for all the projecsts
08:39:53 <serena-zte> imp, functest run twice a day, we can add a periodical image build job also for twice a day
08:40:39 <serena-zte> it is not necessary to trigger build every time feature project merge
08:40:55 <jose_lausuch> yes, we could end up building too frequently, I also agree
08:41:35 <jose_lausuch> but what about that idea of building twice a day? does it make sense? otherwise, we will get the request to trigger a manual build when people ask for it
08:42:44 <ollivier> I think the current process is fine. And we should allow a manual trigger for special cases.
08:43:05 <serena-zte> I think it is better than a manual build
08:43:20 <ollivier> We have never spoken on a manual build.
08:43:32 <serena-zte> allow manual is OK,
08:43:35 <ollivier> or do I miss something?
08:43:50 <jose_lausuch> manual when someone from feature projects ask us to build
08:43:59 <serena-zte> but still HR cost
08:44:00 <ollivier> The purpose is simply to allow clicking on trigger button in opnfv functest-core
08:44:19 <ollivier> Only Jose and I are allowed to do so.
08:44:38 <serena-zte> so people need to contact you both
08:45:05 <serena-zte> and we need to demo if OpenStack relevant projects such as tempest/rally changed
08:45:06 <jose_lausuch> once opnfv-docker.sh works, we will trigger the builds in Jenkins…
08:45:09 <ollivier> In fact we could also use the API. Who can trigger a Jenkins build today?
08:45:17 <jose_lausuch> I can
08:45:18 <LindaWang> Each time once functest-core is rebuilt sucsessfully, other images will be built?
08:45:24 <jose_lausuch> but I don't want to be a bottleneck
08:45:50 <ollivier> Mainly. only parser must be trigger as well. But only for E releasE.
08:45:52 <jose_lausuch> I shouldn't have access, but I have because of historical reasons
08:46:00 <jose_lausuch> only or Aric and Trevor, and son other should have
08:46:09 <jose_lausuch> *some
08:46:19 <jose_lausuch> so we have to wait for them or me to trigger it?
08:46:31 <jose_lausuch> what if people with rights in Jenkins are on vacation?
08:46:33 <jose_lausuch> that's my concern
08:46:38 <jose_lausuch> manual things are not safe
08:46:42 <serena-zte> I should say not only parser
08:46:43 <jose_lausuch> just for special cases
08:47:29 <ollivier> serena-zte: Parser doesn't depend on functest-core for E. For F it can as both will select OpenStack pike.
08:47:30 <serena-zte> just because parser needs a build to see the result in ci, but there's no functest merge in those days
08:47:44 <LindaWang> jose_lausuch: If I want to have the right, who shall i ask for?
08:48:27 <LindaWang> jose_lausuch: Or is it possible to have the right?
08:48:31 <jose_lausuch> LindaWang: I guess LF guys, but I don't think they want to open Jenkins to everyone.. I shouldn't have access even… and I probably request for not having rights any more, it's not my responsability
08:48:49 <serena-zte> I think the authorization manage is very loose
08:49:11 <serena-zte> once you have the right in one job, you have the same right in all the other jobs
08:49:19 <jose_lausuch> ya
08:49:21 <jose_lausuch> right
08:49:56 <LindaWang> what do you mean? Will someone have the right do bad things you mean?
08:49:56 <jose_lausuch> so, what is the conclusion?
08:50:47 <jose_lausuch> LindaWang: not bad things, but this is about responsabilities and roles from people.. only a few should have admin rights in Jenkins, which are the "real" admins
08:50:49 <depo> #info Delia Popescu
08:50:56 <serena-zte> nothing very bad, since it only effects one time manual build
08:50:58 <ollivier> releng too
08:51:09 <ollivier> #agree
08:51:29 <depo> the our changed here, so I got confused and late
08:51:43 <jose_lausuch> but that's bad if a feature projects needs a new docker image, they will have to bother the jenkins admins
08:51:47 <jose_lausuch> that could be a bottleneck
08:52:14 <ollivier> Again only for E.
08:52:22 <serena-zte> yes, that's why I don't like the manual work
08:52:48 <jose_lausuch> for F as well if functest gating is not implemented in feature projects
08:53:52 <ollivier> let's see.
08:54:24 <jose_lausuch> the gating idea is excellent, but I don't think everyone will have it in place..
08:54:31 <ollivier> Let check if we can use the Docker REST API and allows several ssh keys
08:55:25 <jose_lausuch> ok
08:55:41 <jose_lausuch> so, please review Delias patch so we can move forward with Releng
08:55:51 <jose_lausuch> depo: thanks for the work, I'll try to review it today
08:56:03 <jose_lausuch> #topic AoB
08:56:21 <serena-zte> depo I add myself as reviewer, hope you don't mind :)
08:56:22 <jose_lausuch> #info Euphrates release community awards announced
08:56:32 <jose_lausuch> feel free to nominate folks
08:56:41 <jose_lausuch> there are people who have done a very good job in this release
08:56:51 <jose_lausuch> another topic
08:56:52 <depo> you're welcome
08:56:54 <jose_lausuch> to the committers
08:57:20 <jose_lausuch> is there anyone of you interested in taking PTL role? we can start elections
08:57:48 <LindaWang> I am wondering who else have this intention.
08:57:54 <ollivier> Yes we should organize that if we conform to the rules etablished to Espoo.
08:58:36 <jose_lausuch> let's do that openly
08:58:46 <jose_lausuch> who wants to be candidate?
08:59:21 <ollivier> Why not from my side. I'm also asked to be candidate.
09:00:08 <jose_lausuch> ok
09:00:12 <jose_lausuch> who else?
09:00:32 <LindaWang> I am also interested, but i have to consider it a bit
09:00:56 <jose_lausuch> ok
09:01:02 <jose_lausuch> please think about it during this week
09:01:18 <jose_lausuch> and let's talk next week again as this is important
09:01:38 <jose_lausuch> we are out of time
09:01:48 <jose_lausuch> thanks everyone
09:02:00 <jose_lausuch> #endmeeting