08:01:32 <ollivier> #startmeeting Functest weekly meeting 12 Dec. 2017
08:01:32 <collabot> Meeting started Tue Dec 12 08:01:32 2017 UTC.  The chair is ollivier. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:32 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:32 <collabot> The meeting name has been set to 'functest_weekly_meeting_12_dec__2017'
08:01:44 <ollivier> #info Cédric Ollivier
08:01:47 <LindaWang> #info Linda Wang
08:02:01 <juhak> #info Juha Kosonen
08:02:19 <jose_lausuch> #info Jose Lausuch
08:02:31 <ollivier> #topic action points follow up
08:02:38 <depo_> #info Delia Popescu
08:02:55 <ollivier> #info  to implement the container garbage collector
08:03:06 <ollivier> #info to fix functest on ARM with alpine containers for master branch
08:03:33 <jose_lausuch> oops, I forgot about cleanup, sorry
08:03:58 <ollivier> No pb. I opened a Jira ticket to avoid writing it every week.
08:04:05 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-898
08:04:28 <jose_lausuch> ok, better, thanks
08:05:04 <ollivier> There were an issue about container builds which would have been skipped.
08:05:36 <jose_lausuch> yes, also today
08:05:44 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/48569/
08:05:57 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/48567/1
08:06:23 <ollivier> the last pb were related to network issues.
08:06:43 <ollivier> jose_lausuch:  Could you please restart manually the build?
08:07:02 <ollivier> I think containers failed twice in a row.
08:07:14 <LindaWang> ollivier: the lastest opnfv-vnf image does not include vpec
08:07:20 <jose_lausuch> done
08:07:32 <ollivier> yes. the two last builds failed.
08:07:41 <LindaWang> ollivier: but the functest-vnf image with tag amd64-latest does
08:07:41 <ollivier> thank you.
08:08:35 <ollivier> yes but the manifest was not published at the end.
08:09:08 <LindaWang> got it
08:10:03 <ollivier> Then we should complete "reload CONST after updating config file". But I think we should find another way.
08:10:47 <ollivier> we could modify data in memory instead of reloading the file by reimporting modules.
08:10:59 <jose_lausuch> +1 do we know how to do that?
08:11:26 <LindaWang> +1
08:12:04 <LindaWang> Config only reads config file once
08:12:33 <LindaWang> when the config yaml is modified later, Config can not apply it
08:13:46 <ollivier> CONFIG should keep as attributes the data included in yaml file. I will check after the meeting.
08:14:05 <ollivier> #topic Euphrates
08:14:16 <ollivier> #info next corrective will be released this week (December 15)
08:14:38 <jose_lausuch> I guess we need to  update release notes
08:14:52 <LindaWang> # This AP:  Linda,Juha to update the log config (rally) is done, by a patch published to Rally Repo: https://review.openstack.org/#/c/524171/
08:14:53 <jose_lausuch> with latest changes, e.g. docker alpine for arm
08:15:02 <LindaWang> #info  This AP:  Linda,Juha to update the log config (rally) is done, by a patch published to Rally Repo: https://review.openstack.org/#/c/524171/
08:15:03 <ollivier> Yes. Thank you.
08:16:09 <ollivier> Yes Thank you. It was cherry-picked in the right branch https://review.openstack.org/#/c/524564/2
08:16:22 <LindaWang> ollivier:  yes
08:17:14 <jose_lausuch> what else do we need to point out in the release notes?
08:17:27 <LindaWang> vrouter
08:17:44 <ollivier> vyos_router + arm containers
08:18:29 <ollivier> We have cherry-picked lots of bugfixes but it's out of the release notes isn't it?
08:18:42 <jose_lausuch> I would say only important changes
08:18:51 <jose_lausuch> and important bugfixes
08:19:30 <LindaWang> i do not see some important bugfixes
08:19:31 <ollivier> I would have listed this two changes. We could double check via git history.
08:20:25 <ollivier> Please let me know if someone wants to take this point. Else I will take it.
08:20:50 <jose_lausuch> let me take it
08:20:54 <jose_lausuch> I will do it today
08:21:10 <jose_lausuch> I will be off thursday and friday
08:21:38 <ollivier> #action Jose update release notes (+check git history)
08:22:01 <ollivier> we will complete it if you don't finish it today.
08:22:18 <ollivier> #info orchestra_openims and orchestra_clearwaterims fails on all installers (and all branches)
08:22:32 <jose_lausuch> ok
08:22:43 <ollivier> I will send an email to the right devs.
08:23:08 <ollivier> #topic Fraser
08:23:20 <ollivier> #info we created a tox entry to check yaml files via yamllint
08:23:43 <ollivier> It only remains several files in api.
08:24:00 <LindaWang> a patch has been published to fix that
08:24:20 <LindaWang> #link https://gerrit.opnfv.org/gerrit/#/c/48691/
08:24:47 <ollivier> Great. Thank you. The tox entry seems good.
08:25:46 <ollivier> We have closed very quickly that. Great.
08:25:55 <ollivier> #info vEPC tests with juju as an VNF manager was merged
08:26:31 <ollivier> Let's see the next CI loops (the container has not been built)
08:26:37 <LindaWang> i have tested it locally with the amd64-latest tagged image,
08:27:05 <LindaWang> still some issue about the authorization
08:27:45 <LindaWang> i do not know if  the os_auth_url could be replaced with hostname
08:27:46 <ollivier> ok. It will ease sharing logs and multiply the conditions.
08:28:13 <ollivier> I think so.
08:28:23 <LindaWang> i will send the log after meeting.
08:28:49 <ollivier> Thank you. I think it's an added value to integrate vnf in Functest.
08:29:16 <ollivier> #info we could also noted lots of improvements (removed openstack utils calls, fixed [py,yaml] lint errors)
08:29:34 <ollivier> #info several testcase fails (rally, snaps_smoke, refstack...)
08:30:19 <jose_lausuch> in the basic scenario?
08:30:20 <ollivier> It would be great to run succcessfully all testcases to validate the updates (Pike, rally, tempest...)
08:30:24 <ollivier> yes
08:30:34 <LindaWang> besides os_utils is called by features projects, os_utils is now mostly called by oschestra testcases and snapshot-create and clean.
08:31:16 <LindaWang> do we need to remove snapshot-create and clean?
08:31:24 <jose_lausuch> but snapshot is not called in the test cases, right?
08:31:26 <jose_lausuch> it's only manually
08:31:33 <LindaWang> exactly
08:31:34 <jose_lausuch> up to the user…
08:31:41 <jose_lausuch> but if we want to remove os utils…
08:32:27 <jose_lausuch> we could remove it, does anyone use that still?
08:33:48 <LindaWang> as i know, if sdnvpn's garbage collection takes effect, Dovetail will not need these two clis any more
08:34:15 <jose_lausuch> they already implemented that, I think
08:34:35 <ollivier> I think we could wait a little bit if needed. I will add a section to openstack utils in the mail to the orchestra team.
08:35:24 <jose_lausuch> ok
08:35:25 <ollivier> I will send an email opnfv tech to alert about openstack utils removal.
08:35:39 <LindaWang> and only one call by odl.py
08:35:51 <LindaWang> op_utils.get_endpoint(service_type='network')
08:36:22 <ollivier> Yes. I will update it.
08:37:13 <ollivier> #topic Functional Gating/Xtesting:
08:37:21 <ollivier> #info Dockerfile proposed to Doctor
08:37:45 <ollivier> #topic new topics raised during Plugfest/Hackfest or previous release meetings:
08:37:56 <jose_lausuch> wait
08:38:01 <jose_lausuch> what is the statis of xci ?
08:38:02 <ollivier> oh sorry
08:38:07 <jose_lausuch> can it be already deployed for xtesting?
08:38:11 <jose_lausuch> did you talk to fatih?
08:38:58 <ollivier> Yes. From the time being, they are several testcases failed (see main sent by Morgan)
08:39:08 <jose_lausuch> yep, I saw that
08:39:33 <ollivier> The main issue is XCI targets to rely on master branches only.
08:40:04 <jose_lausuch> you mean of openstack branches
08:40:54 <ollivier> Yes. Then Functest would run on top of OpenStack master. It should work anyway unless big changes (eg end of nova network)
08:41:10 <jose_lausuch> ok
08:41:44 <ollivier> Lots of discussion about supporting kolla ansible (and then to work on stable branches)
08:41:55 <LindaWang> But the results from Morgan are based on  Kolla ansible, not OSA, right?
08:42:27 <ollivier> Exact. We are working on XCI and kolla-ansible.
08:44:14 <LindaWang> Has kolla-ansible been published to XCI?
08:44:52 <LindaWang> I mean if this method of deploying openstack has been published to XCI
08:44:55 <ollivier> No. I think we are too early regarding functional gating but that's a topic which is considered as interesting (Doctor team, SDNVPN team, David...)
08:45:35 <jose_lausuch> what was the reaction?
08:45:40 <jose_lausuch> did people like that idea?
08:45:46 <jose_lausuch> I guess so :)
08:45:48 <ollivier> XCI leverages on OpenStack only. Cable Labs, Orange, Intel are considering kolla ansible too.
08:46:03 <ollivier> Yes. David mentioned Functional Gating too.
08:46:29 <ollivier> The main issue is to setup the referent platform and the workflow process.
08:47:19 <ollivier> From a Functest POV we have already implemented the main steps (Docker Framework, requirements...)
08:47:48 <ollivier> let's continue on sharing the ida and the Dockerfile. We will see the first results on XCI soon.
08:49:00 <ollivier> Please let me know if you want much details than my notes.
08:49:22 <jose_lausuch> ok
08:49:29 <ollivier> Regarding the new topics:
08:49:30 <jose_lausuch> your notes are a good summary, thanks for sending that email
08:50:09 <ollivier> #info to refactor our current jobs to multijobs to return quick results for Healthcheck and for every Feature
08:50:36 <jose_lausuch> good idea
08:50:57 <LindaWang> David proposed it?
08:51:06 <ollivier> Tim asked to easily check the status of sdnvpn. The only issue is multijob aggregates the results of singular jobs.
08:51:23 <ollivier> then we revert to OPNFV gating instead of Functest gating.
08:51:48 <LindaWang> I do not think David will check any results shown in Jenkins
08:51:48 <ollivier> (global status will be failed if sdnvpn fails)
08:52:04 <ollivier> Yes. I proposed to send him emails automatically
08:52:15 <LindaWang> Besides, SDNVPN usually fails, doesn't it?
08:52:57 <jose_lausuch> we need to investigate on what are the benefits of that
08:52:58 <LindaWang> I have not seen bgpvpn passed in any job actually
08:53:15 <jose_lausuch> some subtests work, but the overall fail because something fails
08:53:23 <jose_lausuch> I mean, one or 2 of the subtest fail
08:53:34 <ollivier> I don't know. But I think the idea is right. We must precise in that case the global status is related to OPNFV not Functest
08:53:59 <LindaWang> if we create a subjob for sdnvpn, the result color of the result will always be RED
08:53:59 <ollivier> #info to create a new testcase to check the OpenStack version installed
08:54:13 <ollivier> I think Linda already creates a JIRA for that.
08:54:28 <LindaWang> David created it i think
08:54:29 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-806
08:55:21 <LindaWang> Create a new test case included in healthcheck?
08:55:24 <ollivier> Ok. That's a good idea but we must ensure we can detect by API. It shouldn't enforce the right OpenSTack version (it makes sense for gating but not for all purposes)
08:55:56 <ollivier> I would say yes to check MS3 automatically.
08:56:06 <jose_lausuch> is it possible via API?
08:56:26 <jose_lausuch> normally, we needed to go the environment and run a command in the controller...
08:56:31 <ollivier> We could try via API microversions or specific data
08:57:13 <ollivier> We shoud first deeply analyse the possibilities.
08:57:23 <ollivier> #info to take the new service description file into account which could replace the former scenario names
08:57:55 <LindaWang> what does "new service description file " mean?
08:58:10 <ollivier> That's a new topic which isn't fully clear. We should follow that as it could change how we detect dependencies.
08:58:43 <LindaWang> who can provide this file?
08:58:44 <ollivier> They would like to stop multiplying scenarios and to describe the service directly in a new yaml file (see PDF)
08:58:45 <LindaWang> the user?
08:59:33 <ollivier> In case of gating, we could receive it in an Docker var. I only participate in a quick meeting with Tim. We should follow the topic.
08:59:59 <ollivier> # to setup the new git repositories functest-requirements, functest-kubernetes and functest-xtesting (incubated in Functest)
09:00:09 <ollivier> #info to setup the new git repositories functest-requirements, functest-kubernetes and functest-xtesting (incubated in Functest)
09:00:42 <ollivier> David asked me to create requirement as a separate project for G release. Let's see if we will do the same for xtesting.
09:00:49 <LindaWang> good.
09:00:50 <jose_lausuch> so finally the name can't be xtesting only
09:00:54 <jose_lausuch> for law reasons
09:00:58 <jose_lausuch> functest-xtesting
09:01:45 <LindaWang> what should the name be finally?
09:01:48 <ollivier> Yes you're right. I did my best. I asked Trevor if we could keep the git repository after renaming it (if standalone project)
09:01:51 <LindaWang> i am a bit cofused
09:02:48 <ollivier> We are too late for F-release. Then we should follow the rules. Lots of discussions to improve the process. Plese see committer list per gerrit repository.
09:03:17 <ollivier> I think it will be discussed soon in TSC meeting (today?)
09:03:24 <jose_lausuch> ok
09:03:37 <jose_lausuch> so, if xtesting becomes a new project after F, we might change the repo name
09:03:40 <jose_lausuch> well, we will see
09:04:58 <ollivier> The question is to adapt the current subproject model. We ccould create specific committer list and a PTL/referent per subproject.
09:05:35 <jose_lausuch> ok
09:06:10 <ollivier> In fact, they could also ease creating projects... Let's see the suitable models.
09:06:46 <ollivier> As we are late for F we will create them as subprojects which will give us time to update the subproject status or switch to standalone projects.
09:06:57 <jose_lausuch> that makes sense
09:06:59 <ollivier> Let's see how releng will be updated.
09:07:08 <LindaWang> ok
09:07:41 <ollivier> Be free to comment the other points on Plugfest/Hackfest.
09:07:45 <ollivier> #topic AoB
09:07:57 <ollivier> Sorry again we are a little bit late.
09:08:03 <CristinaPauna> yes
09:08:29 <jose_lausuch> nothing from my side
09:08:30 <CristinaPauna> Just a quick note that armband team decided to allocate Delia for Functest project
09:08:49 <CristinaPauna> mostly for ease of arm integration, but also for Functest priorities
09:09:16 <jose_lausuch> that is great! :)
09:09:18 <ollivier> Yes. I didn't mention that. Great news.
09:09:21 <LindaWang> Wow,  great!
09:09:43 <CristinaPauna> So you can consider her when assigning tasks
09:11:03 <ollivier> Noted!
09:11:33 <depo_> thank you! :)
09:12:51 <ollivier> Be free to propose topics as well.
09:13:25 <ollivier> I think we will conclude on Delia helping us. We are already late.
09:13:30 <ollivier> #endmeeting