08:01:48 <ollivier> #startmeeting Functest weekly meeting 30 Jan. 2018
08:01:48 <collabot`> Meeting started Tue Jan 30 08:01:48 2018 UTC.  The chair is ollivier. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:48 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:48 <collabot`> The meeting name has been set to 'functest_weekly_meeting_30_jan__2018'
08:02:25 <ollivier> #topic Role call
08:02:29 <ollivier> #info Cédric
08:02:29 <viktor_t> #info Viktor Tikkanen
08:02:39 <LindaWang> #info Linda Wang
08:02:44 <juhak> #info Juha Kosonen
08:04:52 <ollivier> I added a topic for today's meeting about overall testcase results. I think it's the right time as nosdn no feature scenarios should be stable (regarding milestones)
08:05:26 <ollivier> I will simply list the testcases in failure and we could discuss on them.
08:05:57 <ollivier> #topic Action point follow-up
08:06:14 <ollivier> #info several JIRAS have been created to list the previous actions discussed
08:06:32 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-917
08:06:42 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-918
08:06:57 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-919
08:08:00 <ollivier> They are about Functest jobs refactoring and xtesting related actions (to fully cover run_tests.py, to unlink Framework + entry points and functest_utils) already discussed
08:09:07 <LindaWang> When will we start working on the jobs refactoring? It seems related to Jack's reporting refactoring. JackChan8
08:09:46 <depo> #info Delia Popescu
08:10:45 <ollivier> We could start as soon as possible. I have to check Jack's reporting but they are mainly focused on functest jobs (switch to multijobs for testing, remove obsolete vars, stop hardcoding repo...)
08:12:05 <ollivier> I don't see how it could be part of a big refactoring but I take the point
08:12:23 <ollivier> #action Cédric to check Jack's reporting refactoring proposal
08:13:26 <ollivier> #topic testcases in failure
08:14:23 <ollivier> #info all installers:
08:14:32 <ollivier> #info juju_epc (Workflow failed: Task failed 'neutron_plugin.network.create' -> The request you have made requires authentication)
08:14:42 <ollivier> #info vyos_router (Unauthorized: The request you have made requires authentication)
08:15:50 <ollivier> I sent emails to the right owners but I think we could have a look too. They are still leveraging on openstack utils.
08:16:30 <LindaWang> you mean sfc?
08:16:42 <LindaWang> other feature projects?
08:17:06 <ollivier> epc/juju_epc.py
08:17:29 <LindaWang> and orchestra_*
08:17:32 <ollivier> Yes
08:18:07 <ollivier> But they will be listed in Daisy as they only run vs this installer.
08:19:11 <ollivier> Orchestra testcases are not part of Functest, then the only issue is they don't follow our rules (low rated, no coverage...).
08:20:03 <ollivier> epc and vyos are part of functest and we should fix them as soon as possible for long run testing or functional gating (XCI).
08:22:31 <ollivier> It would be great if we could help them at least to fully switch to snaps. Can I give the action to someone? I will do my best as well.
08:23:57 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-911 for all details
08:24:17 <ollivier> #info Apex
08:24:28 <ollivier> #info rally_sanity (NovaServers.boot_and_live_migrate_server)
08:25:23 <juhak> I have to check this locally
08:25:29 <LindaWang> it failed on nosdn-nofeature-noha scenario (seems 1 controller+2 compute nodes)
08:25:42 <LindaWang> but not sure why Live Migration failed: Migration complete but instance did not change host: overcloud-novacompute-1.opnfvlf.org
08:25:43 <ollivier> Thank you. I think it's induced by Apex but you could please give the requirements: Ceph?
08:26:00 <LindaWang> juhak:  do you have any idea?
08:26:28 <LindaWang> i do not think it has something to do with ceph
08:27:07 <ollivier> Ok. It's enabled when two computes but I don't remember the previous issues (during Euphrates dev cycle)
08:27:39 <LindaWang> we could discuss it with Tim in release meeting if he is there
08:27:42 <juhak> LindaWang: not yet... maybe the type of migaration (block/non-block)
08:28:34 <LindaWang> what is the type of migration in rally?
08:28:41 <ollivier> #action juhak: to check NovaServers.boot_and_live_migrate_server locally
08:30:09 <ollivier> #info snaps_smoke (snaps.openstack.tests.create_router_tests.CreateRouterSuccessTests)
08:30:31 <ollivier> An email was sent to Steven but he asked for access to the POD.
08:30:47 <LindaWang> i am debuging it, snaps's assertion about CreateRouterSuccessTests seems werid:
08:30:55 <juhak> LindaWang: ideally nova can select it but in case of Rally, some challenges (https://bugs.launchpad.net/rally/+bug/1721214)
08:31:31 <LindaWang> https://hastebin.com/ohamudezok.css
08:31:44 <LindaWang> the condition seems useless: orig_settings.external_gateway
08:33:12 <ollivier> Let's discuss about that with Steven too.
08:33:32 <LindaWang> juhak:  in functest/rally, block_migration is false
08:34:29 <ollivier> Then is it a simple race condition ?
08:34:52 <LindaWang> yes
08:35:04 <ollivier> #action LindaWang double check CreateRouterSuccessTests impl with Steven
08:36:06 <ollivier> Could we force it as synchronous (it makes sense here or we should poll the status) via block=True
08:37:02 <juhak> LindaWang: in some configurations only block migration is possible
08:37:21 <juhak> LindaWang: need to check/test this
08:37:41 <ollivier> we could check via Daisy too as the testcase is fine in this case.
08:38:06 <ollivier> #topic Compass
08:38:35 <ollivier> #undo
08:38:35 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1d0cb90>
08:38:41 <ollivier> #info Compass
08:39:05 <ollivier> rally_sanity as well
08:39:19 <ollivier> #info tempest_smoke_serial (tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.test_network_basic_ops)
08:40:11 <ollivier> Is it related to https://gerrit.opnfv.org/gerrit/#/c/51277/ ?
08:40:46 <LindaWang> no
08:41:04 <LindaWang> i did not notice this sub test case error before
08:41:30 <ollivier> #link https://build.opnfv.org/ci/view/functest/job/functest-compass-baremetal-daily-master/1754/console
08:41:36 <LindaWang> that patch is to fix creating network before runing tempest
08:42:12 <ollivier> Yes I would have bet no as well. Maybe Compass is under dev regarding integrating neutron.
08:42:41 <ollivier> LindaWang: Could you please have a look ? We could check the next runs if it's still there.
08:42:52 <LindaWang> i have talked with Compass team to check that
08:42:53 <LindaWang> sure
08:42:56 <juhak> here the problem is related to floating IPs: "No IPv4 addresses found "
08:43:17 <ollivier> no free ip or only IPv6?
08:43:44 <juhak> not sure
08:44:12 <hw_wutianwei_> it seem that the dhcp doesn't assign a ip to the instance
08:44:41 <ollivier> Or no subnet defined.
08:45:48 <ollivier> #action Juha,Linda double check that the tempest issue is related to Compass (SUT)
08:45:49 <juhak> according to log there is a subnet_id defined
08:46:48 <ollivier> #info Daisy
08:47:01 <ollivier> #info orchestra_openims (Orchestra) (sending: http://marketplace.openbaton.org:8080/api/v1/nsds/fokus/OpenImsCore/3.2.0/json)
08:47:12 <ollivier> #info orchestra_clearwaterims (Orchestra) (sending: http://marketplace.openbaton.org:8080/api/v1/nsds/fokus/ClearwaterIMS/3.2.0/json)
08:47:32 <ollivier> Same issue for a while and nothing has been done. I will send a last email on it.
08:48:32 <ollivier> It's out of functest scope but we host the 2 testcases.
08:49:14 <ollivier> #Fuel
08:49:25 <ollivier> #info api_check (snaps.openstack.utils.tests.nova_utils_tests.NovaUtilsInstanceVolumeTests)
08:49:37 <ollivier> I think it's related to SUT.
08:49:55 <ollivier> I should have worked for a while (MS3.1)
08:50:11 <ollivier> #info Fuel (ARM)
08:50:23 <ollivier> #info vping_ssh (no logs published)
08:50:36 <ollivier> #info cloudify_ims (Exception: Cloudify Manager isn't up and running)
08:51:09 <ollivier> depo: CristinaPauna: I think it concerns SUT as well.
08:51:36 <ollivier> depo: CristinaPauna: Could you please publish logs as artifacts? Else we can't debug.
08:52:02 <depo> I will look into into
08:52:09 <ollivier> Thank you
08:52:19 <ollivier> #action depo to publish logs as artifacts
08:52:34 <ollivier> #info Joid
08:52:50 <ollivier> #info no logs before https://gerrit.opnfv.org/gerrit/#/c/50871/ available
08:53:06 <ollivier> I will check the next CI runs
08:53:15 <ollivier> Thank you Linda for the fix.
08:53:25 <LindaWang> np
08:53:35 <ollivier> #info pylint/coverage
08:53:57 <ollivier> Thank you for starting fixing errors/warnings in refstack and rally.
08:54:15 <ollivier> Please review https://gerrit.opnfv.org/gerrit/51295
08:54:54 <ollivier> We should create a method for avoid duplicating code between snaps-related testcases
08:55:19 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-916
08:56:08 <ollivier> #link (epic) https://jira.opnfv.org/browse/FUNCTEST-911
08:56:38 <ollivier> #info core and common modules are fixed and well covered
08:56:49 <ollivier> #topic functest-kubernetes
08:57:09 <ollivier> #info the first testcase was published and opnfv/functest-kubernetes is now built automatically
08:57:23 <ollivier> #info Compass job is under review
08:57:34 <ollivier> #link Compass job is under review
08:57:51 <LindaWang> the issue blocking k8s tests run in Jenkins is about creds file
08:58:44 <ollivier> Yes. I'm fine with your original idea. There is also an issue with logging.ini.
08:59:30 <LindaWang> this patch can be merged only when we remove def cource_openrc in run_tests.py
09:00:30 <ollivier> I think we should discuss with Steven included (I will answer to his previous email)
09:01:25 <LindaWang> why can not we create a new creds file for k8s deployment as this patch proposed: https://gerrit.opnfv.org/gerrit/#/c/51283/
09:01:56 <ollivier> Functest shouldn't host any K8s config files.
09:02:21 <LindaWang> including openstack creds file?
09:03:00 <LindaWang> for snaps, we could read all the env vars and then generates a tmp file for snaps?
09:03:38 <ollivier> We could load a common creds file name whatever the SUT.
09:04:03 <LindaWang> it sounds better
09:04:59 <ollivier> I don't think so but it's simpler and we could start like that. But we have to rename the file in Functest and modify the releng jobs.
09:05:39 <ollivier> ok?
09:05:45 <LindaWang> sure
09:05:56 <ollivier> #topic AoB
09:05:56 <LindaWang> i'd update the patch this way
09:06:00 <ollivier> thank you
09:06:45 <ollivier> About vnf offline, we do setup a specific meeting with Valentin who is in Canada
09:07:00 <ollivier> browbeat is strongly linked to tripleo.
09:07:12 <LindaWang> thanks, but i have not received his answer
09:08:09 <ollivier> Yes, we also discuss in French about several updates for his testcase :)
09:08:15 <LindaWang> i have not seen an example about browbeat in its document
09:09:34 <ollivier> I (and Jose) received a direct email about I'm simply helping to build the container. I can forward the whole chain or extract the key idea.
09:09:53 <LindaWang> thanks, please
09:10:03 <ollivier> Ok. Sorry to be late again.
09:10:46 <ollivier> Most of the failures will be investigated. Thank you. I will do my best to help vnf. Please be free to help too.
09:11:00 <ollivier> #endmeeting