#opnfv-functest: Functest weekly meeting 27 Feb. 2018

Meeting started by ollivier at 07:59:33 UTC (full logs).

Meeting summary

    1. Cédric Ollivier (ollivier, 07:59:42)
    2. Linda Wang (LindaWang, 08:00:29)
    3. Jose Lausuch (jose_lausuch, 08:00:36)
    4. Delia Popescu (depo, 08:02:35)

  1. Action point follow-up (ollivier, 08:03:42)
    1. the full synchonization between functest and functest-xtesting has just been done (ollivier, 08:03:55)
    2. several bugs have been opened vs APEX (ollivier, 08:05:18)
    3. https://jira.opnfv.org/browse/APEX-564 (ollivier, 08:05:27)
    4. https://jira.opnfv.org/browse/APEX-570 (ollivier, 08:05:36)
    5. https://jira.opnfv.org/browse/APEX-571 (ollivier, 08:05:44)
    6. https://build.opnfv.org/ci/view/functest/job/functest-apex-baremetal-daily-master/810/console (LindaWang, 08:08:07)
    7. only refstack_defcore(under investigation) has to fixed in Orange POD (ollivier, 08:12:37)

  2. releng (ollivier, 08:16:20)
    1. the new proposal rewriting our Jenkins jobs has been merged then reverted (ollivier, 08:16:37)
    2. https://gerrit.opnfv.org/gerrit/#/c/51853/ (ollivier, 08:16:45)
    3. ACTION: Cédric ask to David and Tim if they agree with losing jenkins jobs history. (ollivier, 08:22:37)

  3. code improvement (ollivier, 08:22:59)
    1. our code has been rated at 9.61/10 (be free to fix the remaining errors) (ollivier, 08:23:09)
    2. API has been cleant and now only core and utils modules could be reused by third-parties as they are (ollivier, 08:23:25)
    3. orchestra testcases now rely on SNAPS instead of OpenStack utils (even if they still don't work) (ollivier, 08:23:40)
    4. OpenStack utils have been removed from Functest (several methods have been copied to SDNVPN and SFC) (ollivier, 08:23:49)
    5. https://gerrit.opnfv.org/gerrit/#/c/52685/ (ollivier, 08:24:11)
    6. https://jira.opnfv.org/browse/FUNCTEST-938 (ollivier, 08:24:20)

  4. functest (ollivier, 08:28:47)
    1. a new testcase integrating patrole should be published soon (ollivier, 08:29:05)
    2. https://docs.openstack.org/tempest/latest/plugin-registry.html (ollivier, 08:31:33)
    3. the new patchset on refstack has been published (ollivier, 08:34:46)
    4. https://gerrit.opnfv.org/gerrit/#/c/52311/ (ollivier, 08:41:10)
    5. Dovetail still calls our functest binary (ollivier, 08:43:32)

  5. functest-kubernetes (ollivier, 09:03:39)
    1. the second Kubernetes testcase is still under review (ollivier, 09:03:51)
    2. https://gerrit.opnfv.org/gerrit/51635 (ollivier, 09:03:58)
    3. first unit tests are proposed as review (ollivier, 09:04:21)
    4. https://gerrit.opnfv.org/gerrit/#/c/52337/ (ollivier, 09:04:29)

  6. AoB (ollivier, 09:09:24)


Meeting ended at 09:13:14 UTC (full logs).

Action items

  1. Cédric ask to David and Tim if they agree with losing jenkins jobs history.


People present (lines said)

  1. ollivier (115)
  2. LindaWang (34)
  3. serena-zte (22)
  4. depo (7)
  5. collabot` (4)
  6. jose_lausuch (4)


Generated by MeetBot 0.1.4.