08:01:44 <ollivier> #startmeeting Functest weekly meeting 10 Apr. 2018
08:01:44 <collabot`> Meeting started Tue Apr 10 08:01:44 2018 UTC.  The chair is ollivier. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:44 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:44 <collabot`> The meeting name has been set to 'functest_weekly_meeting_10_apr__2018'
08:01:52 <ollivier> #info Cédric Ollivier
08:02:02 <serena-zte> #info SerenaFeng
08:02:07 <juhak> #info Juha Kosonen
08:02:33 <viktor_t> #info Viktor Tikkanen
08:02:51 <LindaWang> #info Linda Wang
08:03:44 <depo> #info Delia Popescu
08:03:54 <ollivier> hi.
08:04:00 <ollivier> #topic Action point follow-up
08:04:22 <ollivier> #info Functest Fraser containers are successfully built (jjobs are updated too)
08:04:38 <ollivier> #link https://build.opnfv.org/ci/view/functest/job/functest-daisy-baremetal-daily-fraser/1/console
08:05:05 <ollivier> #info opnfv/functest-kubernetes was split into 4 containers (core, healthcheck, smoke, features)
08:05:17 <ollivier> #info stor4vnf and clover are now hosted by opnfv/functest-kubernetes-features
08:06:25 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-904
08:06:32 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-905
08:06:39 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-952
08:06:46 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-943
08:07:09 <ollivier> We are still waiting for stor4vnf stable/fraser
08:07:41 <LindaWang> stor4nfv stable/fraser has been created
08:08:04 <ollivier> great. I will update upper-constraints.txt right after the meeting
08:08:22 <ollivier> #topic functest
08:08:32 <ollivier> #info vnf testcases are now enabled in odl nofeature scenarios
08:08:42 <ollivier> #link https://build.opnfv.org/ci/view/functest/job/functest-daisy-baremetal-daily-fraser/1/console
08:10:06 <ollivier> maybe we will have to run them in virtual PODs for the next release as well (from the time being xci only supports virtual env)
08:10:51 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/49071/
08:11:14 <ollivier> #info Gnocchi metric service can be now verified by Rally
08:11:22 <ollivier> #link https://review.openstack.org/532551
08:11:29 <ollivier> #link https://review.openstack.org/#/q/owner:juha.kosonen%2540nokia.com+status:merged
08:12:03 <ollivier> juhak: could you please give us some details how to integrate them (rally versions?)
08:12:41 <juhak> Rally OpenStack plugins have been moved into a separate repo https://github.com/openstack/rally-openstack
08:13:21 <juhak> we need to update this into use
08:13:55 <LindaWang> which version of rally?
08:14:05 <ollivier> we can handle that by requirements + upper-constraints. It's rolling release model ?
08:14:34 <juhak> rally-openstack 1.0.0
08:15:52 <ollivier> juhak: compare to the previous rally integration, we will switch from a stable branch to a pypi package. That's good.
08:16:24 <juhak> ollivier: yes, that's the case
08:16:58 <juhak> rally-openstack 1.0.0 requires rally>=0.11.0
08:17:18 <ollivier> juhak: it seems fine to integrate that in G or do you think we may backport it.
08:17:48 <juhak> I think G would be good
08:18:59 <ollivier> ok. That's clear. We will have to add a third-party requirement (rally-openstack) and a line in upper-constraints. Rally version management will be unchanged.
08:19:07 <ollivier> thank you.
08:19:38 <juhak> nb
08:20:14 <ollivier> nb: nota bene?
08:20:30 <juhak> np
08:20:51 <ollivier> ok :). thank you for the upstream work.
08:21:14 <ollivier> #info one snaps_smoke subtest seems buggy:
08:21:28 <ollivier> #link https://jira.opnfv.org/browse/SNAPS-298
08:21:41 <ollivier> https://jira.opnfv.org/browse/SNAPS-299
08:21:46 <ollivier> #link https://jira.opnfv.org/browse/SNAPS-299
08:23:02 <ollivier> The testcase seems buggy and it could fail on many installers (assert on first element of array)
08:23:31 <ollivier> Steve was on PTO. I hope he will fix that soon.
08:24:33 <ollivier> LindaWang: be free to complete if needed
08:24:36 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/53685/
08:25:31 <LindaWang> ollivier: ok, i will.
08:25:33 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/53685/2/snaps/openstack/tests/create_router_tests.py
08:26:47 <ollivier> #info tempest 17.0.0 has a bug about volume client v2/v3, which also affects volume tests in patrole and refstack
08:27:07 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-954
08:27:45 <LindaWang> i have dicsussed that with Tempest PTL, and he agreed to  update tempest version
08:28:09 <LindaWang> in upper_constraint i mean
08:28:47 <ollivier> yes, it's not the same team. As soon as it's merged, I will synchronize all OPNFV projects.
08:29:18 <ollivier> Does he confirm that the requirements are compatible?
08:29:48 <LindaWang> i am not sure
08:30:04 <LindaWang> i have not seen his patch yet.
08:30:16 <ollivier> It's mandatory.
08:31:02 <ollivier> #action LindaWang to try to update tempest in OpenStack requirements
08:31:18 <ollivier> #action ollivier to synchronize all OPNFV projects if updated
08:31:47 <ollivier> If it's not updated, I think we shouldn't bypass that process.
08:31:59 <ollivier> agree?
08:32:35 <LindaWang> ok.
08:33:56 <ollivier> Then we have to double check if juju_epc is working well vs non default Region name (Apex)
08:34:08 <ollivier> and tempest_smoke_serial, rally_sanity, refstack_defcore, patrole, snaps_smoke, cloudify_ims, vyos_vrouter and juju_epc avs non default Keystone domain (Joid)
08:34:33 <LindaWang> gsutils should be installed on intel-pod18
08:34:47 <LindaWang> otherwise, we could not check the result log
08:34:49 <ollivier> Yes. It has been asked for a while
08:34:57 <ollivier> even David is aware.
08:36:16 <ollivier> It would be very helpful If anybody could setup non default Region names or non default Keystone domains and run these testcases.
08:36:47 <ollivier> The issues may be induced by Joid.
08:39:55 <ollivier> From the time being, our testcases seem fine (except snaps_smoke).
08:40:04 <ollivier> #topic functest-kubernetes
08:40:17 <ollivier> #info Konrad is still converting his presentation to markdown
08:40:33 <ollivier> #info Kubernetes testcases have to be documentated (as part of classical Functest guides?)
08:40:51 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-951
08:42:01 <LindaWang> functest repo is fine i think
08:43:04 <ollivier> agree.
08:44:01 <ollivier> It would be great to document this testcases quite quickly because we are finishing the Functest part.
08:45:07 <ollivier> #info several unit tests have been added to increase coverage
08:45:20 <ollivier> #topic documentation
08:45:30 <ollivier> #info all rst files are now checked via doc8
08:45:41 <ollivier> #info Release notes have been updated (results, links and refs must be modified to Fraser)
08:46:04 <ollivier> #info one patch updating User Guide is under review
08:46:16 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/54367/
08:47:26 <ollivier> thank you all for updating (or reviewing) all documentations.
08:48:30 <ollivier> It remains several minor doc updates and then we will be ready for the release.
08:48:44 <ollivier> well on time. Thank you all.
08:49:24 <ollivier> #info All OpenStack testcases are passing on Orange ONAP Openlab (last night).
08:49:38 <ollivier> (master and fraser)
08:50:31 <ollivier> \o/
08:50:37 <ollivier> #topic AoB
08:51:17 <ollivier> #link https://jira.opnfv.org/browse/SNAPS-295
08:52:12 <ollivier> Our code has depended on snaps since E.
08:52:35 <LindaWang> it is
08:53:42 <ollivier> Let's see hown snaps is involved in the next release process.
08:54:27 <ollivier> I have to send you my notes for ONS. I will write them this afternoon. Sorry for the delay (conflicts with the next release)
08:55:34 <ollivier> Anything else?
08:55:48 <LindaWang> no
08:57:01 <ollivier> Great week! Let's see the first CI runs vs Fraser. Thank you.
08:57:10 <ollivier> #endmeeting