08:00:43 <ollivier> #startmeeting Functest weekly meeting 4 Sept. 2018
08:00:43 <collabot> Meeting started Tue Sep  4 08:00:43 2018 UTC.  The chair is ollivier. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:43 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:43 <collabot> The meeting name has been set to 'functest_weekly_meeting_4_sept__2018'
08:00:49 <ollivier> #Info Cédric Ollivier
08:00:52 <ollivier> hello
08:00:59 <delia_> #info Delia Popescu
08:01:05 <juhak> #info Juha Kosonen
08:01:11 <viktor_t> #info Viktor Tikkanen
08:02:08 <ollivier> #topic Action point follow-up
08:02:21 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-1008
08:02:29 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-1009
08:02:57 <ollivier> juhak: thank you for having removed the last dependencies to OPNFV installers.
08:03:11 <juhak> np
08:04:26 <ollivier> I don't plan to give details the last changes about tempest and rally (static users, specific tempest roles, refactoring).
08:04:59 <ollivier> Be free to ask if you want more details about the next changes:
08:05:22 <ollivier> #link https://gerrit.opnfv.org/gerrit/61531
08:05:32 <ollivier> #link https://gerrit.opnfv.org/gerrit/61529
08:05:47 <ollivier> #link https://gerrit.opnfv.org/gerrit/61669
08:06:26 <ollivier> Else I will switch to the next possible actions per Functest subproject.
08:07:14 <delia_> I am ok
08:07:51 <ollivier> #topic Xtesting
08:08:01 <ollivier> updated to Alpine 3.8
08:08:13 <ollivier> #info we should allow overriding the default runner (more or less linked to OpenStack)
08:09:50 <ollivier> Then we may easily define specific logic per VIM by leveraging on stevedore (OS or K8s). Then https://gerrit.opnfv.org/gerrit/#/c/56625/ coule be merged.
08:10:12 <ollivier> (e.g. getting default values such as DEPLOY_SCENARIO per VIM)
08:10:38 <ollivier> One bug to fix: we shouldn't print an empty tab when all testcases are skipped
08:10:48 <ollivier> and we could publish html reports as unit artifacts (snaps)
08:12:19 <ollivier> #info all patches about new entry points (stevedore) has been pushed in OPNFV Feature trees.
08:13:41 <ollivier> #topic Functest-kubernetes
08:13:53 <ollivier> #info updated to Alpine 3.8 and Kubernetes v1.11.2
08:14:01 <ollivier> #info the docker image sizes have been hugely decreased
08:14:10 <ollivier> #info new jjbs have been proposed
08:14:56 <ollivier> I think it's fine for the new release. David asked me to start an internship. Maybe we could propos to add a VNF testcase in K8s verification.
08:15:31 <ollivier> Rebaca (juju_epc) also proposed their helps on that topic few weeks ago.
08:16:02 <ollivier> Let me know if you're interested in it or if you consider a better internship topic
08:17:29 <ollivier> or if you simply agree
08:18:02 <delia_> I agree
08:18:10 <viktor_t> It is OK
08:18:25 <juhak> agree
08:18:32 <ollivier> thank you. Let's switch to OS
08:18:42 <ollivier> #topic Functest
08:19:11 <ollivier> #info our containers were updated to Alpine 3.8 (+few download optimizations)
08:20:18 <ollivier> #info barbican: few configs are missing compared to the current gates (it requires a dedicated Python class)
08:20:27 <ollivier> #link https://github.com/openstack/barbican-tempest-plugin/blob/master/tools/pre_test_hook.sh
08:20:50 <ollivier> I'm just facing with a last subtest in failure but it may be related to my deployment.
08:21:13 <ollivier> delia_: could you please run a review vs Fuel? I think it's the only installer supporting barbican.
08:22:10 <delia_> I have to check, from what I know it is ok
08:22:32 <ollivier> ok. I'm looking for a second platform to double check.
08:22:47 <delia_> but even if it is the only installer supporting barbican, it does not support everything
08:23:16 <ollivier> about barbican? I think it was passing.
08:23:24 <delia_> like now we do support vol encryption, but no image signing
08:23:28 <delia_> yes, it is
08:24:04 <ollivier> ok. My point is to add that tests. It's working here. the only issue is about one negative test which is falsy passing.
08:24:37 <delia_> though I do not understand how image signing test is passing if we do not have it enabled in fuel
08:25:08 <ollivier> They are all skipped from the time being. (tempest_role and scenario sections are incorrect)
08:25:19 <delia_> ok
08:25:25 <ollivier> I will do my to publish my pending work this afternoon.
08:25:38 <ollivier> #info tempest: all scenario configs are missing (img_dir, img_file and img_properties)
08:25:51 <ollivier> (It's required at least for barbican)
08:26:43 <ollivier> #link https://artifacts.opnfv.org/logs/functest/lf-pod2/2018-09-03_13-16-44/barbican/tempest.conf
08:27:04 <ollivier> be free to pick that action. I haven't opened the JIRA ticket yet.
08:28:15 <ollivier> #info rally raised conflicts once when creating mandatory roles (ResellerAdmin)
08:29:20 <ollivier> It may be related to my parallel test. As far as I know, rally creates the default role when bootstraping tempest (swift, etc.)
08:31:03 <ollivier> juhak: I will send you the exceptions. It would be great if you could confirm.
08:31:09 <ollivier> juhak: or not :)
08:31:37 <juhak> I'll take a look
08:31:49 <ollivier> We may bypass that if needed by creating the roles in Functest before running rally. Then we could catch conflict exceptions.
08:32:15 <ollivier> juhak: Thank you.
08:32:31 <ollivier> #info juju_epc currently raises conflicts when discovering cidr (if parallel testing only).
08:33:01 <ollivier> It was fixed as far as I remember. I have to double check why one nightly run failed.
08:33:15 <ollivier> #info possible remaining resources
08:33:43 <ollivier> volumes after rally_sanity (bug in Orange ONAP Openlab?)
08:33:52 <ollivier> user/project created by tempest-based testcases
08:34:42 <ollivier> I haven't worked on it. At first glance, TempestCommon:clean() looks fine
08:35:22 <ollivier> It would be great if everyone checks the remaining resources after running all testcases.
08:36:12 <delia_> security groups seem to be remaining, not all the time though
08:37:06 <ollivier> delia_: they should be deleted by removing users and projects. Could you please check if user is still defined too?
08:37:35 <delia_> I will, and I'll let you know
08:37:45 <ollivier> great
08:38:08 <ollivier> #info David agreed to create branches before the right milestones. SFC should apply the same rules.
08:38:39 <ollivier> (quickly discussed with Manuel here yesterday)
08:38:51 <delia_> I tried to run parallel testing on different branches, but they failed. I hope to have another chance today
08:39:17 <ollivier> It would be great if you could check he duration of basic testcases when running in //.
08:39:18 <delia_> I will sent you the results from single branch healthcheck and smoke parallel test
08:39:26 <ollivier> thank you.
08:40:05 <ollivier> Here Floating ips are becoming active after a long time when running 3 healthchecks in //.
08:41:15 <ollivier> L3 has always been the worse impl in Neutron but I would bet it's a deployment issue here.
08:41:35 <delia_> it was not the case here, all tests failed, so is not  something I an trust. I will try again today
08:42:43 <ollivier> Here the testcases could fail if timeout is reached as here. But it happens on heavy runs. Only one Functest release seem working well (10 tests in //).
08:43:29 <ollivier> #info tempest_full and tempest_scenario should still be enabled in daily gates
08:43:40 <ollivier> I will update the jjbs right after the meeting
08:43:58 <ollivier> #info: we are asked to split download.sh (per arch and per tiers)
08:44:14 <ollivier> (thank Fatih)
08:44:35 <ollivier> #action all we do update docs and configs before releasing
08:45:09 <ollivier> be free to pick the action (to partially rewrite download.sh)
08:46:34 <ollivier> Even if it remains little bugs and enhancements, I think we could create our branches.
08:47:01 <ollivier> The CI/CD results are very bad but I don't think the installers are good enough.
08:47:34 <ollivier> At least Fuel is passing https://build.opnfv.org/ci/view/functest/job/functest-fuel-baremetal-daily-master/441/console
08:48:02 <OPNFV-Gerrit-Bot> Merged functest: Remove vmtp and shaker from docker/smoke/testcases.yaml  https://gerrit.opnfv.org/gerrit/61793
08:48:44 <delia_> regarding shaker testcase, on fuel. it ties to reach internal endpoints, so it fails.
08:49:30 <delia_> I still have to look into it, case next days I could not reach any public endpoints either. We have like ENDPOINT_TYPE=internal env var
08:49:36 <ollivier> Normally it should force OS_INTERFACE=public
08:49:37 <delia_> so it goes with internal
08:50:19 <ollivier> As it runs in VM, it must reach public endpoints. Then shaker, cloudify_ims, vyos_vrouter and juju_epc will fail.
08:50:35 <delia_> whell, it does not. I set the endpoints to public for the test but I still had issues
08:50:47 <ollivier> https://git.opnfv.org/functest/tree/functest/opnfv_tests/openstack/shaker/shaker.py#n84
08:51:51 <delia_> yes, I know
08:51:56 <delia_> but fuel has: export OS_ENDPOINT_TYPE="internal"
08:52:02 <delia_> https://build.opnfv.org/ci/view/functest/job/functest-fuel-baremetal-daily-master/441/console
08:52:02 <ollivier> Unless there s a conflict between OS_INTERFACE :)
08:52:15 <ollivier> and OS_ENDPOINT_TYPE
08:52:21 <delia_> yes
08:52:27 <delia_> I will look into it
08:52:42 <ollivier> I would have bet that shade first selects the right env var.
08:53:07 <delia_> I am possitive not in this case
08:53:11 <delia_> :)
08:53:30 <delia_> it tied nutron and nova internal endpoints
08:53:46 <ollivier> Here we could simply add "unset OS_INSTALLER_TYPE"
08:54:41 <ollivier> thank you
08:55:03 <ollivier> #topic AoB
08:55:35 <ollivier> Anything Else? I do send an email about the possible Functest meeting shedule.
08:58:16 <delia_> not from me
08:59:10 <ollivier> Then we are on time. Thank you. Have a nice week.
08:59:16 <ollivier> #endmeeting