07:59:58 <ollivier> #startmeeting Functest weekly meeting 09 Oct. 2018
07:59:58 <collabot> Meeting started Tue Oct  9 07:59:58 2018 UTC.  The chair is ollivier. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:59:58 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:59:58 <collabot> The meeting name has been set to 'functest_weekly_meeting_09_oct__2018'
08:00:01 <ollivier> Hello
08:00:06 <ollivier> #info Cédric ollivier
08:00:14 <juhak> #info Juha Kosonen
08:00:30 <viktor_t> #info Viktor Tikkanen
08:01:53 <ollivier> Delia is not connected. Let's wait few minutes.
08:03:23 <delia_> #info Delia Popescu
08:03:25 <delia_> Hi!
08:03:47 <viktor_t> Hello!
08:04:25 <ollivier> Hello
08:04:46 <ollivier> #info Action point follow-up
08:04:51 <ollivier> #undo
08:04:51 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2125390>
08:04:57 <ollivier> #topic Action point follow-up
08:05:15 <ollivier> #info Intel NFV CI test-cases is ready for reviews
08:06:02 <ollivier> It seems quite good. I will check how the patches on OpenStack side are rated.
08:06:34 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/61151/
08:07:16 <ollivier> #link https://gerrit.opnfv.org/gerrit/gitweb?p=functest.git;a=blob;f=docker/smoke/Dockerfile;h=c35d0ca27967c0c84b34feedecc4612189dd4e4c;hb=0a009fc2abb3eeb9d7240853ae8d5643e3722d2f#l10
08:07:36 <ollivier> #info LFN team asks for modifying our tox.ini + doc trees
08:07:47 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/62523/
08:08:15 <ollivier> I think both LFN packages (theme and conf) should be improved before merge (conf.py is rated at -330/10)
08:08:50 <ollivier> And if merge, the overall jjb verification would raise  timeout (30 min)
08:09:03 <ollivier> I just sent an email to LFN
08:09:45 <ollivier> #link https://build.opnfv.org/ci/job/functest-verify-unit-tests-and-docs-master/1778/console
08:10:52 <ollivier> #info requirements have been synchronized in most Features integrated in Functest
08:11:09 <ollivier> be free to review https://gerrit.opnfv.org/gerrit/#/c/63317/
08:11:21 <ollivier> (FDS doesn't participate to Gambia)
08:13:49 <ollivier> #topic Functest
08:14:09 <ollivier> #info Fraser last Apex run was successful
08:14:32 <ollivier> #link https://build.opnfv.org/ci/view/functest/job/functest-apex-baremetal-daily-fraser/294/console
08:14:38 <ollivier> the branch seems over
08:15:07 <ollivier> #info Gambia
08:15:27 <ollivier> Fuel (both architectures) starts running Functest gambia containers (unsuccessfully)
08:16:06 <ollivier> Sorry the last runs are much better
08:16:35 <ollivier> #link https://build.opnfv.org/ci/view/functest/job/functest-fuel-armband-baremetal-daily-gambia/lastFailedBuild/console
08:16:42 <ollivier> At least for Healthcheck
08:17:23 <ollivier> delia_: it seems related to fuel arm64, no?
08:17:55 <delia_> ollivier: whell, it depends on the error
08:18:22 <delia_> ollivier: on what you sent yes it is
08:18:26 <delia_> I will look into it
08:19:17 <ollivier> delia_: thank you.
08:19:20 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/63319/
08:19:42 <ollivier> #info new IMG_PROPERTIES env var to reduce config patches
08:19:50 <ollivier> delia_: Thank you for that patches
08:20:00 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/61913/
08:20:03 <delia_> ollivier: any time
08:20:30 <delia_> ollivier; patch to fix sent :(
08:20:41 <ollivier> We may apply the same rules for Flavor extra specs?
08:21:06 <ollivier> delia_: the patch is about releng. Functest is working well ;)
08:21:24 <delia_> ollivier: I say we can
08:21:56 <ollivier> Can I action you about that ?
08:22:14 <delia_> sure
08:22:37 <ollivier> #action Delia ease configuring extra specs via env vars
08:22:38 <ollivier> Thank you
08:23:18 <ollivier> #info Rally: floating ip tests have been integrated
08:23:25 <ollivier> juhak: Thank you
08:23:33 <ollivier> It helped us to highligh issues in Orange Openlab
08:23:56 <juhak> that's great
08:24:17 <ollivier> I should be noted that the rally test doesn't wait the floating ip to be active (few sec in normal cases).
08:24:35 <ollivier> #link https://gerrit.opnfv.org/gerrit/#/c/63099/
08:24:45 <ollivier> do we backport it till gambia?
08:25:09 <ollivier> I would say yes.
08:25:15 <juhak> I think we should
08:26:08 <delia_> agree
08:26:09 <ollivier> juhak: would you mind backporting the patch?
08:26:33 <juhak> already on progress
08:26:39 <ollivier> thank you
08:27:43 <ollivier> I would like to share with you one rally exception
08:27:59 <ollivier> juhak: maybe you're already aware of it.
08:28:12 <ollivier> If shared networks already exist, rally creates a new shared network
08:28:39 <ollivier> It may change a little bit the bahavior (ie. vm booting with network or not in case of Cinder tests)
08:29:32 <ollivier> Then tempest.conf in res dir is not a full copy of the executed one (fixed_network_name is modified during rally execution)
08:30:02 <juhak> I think the network creation depends on test case
08:30:11 <juhak> what case you are referring?
08:30:30 <ollivier> few sec
08:31:54 <ollivier> tempest.api.volume.test_volumes_actions.VolumesActionsTest.test_attach_detach_volume_to_instance[compute,id-fff42874-7db5-4487-a8e1-ddda5fb5288d,smoke]
08:32:36 <ollivier> If one shared network already exists, then fixed_network_name is set and the vm is connected to the new network.
08:32:57 <juhak> ah, tempest cases executed by Rally
08:32:59 <ollivier> If not, no network is detected and the vm is not connected to any network
08:33:13 <ollivier> It works here in both cases
08:33:35 <ollivier> It may raise side effects vs Contrail what I'm checking
08:33:59 <ollivier> juhak: yes.
08:35:02 <juhak> ok, your analysis make sense
08:35:06 <ollivier> Nothing wrong. But I would like to share this very specific case where the tempest.conf saved is not the right one. It may happen when testing OpenStack in production.
08:35:57 <juhak> thanks, this is good to know
08:36:09 <ollivier> #info rally_full sometimes fails when testing Cinder in Openlab (in progress)
08:36:39 <ollivier> Rally seems fine. I'm writing a new task to raise the bugs.
08:38:28 <ollivier> Nothing else from my side. I cleant several JIRA tickets for the next release. Only docs have to be updated (+ few backports)
08:38:50 <ollivier> #topic AoB
08:39:48 <ollivier> I forgot the new bug opened by CristinaPauna
08:39:52 <ollivier> #link https://jira.opnfv.org/browse/FUNCTEST-1010
08:40:14 <ollivier> I will add the missing condition in jjbs.
08:40:18 <ollivier> Anything else?
08:40:29 <viktor_t> I'll be "out of office" this and next week
08:41:43 <ollivier> Thank you for sharing that. It's not related to OpenSource summit
08:42:43 <ollivier> Then let's close the meeting. Thank you. Have a nice week!
08:42:48 <ollivier> #endmeeting