#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 15:01:08 UTC (full logs).

Meeting summary

    1. Julien (julienjut, 15:01:20)
    2. Chris Price (ChrisPriceAB, 15:01:28)

  1. roll call (ChrisPriceAB, 15:01:35)
    1. Uli Kleber (Huawei) (uli_, 15:01:56)
    2. Chris Price (ChrisPriceAB, 15:02:05)
    3. Ashiq Khan (DOCOMO) (Ashiq, 15:02:13)
    4. Tapio Tallgren (TapioT, 15:02:30)
    5. dlenrow (dlenrow, 15:03:43)
    6. Bin (bin_, 15:03:53)

  2. roll call (dlenrow, 15:04:12)
    1. Frank Brockners (frankbrockners, 15:04:20)
    2. Pranav Mehta (Pranav, 15:04:30)
    3. Wenjing Chu (Wenjing, 15:04:31)
    4. palani (palani, 15:05:11)

  3. minute approval (ChrisPriceAB, 15:06:35)
  4. approve previous minutes (dlenrow, 15:06:54)
    1. Bryan Sullivan (bryan_att, 15:07:25)
    2. Tapio asks for adjustment to minutes related to writeup of using CI tools (dlenrow, 15:08:09)
    3. Tapio proposed changes to the action on himself for the previous minutes (ChrisPriceAB, 15:08:10)
    4. postpone approval until we can correct (dlenrow, 15:08:33)
    5. pranav reminds that we need to get convo on agenda about top level project selection (dlenrow, 15:09:04)
    6. wants TSC discussion about how we create top level project, subproject (dlenrow, 15:09:49)
    7. CP suggests we wait until we have more projects in motion and learn what issues are. (dlenrow, 15:10:23)
    8. Dirk Kutscher (dku, 15:10:29)
    9. fbrockners agrees this won't become issue until we have more mature projects (dlenrow, 15:11:00)
    10. occurs later in our lifecycle (dlenrow, 15:11:35)
    11. Uli points out we're building bottom up and may want to discuss some top-down soon (dlenrow, 15:12:15)
    12. general agreement to defer (dlenrow, 15:12:31)

  5. agenda bashing (ChrisPriceAB, 15:12:37)
  6. agenda bashing (dlenrow, 15:12:40)
    1. Chris reminds CI project is in public review and now is the time to contribute founding contributors/committers (dlenrow, 15:14:04)
    2. discussion of SR and of linux distro will be added to agenda (dlenrow, 15:16:09)

  7. 2015 OPNFV event planning (dlenrow, 15:16:22)
    1. Brandon outlines event possibilities, hackfests, etc., (dlenrow, 15:17:11)
    2. ray___: Thx (dlenrow, 15:17:57)
    3. Brandon describes the plan to develop a presence for OPNFV at key events during 2015 including MWC and the OPNFV Summit (ChrisPriceAB, 15:18:20)
    4. Planning to improve tools to help remote folks participate (dlenrow, 15:18:23)
    5. OPNFV marketing committee calls bi-weekly on Wednesdays at 7:30am PT (ray___, 15:18:25)
    6. describes plans for expanding presence at events (dlenrow, 15:19:01)
    7. marketting events can include speakerships and panels at conferences and summits as well as OPNFV specific events (ChrisPriceAB, 15:19:12)
    8. Plan to discuss event candidates at next mktg call (dlenrow, 15:19:49)
    9. describes some collateral under development. Looking to have material to describe release. (dlenrow, 15:20:32)
    10. Brandon has a sort of strawman roadmap he will show (dlenrow, 15:21:42)
    11. Chris Wright (cdub, 15:22:14)
    12. co-located events at OS Summit and SDN/NFV World congress next year (dlenrow, 15:23:59)
    13. ACTION: ray will send to mailing list (dlenrow, 15:24:25)
    14. discussion of tradeoffs evaluated in choosing some dates and venues. (dlenrow, 15:26:10)
    15. lots of discussion about difficulty scheduling our summit in November-ish against existing cloud events (dlenrow, 15:30:15)
    16. cwright asks "what are we trying to achieve at summit?" (dlenrow, 15:32:48)
    17. discussion of attract devs versus announce release details vs. plan next release (dlenrow, 15:33:49)
    18. summit + hackfest targetting 3-4 days, expect TSC and devs to do presos, etc. Many on this call will find value in both summit and hackfest (dlenrow, 15:35:12)
    19. CP asks for folks to check calendars and find conflicts to help input into this difficult scheduling requirement (dlenrow, 15:35:45)
    20. CP Hackfest in May at OS Summit seems to make lots of sense due to tight coupling of projects/communities (dlenrow, 15:36:15)
    21. discussion of doodle poll or similar to zero in (dlenrow, 15:38:20)
    22. we need to give poll responders a way to say why they cannot support a proposed date, so that major conflicts with other meetings e.g. IETF are clearer (bryan_att, 15:39:49)
    23. ACTION: Ray/Brandon to move this along offline so we can move on in agenda. To get poll out by end of week (dlenrow, 15:41:26)
    24. CP asks TSC to provide feedback on summit dates. (dlenrow, 15:41:40)

  8. Project status (dlenrow, 15:42:12)
    1. trevor updates: testing plan to come back to TSC next week with more detailed updae (dlenrow, 15:43:00)
    2. lots of work items and volunteers to progress them across the four sub-areas identified within test (dlenrow, 15:43:49)
    3. will propose infrastructure, platform characterization sub-projects, asks if this direction makes sense to TSC. (dlenrow, 15:45:50)
    4. characterization 2 approaches, top-down VNF deployment test cases, or more traditional benchmarking approach. Both have owners working (dlenrow, 15:46:36)
    5. telco use cases and carrier grade performance testing are driving this (dlenrow, 15:47:30)
    6. 3 tracks top down, bottom up platform and then stability/reliability/perf testing (dlenrow, 15:47:55)
    7. asks for guidance now toward preso next week and project proposals (dlenrow, 15:50:04)
    8. dlenrow suggests we need some finer breakdown of OPNFV project than a single massive/monolithic test project (dlenrow, 15:50:36)
    9. CI update from ULI (dlenrow, 15:50:58)
    10. CI still waiting for resource commitments on project proposal. Need to get moving. (dlenrow, 15:51:43)
    11. bin update on requirements and collaborative projects' (dlenrow, 15:52:19)
    12. several are announced and in public review window. Please read and familiarize yourself with these projects. Need feedback and contributors (dlenrow, 15:53:11)
    13. CP points out that committer list is critical before approval meeting. (dlenrow, 15:54:56)
    14. discussion about getting reviews scheduled for projects coming out of public review stage. (dlenrow, 15:56:37)
    15. ACTION: CP to add some creation reviews to agenda for next TSC (dlenrow, 15:56:56)
    16. Ashik asks for clarification of process. Process is sending email to TSC mail list starts two weeks, after two weeks founders can request by email to TSC a creation review (dlenrow, 15:58:39)

  9. (dlenrow, 15:58:51)
  10. OpenStack summit update (ChrisPriceAB, 15:59:05)
  11. OSTack Summit and design conference learnings (dlenrow, 15:59:12)
    1. dneary reports lots of NFV sessions, panels, well attended, some booked simultaneous made it hard to cover all. (dlenrow, 16:00:09)
    2. Thinh Nguyenphu (Thinh_, 16:00:22)
    3. dneary will post some links to some of the sessions he considered most interesting and relevant (dlenrow, 16:00:56)
    4. telco working group and NFV plans review both standing room only. dneary thinks dev community not fully sold on the value to them of supporting NFV use cases (dlenrow, 16:01:51)
    5. congress session was helpful in terms of educating them about why they should care about NFV (dlenrow, 16:02:17)
    6. dneary reports that other communities encouraging OPNFV to make sure test coverage of contributions is strong and included with proposals/blueprints (dlenrow, 16:03:02)
    7. it would be great to get the materials from the congress/NFV session posted on the wiki or otherwise shared as this relates to the policy project we have proposed (bryan_att, 16:03:06)
    8. openstack kilo M1 and M2 are critical dates for work proposed to support NFV (dlenrow, 16:04:27)
    9. http://etherpad.openstack.org/kilo-nova-nfv NFV Nova blueprint review agenda and notes (cdub, 16:04:43)
    10. https://wiki.openstack.org/wiki/Kilo_Release_Schedule for kilo_release_schedule (julienjut, 16:06:10)
    11. https://etherpad.openstack.org/p/kilo-summit-ops-telco (dneary, 16:06:15)
    12. dneary notes there are several new Open "SDN" projects midonet, ONOS, Akanda vying for relationship with NFV/OPNFV (dlenrow, 16:06:21)
    13. margaret asks what commitments we made against Openstack milestones (dlenrow, 16:06:44)
    14. https://etherpad.openstack.org/p/kilo-summit-ops-telco (dneary, 16:06:52)
    15. cdub points out that ian represented OPNFV and agreed we would respect their dates. (dlenrow, 16:07:07)
    16. Trevor (Trevor_, 16:07:28)
    17. cdub clarifies this is light-weight coupling with OStack, and shouldn't need a team (dlenrow, 16:07:51)
    18. margaret reminds pranav volunteered for this area (dlenrow, 16:08:18)
    19. "Developing OpenStack for NFV": https://www.youtube.com/watch?v=aQJ2du2UalA (dneary, 16:08:23)
    20. CP suggests we need ian on call to finish discussion about whether we need a project, etc. (dlenrow, 16:08:40)
    21. Test and Performance info on proposals and metings: https://wiki.opnfv.org/integration_testing_projects (Trevor_, 16:09:05)
    22. "Demonstrating NFV on OpenStack": https://www.youtube.com/watch?v=nqxKKJBCDjE (dneary, 16:09:06)
    23. cdub suggests we do real work upstream first because spinning up a project in OPNFV will have lead times (dlenrow, 16:09:17)

  12. action item status (dlenrow, 16:09:47)
    1. fbrockners updates community began discussion last week about pro/con of various Linux distros for our CI/deployment work. (dlenrow, 16:10:46)
    2. mike young started table (not much feedback yet) comparing pluses and minuses (dlenrow, 16:11:19)
    3. and interesting link on the mailing list providing data on OpenStack and operating system: http://superuser.openstack.org/articles/openstack-user-survey-insights-november-2014 (ChrisPriceAB, 16:11:42)
    4. uli describes difficulty is the dependencies that come with various distros. packaging tools tie to distros, etc. (dlenrow, 16:13:28)
    5. uli reports CI can't move forward without a decision here. (dlenrow, 16:14:14)
    6. dlenrow reminds that picking a fork/distro is a short term hack we agreed to get version 1 out the door. Long term goal is to have tooling to make upstream consumable (dlenrow, 16:17:34)
    7. general agreement that this is a V1 decision not a roadmap plan. fbrockner suggests we do offline discussion/analysis to enable a descions at next TSC (dlenrow, 16:18:24)
    8. CP aks who can take action to progress this (dlenrow, 16:19:52)
    9. pals feels it is close to his sandbox work as well. He hasn't had good support for canonical and leans toward RH (dlenrow, 16:21:11)
    10. aric suggest ODL has had good experience with vagrant images,may be targetted to avoid some of this sort of problem (dlenrow, 16:22:12)
    11. Uli asks for two proposals to "bake off" at next TSC. Get a RH sponsor and an Ubuntu sponsor to describe a full stack proposal including linux distero and deploy tools (dlenrow, 16:23:41)
    12. cdub points out there are entire companies devoted to this. Describes more of the complexity of the inter-dependencies in the "whole stack". (dlenrow, 16:25:03)
    13. RH ready to help but needs some scope restriction so it's not open ended. cdub points out we've discussed much of this on CI calls (dlenrow, 16:25:42)
    14. cdub talks about how RH has looked at lots of the stack inter-dependencies. Suggests we need more mix-and-match not two competing vertical stacks around linux distros (dlenrow, 16:27:01)
    15. suggests OPNFV may need to build some tooling to support this (dlenrow, 16:27:14)
    16. pals prefers centos/packstack based on his POC/proto work. (dlenrow, 16:27:45)
    17. begin diverging into a debate about favorite stack configurations (dlenrow, 16:28:53)
    18. CP encourages us to finish this discussion to the lists because we need to decide at next TSC to unblock work items (dlenrow, 16:31:56)
    19. Tapio suggests we work towards a wiki page with proposals to choose from on next call (dlenrow, 16:32:44)
    20. aric clarifies that call tomorrow is not specifically focused on distro choice (dlenrow, 16:33:42)
    21. ACTION: palani will organize meeting and herd us towards a final discussion and decision on next call (dlenrow, 16:34:12)
    22. ACTION: CP to add discuss/decide to agenda for next TSC (dlenrow, 16:34:51)

  13. SR plan (dlenrow, 16:35:03)
    1. Dave identifies a matrix sent to the mail list as a point for discussion on the SR process (ChrisPriceAB, 16:35:58)
    2. CP has fallen and can't do audio. fbrockners steps in to Moderate (dlenrow, 16:39:16)

  14. aob (ChrisPriceAB, 16:39:56)
    1. release name theme will be rivers as decided by poll last week (dlenrow, 16:40:41)
    2. mailing list archives to be open to the public (ChrisPriceAB, 16:40:41)
    3. revisit TSC call timing. Propose a rotating schedule to share the pain of off-hours attendance globally (dlenrow, 16:41:34)
    4. ACTION: dlenrow to schedule meeting this week to discuss SR strawman schedule and SR process proposals (dlenrow, 16:42:28)
    5. frank suggest a poll is the route to driving a decision. (dlenrow, 16:43:09)
    6. ACTION: ray to start a poll of community (not just TSC) on solution to call timing (dlenrow, 16:45:15)
    7. dku points out that alternating can be confusing (dlenrow, 16:46:29)
    8. update on planning next hackfest. Ray's view is venue is free and lots live close, there is no good reason not to take advantage (dlenrow, 16:47:08)
    9. ray reminds that prague opportunity exists, but may have lead time issues due to ETSI liaison process. (dlenrow, 16:48:40)
    10. M-P clarifies logistics and suggests formal colo could be approved at plenary next week if we move fast. She has drafted proposal/preso. (dlenrow, 16:49:27)
    11. M-P clairifies she has drafted liaison proposal and is on agenda at plenary. (dlenrow, 16:50:04)
    12. problems with MP's voice line. Please summarize to IRC w/ #info... (dlenrow, 16:53:17)
    13. margaret aware of members ready to send devs who feel it's hard to engage. We need to support/encourage them (dlenrow, 16:55:19)
    14. fbrockner suggests we make a breakout room available at meetups to give devs a place to do implementation work in parallel with our work to bootstrap community (dlenrow, 16:56:03)
    15. Chris Wright can you post your email address (palani, 16:56:18)
    16. mine is pals@cisco.com (palani, 16:56:34)
    17. fbrockner asks if there are any prohibitive costs or should we just plan to proceed (dlenrow, 16:56:39)
    18. Ray reports we don't have a handle on potential cost. fbrockner suggests we continue this on the mail lists. (dlenrow, 16:57:56)
    19. fbrockner points out we're only hearing a few opinions and wants wider input from community (dlenrow, 16:58:20)
    20. cdub suggests we broadcast a call for input to community (dlenrow, 16:58:46)
    21. ACTION: ray to take to list, present prospect events/venues ask for input (dlenrow, 16:59:51)

  15. status of beginners guide (dlenrow, 17:00:11)


Meeting ended at 17:00:58 UTC (full logs).

Action items

  1. ray will send to mailing list
  2. Ray/Brandon to move this along offline so we can move on in agenda. To get poll out by end of week
  3. CP to add some creation reviews to agenda for next TSC
  4. palani will organize meeting and herd us towards a final discussion and decision on next call
  5. CP to add discuss/decide to agenda for next TSC
  6. dlenrow to schedule meeting this week to discuss SR strawman schedule and SR process proposals
  7. ray to start a poll of community (not just TSC) on solution to call timing
  8. ray to take to list, present prospect events/venues ask for input


Action items, by person

  1. dlenrow
    1. dlenrow to schedule meeting this week to discuss SR strawman schedule and SR process proposals
  2. palani
    1. palani will organize meeting and herd us towards a final discussion and decision on next call
  3. UNASSIGNED
    1. ray will send to mailing list
    2. Ray/Brandon to move this along offline so we can move on in agenda. To get poll out by end of week
    3. CP to add some creation reviews to agenda for next TSC
    4. CP to add discuss/decide to agenda for next TSC
    5. ray to start a poll of community (not just TSC) on solution to call timing
    6. ray to take to list, present prospect events/venues ask for input


People present (lines said)

  1. dlenrow (121)
  2. ChrisPriceAB (26)
  3. dneary (14)
  4. cdub (12)
  5. julienjut (8)
  6. collabot (7)
  7. palani (4)
  8. ray___ (4)
  9. bryan_att (3)
  10. margaret (3)
  11. Trevor_ (2)
  12. TapioT (2)
  13. RK_ (2)
  14. dku (2)
  15. Thinh_ (1)
  16. uli_ (1)
  17. Pranav (1)
  18. aricg (1)
  19. frankbrockners (1)
  20. bin_ (1)
  21. Wenjing (1)
  22. Ashiq (1)
  23. rpaik (0)


Generated by MeetBot 0.1.4.