#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 14:57:56 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 14:58:09)
    1. Chris Price (ChrisPriceAB, 14:58:15)
    2. Uli (uli, 14:58:51)
    3. palani (palani, 15:01:42)
    4. Hui (hui, 15:01:52)
    5. Frank Brockners (frankbrockners, 15:02:30)
    6. Thinh Nguyenphu (Thinh_, 15:02:55)
    7. Ashiq Khan (Ashiq, 15:03:54)

  2. Approval of previous minutes (ChrisPriceAB, 15:04:51)
    1. julien_ZTE (rpaik, 15:05:09)
    2. AGREED: Previous minutes approved. (ChrisPriceAB, 15:05:10)

  3. Agenda Bashing (ChrisPriceAB, 15:05:18)
    1. Wenjing (rpaik, 15:05:20)
    2. Parviz Yegani (Parviz, 15:05:21)
    3. Tapio Tallgren (Nokia) (tapio_, 15:06:23)
    4. Adding an item from aric to the agenda related to release 1 topics (ChrisPriceAB, 15:08:02)
    5. Lingli, asks to review the dpacc project earlier in the agenda (ChrisPriceAB, 15:08:35)
    6. AGREED: moved to the first item (ChrisPriceAB, 15:08:42)
    7. ashiq asks if we can discuss the deliverable of the requirements on the call (ChrisPriceAB, 15:09:27)
    8. AGREED: added to the development process discussion (ChrisPriceAB, 15:09:37)

  4. Creation review for the dpacc (Data Path Acceleration) project (ChrisPriceAB, 15:10:06)
    1. https://wiki.opnfv.org/requirements_projects/data_plane_acceleration (ChrisPriceAB, 15:10:25)
    2. Lingli describes the histroty for proposing the dpacc project, and outlines the proposal according to a summary of the WiKi description (ChrisPriceAB, 15:12:36)
    3. Dirk Kutscher (dku, 15:14:41)
    4. Lingli describes and internal proof of concept for small cell gateways that has identified the needs for dpacc like functionality in the platform (ChrisPriceAB, 15:14:43)
    5. the goal is to decouple the application layer from the hardware layer, an issue arises in the performance of virtualized devices that requires higher datapath throughput. (ChrisPriceAB, 15:15:42)
    6. there is an identified need for common API's to present the needed capabilities for dataplane acceleration in a common way for high throughput devices in a virtual environment. (ChrisPriceAB, 15:16:44)
    7. Lingli outlines the focus interfaces for the activity according to the ETSI NFV functional architecture representative diagram. (ChrisPriceAB, 15:20:50)
    8. Joseph asks if the proposed changes recently received by the community have been considered. (ChrisPriceAB, 15:26:15)
    9. Bryan Sullivan (bryan_att, 15:26:39)
    10. the changes have not yet been able to be incorporated onto the WiKi page, and that further discussions may be required regarding that contribution (ChrisPriceAB, 15:26:52)
    11. the changes are not deemed to impact the scope or deliverables targetted for the project. (ChrisPriceAB, 15:27:31)
    12. Bob Monkman identifies some changes that may be resultant on the proposed project scope. (ChrisPriceAB, 15:32:07)
    13. suggestion from the TSC is for the dpacc project team to revise the wiki/project proposal and come back for a quick review next week (rpaik, 15:38:22)

  5. OPNFV Release 1 updates (ChrisPriceAB, 15:39:20)
    1. frankbrockners indicates the team is making progress with two efforts on the installer component. The efforts looks to extend existing installer tools with OPNFV delta's. (ChrisPriceAB, 15:40:48)
    2. One approach looks to leverage Fuel as an installer, the other approach looks to leverage quickstack and khaleesi to achieve the same goals. (ChrisPriceAB, 15:41:39)
    3. OpenDaylight has been integrated into the tools. Demostrations are planned for these foundations on Monday of next week. (ChrisPriceAB, 15:42:23)
    4. once the foundation is established the ability for the broader community to add components of the BGS project and establish a goal for march. (ChrisPriceAB, 15:43:08)
    5. https://wiki.opnfv.org/get_started/get_started_installer_approach (ChrisPriceAB, 15:43:43)
    6. bryan_att asks for clarifications on the way ODL is integrated. (ChrisPriceAB, 15:45:03)
    7. frankbrockners describes some of the options being used to approach this task. (ChrisPriceAB, 15:45:45)
    8. Uli outlines the CI updates to the diagram meetings on octopus. Progress is being made on the structure and still awaiting the concrete outputs from BGS. (ChrisPriceAB, 15:47:36)
    9. https://etherpad.opnfv.org/p/octopus (rpaik, 15:47:43)
    10. interfaces/dependancies on other porects are being defined. (ChrisPriceAB, 15:47:57)
    11. See https://wiki.opnfv.org/get_started/get_started_installer_approach for the installer approach in BGS (2-phase approach) (frankbrockners, 15:47:58)

  6. Project leads discussion (ChrisPriceAB, 15:50:04)
    1. aricg asks for project to nominate leads for the project regarding jira and contact for aricg on the project needs and committer roles. (ChrisPriceAB, 15:50:46)
    2. Uli asks if the projects should assign a project leader. (ChrisPriceAB, 15:51:54)
    3. Heather clarifies that for administrative and infrastructure needs a project representative is needed. (ChrisPriceAB, 15:53:02)
    4. send names of project contact person (from the list of committers) to Aric (rpaik, 15:55:13)
    5. ACTION: Ray/Aric to send emails to mailing lists on project contact persons (rpaik, 15:57:34)
    6. fbrockners suggests it’d to good to create a teample for project repo names/contact persons/etc. (“key project facts”) (rpaik, 15:58:44)

  7. OPNFV Security Discussions (ChrisPriceAB, 15:59:49)
    1. Luke Hinds describes that some e-mail discussion has occured around establishing a secuiry community (ChrisPriceAB, 16:00:20)
    2. Luke sent an e-mail thread to describe what this might mean (ChrisPriceAB, 16:00:36)
    3. areas of interest; security discussion list, advisory group, working with other security groups, governance risk and compliance feedbacks, covering eventually LI and security architectures. (potentially software reviews) (ChrisPriceAB, 16:03:29)
    4. frankbrockners describes that some functions of the security group may want to integrate themselves with OPNFV operational activities. (ChrisPriceAB, 16:07:39)

  8. development process (ChrisPriceAB, 16:09:19)
    1. discussion occurred :D (ChrisPriceAB, 16:28:49)

  9. Creation review for the Parser project (ChrisPriceAB, 16:29:25)
    1. https://wiki.opnfv.org/parser (ChrisPriceAB, 16:29:49)
    2. the proposal has been modified to clarify the scope of the project. (ChrisPriceAB, 16:30:31)
    3. further discussion on the mailing list for defining methods for working with upstream communities (amongst requirements projects) (rpaik, 16:30:49)
    4. Parser will provide a template translation engine, in the form of a tool to perform this function (ChrisPriceAB, 16:31:24)
    5. Parser provides an interface northbound of the VIM on the NFVI interface (ChrisPriceAB, 16:32:24)
    6. intending to be implemented as an integration and testing project (ChrisPriceAB, 16:32:57)
    7. Parser aims to deliver a translation to HOT, but could be extended to other formats (ChrisPriceAB, 16:34:01)
    8. bryan_att asks if this proposal is adopting some functionality of the orchestrator. (ChrisPriceAB, 16:38:39)
    9. uli responds that parser will only consumer deployment templates for functions to HOT (ChrisPriceAB, 16:39:37)
    10. AGREED: the Parser project was approved for creation (ChrisPriceAB, 17:03:34)


Meeting ended at 17:03:37 UTC (full logs).

Action items

  1. Ray/Aric to send emails to mailing lists on project contact persons


People present (lines said)

  1. ChrisPriceAB (64)
  2. collabot (9)
  3. rpaik (9)
  4. tapio_ (7)
  5. dlenrow (4)
  6. bryan_att (3)
  7. Ashiq (3)
  8. dku (2)
  9. frankbrockners (2)
  10. uli (2)
  11. Parviz (2)
  12. palani (1)
  13. aricg (1)
  14. Thinh_ (1)
  15. hui (1)
  16. julien_ZTE (1)
  17. Wenjing (1)
  18. rapik (0)


Generated by MeetBot 0.1.4.