#opnfv-meeting: BGS weekly

Meeting started by frankbrockners at 16:05:42 UTC (full logs).

Meeting summary

    1. Discussion today: (1) Follow-up on topics of the hackfest - see etherpad: https://etherpad.opnfv.org/p/bgs - and (2) take-aways from the meeting in Santa Rosa (frankbrockners, 16:12:17)
    2. https://etherpad.opnfv.org/p/bgs (frankbrockners, 16:13:48)
    3. https://etherpad.opnfv.org/p/bgs (arnaud_orange, 16:21:17)
    4. https://etherpad.opnfv.org/p/bgs (frankbrockners, 16:21:29)
    5. https://etherpad.opnfv.org/p/bgs (dneary, 16:21:42)
    6. current foreman approach uses OVS instance per node. VXLAN is used to interconnect OVSs. (frankbrockners, 16:22:37)
    7. with the foreman approach, networking is brought up post the base installation (i.e. not through foreman). With Fuel it is currently different - i.e. networking is part of the installer. (frankbrockners, 16:26:22)
    8. good approach is to separate concerns between networking and base-installer. (frankbrockners, 16:27:27)
    9. with the foreman approach, networking isn't automated yet: Good time to agree on the network layout (frankbrockners, 16:27:54)
    10. trozet gave an overview on the BGS session at Santa Rosa (frankbrockners, 16:30:23)
    11. interest from several people to replicate the environment in a virtual environment locally (frankbrockners, 16:30:47)
    12. integration into Intel lab and support for O/S HA (frankbrockners, 16:31:16)
    13. for OPNFV release #1 we'll not do ODL clustering (Helium version of Neutron plugin does not support clustering - clustering support expected for Lithium) (frankbrockners, 16:34:45)
    14. Question: Are there conflicts in dependencies between ODL and O/S? (frankbrockners, 16:35:25)
    15. trozet mentioned that he's not aware of any - but he's going to check with his friends (frankbrockners, 16:36:48)
    16. dneary - clearwater might have a set of images that we might want to use (frankbrockners, 16:40:35)
    17. If sample VNFs have Glance images and a Heat template we can use it would be an easy way to get started (dneary, 16:42:38)
    18. ACTION: Dave to contact the Test VNF project to see if they have something we can use (dneary, 16:43:02)
    19. Discussion around common test framework - nothing standard being used right now (dneary, 16:47:23)
    20. ACTION: Jonas to create a starting point from the Tempest tests he is running on the Fuel deployment, and Tim to review it afterwards (dneary, 16:48:10)
    21. 2 more PODs from Intel: One for BGS and one for vSwitch characterization (frankbrockners, 16:54:21)
    22. http://hackstack.org/x/blog/2014/08/17/openwrt-images-for-openstack/ (frankbrockners, 16:55:35)
    23. Praveen Kumar will work on creating an OVA for OpenWRT and PF-Sense to run on the sample deployments (dneary, 16:57:11)
    24. Praveen: What is the goal? Frank: Verify that traffic passes - ping is a good test case (dneary, 16:57:43)
    25. trozet: one thing that would be cool is once openwrt or router type vnf is working. Bring up instances that use jmeter or some type of traffic generation, setup a firewall on openwrt, and gather stats on different protocol traffic types, http, p2p, etc and see stats, if the firewall works etc. (frankbrockners, 17:03:03)


Meeting ended at 17:03:09 UTC (full logs).

Action items

  1. Dave to contact the Test VNF project to see if they have something we can use
  2. Jonas to create a starting point from the Tempest tests he is running on the Fuel deployment, and Tim to review it afterwards


People present (lines said)

  1. frankbrockners (26)
  2. dneary (14)
  3. collabot (4)
  4. arnaud_orange (2)
  5. trozet (2)
  6. David_Orange (1)


Generated by MeetBot 0.1.4.