15:04:12 <dneary> #startmeeting Octomus weekly meeting
15:04:12 <collabot> Meeting started Mon Mar  2 15:04:12 2015 UTC.  The chair is dneary. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:12 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:04:12 <collabot> The meeting name has been set to 'octomus_weekly_meeting'
15:04:32 <dneary> #chair rprakash
15:04:32 <collabot> Current chairs: dneary rprakash
15:04:38 <dneary> Anyone else for chair?
15:04:57 <dneary> #info Agenda bashing: Account of hackfest from Prague
15:06:06 * ChrisPriceAB chair me in dneary (I may not be active but good to be in reserve)
15:06:08 <dneary> #topic Jenkins set-up
15:06:13 <dneary> #chair ChrisPriceAB
15:06:13 <collabot> Current chairs: ChrisPriceAB dneary rprakash
15:06:40 <dneary> ChrisPriceAB, I'm not 100% concentrated either - we'll need multiple note-takers
15:08:12 <ChrisPriceAB> #info fdegir describes the current status of the CI project.
15:08:34 <dneary> Thanks ChrisPriceAB - I didn't recognise the voice
15:09:01 <ChrisPriceAB> #info CI scripts in place awaiting BGS and functest to provide build/deploy/commit scripts to be invoked.
15:09:42 <ChrisPriceAB> #info uli asks about maintenance of the scripts and coordination with other projects
15:11:18 <ChrisPriceAB> #info fdegir describes the current setup in releng and how these scripts will be evolved and invoke octopus scripts maintained by the community.
15:12:24 <dneary> #chair aricg
15:12:24 <collabot> Current chairs: ChrisPriceAB aricg dneary rprakash
15:13:15 <dneary> #chair ulik
15:13:15 <collabot> Current chairs: ChrisPriceAB aricg dneary rprakash ulik
15:18:30 <dneary> #info Discussion about Jenkins jobs to be added initially, jobs to deploy projects, and various jobs which will be used for all projects (eg. verification job)
15:23:42 <ulik> #info Chris Price asking whether jobs should be in octopus repo instead of releng
15:27:27 <ulik> #info Aric suggest to move to octopus repo at the same time when we have the hardware
15:28:38 <ChrisPriceAB> #topic Jira backlog
15:29:09 <ChrisPriceAB> #info fdegir talks about using Jira for backlog management and outlining inter project dependencies to be visible between projects.
15:29:35 <ChrisPriceAB> #info rather than using WiKi or etherpad moving to Jira makes things more visible
15:30:28 <ChrisPriceAB> #info aricg states we can submit bugs against octopus for the releng already now
15:31:04 <ChrisPriceAB> #info ChrisPriceAB states it is very good for CI as you can add actions to other projects backlog
15:31:42 <ChrisPriceAB> #info uli asks if this is only for inter-project issues or for use internally
15:31:59 <ChrisPriceAB> #info it is clarified that it should be for all agile backlog int the project and externally.
15:32:22 <ChrisPriceAB> #info iben asks if Jira items can be created by anyone?
15:32:54 <ChrisPriceAB> #info aricg indicates it is open to all, dneary agrees that it should be open for all to raise items and browse (chrispriceab agrees)
15:33:13 <dneary> Thanks for minute taking ChrisPriceAB
15:33:24 <ChrisPriceAB> #info aricg will look into it offline to test.  fdegir indicates he cannot modify
15:44:40 * ChrisPriceAB no problems dneary, I have to drop off now though...
15:45:06 <dneary> ChrisPriceAB, OK, I'll take over
15:47:47 <aricg> #info temporary home of released artifacts. https://build.opnfv.org/releases/
15:47:48 <dneary> #info radez confirms there's no real directory structure in Genedis right now, that fdegir's proposal of a convention for directory structure would be a good initiative
15:48:04 <iben_> Question - who can provide a list of all the etherpads?
15:49:56 <aricg> iben_: I can.
15:50:24 <aricg> But I have to do it in mysql, I don't have any easy way of providing a dynamic list
15:50:33 <iben_> #action - aricg to provide list of etherpads
15:51:37 <iben_> #action - etherpads with technical debt and “todo” lists should make issues in JIRA for these. The etherpad should be updated with a link to JIRA and message about this recommendation
15:52:35 <iben_> #info It’s recommended to ensure the project leads are aware of new JIRA issues
15:54:28 <aricg> #action aricg will add a build and verify job for each project to releng (that does nothing at first)
15:56:05 <dneary> #info iben_ offered to help set up multi-site Jenkins by connecting multiple instances in different labs
15:59:43 <dneary> #endmeeting