14:00:54 <ulik> #startmeeting Octopus Weekly Call
14:00:54 <collabot> Meeting started Mon Mar  9 14:00:54 2015 UTC.  The chair is ulik. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:54 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:54 <collabot> The meeting name has been set to 'octopus_weekly_call'
14:03:57 <ulik> #chair fdegir jerryz
14:03:57 <collabot> Current chairs: fdegir jerryz ulik
14:05:22 <ChrisPriceAB> is the goto different than on the WiKi?
14:07:24 <ulik> GTM is 150-627-173
14:12:27 <ulik> #topic Walk through CI workflows
14:13:17 <ulik> #link https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=tree
14:13:44 <ulik> #info .. brings to the directory showing the jjb jobs
14:14:05 <ulik> #info Jerry asks about the connection between Jira and Gerrit
14:14:46 <ulik> #info Aric explains that it's not yet connected via the plugin
14:15:27 <ulik> #info Let's create Jira task for Aric to implement that
14:15:58 <ulik> #action jerryz to create Jira story for this
14:16:36 <fdegir> #info Fatih Degirmenci
14:18:50 <fdegir> #info Proposal for basic flow to work with Jenkins Jobs is: create a story in JIRA Octopus Project -> Do your changes in git repo -> commit & push your changes -> get it verified by automatic verification job -> add reviewers and get it verified -> get it submitted and deployed
14:25:02 <ulik> #info Fatih explains that our script could already call scripts from genesis, as soon as those scripts are there
14:25:09 <ulik> #topic Jira introduction
14:25:20 <ulik> #link https://jira.opnfv.org/i#issues/?jql=project%20%3D%20OCTO
14:27:07 <ulik> #info Fatih shows that there is Jira story and epic already for this dependency to genesis
14:27:37 <ulik> #info see there for instance  OCTO-3
14:28:23 <ulik> #info Fatih encourages to create jobs for everything we have to do in R1
14:28:47 <ulik> #info also encourage to take one of the stories and work on it.
14:30:08 <fdegir> #info Stories should contain good description and DOD (Definition of Done) so any of us can take and work on stories.
14:30:16 <ulik> #action to all: take on topics from Jira, assign yourself and work on it
14:31:04 * ChrisPriceAB going to drop off, apologies for not being so engaged on this call.
14:36:22 * jerryz audio in and out, going to use phone
14:37:25 <ulik> #topic aob
14:38:13 <ulik> #info Iben asks about the exact scope of Octopus
14:39:01 <ulik> #info Question: are other projects (that are not in R1) able to use CI? Answer: Yes
14:43:16 <ulik> #action ulik to raise in TSC that we will enable connection between Jira and Gerrit. Then every commit will need reference to Jira, but dummy reference will be possible
14:45:04 <ulik> #info Question about the number of repos for build scripts from the different BGS experiments
14:47:47 <ulik> #info Answer We can create saltstack, OpenSteak in the same way.
14:48:28 <ulik> #info We had a look at the directory structure
14:49:56 <ulik> #info question to script for merge, daily etc.
14:50:23 <ulik> #info Answer: daily and merge from jenkins will call the build.sh script
14:51:39 <ulik> #info There is no 1:1 mapping in the names between jenkins and the scripts in projects' repos
14:54:40 <ulik> #info Jerry remarks that there should be separate genesis-fuel-build etc. Fatih says this can be done later.
14:57:14 <ulik> #info question how to address the different environments, including that there are multiple PODs in one environment.
14:59:36 <ulik> #info Fatih explains the difference between epic (highest), story (medium), task (smallest)
15:00:21 <ulik> #info Every new topic should start with a story. If necessary they can be combined to an epic.
15:01:58 <ulik> #endmeeting