#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 14:00:14 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 14:00:22)
    1. Chris Price (ChrisPriceAB, 14:00:27)
    2. colindixon for Tom Nadeau (colindixon, 14:00:31)
    3. Dirk Kutscher (dku, 14:00:38)
    4. Uli Kleber (ulik, 14:00:53)
    5. Frank Brockners (frankbrockners, 14:01:26)

  2. approval of previous meeting minutes (ChrisPriceAB, 14:03:44)
    1. AGREED: minutes approved (ChrisPriceAB, 14:03:50)
    2. Ashiq Khan (Ashiq_, 14:03:59)

  3. Agenda Bashing (ChrisPriceAB, 14:04:02)
    1. https://wiki.opnfv.org/wiki/tsc (ChrisPriceAB, 14:04:09)
    2. dlenrow (dlenrow, 14:04:29)
    3. Wenjing Chu (Wenjing, 14:05:56)
    4. discuss release artifacts in the context of the releases wiki (ChrisPriceAB, 14:06:22)
    5. https://wiki.opnfv.org/releases (ChrisPriceAB, 14:06:25)
    6. Julien (julien_ZTE, 14:06:31)
    7. Pierre Lynch (plynch, 14:08:12)

  4. OpenStack community status (ChrisPriceAB, 14:08:14)
    1. https://wiki.opnfv.org/community/openstack (rpaik, 14:08:37)
    2. dneary outlines blueprint review is occuring on the Thursday technical community calls (ChrisPriceAB, 14:09:16)
    3. work has been done on reviewing the propsals and work is ongoing to develop the blueprints to a point where we are ready to add them to the upstream gerrit for further discussion and review (ChrisPriceAB, 14:10:12)
    4. the idea is to do the work in the target community as soon as we are ready (ChrisPriceAB, 14:10:24)
    5. I will be providing the Copper blueprints in the ceilometer template this week, starting today I will upload the first versions (bryan_att, 14:11:08)
    6. dneary outlines we would like to establish best practices and a repeatable process for OPNFV projects to engage (ChrisPriceAB, 14:11:11)
    7. https://wiki.opnfv.org/community/openstack (rprakash, 14:11:26)
    8. dneary outlines the list on the community page only addresses blueprints for the OPNFV requirements (ChrisPriceAB, 14:12:02)
    9. dneary describes that blueprints to be reviewed by the community should be handled through the community page. (ChrisPriceAB, 14:12:33)
    10. Dave - what does "sent off to Openstack" mean? I think we will be submitting the blueprtints as individual members of the Openstack projects, right? (bryan_att, 14:13:06)
    11. current blueprint activity is targetting Liberty which will be release in October of 2015 (ChrisPriceAB, 14:13:14)
    12. dneary says that “while you’re free to do what you want, we suggest you do an internal review process (inside OPNFV) first so that blueprints that go to OpenStack aren’t rejected out of hand” (colindixon, 14:14:59)
    13. Ashiq suggests that all blueprints from OPNFV should go through this review process (Gerald_K, 14:15:06)
    14. Ashiq_ makes the suggestion that all OPNFV blueprints shoudl participate in the review process before being submitted to openstack (ChrisPriceAB, 14:15:06)
    15. bryan_att asks what is required for a blueprint to be reviewed by OPNFV before it is submitted to openstack. (ChrisPriceAB, 14:17:11)
    16. dneary reccomends the bar be set low in OPNFV, the technical discussion on the submission should be done in the openstack community process. (ChrisPriceAB, 14:18:00)
    17. bryan_att asks who will measure and "approve" the submission of proposals (ChrisPriceAB, 14:18:42)
    18. it sounds like we are saying "do diligence" but setting no concrete expectations for that. That's OK but let's be clear. We are not setting up any specific review process internal to OPNFV (bryan_att, 14:20:29)
    19. ChrisPraiceAB also suggest considering resource availiability within OPNFV before submitting blueprints (rpaik, 14:21:08)
    20. We have to be able to resource the blueprints but that's just part of the diligence - don't propose what you can't deliver on\ (bryan_att, 14:21:23)
    21. ChrisPriceAB reiterates that there are lots of communities, which do things differently, and we need to be respectful of upstream processes (dneary, 14:24:05)
    22. frankbrockners asks if it makes sense to use our dev tools (e.g. gerritt) for the review process (rpaik, 14:25:20)
    23. dneary: agreed - the committers of blueprint patches are the discrete participants in the Openstack community that represent the consensus of the OPNFV project, and should be somehow agreed as such (the OPNFV representative) by the OPNFV project. (bryan_att, 14:25:29)
    24. ChrisPriceAB asks can we form a core group for this activity? (rpaik, 14:31:21)
    25. dneary is our contact for this activity with OpenStack community (rpaik, 14:33:43)

  5. Arno release candidacy and final release activities (ChrisPriceAB, 14:33:48)
    1. https://wiki.opnfv.org/releases (rprakash, 14:35:40)
    2. release candiate activities highlight issues/things that need to be fixed (rpaik, 14:36:01)
    3. ChrisPriceAB suggests April 9th as the first release candidate date. 2nd release candidate the following week. (rpaik, 14:37:40)
    4. frankbrockners adds we need a definition of a candidate prior to April 9th (rpaik, 14:40:15)
    5. Release Candidates scope per track/stack should be defined by next week TSC meeting March 31st (rprakash, 14:40:43)
    6. Final cut release should be cut by April 21st (rprakash, 14:43:46)
    7. https://wiki.opnfv.org/releases OPNFV release page (ChrisPriceAB, 14:44:31)
    8. Currently, we can not build the BGS(Fuel) ISO successfully if we plan to provide the resource to provide the ISO because of the Great FireWall (julien_ZTE, 14:48:02)
    9. frankbrockners describes the documentation needs as: hardware platform state, installed system state, user guide, validation completed (ChrisPriceAB, 14:49:20)
    10. I suggest ISO the relevant resources both will be released (julien_ZTE, 14:49:46)
    11. ChrisPriceAB suggests documentation format should be PDF & ISO (rpaik, 14:49:50)
    12. Can bring ISO behind a firewall and bring-up on a Pharos-like environment (rpaik, 14:55:49)
    13. https://etherpad.opnfv.org/p/bgs (frankbrockners, 15:00:37)
    14. +2 to a deterministic install experience! we need to be sure that it works and is not as chaotic/painful as the current experience in installing these components. (bryan_att, 15:00:41)
    15. #info frank is referring to line 16 on the etherpad (ChrisPriceAB, 15:01:57)
    16. AGREED: to the release vehicle being: (ChrisPriceAB, 15:05:10)
    17. rc0 on april2, rc1 on april9, rc2 onapril 16 and fianl rel 1 cut on 21 , test and verify on April 22 - lable, cerate repo etc and release 1on April 23rd (rprakash, 15:10:35)
    18. - openstack release schedule - https://wiki.openstack.org/wiki/Kilo_Release_Schedule (iben, 15:11:25)
    19. https://wiki.openstack.org/wiki/Release_Cycle openstack release cycle definitions (iben, 15:12:11)
    20. Paviz Yegani (Parviz, 15:12:34)
    21. Tapio Tallgren (Nokia) (tapio__, 15:12:55)
    22. question are we trying to portray Release 1 vs. OPNFV architecture? (rpaik, 15:19:32)
    23. We need to ensure we convey that OPNFV is publishing a complete, out-of-the-box NFVI reference platform. Just a picture with boxes and lines does not capture that. (bryan_att, 15:20:19)
    24. We need to capture the vision in a graphic, not necessarily the architecture. ODL (bryan_att, 15:21:47)
    25. ODL has a diagram that is less useful in capturing the vision (and includes things outside ODL's scope), as compared to OpenStack's, We need something less detailed and more objective-evoking. (bryan_att, 15:23:06)
    26. https://wiki.opnfv.org/oscar/project_proposal. (rprakash, 15:24:03)
    27. We need to capture the vision of OPNFV as a system integration project that simplifies NFVI while it provide a comprehensive platform (bryan_att, 15:27:11)
    28. The call for inputs should include the expectation that all diagram proposals will identity the targeted audience for the diagram. There will be different audiences that people are thinking of as most important. (bryan_att, 15:35:14)
    29. IMO the key audience will be those who attend conferences at which the OPNFV graphic is presented, and those that visit the OPNFV website. (bryan_att, 15:36:08)
    30. ACTION: rpaik to call for a discussion on the diagramattic representation for OPNFV. (Later this week) (ChrisPriceAB, 15:37:49)

  6. Arno Project plans & tracking (ChrisPriceAB, 15:40:01)
    1. BGS updates for Arno (ChrisPriceAB, 15:40:13)
    2. https://etherpad.opnfv.org/p/bgs The BGS team high level schedule for Arno (ChrisPriceAB, 15:40:32)
    3. https://wiki.opnfv.org/get_started/get_started_system_state defined end system state for BGS (ChrisPriceAB, 15:42:26)
    4. https://wiki.opnfv.org/pharos/pharos_specification defined hardware state for deployment (ChrisPriceAB, 15:43:16)
    5. work is needed on defining the stable installed Networking state of the get_started_system_state wiki page (ChrisPriceAB, 15:44:08)
    6. there is a target to have this wiki defined by the end of the week for the installers to build toward (ChrisPriceAB, 15:45:01)
    7. ulik outlines the octopus readiness (ChrisPriceAB, 15:46:12)
    8. there is further work to be done with the functest team to identify structure/triggers (ChrisPriceAB, 15:46:34)
    9. for artifact storage google storage was proposed but is not able to be acessed from China at all (ChrisPriceAB, 15:47:00)
    10. ACTION: iben to document how ci and testing is done for openstack storage (iben, 15:47:01)
    11. Jonas asks if CI has mechanisms for build time as we have common libraries in genesis for deplyment (ChrisPriceAB, 15:48:28)
    12. Fatih answers that Jenkins jobs have been seperated based on where the commits are being generated to only build relevant artefacts. (ChrisPriceAB, 15:49:15)
    13. Morgan describes the state for functest (ChrisPriceAB, 15:49:38)
    14. the intention is each of the toochains should be able to run autonomously by Jenkins (ChrisPriceAB, 15:50:09)
    15. the robot framework and rally framework is ongoing for automation development, this includes tempest work also (ChrisPriceAB, 15:50:36)
    16. the vIMS is due to be ready by the end o f this week, or next week (ChrisPriceAB, 15:50:54)
    17. the vPing project in ongoing (ChrisPriceAB, 15:51:06)
    18. https://wiki.opnfv.org/pharos_testing (morgan_orange, 15:51:24)
    19. https://wiki.opnfv.org/pharos_testing testing wiki page (ChrisPriceAB, 15:53:31)
    20. https://wiki.opnfv.org/documentation_projects/opnfv_documentation documentation project proposal (ChrisPriceAB, 16:00:21)


Meeting ended at 16:03:13 UTC (full logs).

Action items

  1. rpaik to call for a discussion on the diagramattic representation for OPNFV. (Later this week)
  2. iben to document how ci and testing is done for openstack storage


Action items, by person

  1. iben
    1. iben to document how ci and testing is done for openstack storage
  2. rpaik
    1. rpaik to call for a discussion on the diagramattic representation for OPNFV. (Later this week)


People present (lines said)

  1. ChrisPriceAB (65)
  2. dneary (20)
  3. bryan_att (13)
  4. rpaik (12)
  5. collabot (8)
  6. frankbrockners (7)
  7. colindixon (6)
  8. rprakash (6)
  9. julien_ZTE (4)
  10. iben (3)
  11. tapio__ (2)
  12. dlenrow (1)
  13. plynch (1)
  14. Ashiq_ (1)
  15. LouisF (1)
  16. morgan_orange (1)
  17. ulik (1)
  18. Gerald_K (1)
  19. B_Smith_ (1)
  20. Parviz (1)
  21. Wenjing (1)
  22. dku (1)


Generated by MeetBot 0.1.4.