13:59:47 <frankbrockners> #startmeeting RC1 status and RC2 readiness meeting
13:59:48 <collabot> Meeting started Thu Apr  9 13:59:47 2015 UTC.  The chair is frankbrockners. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:48 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:48 <collabot> The meeting name has been set to 'rc1_status_and_rc2_readiness_meeting'
13:59:59 <frankbrockners> #topic roll call
14:00:18 <frankbrockners> could those of you participating info in?
14:00:38 <trozet> #info trozet
14:00:55 <fdegir> #info Fatih Degirmenci
14:01:43 <iben__> Iben here
14:01:48 <frankbrockners> hey folks - anyone else around for the RC1/2 meeting?
14:01:56 <[1]JonasB> Jonas here
14:01:57 <frankbrockners> iben__ can you info in?
14:02:03 <morgan_orange> #info morgan
14:02:16 <frankbrockners> [1]JonasB can you info in?
14:02:31 <trevor_intel> #info Trevor
14:02:38 <[1]JonasB> Yes, as you know we didnt make it with fuel for RC1
14:02:57 <iben__> #info iben
14:03:13 <[1]JonasB> #info Fuel didnt make it for RC1
14:03:14 <frankbrockners> [1]JonasB - let's discuss this in a bit
14:03:33 <[1]JonasB> Yes
14:03:42 <frankbrockners> ok - looks like we have a quorum
14:03:49 <bryan_att> #info Bryan
14:04:13 <frankbrockners> #topic Agenda for the meeting
14:04:16 <[1]JonasB> #info we're working hard to make it for RC2, and have more hands on the deploy script
14:04:24 <frankbrockners> #info RC execution reporting and issue logging – Fatih/Aric
14:04:36 <frankbrockners> #info Project reports on RC completion and next RC readiness – Project Leads
14:04:47 <frankbrockners> #info Actions and activities planned - All
14:04:51 <iben__> I'm here to discuss documentation for the 4 projects that are part of r1.
14:05:00 <frankbrockners> #info Any other topics people would like to see on the meeting?
14:05:10 <frankbrockners> thanks iben__
14:05:23 <ulik> .. I arrived (I am late because of the other meetings....)
14:05:33 <[1]JonasB> #info HW pods, Ericsson Lab utilization
14:05:38 <ulik> #info Uli
14:05:38 <frankbrockners> ulik could you info in
14:05:48 <frankbrockners> thanks Jonas
14:05:52 <frankbrockners> anything else?
14:05:53 <B_Smith_> listening in on ETSI security call, here on irc
14:05:54 <vlaza> me also to push for people to review and submit out patch sets
14:06:00 <vlaza> regarding documentation
14:06:21 <iben__> FYI I'm a little slow today as I'm running irc cloud on my phone
14:06:32 <frankbrockners> iben__ :-) same here
14:06:35 <frankbrockners> #topic RC execution reporting and issue logging
14:06:42 <morgan_orange> working on integration of first functional tests in CI:
14:06:46 <iben__> #info this is an irc only meeting.  No audio
14:06:57 <morgan_orange> ODL shall be possible
14:06:58 <frankbrockners> Fatih - could you give us a brief update?
14:07:15 <fdegir> #info We had very little progress over the week due to holidays, HW availability, connection to OPNFV Jenkins
14:07:37 <fdegir> #info Due to not being able to connect Intel POD to OPNFV Jenkins, we haven't been able to progress much with FuncTest
14:07:49 <fdegir> #info However, we were able to connect a server from Orange POD
14:08:05 <trevor_intel> #info we hae identified issue with Intel POD and woking to resolve (firewall issue)
14:08:20 <aricg> beat me to it ;)
14:08:24 <fdegir> #info We also started working with FuncTest(Morgan) to try out basic rally execution
14:08:36 <fdegir> #info on Orange POD
14:08:39 <morgan_orange> Peter committed code for ODL automation tests
14:08:40 <trevor_intel> :)
14:08:49 <fdegir> #info apart from this, we haven't been able to progress much
14:08:59 <morgan_orange> but he cannot do them neither on Intel POD (Jenkins) nor Orange (ni OLD)
14:09:08 <morgan_orange> he shall test automation on E/// POD
14:09:10 <frankbrockners> #info have we agreed on common paswords for the hardware (to use by jenkins)?
14:09:16 <aricg> #info documentation jenkins jobs are ready to test (just need some documentation)
14:09:51 <frankbrockners> thanks Fatih, Aric
14:10:04 <ulik> #info also Huawei lab is connected.
14:10:22 <vlaza> aricg: it should be working if code gets reviewed and submited
14:10:38 <[1]JonasB> #info We're rearranging the Ericsson lab such that more people can work on it at the same time.
14:11:06 <[1]JonasB> #info also to get a more potent build server incase LF is delayed further
14:11:24 <frankbrockners> aricg: any updates on LF HW?
14:11:27 <iben_> that’s the same as the documentation project update - pretty much - we’re in the same state
14:11:38 <aricg> frankbrockners: checking
14:11:43 <pbandzi> JonasB: this is the reason that I am not able to connect? or am I doing something wrong?
14:12:09 <frankbrockners> per my earlier question: do we have agreed passwords for jenkins? this was an AI from the past meeting
14:12:38 <[1]JonasB> pbandzi: No the access should be ther, make sure you use your rsa key for authentication
14:12:55 <frankbrockners> #info BGS team to resolve consistent user names for RC1 - still open - will action again
14:12:59 <aricg> #info adapters came in for HW yesterday, plan is to finish today.
14:12:59 <frankbrockners> #action BGS team to resolve consistent user names for RC1.
14:13:45 <frankbrockners> aricg: could I action you to sent out "ready" status as soon as HW is up and running?
14:14:00 <aricg> ya
14:14:25 <frankbrockners> #action aricg to send "HW ready" status to opnfv-tech-discuss as soon as the LF HW is ready for use
14:14:51 <iben_> aricg: how many jenkins servers are connected for OPNFV now?
14:15:11 <iben_> and where can we find this list?
14:15:30 <frankbrockners> asking again - per AI from last meeting: "Pharos team to provide consistent usernames for infrastucture" --- any updates from Pharos team? Otherwise will action Pharos team again.
14:15:42 <aricg> iben https://build.opnfv.org/ci/
14:15:48 <jerryz> #info we here in huawei are using libvirt vms to test compass bgs track. each jenkins slave will stand up a "pod" within
14:15:55 <aricg> 11, 6 are offline
14:16:01 <frankbrockners> #action
14:16:04 <trevor_intel> Still working on documenting pharos sepc and naming
14:16:06 <frankbrockners> #action Pharos team to provide consistent usernames for infrastucture
14:16:23 <fdegir> to be more precise: https://build.opnfv.org/ci/computer/
14:16:46 <frankbrockners> ok - let's move to the individual project updates.
14:16:48 <jerryz> aricg: we already have one online. the rest will be on when we need them
14:17:02 <frankbrockners> #topic Project reports on RC completion and next RC readiness
14:17:35 <frankbrockners> #info BGS RC1 status report and RC2 readiness?
14:17:46 <frankbrockners> I can do a brief summary here.
14:17:57 <frankbrockners> #info Because LF hardware not yet available to project teams, "deploy to LF HW" pending
14:18:07 <frankbrockners> #info Issues which were pending from RC0 resolved (HA deployment, Ceph deployment)#
14:18:25 <[1]JonasB> #info Fuel track didn't make the target for RC1, we have more hands on the deployment and we hope to recoupe til RC2
14:18:26 <frankbrockners> #info Fuel and Foreman deployment approaches both have build scripts available (in the process of maturing)
14:18:50 <frankbrockners> #info Hope/expectation is that RC2 can be fully met (which was move from "deploy available (RC1)" to "fully functional (RC2)")
14:19:04 <[1]JonasB> #info However fuel deploys fine manually
14:19:17 <frankbrockners> thanks [1]JonasB
14:19:23 <dneary> frankbrockners, Sorry, missed roll call, I'm around.
14:19:24 <frankbrockners> anything else to add for BGS?
14:19:27 <dneary> #info dneary
14:19:48 <frankbrockners> trozet: Anything to add?
14:20:14 <frankbrockners> does not seem to be the case
14:20:18 <trozet> #info Foreman/Quickstack has a deploy.sh script, although it needs testing
14:20:38 <frankbrockners> thanks trozet
14:21:01 <frankbrockners> let's move to functest then
14:21:04 <frankbrockners> #info FuncTest RC1 status report and RC2 readiness?
14:21:09 <martintaylor> #info Intel POD not providing working OpenStack needed for functest, apparently due to some Foreman issues
14:21:23 <frankbrockners> Morgan can you cover functest?
14:21:27 <morgan_orange> yes
14:21:39 <iben_> can we use spirent lab for functest development work?
14:21:41 <morgan_orange> first commits today on ODL and OpenStack test suites
14:21:57 <morgan_orange> E/// POD only available POD so far
14:22:02 <morgan_orange> Intel not connected to jenkins
14:22:07 <[1]JonasB> martintailor: What about functest of Fuel?
14:22:07 <morgan_orange> Orange alpha version without ODL
14:22:12 <frankbrockners> morgan_orange - can you info things so that they get recorded?
14:22:30 <morgan_orange> #info first commits today on ODL and OpenStack test suites
14:22:42 <martintaylor> JonasB: we haven't been given access to any Fuel-based pod to test vIMS
14:22:47 <frankbrockners> thanks morgan_orange
14:22:56 <morgan_orange> #info E/// POD only available POD so far, Intel not connected to jenkins, Orange alpha version without ODL
14:23:06 <trozet> martintaylor: your testing should be able to continue on intel pod with the workaround I provided in email yesterday
14:23:19 <aricg> have to run to the dentist. /sorry
14:23:19 <morgan_orange> #manual vPing OK but work on automation in progress
14:23:27 <[1]JonasB> martintailor: Just give me your pub keys and I'l grant you access.
14:23:29 <frankbrockners> aricg: good luck
14:23:35 <morgan_orange> #vIMS no target paltform available
14:23:41 <morgan_orange> yet
14:23:46 <martintaylor> trozet: thx
14:24:15 <morgan_orange> #info doc initiated first draft under gerrit review, to be completed
14:24:41 <martintaylor> JonasB: we'll get in touch offline
14:24:43 <frankbrockners> morgan_orange: does this doc explain the set of tests that we'll have for Arno release?
14:24:52 <morgan_orange> yes
14:25:29 <frankbrockners> morgan_orange: could you info in the gerrit link to the doc commit?
14:26:14 <[1]JonasB> Question, will doc be in md or what format, sorry if I missed the conclusion of this previous discuss
14:26:27 <frankbrockners> morgan_orange: assuming the LF HW becomes available tomorrow - will functest be up and running by RC2?
14:26:52 <frankbrockners> [1]JonasB - I believe doc folks use .rst
14:26:56 <morgan_orange> RC2 is 16/4?
14:27:06 <frankbrockners> mroagen_orange: yes
14:27:07 <morgan_orange> ODL and Rally possible
14:27:13 <frankbrockners> morgan_orange: yes
14:27:29 <iben__> Victor can help answer doc questions
14:27:30 <morgan_orange> vIMS I assume it is a matter of integration
14:27:38 <vlaza> for the documentation project here is how we are standing: have the jobs defined via JJB + script to search for files to be converted - done ; packages for conversion installed on Jenkins - done ; documentation sent for review (opnfvdocs, pharos, genesis, functest) - waiting for review and submit ; artifacts storage - in progress
14:27:39 <frankbrockners> Rally would include standard tempest tests, correct?
14:27:41 <martintaylor> vIMS is ready for testing
14:27:53 <morgan_orange> for the doc we initiated a rst file
14:27:53 <frankbrockners> vlaza: we'll switch to docs soon
14:27:58 <vlaza> sorry
14:28:37 <frankbrockners> any additional updates from functest?
14:29:01 <frankbrockners> ok - then let's switch to opnfvdocs
14:29:04 <frankbrockners> #info Docs RC1 status and RC2 readiness?
14:29:16 <frankbrockners> iben__ or vlaza - could you info the current status?
14:29:23 <vlaza> I will
14:29:25 <frankbrockners> and RC2 readiness
14:29:31 <frankbrockners> vlaza: thanks
14:29:39 <vlaza> for now will just paste what I just wrote
14:29:46 <vlaza> here is how we are standing: have the jobs defined via JJB + script to search for files to be converted - done ; packages for conversion installed on Jenkins - done ; documentation sent for review (opnfvdocs, pharos, genesis, functest) - waiting for review and submit ; artifacts storage - in progress
14:30:04 <frankbrockners> could you hash info the text please
14:30:10 <frankbrockners> so that it gets logged?
14:30:31 <vlaza> #info  here is how we are standing: have the jobs defined via JJB + script to search for files to be converted - done ; packages for conversion installed on Jenkins - done ; documentation sent for review (opnfvdocs, pharos, genesis, functest) - waiting for review and submit ; artifacts storage - in progress
14:30:32 <trevor_intel> vlaza: need to add pharos spec (what is there now is project info)
14:30:57 <vlaza> trevor_intel: I can do that
14:31:08 <trevor_intel> thx ill ping you with link
14:31:16 <frankbrockners> #action vlaza to add pharos spec (what is there now is project info) to docs
14:31:22 <fdegir> #info Octopus needs documentation template and corresponding document generation job available
14:31:31 <vlaza> #info if we have things submitted we can already build artifacts
14:32:08 <fdegir> can I action vlaza?
14:32:11 <frankbrockners> vlaza: I say you had a commit to genesis - but pulled it. Are you planning to commit a new template?
14:32:59 <vlaza> frankbrockners: no, unless something changes and we need to add more things
14:33:12 <iben__> The whole goal initially is to show a documentation work flow process
14:33:31 <iben__> Then we can improve the content of the docs
14:33:32 <frankbrockners> vlaza: could you send out an email on where folks can pick the appropriate template from?
14:33:59 <vlaza> frankbrockners: what do you mean by template?
14:34:44 <frankbrockners> vlaza: plan was to have a template available by today which would help projects to create their documentation
14:35:16 <vlaza> #info it just has to be in reST markup format and best practice is that main file to be docs/main.rst ; jjb job template is standard for all projects
14:35:17 <frankbrockners> RC1 task for docs was "Documentation templates are available, with associated structure and documentation 'guidelines'"
14:35:47 <iben__> We will be creating boilerplate templates for each project
14:35:47 <vlaza> I can write an email to the mailing list with those details & some more; to have it clear
14:36:33 <frankbrockners> #action opnfvdocs to create boilerplate templates for each project
14:36:34 <dneary> I don't see anything in opnfvdocs - either review or in the tree
14:36:51 <frankbrockners> vlaza: that would be good. will action you
14:36:54 <dneary> Is there a proposal for a directory structure etc?
14:37:07 <dneary> And perhaps a list of templates we need?
14:37:17 <dneary> If there's an easy checklist to follow, I can help
14:37:30 <dneary> At least putting together a draft that we can iterate on
14:37:30 <fdegir> dneary: https://gerrit.opnfv.org/gerrit/#/c/254/
14:37:34 <vlaza> dneary: https://gerrit.opnfv.org/gerrit/#/c/254/
14:37:35 <frankbrockners> #action vlaza to write an email to the mailing list with documentation details (format, template, location in repo etc.)
14:37:54 <iben__> We have that data. Just need to collect and present
14:38:01 <frankbrockners> #link https://gerrit.opnfv.org/gerrit/#/c/254/
14:38:17 <frankbrockners> #info draft directory structure for docus
14:38:21 <frankbrockners> #undo
14:38:21 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1cf6950>
14:38:30 <frankbrockners> #info draft directory structure for docs
14:38:35 <dneary> fdegir, vlaza: Thanks - I do not have Gerrit marts apparently
14:38:54 <dneary> smarts
14:38:57 <fdegir> #info see all patchsets submitted by vlaza related to documentation from below link
14:39:02 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/q/owner:%22Victor+Laza+%253Cvlaza%2540cloudbasesolutions.com%253E%22
14:39:27 <fdegir> they ar ewaiting for reviews
14:39:52 <frankbrockners> fdegir: some of them got abandoned - hence my earlier question about the genesis repo
14:40:17 <fdegir> one of them was duplicate and missing change id
14:40:21 <fdegir> but this is still up for review
14:40:22 <fdegir> https://gerrit.opnfv.org/gerrit/#/c/268/
14:40:25 <fdegir> for genesis
14:40:45 <frankbrockners> thanks - I missed that one!
14:41:00 <frankbrockners> anything else on docs?
14:41:13 <vlaza> no from my side
14:41:17 <vlaza> iben?
14:41:33 <frankbrockners> ok - let's switch to futures...
14:41:36 <frankbrockners> #topic Actions and activities planned - All
14:41:41 <iben__> Thanks
14:42:18 <fdegir> #info Octopus is working with FuncTest to get basic testing job created
14:42:31 <fdegir> #info Octopus will also work with BGS with regards to deployment parts
14:43:13 <frankbrockners> #info BGS team hopes to have functional deploy.sh ready by RC2
14:43:40 <iben__> Request to use the Spirent lab with octopus and functest.
14:44:10 <fdegir> iben__: that might complicate things a bit as we are trying things with Ericsson, Intel, Orange, and LF HW
14:44:29 <fdegir> I propose we focus the one that is already proven to  be working
14:44:38 <fdegir> and switch to LF HW when it becomes available
14:44:43 <iben__> Okay. I heard there were issues.
14:44:55 <fdegir> Intel issues have been identified
14:45:02 <fdegir> Ericsson lab partitioning is going on
14:45:06 <fdegir> and LF is about to arrive
14:45:07 <iben__> If it's not necessary then that's fine. No worries.
14:46:54 <frankbrockners> fdegir: by when do you think the Ericsson lab would be available in "partitioned form"?
14:47:35 <fdegir> I haeard from [1]JonasB that the work has been started
14:47:38 <frankbrockners> (mostly as backup in case there are further delays with LF HW)
14:47:50 <fdegir> [1]JonasB: : can you answer this question please?
14:48:00 <[1]JonasB> #info hopefully tomorrow, latest Monday.
14:49:19 <fdegir> trevor_intel: when do you think Intel lab can be connected to OPNFV Jenkins as you said issues have been identified?
14:49:50 <trevor_intel> I am going to the lab this morning and will give an update I am hoping today
14:49:55 <[1]JonasB> #info We will host one build server, 1 repo mirror server, one landing server 5 servers for BM deploy and 8 GP servers.
14:50:24 <[1]JonasB> #info GP=general purpose wich we can partition the way we like.
14:50:24 <fdegir> thanks trevor_intel
14:52:57 <frankbrockners> anything else for today?
14:53:13 <frankbrockners> otherwise we can close the meeting...
14:53:39 <frankbrockners> ... doesn't seem to be the case...
14:53:43 <fdegir> first real-ish functest job has just been created
14:53:44 <fdegir> https://build.opnfv.org/ci/view/functest/job/functest-vim_bench-test/
14:53:49 <frankbrockners> ah
14:53:56 <frankbrockners> cool
14:54:10 <fdegir> and running on orange-build server
14:54:11 <fdegir> https://build.opnfv.org/ci/view/functest/job/functest-vim_bench-test/1/console
14:54:13 <frankbrockners> #info fdegir says first real-ish functest job has just been created
14:54:14 <morgan_orange> there is (almsot) nothing inside ...
14:54:14 <fdegir> and failed
14:54:20 <fdegir> will fix and retry
14:54:21 <vlaza> Any chance to connect SPirent's jenkins to the jenkins-master?
14:54:24 <morgan_orange> keep cool
14:54:49 <frankbrockners> ok - sounds like we're done with RC1 reporting
14:54:58 <frankbrockners> let's keep fingers crossed for next week....
14:55:11 <frankbrockners> thanks you everybody
14:55:22 <frankbrockners> thank you everybody
14:55:27 <iben_> ciao!
14:55:28 <frankbrockners> #endmeeting