14:01:07 <ulik> #startmeeting Octopus Weekly Meeting
14:01:07 <collabot> Meeting started Mon Apr 13 14:01:07 2015 UTC.  The chair is ulik. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:07 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:07 <collabot> The meeting name has been set to 'octopus_weekly_meeting'
14:04:42 <iben_> good morning
14:04:53 <radez> morning iben_
14:05:21 <iben_> agenda bashing
14:05:30 <iben_> https://wiki.opnfv.org/meetings/octopus
14:05:43 <iben_> Agenda of next meeting, Monday, April 13, 14:00 UTC
14:05:44 <iben_> Welcome to new committers
14:05:44 <ulik> #chair iben_ radez
14:05:44 <collabot> Current chairs: iben_ radez ulik
14:05:45 <iben_> Meeting format (use of IRC)
14:05:47 <iben_> Status update: connecting labs
14:05:48 <iben_> Status update: artifact repository
14:05:50 <iben_> Achieving RC2 (Automatic testing on LF hardware fully functional)
14:05:51 <iben_> Octopus documentation for Arno
14:05:52 <iben_> First thoughts about Octopus in Release 2
14:05:53 <iben_> AoB
14:05:54 <iben_> sounds good
14:05:57 <rprakash> good morning
14:06:01 <fdegir> please prepend stuff with #info
14:06:12 <iben_> let’s do the irc way?
14:06:22 <iben_> it’s very early monday morning
14:06:27 <fdegir> #info agenda bashing
14:06:35 <fdegir> #info https://wiki.opnfv.org/meetings/octop
14:06:36 <iben_> kids are all off on break - it’s a holiday week
14:06:52 <ulik> #topic Welcome to new committers
14:07:11 <iben_> thank you!
14:07:24 <rprakash> #link https://wiki.opnfv.org/meetings/octopus
14:08:21 <iben_> people caon contribue through wiki updates and community involvement too
14:08:38 <iben_> what makes a “contributor”
14:08:43 <iben_> using JIRA
14:08:51 <iben_> making JJB jobs
14:08:55 <fdegir> documentation
14:09:01 <iben_> getting other members involved
14:09:01 <fdegir> writing utilities/scripts
14:09:09 <fdegir> involving in setup/infra stuff
14:09:25 <ulik> #info Uli reports from the voting (7 +1 votes for the new committers)
14:09:26 <fdegir> helping other projects with general questions regarding CI/infra questions
14:09:34 <iben_> we had some questions in IRC last week about getting JJB built - how to do this?  Is it well documented?
14:10:03 <ulik> #info Uli encourages to document in Jira when doing contributions
14:10:11 <iben_> this can be a topic for documentation part of discussion
14:10:29 <iben_> okay - thanks!
14:10:54 <iben_> BGS has stories for setting up JJB
14:11:13 <iben_> if we can get a link ?
14:11:20 <iben_> these stories are in JIRA?
14:12:01 <fdegir> #link https://jira.opnfv.org/issues/?jql=project%20%3D%20OCTO
14:12:12 <iben_> Question: Scope for Octopus porject is how to follow proper CI Pipeline workflow?
14:12:30 <iben_> JIRA, JJB, Gerrit,Jenkins,
14:12:33 <ulik> #topic Meeting format
14:12:43 <fdegir> jjb info is also documented on wiki
14:13:07 <fdegir> not perfect but good to start with
14:13:08 <fdegir> https://wiki.opnfv.org/octopus/jenkins_wow
14:13:22 <iben_> found it - thanks! we will look here.
14:13:24 <ulik> #info Uli proposes to move to pure IRC meetings
14:13:32 <iben_> +1
14:13:35 <radez> +1
14:13:37 <fdegir> +1
14:13:42 <rprakash> #info it is difficult tpo co-ordinate without voice calls
14:13:54 <jerryz> +1
14:14:01 <iben_> it’s okay to have voice too
14:14:14 <iben_> there are many who want to talk or have trouble with IRC
14:14:36 <iben_> when I’m driving for example - need to use voice
14:14:58 <iben_> it’s 7am here - normally a commute time of day
14:15:16 <iben_> but this week is vacation so irc is better
14:16:05 <iben_> we can have more discussions on IRC during the week at any time
14:16:27 <iben_> this weekly call can jsut be for a status update for what happened during the week
14:17:09 <iben_> if i can’t make a weekly call - because it is on IRC I can easily review it better
14:17:41 <ulik> #agree to try IRC only meetings.
14:17:47 <iben_> suggestion was made to do IRC first and if Audio is needed we can bring it up
14:17:47 <rprakash> #agreed irc first and if need be gt gotomeeting voive call asap
14:18:00 <ulik> #info if we want to add voice we can do so quickly.
14:18:19 <ulik> #topic Status update: connected labs
14:18:27 <fdegir> #info Connected labs are ATT, Huawei, Dell, Ericsson, Intel, Orange
14:18:29 <iben_> connected labs means “jenkins”
14:18:45 <fdegir> #link https://build.opnfv.org/ci/computer/
14:18:46 <ulik> yes.
14:20:01 <fdegir> #info "Connected labs" means one or more servers from these labs are connected to OPNFV Jenkins as slaves
14:20:16 <ulik> intel connection problem was firewall problem, signature entered in firewall.
14:20:34 <fdegir> #info and these slaves are currently doing different things building or testing depending on the lab/server configuration
14:20:42 <rprakash> #info Intel had Firewall problems for Jenkins slave to communicate two way with Jenkin Master
14:20:50 <iben_> #link https://wiki.opnfv.org/wiki/jenkins#jenkins_slaves <— a list maintained on the wiki
14:21:01 <fdegir> that list might not be up to date
14:21:08 <fdegir> so use the other link I put before
14:21:13 <fdegir> https://build.opnfv.org/ci/computer/
14:21:15 <iben_> Trevor - was the troubleshooting done over IRC in the end?
14:21:42 <fdegir> yes
14:21:56 <iben_> we are working for setup of Spirent lab too
14:22:01 <fdegir> Trevor confirms that Aric and Intel admin fixed issues over irc
14:22:33 <fdegir> #Info Work with connecting slave(s) from Spirent lab is curently ongoing
14:22:45 <ulik> #topic status update artifact repository
14:22:56 <ulik> #info Google storage is in use now
14:23:06 <rprakash> #info using Google storage with Fuel and Foreman
14:23:09 <iben_> google storage is our ARM
14:23:18 <ulik> #chair rprakash
14:23:18 <collabot> Current chairs: iben_ radez rprakash ulik
14:23:27 <fdegir> #link https://build.opnfv.org/ci/computer/
14:23:31 <fdegir> #undo
14:23:35 <iben_> #link https://wiki.opnfv.org/wiki/artifactrepos
14:23:38 <fdegir> #link http://artifacts.opnfv.org/
14:23:49 <rprakash> #info Artifiact Resource Manager (ARM)
14:23:59 <iben_> how do files get on hte ARM?
14:24:12 <fdegir> #info Example build metadata is
14:24:14 <fdegir> #link http://artifacts.opnfv.org/genesis/fuel/opnfv-35.properties
14:24:15 <iben_> can humans put files there?
14:24:20 <iben_> or only jenkins jobs
14:24:52 <fdegir> #info How to get files to ARM
14:24:57 <iben_> each jenkins slave can upload via a token from RELENG team
14:25:04 <fdegir> #info Slave specific tokens are needed
14:25:13 <iben_> i sent an email about artifacts versus code
14:25:18 <fdegir> #info Request access/permission by opening ticket to LF helpdesk
14:25:18 <iben_> PDF is an artifact
14:25:29 <rprakash> #info need upload permision and can be obtained from Artic Garner for ARM update
14:25:32 <iben_> but they are checking in to Gerrit
14:25:51 <iben_> we have people doing the IRC to voice bridge
14:25:56 <iben_> thank you!
14:26:10 <fdegir> only source of documentation is stored in gerrit
14:26:14 <fdegir> isn't it so?
14:26:22 <iben_> fdegir: it should be that way
14:26:32 <iben_> but we need to figure out how to enforce that
14:26:46 <iben_> is there a way?
14:27:06 <iben_> gerrit should report an error when checking in a PDF
14:27:08 <fdegir> I don't think so
14:27:10 <iben_> or ISO
14:27:29 <iben_> the build will generate the PDF
14:27:35 <iben_> that is an artifact
14:27:51 <iben_> we have a tool doing these documentation builds
14:27:56 <ulik> how do I find the PDF that was created in the build
14:27:57 <iben_> it is being setup for all projects
14:28:06 <iben_> they will go in the ARM
14:28:11 <fdegir> #info We need clear instructions for how to work with documentation and what to do with produced documents/artifacts
14:28:12 <iben_> just like any artifact
14:28:17 <jerryz> i heard doc project use rst file as source code and can build html out of it
14:28:20 <iben_> so let’s make that an action
14:28:33 <iben_> even word doc or PPT can be source for the PDF builder
14:28:48 <fdegir> #action We need clear instructions for how to work with documentation and what to do with produced documents/artifacts
14:28:55 <iben_> we take any source input file and covert it to HTML, TXT, and PDF
14:29:13 <iben_> we are building this process out as an example now and will have it ready for R1
14:29:32 <fdegir> can you info these please iben_?
14:29:34 <ulik> The process also needs to be described in wiki
14:29:41 <iben_> I invited Victor Laza who is working on this to this meeting
14:29:42 <iben_> but
14:29:52 <iben_> he is on holiday today
14:30:04 <iben_> i am told it is still easter celebration today
14:30:26 <iben_> the wiki will be updated automatically from HTML
14:30:36 <iben_> the HTML is stored on the gerrit
14:30:40 <iben_> the wiki is scraped
14:30:41 <fdegir> #info Main source information should be the repo
14:30:48 <iben_> i can share a link on this - one sec
14:30:52 <fdegir> #info the wiki will be updated automatically from HTML
14:31:02 <iben_> #link https://wiki.opnfv.org/exampledoc
14:31:07 <rprakash> #info RST files are created in document directory corresponding to PDFs
14:31:10 <rprakash> OPNFV_GIT_URL=https://gerrit.opnfv.org/gerrit/genesis
14:31:10 <rprakash> OPNFV_GIT_SHA1=3525d52f2dc83ce3f4675004a49616c9d621cef8
14:31:11 <rprakash> OPNFV_ARTIFACT_URL=artifacts.opnfv.org/genesis/fuel/opnfv-35.iso
14:31:11 <rprakash> OPNFV_BUILD_URL=https://build.opnfv.org/ci/job/genesis-fuel-daily-master/35/
14:31:12 <rprakash> OPNFV_BUILD=OK
14:31:13 <fdegir> #info uby automatically generating documentation using the documentation source in Gerrit
14:31:34 <iben_> you see the line here - {{scrape>https://
14:31:42 <ulik> #topic Documentation
14:32:20 <fdegir> #info Is Octopus expected to provide documentation for R1?
14:32:46 <ulik> #action Uli to clarify in TSC whether Octopus documentation is part of Arno
14:32:51 <fdegir> #info Octopus should provide documentation for R1 even though it is not expected based on what is written on Wiki
14:33:05 <iben_> https://wiki.opnfv.org/documentation_projects
14:33:22 <iben_> this is the info I got on release 1 projects
14:33:23 <iben_> Release One Project List Summary
14:33:23 <iben_> functest - Functional Testing - https://wiki.opnfv.org/opnfv_functional_testing
14:33:25 <iben_> bgs - Bootstrap/Get started (Genesis) - https://wiki.opnfv.org/get_started
14:33:25 <iben_> pharos - Testbed infrastructure - https://wiki.opnfv.org/pharos
14:33:26 <iben_> documentation - https://wiki.opnfv.org/documentation_projects/opnfv_documentation
14:33:36 <iben_> that doesn’t mean we can’t work on it
14:33:39 <fdegir> #link https://wiki.opnfv.org/documentation_projects
14:33:45 <iben_> we will still work on any documentation
14:34:09 <iben_> octopus is a requirement for other projects
14:34:20 <fdegir> #info Scope of Octopus documentation needs to be decided
14:34:33 <iben_> so this means as long as CI Pipeline is working to make R1 happen we are okay
14:34:35 <fdegir> #info Octopus should document current loops/jobs
14:34:42 <iben_> but we all agree it should still be documented
14:34:50 <fdegir> #link https://wiki.opnfv.org/octopus/flows#candidates_for_release_1
14:34:59 <iben_> it should be a best practice to document what we do first
14:35:32 <iben_> there are many good examples we already have - since jenkins is “self-documenting” it is easy to look at the jenkins servers to see the jobs
14:35:41 <fdegir> #info Octopus should provide information regarding how to work with jobs using JJB
14:35:44 <fdegir> #link https://wiki.opnfv.org/octopus/flows#candidates_for_release_1
14:35:56 <fdegir> #info Documentation regarding Artifact Repository
14:35:57 <iben_> question: if a jenkins job was built with JJB is there a note or comment in the job about this?  how it was built?
14:36:17 <fdegir> #info Documentation regarding how to connect external labs to OPNFV Jenkins
14:36:20 <iben_> https://build.opnfv.org/ci/job/genesis-fuel-daily-att-master/
14:36:26 <iben_> here is an example
14:36:37 <iben_> all it says is <!-- Managed by Jenkins Job Builder -->
14:36:39 <fdegir> iben_ that will be documented
14:36:44 <fdegir> and improved
14:36:51 <iben_> but it is not clear how I would update the jenkins job
14:37:27 <fdegir> #info This list is the bare minimum for R1
14:37:45 <jerryz> iben_: currently the jjb template is hosted on https://gerrit.opnfv.org/gerrit/releng
14:37:49 <iben_> the key is in the JJB script - it should reference itself
14:38:00 <iben_> i see
14:38:36 <iben_> i get a “not found” for that url jerryz
14:38:57 <jerryz> iben_: git clone
14:39:05 <rprakash> #info releng not found
14:39:13 <fdegir> #info story for Ocotpus documentation
14:39:14 <fdegir> #link https://jira.opnfv.org/browse/OCTO-33
14:39:41 <iben_> #link https://gerrit.opnfv.org/gerrit/#/admin/projects/releng
14:40:09 <iben_> who will work on octopus docs?
14:40:17 <fdegir> I started working on it
14:40:36 <iben_> we can ask Victor
14:40:44 <rprakash> #info confirmed https://gerrit.opnfv.org/gerrit/#/admin/projects/releng works
14:41:11 <rprakash> #info 4 documents
14:41:17 <iben_> perfect! thanks
14:41:24 <fdegir> #info We need help with documenting
14:41:25 <fdegir> #info How to connect labs to OPNFV Jenkins
14:41:30 <fdegir> #info How to use JJB
14:41:37 <fdegir> #info How to use Artifact Repository
14:41:44 <iben_> fdegir: I will put this in the JIRA
14:41:50 <fdegir> #info fdegir is working with documenting current jobs
14:41:57 <fdegir> iben_ I hvae the story there already
14:42:02 <fdegir> subtasks can be created under it
14:42:06 <iben_> okay - never mind - thanks
14:42:49 <ulik> #topic Achieving RC2
14:43:26 <ulik> #info LF hardware not yet fully functional
14:43:30 <rprakash> #info LF hardware is not fully fucntional yet
14:44:03 <rprakash> #info waht time do we need once LF hardware is ready
14:44:46 <jerryz> #info what is the topo of test env. jenkins master->jump server(slave)->LF hardware?
14:44:52 <rprakash> #info we connect Jenkins Slave server that's not enough will need automation and that takes a day least
14:45:17 <rprakash> #info Have a deploy script ready but need to test
14:45:32 <iben_> did we decide on support for containers?
14:45:40 <iben_> will we support only VMs?
14:45:51 <ulik> #info Scripts are already prepared, so we can easily move forward as soon as the hardware is ready.
14:46:09 <fdegir> #info Foreman deploy scripts are ready
14:46:21 <rprakash> #info Foreman deploy script are ready not for Fuel
14:46:22 <fdegir> #info We need to check Fuel deploy script
14:46:22 <jerryz> #info compass has vm-based deploy.sh ready
14:47:03 <fdegir> #info The requirement is to have bare metal deployment for R1
14:47:18 <iben_> yes but the installer for bare metal
14:47:25 <iben_> that is a vm? or vagrant?
14:47:38 <jerryz> we use vm to simulate baremetal
14:47:40 <iben_> there was some discussion aboit the format for the installer
14:48:10 <jerryz> only difference is power management, ipmitool vs virsh
14:48:24 <ulik> There was a request to have all installers use same build output
14:48:37 <iben_> i guess the real question is - does octopus care about this?
14:48:52 <ulik> Octopus shouldn't care :-)
14:49:01 <fdegir> yep
14:49:10 <jerryz> octopus should care about test topology of the environment
14:49:13 <iben_> okay - either way they are making artifacts
14:49:14 <fdegir> if they have certain artifact
14:49:17 <fdegir> we support storing it
14:49:19 <fdegir> if not
14:49:22 <fdegir> then we don't
14:50:12 <ulik> #info concluding statement: Octopus is fine for RC2. About one day after hardware is ready.
14:50:39 <fdegir> #info Hardware ready means that they are connected to Jenkins as slaves
14:50:56 <rprakash> #info for rc2 deployment scripts once ready need a day or two to test once LF harware is ready with Jenkins Mater /Salve connected to labs
14:51:09 <ulik> at least we shouldn't have a firewall inbetween :)
14:51:54 <ulik> #topic starting to think about release 2
14:52:37 <ulik> we need some brainstorm
14:52:38 <rprakash> #info release 1 is just basic
14:52:50 <ulik> There were also already some suggestions.
14:52:52 <fdegir> #info We need to go through the R1 CI setup and evaluate it
14:53:12 <fdegir> #info Improve the CI moving forward
14:53:18 <ulik> How about an etherpad
14:53:29 <rprakash> #info workflow needs to be im[roved and Zool may be a good idea to investigate
14:53:51 <jerryz> #info s/Zool/Zuul
14:54:05 <rprakash> #info Project needs are important for CI to improve its workflow
14:54:11 <ulik> also other projects should send their ideas / requests
14:54:37 <rprakash> #info Jeera story for CI example
14:54:45 <fdegir> #link https://jira.opnfv.org/browse/OCTO-31
14:55:24 <ulik> #action Uli to start discussion on etherpad and send email to all projects
14:55:33 <fdegir> #info We need input from people who have experience with different tools upstream projects use
14:55:44 <fdegir> #info Then we need to evaluate these tools to determine if they add value
14:55:52 <fdegir> #info or if they increase the complexity
14:56:23 <rprakash> #info get agreement for inputs to CI from other projects to feed the etherpad that will be setup by Uli
14:56:34 <iben_> we can follow the examples of other projects
14:56:44 <iben_> it’s a good idea to brainstorm on these things
14:56:45 <jerryz> like openstack
14:56:52 <fdegir> yes
14:56:55 <iben_> good idea to make the list and prioritize it
14:57:11 <fdegir> ulik has the action already
14:57:20 <fdegir> to collect the input
14:57:25 <jerryz> puppet modules for ci infrastructure are worth looking at
14:57:39 <rprakash> #info build priority list of requirments for CI in etherpad and go over them weekly yo agree on what to do
14:57:53 <ulik> #topic AoB
14:57:53 <iben_> will we make a recomendation
14:57:58 <iben_> about docs
14:58:00 <iben_> and ARM
14:58:08 <iben_> PDF should not go in Gerrit?
14:58:12 <iben_> ?
14:58:21 <fdegir> iben_ : yep, pdf should not go into gerrit if you ask me
14:58:29 <iben_> how to get the word out?
14:58:36 <iben_> okay - we are ending meeting
14:58:47 <frankbrockners> thanks folks :-)
14:58:50 <fdegir> but again there are some people who are not comfortable with anything but word
14:58:50 <iben_> moving to 3opnfv-octopus
14:58:51 <frankbrockners> BGS is waiting...
14:58:54 <ulik> #endmeeting