14:00:37 <ulik> #startmeeting Octopus weekly meeting
14:00:37 <collabot> Meeting started Mon Apr 20 14:00:37 2015 UTC.  The chair is ulik. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:37 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:37 <collabot> The meeting name has been set to 'octopus_weekly_meeting'
14:01:01 <ulik> Welcome! Please type info in
14:01:06 <ulik> #info Uli Kleber
14:01:07 <lmcdasm> #info
14:01:13 <fdegir> #info Fatih Degirmenci
14:01:40 <zhifeng> info zhifeng.jiang
14:01:52 <aricg> #info aricg
14:02:02 <zhifeng> #info zhifeng.jiang
14:02:28 <ulik> I have put agenda on the wiki:
14:03:15 <ulik> https://www.irccloud.com/pastebin/CnzaOtld
14:03:34 <ulik> #topic agenda bashing
14:03:46 <ulik> any other topics?
14:04:46 <ulik> sounds ok. so let's start with LF hardware then.
14:04:55 <ulik> #topic Status of LF hardware
14:05:22 <ulik> Can we now connect jenkins slaves?
14:05:47 <aricg> only lf_pod1 is up, it is connected
14:05:59 <fdegir> #info JS from LF POD1 is connected
14:06:27 <ulik> So can we run Fuel deploy there?
14:06:40 <radez> I thought fuel was going on pod2?
14:06:49 <ulik> sorry
14:07:01 <aricg> we switched this weekend
14:07:13 <radez> ah, k missed that.
14:07:13 <fdegir> after yesterday's meeting
14:07:26 <radez> is there an architechure layout for POD2?
14:07:53 <fdegir> I think pbandzi is working on pod2
14:07:57 <radez> just curious, why did we swtich?
14:08:22 <fdegir> ChrisPriceAB: ping
14:08:22 <aricg> So that Dan could do some work this weekend
14:08:36 <aricg> this is how far he got: https://dl.dropboxusercontent.com/u/12773330/opnfv_hw_pics/Success-FUEL.PNG
14:08:40 <fdegir> to gain some time
14:08:50 <ChrisPriceAB> hi all
14:09:12 <radez> we were planning to do a top to bottom deployment of the foreman stuff starting first thing this morning
14:09:28 <radez> so there are not resources for us now?
14:09:48 <aricg> here are the changes we need to do both deplpoys properly (from a networking persepctive) https://etherpad.opnfv.org/p/lfwh
14:10:13 <ChrisPriceAB> hi guys pbandzi is working on the HW now. there's a chat ongoing on opnfv discussing this.
14:10:22 <aricg> (you only need to read the: THIS IS WHAT WE WANT: part)
14:10:23 <ChrisPriceAB> We are approaching POD's up
14:11:24 <aricg> oh, and the etherpad only has info for fuel. probably need something diffrent on pod2 for forman.
14:11:38 <fdegir> #info pbandzi working on setting up LF POD2
14:11:45 <lmcdasm> hmm. i dont see anything done on POD1 JS today -
14:12:01 <lmcdasm> so.. i dont see (since i logged off at 2am) what has been done on POD1
14:12:24 <lmcdasm> also  seems that Peter is not the person to go VR/GW's on the switch -
14:12:34 <radez> aricg: I also though the networking topo was supposed to be the same on both PODs?
14:12:36 <lmcdasm> however, Konstantin said he didnt know how to do it a
14:12:48 <aricg> pbandzi can you confirm?
14:13:58 <aricg> radez:  probably/maybe/dont actually know/ need something diffrent on pod2
14:14:21 <radez> the originally topo that was sent out was fine for us
14:15:12 <pbandzi> POD2 ip 172.30.9.72 for a minute i'll send link to wiki
14:16:06 <aricg> nice. thanks pbandzi
14:16:08 <fdegir> #info pbandzi says POD2 ip 172.30.9.72
14:16:31 <fdegir> #info more info coming
14:17:25 <lmcdasm> #info - so the focus is now back to POD2 today?
14:17:29 <ulik> ok. So POD2 in progress and will be used for Foreman (after we switched). Correct?
14:17:42 <lmcdasm> #info - has any of the followup actions that i requestsed on Saturday or Sunday been implemented?
14:17:58 <fdegir> yes, according to yesterday's decision
14:18:03 <lmcdasm> #info plesae let me know - and if POD1 will be done today or when - so that i can logoff
14:18:18 <lmcdasm> #info - what??  what yesterdays decision???
14:18:28 <ulik> #info let's summarize status of POD2 and then move to POD1.
14:18:44 <fdegir> #info fuel -> pod1
14:18:53 <ulik> #info POD2 setup in progress and will be used for Foreman.
14:18:57 <fdegir> #info foreman -> pod2
14:19:08 <ulik> POD1 will now be used for fuel. Status there?
14:19:25 <fdegir> lmcdasm: was answering ulik
14:19:52 <lmcdasm> #info - no support over the weekend, VLAns not in place, networking not sorted, FUEL VLans not provisioned
14:20:06 <lmcdasm> #info outstanding question of split-NIC approach remains
14:20:20 <lmcdasm> #info -FUEL installed and Running, but not deployable due to lack of readiness of the LAB
14:20:53 <lmcdasm> #info - Frank and team has asked for "another" diagram .. we need to find a better method cause we have not made a signle move on this networking setup for days
14:21:07 <rprakash> #link https://etherpads.opnfv.org/p/lfhw
14:21:33 <lmcdasm> #info - link doesnt work
14:21:49 <radez> etherpad not etherpads
14:21:51 <ulik> #link https://etherpad.opnfv.org/p/lfwh
14:21:59 <lmcdasm> #info - so.. anyone else want to chime in here?  Has anyone reviewed the PPT and questions sent out?
14:22:10 <radez> what ppt and questions?
14:22:17 <lmcdasm> ok.. well.  they were setnt to infra
14:22:25 <lmcdasm> cause there are a number of questins
14:22:29 <lmcdasm> first - on the JS Host
14:22:32 <lmcdasm> are you using a single NIC ro two
14:22:45 <lmcdasm> fro everything includin access to the JS host and to the JS host VMSs
14:22:55 <lmcdasm> as well as the VLANs that you need for OPEnstack / deplopyment
14:22:58 <lmcdasm> or are we splitting them
14:23:08 <lmcdasm> so you have an external NIC (and bridges to a FUEL/FOREMAN VM)
14:23:20 <lmcdasm> and then a second nic where we do all Openstack/ODL/FUEl/FOREMAN Stuff?
14:23:29 <lmcdasm> so that was asked last week and again on Friday and in a PPT
14:23:35 <radez> is the jump host common for both bods?
14:23:37 <radez> Pods
14:23:38 <lmcdasm> no
14:23:39 <radez> ?
14:23:43 <lmcdasm> there are two differetn JS HOsts
14:23:45 <lmcdasm> 1 per POD
14:23:55 <lmcdasm> later it will be common JS HOST (with two VMs - one foreman and one fuel).
14:24:09 <lmcdasm> second - where are th IP subnet lists, GWs and IPs setups for aeverything?
14:24:19 <lmcdasm> showing what IPs on which POD can be taken, etc
14:24:42 <lmcdasm> seems to me like we need to take some time for everyone to get caught up on the same page.
14:24:58 <lmcdasm> cause i dont think we hav a common understanding of how we want th lab to get setup.
14:25:24 <lmcdasm> three are questions about why the JS host would need vlans when we are putting the Installers in VM and the installers are documented using this VLANs/
14:26:58 <fdegir> should we move?
14:27:10 <fdegir> to next topic perhaps
14:27:17 <lmcdasm> well. no.. i dont have resolution
14:27:27 <lmcdasm> so i would expect from a meeting where i have outlined issues
14:27:46 <ulik> you are right. But I would like to know, who is gathering some answers for lcmdasm.
14:28:14 <lmcdasm> info - ok to be honest, this is pretty frustrating, the are 10 IRC channels and the same people are in the same channels seeing and writing this same stuff
14:28:28 <lmcdasm> so ive giving the update in a couple different spots, but no motion on this.
14:28:31 <fdegir> yes, that was my point
14:28:47 <fdegir> weekly meeting wont be enough to solve it
14:28:58 <ulik> Yes. So since we are in octopus meeting, we cannot solve infra.
14:29:05 <lmcdasm> ok
14:29:11 <lmcdasm> ciao
14:29:29 <ulik> I think we should solve infra on #opnfv channel, but We should know who is solving it.
14:29:56 <ulik> sorry, we couldn't help there.......
14:30:02 <ulik> let's move on then.
14:30:14 <fdegir> I think pharos, bgs, lf should be the ones to focus on this
14:30:34 <ulik> Yes. let's hope for the BGS meeting in 30 min.
14:30:48 <fdegir> ok
14:30:57 <ulik> #topic Arno related jira topics
14:31:29 <ulik> #info I found 3 critical and 19 major topics (not closed)
14:31:48 <fdegir> #info fdegir has gone through the jira backlog and applied label R1 to the ones needed for R1
14:31:51 <ulik> #info 2 are for Juju, 3 for OpenSteak, 1 for compass
14:32:23 <fdegir> juju, opensteak are probably not crucial for R1
14:32:24 <ulik> great! I didn't know how to do that, I wanted something like that.
14:32:30 <fdegir> as the things stand
14:32:39 <fdegir> #link https://jira.opnfv.org/issues/?jql=project%20%3D%20OCTO%20AND%20status%20in%20%28Open%2C%20%22In%20Progress%22%2C%20Reopened%29%20AND%20labels%20%3D%20R1
14:33:11 <fdegir> (again, this is my view based on RCs)
14:33:38 <fdegir> #info closed and resolved items are excluded
14:33:55 <ulik> I also found 16 open/in progress for Arno.
14:35:29 <fdegir> #info Query is based on BGS Installers passed RC(s)
14:36:01 <ulik> that is fuel&foreman only?
14:36:10 <fdegir> #info Fuel & Foreman Daily Pipelines have highest prio at the moment
14:37:08 <fdegir> #info Deployment stories are either in progress or about to be started for these installers
14:37:10 <ulik> Any issues where additional help is needed or is everything progressing (assuming 4, 46, 47 assigned to Prakash)
14:37:32 <fdegir> #info Info regarding funcTest is yet to be received
14:38:04 <ulik> should we add issues for the tests?
14:38:32 <rprakash> I asked for access on intel and lf for openvpn and do not still have vpn access
14:38:34 <fdegir> we can create subtasks under daily pipeline story
14:38:49 <fdegir> rprakash: access is not crucial
14:38:58 <aricg> rprakash: how did you request access?
14:39:08 <rprakash> by email
14:39:27 <aricg> can you fwd me the email you sent for the lf access?
14:39:50 <rprakash> will do thanks
14:40:01 <ulik> rprakash: did you request access to intel or to lf lab?
14:40:07 <fdegir> ok
14:40:17 <fdegir> it seems Im talking to air
14:40:19 <rprakash> both
14:40:55 <ulik> fdegir said access is not crucial.
14:41:15 <fdegir> at this phase
14:41:21 <fdegir> please do not idle
14:41:38 <fdegir> and start with jenkins jobs
14:41:45 <ulik> We should concentrate that jenkis triggers the scripts.
14:42:32 <fdegir> anyway
14:42:50 <fdegir> #info we also have some doc work going on
14:43:23 <fdegir> #info jjb-usage and artifact-repo docs are under review for corresponding jira stories
14:43:59 <fdegir> #info 2 other doc stories; slave connection and existing jobs
14:44:09 <fdegir> #info are pending
14:44:36 <fdegir> that's all for jora stuff as far as i can tell
14:44:59 <ulik> yes. 4 dos defined.
14:45:24 <ulik> Suggest to start reviewing already when docs are not yet finished. Is that possible?
14:45:33 <fdegir> all those stories have owners which is good
14:45:43 <fdegir> so thanks for taking them over
14:46:00 <fdegir> ulik: 2 reviews are already on gerrit
14:46:42 <ulik> #info All, please review! can you put some links?
14:47:12 <ulik> (just to encourage people)
14:47:15 <fdegir> #link https://gerrit.opnfv.org/gerrit/364
14:47:26 <fdegir> #link https://gerrit.opnfv.org/gerrit/393
14:48:04 <ulik> #info Thanks! 2 other docs. maybe we can share already a part of it so people can start review?
14:48:51 <fdegir> I started with jibs story
14:49:16 <fdegir> and the otger story is also taken over
14:50:12 <ulik> Great. So better progress on docs than on connecting labs.....
14:50:22 <fdegir> I think so
14:50:34 <fdegir> we need reviews as you highlighted
14:50:43 <ulik> #info that included #topic Documentation status ;-)
14:50:50 <fdegir> yep
14:51:05 <ulik> Should I send out an email to encourage more reviews?
14:51:40 <fdegir> I think attendees of this meeting is enough
14:51:48 <ulik> agree ;-)
14:52:07 <ulik> more reviewers --> more work --> later delivery
14:52:12 <fdegir> :)
14:52:12 <ulik> ;-)
14:52:28 <ulik> But please Octopus guys, do the reviews!
14:52:37 <ulik> #topic Review process
14:52:59 <vlaza1> if anyone has other docs that want them included in repos, give them for conversion or just add them yourselves
14:52:59 <ulik> #info fdegir has reminded people to follow process
14:53:11 <fdegir> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-April/002315.html
14:54:02 <vlaza> #info latest version of the guide for documentation
14:54:07 <vlaza> #link https://wiki.opnfv.org/documentation/tools
14:54:56 <ulik> Good.
14:55:18 <ulik> About review process: My apology for too fast merging ....
14:55:43 <ulik> Suggest we officially agree to adopt the process proposed by fdegir.
14:56:17 <fdegir> I've taken it from Frank's suggestion
14:56:24 <ulik> no objection, so I #agree that.
14:56:26 <fdegir> and we can always fine tune it
14:56:36 <fdegir> if it blocks stuff
14:56:42 <ulik> #agree to follow the review process as shared by email.
14:57:05 <ulik> need to put one more question before we can switch to BGS meeting.
14:57:23 <ulik> #info Can we have the next meeting also IRC-only?
14:57:44 <fdegir> +1
14:57:47 <radez> +1
14:58:05 <aricg> +1
14:58:11 <ulik> my own experience says, we still have to learn to be more effective in it (at least me). But I also like to +1
14:58:36 <ulik> #agree Next meeting also IRC only.
14:58:51 <ulik> #info Any other?
14:59:10 <ulik> Then like to close.
14:59:21 <ulik> #endmeeting