19:01:06 <ChrisPriceAB> #startmeeting Arno adjusted target release plan planning meeting :D
19:01:06 <collabot> Meeting started Wed Apr 22 19:01:06 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:06 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:01:06 <collabot> The meeting name has been set to 'arno_adjusted_target_release_plan_planning_meeting__d'
19:01:11 <ChrisPriceAB> #roll call
19:01:16 * ChrisPriceAB just for prosperity
19:01:21 <ChrisPriceAB> #Chris Price
19:01:26 <trevor_intel> #info Trevor Cooper
19:01:52 <trevor_intel> posterity or prosperity?
19:02:02 * ChrisPriceAB lol yeah it's late :D
19:02:20 <frankbrockners> #info Frank Brockners
19:02:21 <trevor_intel> I'm ok with prosperity!
19:02:22 <ChrisPriceAB> #info ulik could not attend the (european evening) meeting
19:02:39 <ChrisPriceAB> I would love it as well
19:02:48 * frankbrockners hmm ... I'm in Europe as well ...
19:02:49 <ChrisPriceAB> #info morgan_orange on vacation until tomorrow
19:03:03 * ChrisPriceAB Cry me an Arno so am I!!!!
19:03:04 * frankbrockners doing something wrong...
19:03:08 <ChrisPriceAB> lol
19:03:30 <ChrisPriceAB> #topic wiki updating readiness of information
19:03:47 * ChrisPriceAB lets move fast, just want to make sure we are all clear on what the plan is
19:04:12 <ChrisPriceAB> #link https://wiki.opnfv.org/releases/arno/releasereadiness Arno overall release raediness tracking wiki mpage.
19:04:38 <ChrisPriceAB> #info Is everyone happy with the level of detail of the items on the list at this time?
19:04:58 <trevor_intel> #info yes for me I think its what we need
19:05:05 <ChrisPriceAB> #info I may add some details to the docs items as I think a 3 day action is a little too long for the type of iterations we need here
19:05:25 <ChrisPriceAB> #info have a pending action to collate the infrmation available to perform first :D
19:06:04 <ChrisPriceAB> #info Ok great.  Another thing I would like to do is to begin to identify dependancies between tasks on the list.
19:06:17 <frankbrockners> #info on docs: Could we add an entry that asks for a list of *all* required docs across all projects?
19:06:41 <ChrisPriceAB> #info Yeah sure, feel free to plug it in there or action me
19:06:51 <ChrisPriceAB> This needs to be clear for everyone
19:07:23 <frankbrockners> #action ChrisPriceAB: Add an entry for docs that lists *all* required docs across all projects
19:07:39 <ChrisPriceAB> #info second thing i would like to see if Jira stories on each.  I noticed Fatih has already done that for octopus, I will do so on docs once I get a chance to sync with my team
19:07:41 <frankbrockners> on cross dependencies
19:08:07 <ChrisPriceAB> #info although I realize it may be a little tough to spin it up all over the place and still focus on the gting the job done, so I don't think it should be mandeted
19:08:11 <frankbrockners> could we consider just doing the major things for now?
19:08:15 <trevor_intel> #info Jira is missing for Pharos ... I have to do that
19:08:15 <ChrisPriceAB> #undo
19:08:15 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1d86050>
19:08:22 <ChrisPriceAB> #info although I realize it may be a little tough to spin it up all over the place and still focus on the gting the job done, so I don't think it should be mandated
19:08:43 <ChrisPriceAB> #info Donät let Jira gate you on getting stuff done...
19:08:55 * frankbrockners you undid the wrong item...
19:09:03 <ChrisPriceAB> #info just helps with tracking and knowing who has the ball on items
19:09:03 <trevor_intel> #info ... these are just the tasks, correct?
19:09:11 <ChrisPriceAB> lol so I did
19:09:30 <ChrisPriceAB> #info Jira is missing for Pharos ... I have to do that  (trevor_intel)
19:10:09 <ChrisPriceAB> Yes can be tasks to keep it simple.  Some are using stories in order to organise specifi tasks in an area, but that's Jira 102, not Jira 101
19:10:24 <frankbrockners> on x-dependencies: Should we just focus on the major tasks - and reference them by name as opposed to number all items and use the number?
19:10:24 <trevor_intel> Ok
19:10:34 <frankbrockners> I'd like to avoid renumbering...
19:10:53 <ChrisPriceAB> Yes we can do that.  Can we organise by theme?  I think each project needs to tackle that itself a little
19:11:10 <frankbrockners> theme is good for me
19:11:37 <ChrisPriceAB> I'm fine with it.  We can remove the numbering as I realised when I got started just what a bad idea it was
19:12:02 <ChrisPriceAB> #topic Setting the plan and timeline
19:12:15 <ChrisPriceAB> #info just to get our minds on this topic.  We also need to move into this phase.
19:12:51 <ChrisPriceAB> #info once we have a good idea of the tasks/dependancies etc.  I think we can finalize this bit on the meeting just before the TSC call tomorrow.
19:13:17 <ChrisPriceAB> #info I will start a section at the top of the WiKi where we can capture the planning part and let's try and keep our thoughts up there
19:13:29 <frankbrockners> #info estimated duration of the tasks is critical info to have
19:13:41 <frankbrockners> #info and I don't think we have this for functest by tomorrow
19:13:56 <ChrisPriceAB> #info yes.  Is also tough on the first iteration to get it right.  And we only have one iteration...
19:14:24 <ChrisPriceAB> #info you are right, I plan to get as much as we can in place by tomorrow.  Hopefully it does not present as the critical path...
19:14:35 <ChrisPriceAB> #info functest that is
19:14:48 <frankbrockners> at a high level it would be: today + (BGS to install to 3rd-party lab) + (BGS automation) + (FuncTest automation)
19:15:09 <frankbrockners> which assumes that (Functest manual) < (BGS to install to 3rd-party lab) + (BGS automation)
19:15:14 <ChrisPriceAB> That's the general gist.  Easy at 10000 ft
19:15:29 <frankbrockners> so in summary max ((Functest manual), (BGS to install to 3rd-party lab)) + (BGS automation)
19:16:02 <frankbrockners> + slack for docs readiness, packaging etc.
19:16:06 <ChrisPriceAB> Yeah, but I still see a risk functest might present as the critical path....  then we need ppl to help
19:16:26 <ChrisPriceAB> #info anything else to capture on the planning piece at this time?
19:16:33 <frankbrockners> ack - which the above says max()... so Functest might win
19:16:44 <trevor_intel> I think its a big risk
19:16:49 <frankbrockners> and there is the x-dependency: unless functest works we don't know whether bgs works
19:16:58 <frankbrockners> so post functest works bgs might have additional work to do
19:17:14 <ChrisPriceAB> hehe yeah there's the catch.
19:17:28 <frankbrockners> so refined:
19:17:40 <ChrisPriceAB> #topic any other items?
19:17:52 <ChrisPriceAB> #info anything else we should capture in the meeting?
19:18:00 <frankbrockners> max ((Functest manual), (BGS to install to 3rd-party lab)) + (BGS automation) + (BGS fixes for all tests) + (Docs + Packaging)
19:18:26 <ChrisPriceAB> Oh cool, I just put an integer into each and I get the answer :D
19:18:28 <frankbrockners> #info rough estimate (once we have data): time needed =  max ((Functest manual), (BGS to install to 3rd-party lab)) + (BGS automation) + (BGS fixes for all tests) + (Docs + Packaging)
19:18:48 * ChrisPriceAB x to the power of (foo,bar)
19:19:10 <frankbrockners> ack - but even with small integers things add up...
19:19:20 <ChrisPriceAB> it's getting late for me this week.
19:19:25 <ChrisPriceAB> what day is it?
19:19:31 <trevor_intel> Friday
19:19:40 * frankbrockners no idea any more
19:20:08 <frankbrockners> you want another check in tomorrow morning?
19:20:09 <ChrisPriceAB> #info Ok, so I will try to iterate on the docs items.  Add a planning section at the top of the page.  First realignment early Europe time, second realignment early US time.
19:20:24 <ChrisPriceAB> Yes at least to get Morgan onboard
19:20:32 * frankbrockners fingers crossed
19:20:58 <ChrisPriceAB> :) finally got an sms conversation with him today.  He's back tomorrow.  But he will land in a huge backlog
19:21:37 <frankbrockners> ok - r we done?
19:21:38 <ChrisPriceAB> ok thankls guys.  Unless we have something to follow with I'm happy to close
19:21:47 <ChrisPriceAB> trevor_intel anything?
19:21:53 <trevor_intel> ok for now
19:21:57 <frankbrockners> same here
19:21:58 <ChrisPriceAB> #endmeeting