07:01:49 <ChrisPriceAB> #startmeeting Second Arno adjusted target release plan planning meeting :D
07:01:49 <collabot> Meeting started Thu Apr 23 07:01:49 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:01:49 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:01:49 <collabot> The meeting name has been set to 'second_arno_adjusted_target_release_plan_planning_meeting__d'
07:01:55 <ChrisPriceAB> #topic roll call
07:02:03 <ChrisPriceAB> #info Chris Price
07:02:06 <ulik> #info Uli
07:04:07 <ChrisPriceAB> #topic Release readiness update
07:04:25 <ChrisPriceAB> #link https://wiki.opnfv.org/releases/arno/releasereadiness release readiness task list
07:04:49 <ChrisPriceAB> #info we discussed last night beginning to put dependancies in this task list, I also had an action to update the opnfvdocs pieces.
07:05:03 <ChrisPriceAB> #info these did not start last night after the meeting, we can do so today.
07:05:36 <ChrisPriceAB> #info we agreed to use "themes" as a way or organising activities into dependancies, rather than trying ot use the numbered list.
07:05:54 <frankbrockners> #info Frank Brockners
07:06:12 <ulik> Can you explain "themes"
07:06:14 <ChrisPriceAB> #info we also agreed to provide some project planning on the wiki and develop that during today.
07:06:29 <frankbrockners> #info Themes  = high-level categories/groups
07:06:39 <frankbrockners> #info have a look at the wiki
07:06:49 <ulik> OK
07:07:03 <ChrisPriceAB> #info The themes we to be idetifyable activities that might contain sub-tasks that are easily refferable as depenadancies on the other items  (like a story)
07:07:08 <frankbrockners> #info first column is the category - things that naturally belong together
07:07:35 <frankbrockners> yup - epic -> userstory is a good analogy
07:07:40 <ChrisPriceAB> #info a theme is like SYS.READY which requires all system readiness activities to be complete prior to the theme itself being ready
07:08:21 <ulik> ok. Just feared there is some software called "themes" ..... :D
07:08:27 <ChrisPriceAB> hehe
07:08:48 <ChrisPriceAB> #info we additional articulated the task dependancy that forms the process required to achieve Arno completion
07:08:51 <ChrisPriceAB> #info Time to release readiness: max{TEST.READY, SYS.READY} + max{SYS.AUTOMATED,TEST.EXEC} + SYS.RELEASE + DOCS.READY
07:09:26 <ChrisPriceAB> #info this provides us with a way of combining tasks and pending time into an equation that gives an indicative release date
07:09:32 <ulik> + 1-2 days risk buffer
07:09:36 * ChrisPriceAB very engineering, thanks frank
07:10:10 <ChrisPriceAB> well the buffer is in the final, or is it in the people estimating time for a task buffer+buffet and an added buffer = a long time in my experience
07:10:42 <ChrisPriceAB> #info we still have not begun to work with functest, morgan is back in the office today.
07:11:13 * ulik Poor guy
07:11:33 <frankbrockners> #info and there are themes/categories which have an "unknown" time for now - true for SYS.RELEASE, SYS.READY and TEST.READY
07:11:38 <ChrisPriceAB> #info in parallel jose_lausuch will work on Tempest automation, pbandzi will work on robot automation, the app deploy teams are working in parallel.
07:11:50 <ChrisPriceAB> #info no timelines have been developed for these activities yet.
07:12:45 <ChrisPriceAB> #action all project leads to ensure we have time estimates for remaining tasks and that the dependancies are defined on other tasks
07:13:11 <ChrisPriceAB> #info this will provide a method of estimating parallelism and the critical path for the remaining project activities
07:13:52 <ChrisPriceAB> questions?
07:14:28 <ChrisPriceAB> #info we need to work in parallel on the WiKi during the day and will agree between the project leads on the final pre-TSC meeting today on the proposed plan
07:14:40 <ulik> Can we give each task a number (or a 3-5 char name) just to use it in the dependencies
07:14:58 <ChrisPriceAB> we should use the "theme" names.  numbers move around too much
07:15:09 <ChrisPriceAB> the list will probably shuffle during the say
07:15:11 <ChrisPriceAB> day
07:15:25 <ulik> I meant fix numbers.....
07:15:41 <ulik> We might need dependencies inside a theme
07:16:01 <ulik> Or is that too fine granular?
07:16:09 <frankbrockners> on the TSC call later today: do we feel like we're able to present a rough estimate for the additional time required?
07:16:18 <ChrisPriceAB> Yeah, for theme internal dependencies I'm ok for that to handled in such a way.  I hope there are not internal theme dependancies that we need to expose.
07:16:24 <ulik> We have to give a date.
07:16:32 <ChrisPriceAB> 'But tbh, I expect the project leads have that under control.
07:16:46 <frankbrockners> ulik - IMHO we don't need those dependencies within a team - it is clear for those working on the tasks and for others it does not matter
07:17:04 <ChrisPriceAB> frankckbrockners, that is what we have to work toward today.
07:17:32 <frankbrockners> ulik: BGS can't give a date until we have technical certainty on SYS.RELEASE and we know what TEST.READY is
07:17:38 <ChrisPriceAB> I doubt we will be scientifically accurate.  But we need to be confident enough that we can tackle thing in a given timeframe.
07:17:41 <frankbrockners> i.e. we don't even know what will be tested
07:18:16 <ChrisPriceAB> yes we have cyclic dependancies, test depends on bgs depends on test which both depend on specific ci activities...
07:18:32 <ChrisPriceAB> we need to manage those and focus on task completion tracking in the project plan.
07:19:17 <ChrisPriceAB> hopefully Jose get's things on track today for functest.  We gave him a set up lab and said get test running :D
07:19:35 <ChrisPriceAB> this should begin to feed-back probable times to competion.
07:19:46 <ChrisPriceAB> hopefully in time for the meeting today :D
07:20:06 <ChrisPriceAB> Ok...
07:20:25 <ulik> So you want every PL to fill column 7 in each line with his project in col.5 ?
07:20:31 <ChrisPriceAB> #topic activities to be completed prior to Final pre-TSC Arno planning meeting.
07:20:53 <ulik> And just put there something like SYS:DOCS as dependency.
07:21:05 <ChrisPriceAB> #info fill in column 7 (dependancies) where needed to be drawn out
07:21:27 <ChrisPriceAB> #info fill in column 6 (time to completion) with estimates on task completion timelines
07:21:50 <ChrisPriceAB> #info only add dependancies were there cannot be parallelism (that includes resources)
07:22:39 <ChrisPriceAB> #info for tasks "almost complete" where we will be troubleshooting when a dependant task tries to use it, it may be better to dfactor that cost in to the dependant task.  opinions?
07:23:28 <ChrisPriceAB> #action functest team to complete the project with best known estimates
07:23:45 <ChrisPriceAB> #action opnfvdocs team to compete actions outlined in the previous meeting
07:24:39 <ChrisPriceAB> #action PL's to work on the project plan text on the wiki.  We can add a description of our tasks in simple language there which we can edit after lunch today into a singular Arno text
07:24:58 <ChrisPriceAB> the plan shuld be described in text under franks equation.
07:25:06 <ChrisPriceAB> we all good?  anything else?
07:25:27 <ChrisPriceAB> I'll follow up with trevor once he is up and morgan once I can get hold of him
07:26:26 <ChrisPriceAB> ulik, frankckbrockners:  shall we close?
07:26:36 <ulik> ok
07:26:40 <frankbrockners> ChrisPriceAB: we can close... but
07:26:50 <ChrisPriceAB> thanks guys, onward and upward
07:26:52 <ChrisPriceAB> #endmeeting