#opnfv-meeting: BGS weekly meeting

Meeting started by frankbrockners at 15:00:28 UTC (full logs).

Meeting summary

    1. morgan_orange (morgan_orange, 15:01:05)
    2. Malla (Malla, 15:01:16)
    3. Frank Brockners (frankbrockners, 15:01:20)
    4. David Karr (davidmichaelkarr, 15:01:22)
    5. Jun Li (MatthewL2, 15:01:33)
    6. Fatih Degirmenci (fdegir, 15:01:38)
    7. chigang(Justin) (chigang, 15:02:02)
    8. Tim Rozet (trozet, 15:02:04)
    9. Heather Kirksey (HKirksey, 15:02:20)
    10. Peter Bandzi (pbandzi, 15:02:34)
    11. rprakash (rprakash, 15:02:34)
    12. uli (ulik, 15:02:40)

  1. agenda bashing (frankbrockners, 15:04:14)
    1. https://wiki.opnfv.org/meetings/bgs?&#april272015 - draft agenda (frankbrockners, 15:04:25)

  2. Functest status update (incl. tests planned for Arno, testing requirements) (frankbrockners, 15:05:37)
    1. dneary (dneary, 15:05:44)
    2. 5 functests on Arno (morgan_orange, 15:06:33)
    3. Bench from rally, Tempest from Rally, ODL suite using Robot Framework, vPing, vIMS (morgan_orange, 15:06:52)
    4. manual and automated tests OK, we have to clean the tests (to keep only successful tests) (morgan_orange, 15:08:01)
    5. tested on Ericsson POD and Orange POD => to be tested on LF POD when available (morgan_orange, 15:08:09)
    6. ODL pbandzi working on it on Intel POD 2 (morgan_orange, 15:08:27)
    7. Jonas Bjurel ([2]JonasB, 15:08:51)
    8. vPing successfully manually tested on Orange POD, adaptation in progress by Malla, shall be committed tomorrow and documented (morgan_orange, 15:09:00)
    9. for vIMS, team had trouble accessing the POD, no feedback since last week (morgan_orange, 15:09:29)
    10. documentation initiated (to be completed) (morgan_orange, 15:09:49)
    11. Where can one find details on which tests will be run by Rally, Tempest, Robot? (frankbrockners, 15:10:15)
    12. Daniel Smith (lmcdasm, 15:10:47)
    13. rally scenario are here https://git.opnfv.org/cgit/functest/tree/testcases/VIM/OpenStack/CI/suites (butneed to be clean a little bit) (morgan_orange, 15:11:38)
    14. Trevor Cooper (trevor_intel, 15:11:44)
    15. ODL: https://git.opnfv.org/cgit/functest/tree/testcases/Controllers/ODL/CI/test_list.txt (morgan_orange, 15:12:01)
    16. Rally tempest so far still more than 70 errors on smoke tests (on E/// and Orange PoD) under investigation (morgan_orange, 15:12:49)
    17. What are the FuncTest plans from a user perspective for R1? Are we running FuncTest just as part of the CI toolchain on LF HW - or are we making Functest available to users directly (to do smoke testing of their installations)? (frankbrockners, 15:14:04)
    18. my view is both. It must be integrated in the CI (on LF) but also on other POD (interesting to get bench figures) and we should write a "user" guide to allow people having installed their OPNFV solution to perform the same tests on their solution (morgan_orange, 15:15:05)
    19. functest documentation describes (or shall describe) the testcases, the tools needed (robot and rally) and the procedure to perform the tests (morgan_orange, 15:15:54)
    20. does documentation also cover how the tools will be installed (for user-driven testing)? (frankbrockners, 15:16:23)
    21. yes => needed because there is some customization to be planned depending on the installation (login password of Openstack to source the rc file for instance) (morgan_orange, 15:17:11)

  3. LF hardware config: changes / finalization (frankbrockners, 15:18:26)
    1. we plan to work with erricson to configure POD1 (pbandzi, 15:19:25)
    2. plan to set vlan 411 as deafult for public network which I hope will get rid of unneded VLAN0 tag (pbandzi, 15:20:07)
    3. need to agfee on maintanence windoiw with both teams Fuel and Foreman (pbandzi, 15:20:45)
    4. can be done also after this meeting from my side (pbandzi, 15:21:50)
    5. for me it's ok as well (pbandzi, 15:24:07)
    6. AGREED: maintenance window to perform config changes to LF HW: 9am CET (==12am PDT - midnight) to 10am CET (1am PDT) on Apr/28 (frankbrockners, 15:27:07)

  4. BGS status and workplan review (frankbrockners, 15:27:53)
    1. Was able to deploy a single node on Friday. I think the network setup is good now in UCS (trozet, 15:29:03)
    2. needed a patch for our deploy to work with current LF environment where Admin network has no internet access and need to NAT to public (trozet, 15:29:24)
    3. have a patch for that issue and going to try it out here shortly. (trozet, 15:29:36)
    4. No new status since last Fri ([1]JonasB, 15:30:13)
    5. ACTION: trozet: Update https://wiki.opnfv.org/releases/arno/releasereadiness to reflect most recent status (frankbrockners, 15:33:29)
    6. ACTION: pbandzi: Update https://wiki.opnfv.org/releases/arno/releasereadiness to reflect most recent status (frankbrockners, 15:33:40)
    7. ACTION: [1]JonasB: Update https://wiki.opnfv.org/releases/arno/releasereadiness to reflect most recent status (frankbrockners, 15:33:51)
    8. Any additional urgent issues that require attention? (frankbrockners, 15:34:13)
    9. No additional urgent issues mentioned... (frankbrockners, 15:35:16)


Meeting ended at 15:36:35 UTC (full logs).

Action items

  1. trozet: Update https://wiki.opnfv.org/releases/arno/releasereadiness to reflect most recent status
  2. pbandzi: Update https://wiki.opnfv.org/releases/arno/releasereadiness to reflect most recent status
  3. [1]JonasB: Update https://wiki.opnfv.org/releases/arno/releasereadiness to reflect most recent status


Action items, by person

  1. pbandzi
    1. pbandzi: Update https://wiki.opnfv.org/releases/arno/releasereadiness to reflect most recent status
  2. trozet
    1. trozet: Update https://wiki.opnfv.org/releases/arno/releasereadiness to reflect most recent status


People present (lines said)

  1. frankbrockners (55)
  2. morgan_orange (19)
  3. pbandzi (11)
  4. trozet (11)
  5. [1]JonasB (6)
  6. collabot (3)
  7. lmcdasm (3)
  8. rprakash (2)
  9. ulik (2)
  10. trevor_intel (1)
  11. dneary (1)
  12. Malla (1)
  13. fdegir (1)
  14. davidmichaelkarr (1)
  15. chigang (1)
  16. MatthewL2 (1)
  17. [2]JonasB (1)
  18. HKirksey (1)


Generated by MeetBot 0.1.4.