13:59:10 <frankbrockners> #startmeeting OPNFV TSC meeting
13:59:10 <collabot> Meeting started Tue Apr 28 13:59:10 2015 UTC.  The chair is frankbrockners. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:10 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:10 <collabot> The meeting name has been set to 'opnfv_tsc_meeting'
13:59:25 <ulik> #info Uli Kleber
13:59:41 <GeraldK> #info Gerald Kunzmann (DOCOMO)
14:00:47 <frankbrockners> #chair ulik
14:00:47 <collabot> Current chairs: frankbrockners ulik
14:00:56 <dneary> #info Dave Neary (proxy for Chris Wright)
14:01:19 <frankbrockners> #chair dneary
14:01:19 <collabot> Current chairs: dneary frankbrockners ulik
14:01:28 <dneary> :-)
14:01:58 <dneary> Once on conf call speaker phone, once to see screen on phone
14:02:25 <[1]JonasB> #info Jonas Bjurel
14:02:48 <julien_ZTE> #info Julien
14:02:59 <dku> #info Dirk Kutscher
14:03:01 <Wenjing> #info Wenjing Chu
14:03:09 <frankbrockners> #chair [1]JonasB
14:03:09 <collabot> Current chairs: [1]JonasB dneary frankbrockners ulik
14:03:13 <morgan_orange> #info morgan
14:03:18 <dku> Hi, is the audio bridge operational? (I am not hearing anything...)
14:03:32 <aricg> Working here
14:03:32 <ulik> there is. usual one.
14:03:35 <frankbrockners> dku: yes it is
14:03:42 <dku> ok, thanks --
14:03:52 <ulik> #link https://global.gotomeeting.com/join/798898261
14:04:41 <GeraldK> can we pls wait 2 more minutes. Doctor? NFV REL call is still ongoing.
14:04:48 <frankbrockners> #chair rpaik
14:04:48 <collabot> Current chairs: [1]JonasB dneary frankbrockners rpaik ulik
14:04:53 <GeraldK> can we pls wait 2 more minutes? Doctor - NFV REL call is still ongoing.
14:05:49 <frankbrockners> #info agenda for today: https://wiki.opnfv.org/wiki/tsc#april_28_2015
14:07:01 <frankbrockners> #topic approval of previous minutes
14:07:11 * ulik tapio, can you (and others) #info please
14:07:14 <tallgren> #info Tapio Tallgren
14:07:32 <frankbrockners> #info previous minutes approved
14:07:39 <frankbrockners> #topic agenda bashing
14:07:42 <trevor_intel1> #info Trevor Cooper
14:09:04 <bryan_att> #info Bryan Sullivan
14:11:11 <frankbrockners> #info agenda agreed
14:11:29 <frankbrockners> #topic Arno Project plans & tracking
14:11:57 <ManuelR_Sandvine> #info Manuel Rebellon
14:12:03 <dneary> ulik, Which requirements projects?
14:12:29 <LouisF> where are these docs?
14:12:40 <GeraldK> Doctor and Promise
14:12:44 <GeraldK> both are in Gerrit
14:12:53 <ulik> #info I would like to put somethign on the backlog: We should talk about how to deal with the requirement documents that were shared for review already.
14:13:23 <rprakash> #info Ui tpo discussion on requirement for requirment documents beyond Arno
14:13:26 <GeraldK> #info requirement docs for Doctor and Promise; both are available in Gerrit
14:14:14 <ulik> #action Uli to prepare the discussion on requirement projects document approval and further proceeding in the next TSC meeting
14:14:29 <ulik> #info Gerald will help
14:14:58 <rpaik> #info Gerald asks if links to Doctor & Promise documents can be included in Arno documentations
14:15:21 <frankbrockners> #link https://wiki.opnfv.org/releases/arno/releasereadiness
14:15:57 <rpaik> #topic Arno project plans & tracking
14:16:01 <rprakash> #info How do we make requirement documents of projects and proposal for release of it and its dependency
14:17:10 <frankbrockners> #info Pharos update: waiting for finalization/documentation of LF HW POD deployments
14:17:39 <frankbrockners> #info Pharos requires another "couple of days" to complete the overall work for Arno
14:18:08 <dneary> I have to leave after 90 mins
14:18:16 <dneary> (so, in 1h10)
14:18:16 <dku> #info Dirk Kutscher
14:18:31 <rprakash> #info There is still deployment in devlopment lbas, migration to LF is continuing
14:19:19 <Parviz> #info Parviz
14:19:22 <rprakash> #info Getting things operational on LF is pending but both teams have a made a good progress  like IPMI filtered on Firewall etc
14:19:27 <cdub> #info Dave Neary is proxy for me (Chris Wright) today
14:20:47 <frankbrockners> #info BGS: Work still progressing to get things deployed on LF lab (progress made - but still work to be done).
14:20:49 <rprakash> #info At the same point awaiting Automation on LF, but good progress on Octopus documentation
14:21:19 <frankbrockners> #info Octopus: Docs progressing. Automatic build working. Automatic deploy pending BGS work
14:22:02 <frankbrockners> #info Functest: Manual installs of tools (Rally, Robot) available.
14:22:46 <frankbrockners> #info Functest: vIMS still pending (working in Metaswitch lab only). Requires features (e.g. Heat) originally not planned for Arno - but considered as a stretch addition.
14:22:58 <frankbrockners> #info Functest: Documentation progressing.
14:23:13 <rprakash> #info func_test working on scripts and some use cases and good work on meta switch lab , manual test on Ericsson lab, ODL being in pipeline today, before end of week will have better results
14:25:28 <rprakash> #info is it possible to use func_test in BGS for Smoke test? Ericcson is close and on Intel depends on resource available after LF , excluding IMS may be a week
14:26:46 <rprakash> #info BSG stack on Ericsson works and able to run Sanity checks, about 70 error from 300 in Fuel, some anaysis to be done to clear the tets and missing modules, may take few more days
14:27:59 <frankbrockners> #info Functest: Rough estimate: "couple of days to have smoke testing available" - "vIMS - unsure about required time to complete work".
14:28:40 <rprakash> #info Docs Iban - lot for progress, document guidelines, more comfortable with MS word, can use RST formats to be able to deploy to iso, pdf ad wiki formats
14:28:56 <frankbrockners> #info Docs: Team is there to help with converting proprietary file formats (like MSFT) to .rst
14:29:12 <rpaik> #info Iben reports that documentation pipeline coming along.  If people are more comfrtable with MS Word, that can be converted to .rst
14:29:29 <rprakash> #info 4 projects using this docs formats in ci
14:31:32 <rprakash> #info staus and state of items per projct  readme, lincense etc listed , some may require Architecture Guide, Installation Guide etc. is Customer consumable
14:31:47 <rpaik> #action Iben to provide an invventory of what is required for documentation
14:31:56 <rpaik> Iben is this it? https://wiki.opnfv.org/documentation_projects/opnfv_documentation?&#scope
14:32:08 <rprakash> #info across the project with contents may help as per Iben
14:33:21 <rprakash> #info for outgoing documents etc logo etc may be good and so some cleanup required
14:34:41 <rprakash> #info checklist of documents is defined as basic minimum and each project can add as and when there is seen addition al requirements
14:36:20 <rprakash> #info some templates are lsited in documents projects and feed back sought in Gitrepo
14:37:05 <rpaik> #link https://wiki.opnfv.org/documents MS Word template
14:37:20 <rprakash> #info please review +1 or -1 as one uses it
14:38:41 <[1]JonasB> #link https://gerrit.opnfv.org/gerrit/#/c/356/
14:40:46 <rpaik> #info suggestion is to setup a meeting between Arno project leads and the documentation team so that documentation questions can be addressed
14:41:18 <frankbrockners> #action Iben to create a "documentation happy hour" where people can meet on IRC and get their docs questions answered
14:42:11 <julien_ZTE> #info can we devide code review and documentation review in to diffrent links or can we use some filter?
14:44:56 <bryan_att> Are all the currently available docs/remplates in https://git.opnfv.org/cgit/opnfvdocs/ ?
14:45:10 <ulik> #info we need Arno users to check the documents whether they provide the necessary information
14:45:52 <julien_ZTE> #info agree with Uli
14:46:31 <fdegir> bryan_att: no, they won't be visible on cgit until they get merged
14:46:42 <bryan_att> iben, can you put a link in IRC which points to where the current docs/templates are for review? And where should we create new docs/templates that seem to be missing?
14:46:47 <dneary> Still feels uncertain to me
14:47:12 <fdegir> here is a link to all open/merged documents on opnfvdocs: https://gerrit.opnfv.org/gerrit/#/q/project:opnfvdocs
14:47:12 <[1]JonasB> Agree
14:47:26 <frankbrockners> #info Target release date: Stil kept at 2nd half of May.
14:47:29 <frankbrockners> #undo
14:47:29 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1e14210>
14:47:38 <frankbrockners> #info Target release date: Still kept at 2nd half of May.
14:47:43 <rpaik> #info We are further along in terms of release readiness, but not able to narrow down the Arno release target date
14:48:30 <frankbrockners> #topic Ratify updates to Section 7 of TSC Charter - https://www.opnfv.org/developers/technical-project-governance/tsc-charter
14:48:47 <dneary> Can we time-box this topic to 10 mins max?
14:48:55 <ulik> +1
14:49:02 <dneary> If it takes any more then it should be punted back to the list
14:49:05 * frankbrockners we'll try hard
14:49:28 <dneary> At the top of the hour I will move that we defer or approve.
14:49:29 <bryan_att> fdegir, on the last topic can anyone add comments or +1 etc to the docs in gerrit or only the opnfvdocs committers?
14:49:46 <fdegir> everyone can do reviews and give +1/-1
14:50:05 <fdegir> only committers can give +2/-2 and merge
14:50:51 <bryan_att> what's the difference between +1 and +2 (is 2 "I feel stronger"?)
14:51:03 <fdegir> +2 means the change can be merged to master
14:51:14 <fdegir> +1 means it is just good and someone else must approve and give +2
14:51:21 <ulik> and merge can happen only if there has been a +2
14:52:57 <dneary> bryan_att, A +2 is "this can be committed now"
14:52:57 <fdegir> merge to happen, +2 and jenkins verified, +2 is not enough if jenkins -1d the change
14:52:59 <bryan_att> works for me either way - simple or not
14:53:06 <dneary> Therefore, only committers can +2
14:55:04 <rpaik> #agree For internal project decisions where no consensus can be reached, a majority vote among all Committers of the project via +1 voting should be used.
14:55:04 <rpaik> A simple majority voting should be used for decisions within the TSC at which a quorum is present, unless otherwise required.
14:55:11 <frankbrockners> #agree Updated verbiage as presented by Ray was agreed.
14:55:17 <dneary> 5 minutes early!
14:55:42 <frankbrockners> #topic OPNFV Day at OpenStack Summit
14:55:48 <rprakash> #info voting process agreed
14:56:04 <dneary> #undo
14:56:04 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1dfe110>
14:56:05 <dneary> #undo
14:56:05 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1dfe7d0>
14:56:10 <dneary> #info voting process agreed
14:56:18 <dneary> #topic OPNFV Day at OpenStack Summit
14:56:28 <dneary> (just getting things in order
14:57:56 <ulik> #link https://etherpad.opnfv.org/p/Vancouver_OpenStack for preparation of Vancouver OpenStack summit
14:59:09 <rprakash> #info Looking through BP submitted , no design summit sessions are there for BP , so make few sessions of VNFFG , IPv6, Doctor, Multi-site for hashing out opnfv use cases
15:00:45 <rprakash> #info should the breakout sessions simultaneous or go one after another or divide 270 preople room in to partition or request facility to split
15:01:18 <rprakash> #info so post lunch can be split in 2 or 4 sessions tec
15:02:08 <rprakash> #info have agenda and then plan out 2 is better than 4
15:03:14 <rprakash> #info 3 slots 2 in paralle with say 20-40  min each etc
15:04:55 <rprakash> #info add to etherpad sessions and requirements for projects etc and with telcowg etc. 3 weeks from now so time is premium
15:05:30 <rpaik> #action dneary/rpaik/hkirksey to schedule an IRC session to discuss OpenStack Summit agenda
15:06:51 <rprakash> #info nfv global world no specific ther than opnfv day session details
15:07:06 <frankbrockners> #topic Project Proposal & Creation Review Checklist
15:07:22 <frankbrockners> #link https://wiki.opnfv.org/developers/project_proposal_creation_review_checklist
15:12:29 <dneary> FYI for NFV World Congress: http://www.layer123.com/nfv-agenda-workshop/
15:12:38 <dneary> bryan_att, http://www.layer123.com/nfv-agenda-workshop/
15:13:50 <rprakash> #info Bin Hui mentiones difference between maturity verses two weeks as mimimum and depending on project review and mailing list , prefer agree to maturity level
15:16:57 <rprakash> #info Frank would like updtae the page with this suggessions made earlier and get this suggested by Bin and finally voted to get into the new process
15:18:02 <rpaik> #action ChrisPriceAB bring this topic back to next week’s TSC call to come to a consensus
15:18:06 <frankbrockners> #topic Project Approvals
15:18:35 <frankbrockners> #info Yardstick - https://wiki.opnfv.org/project_proposals/yardstick
15:19:50 <frankbrockners> #info Yardstick:  test framework, including test cases and test stimuli, to verify the infrastructure compliance when running VNF applications
15:27:04 <julien_ZTE> #info anac, I'm interested in this project, please add me to the contributor list, 3x.
15:28:48 <dneary> Moving to IRC only for the rest of the meeting... I have to drop off
15:29:02 <iben_> #link to rally for #info on benchmarking https://wiki.openstack.org/wiki/Rally#Use_Cases
15:32:24 <ulik> frankbrockners: will we have time for more creation reviews if we need to discuss all these details here?
15:33:44 <frankbrockners> ulik: ack - we'll move to vote shortly - 15min each is typical - so let's allow for some discussion
15:38:23 <frankbrockners> #startvote TSC to vote to create the project yardstick? (+1, 0, -1)
15:38:23 <collabot> Begin voting on: TSC to vote to create the project yardstick? Valid vote options are , +1, 0, -1, .
15:38:23 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
15:38:39 <tallgren> #vote +1
15:38:39 <frankbrockners> #vote +1
15:38:41 <julien_ZTE> #vote +1
15:38:43 <[1]JonasB> #vote +1
15:38:43 <trevor_intel> #vote +1
15:38:44 <GeraldK> #vote +1
15:38:45 <ulik> #vote +1
15:38:51 <bryan_att> #vote +1
15:38:51 <Parviz> #vote +1
15:39:05 <ManuelR_Sandvine> +1
15:39:13 <trevor_intel> #info - trevor Cooper representing Rajeev Koodli
15:39:35 <[1]JonasB> #info Jonas Bjurel representing Chris Price
15:39:48 <GeraldK> #info GeraldK representing Ashiq Khan
15:40:08 <frankbrockners> #endvote
15:40:08 <collabot> Voted on "TSC to vote to create the project yardstick?" Results are
15:40:08 <collabot> +1 (8): frankbrockners, trevor_intel, bryan_att, GeraldK, tallgren, [1]JonasB, julien_ZTE, Parviz
15:40:34 <dneary> I missed it
15:40:39 <dneary> #vote +1
15:40:51 <dneary> Too late?
15:40:56 <trevor_intel> #info Trevor Cooper
15:41:20 <frankbrockners> #info late +1 vote from Dave Neary
15:41:42 <frankbrockners> #info Project yardstick got approved by TSC majority vote over IRC
15:42:21 <frankbrockners> #info OPNFV Service Function Chaining project approval review
15:42:25 <frankbrockners> #link https://wiki.opnfv.org/network_function_chaining
15:44:47 <frankbrockners> #info no representative of OPNFV Service Function Chaining was on the TSC call to present the project. Project will be up for review at the next TSC meeting.
15:45:14 <rpaik> #link https://wiki.opnfv.org/onosfw
15:45:36 <frankbrockners> #info ONOS framework project review
15:45:45 <frankbrockners> #link https://wiki.opnfv.org/onosfw
15:52:41 <dneary> Call finished early - joining back
15:59:52 <LouisF> what is link to opentack bp for ONOS ML2 driver?
16:02:27 <rpaik> #info to re-visit the project review next week
16:02:52 <frankbrockners> Ray - can we close?
16:02:58 <ulik> #info re-visit first on agenda.
16:03:01 <rpaik> #stopmeeting
16:03:06 <frankbrockners> #endmeeting