15:00:33 <frankbrockners> #startmeeting OPNFV BGS weekly meeting
15:00:33 <collabot> Meeting started Mon May 11 15:00:33 2015 UTC.  The chair is frankbrockners. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:33 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:33 <collabot> The meeting name has been set to 'opnfv_bgs_weekly_meeting'
15:00:48 <[1]JonasB> info Jonas Bjurel'
15:00:51 <ChrisPriceAB> #info Chris Price
15:00:55 <pbandzi> #info Peter Bandzi
15:00:56 <morgan_orange> #info Morgan Richomme
15:00:57 <fdegir> #info Fatih Degirmenci
15:01:01 <jose_lausuch> #info Jose Lausuch
15:01:05 <frankbrockners> #link https://wiki.opnfv.org/meetings/bgs#may112015 - draft agenda
15:01:08 <[1]JonasB> #info Jonas Bjurel
15:01:10 <frankbrockners> #info Frank Brockners
15:01:11 <lmcdasm> #info daniel smith
15:01:16 <arnaud_orange> #info Arnaud Morin
15:01:22 <MatthewL1> #INFO Jun Li
15:01:48 * ChrisPriceAB just because I may need to run away shortly I want to drop a docs link for docs draft reviewing.
15:01:57 <ChrisPriceAB> drafts of release relevant documentation can be found here:  https://wiki.opnfv.org/documentation/arno
15:02:19 <dneary> #info dneary
15:02:23 * frankbrockners thanks Chris
15:02:37 <rprakash> #info rprakash
15:03:22 <frankbrockners> ok - let's get slowly rolling... draft agenda: https://wiki.opnfv.org/meetings/bgs#may112015
15:03:32 <frankbrockners> #topic agenda bashing
15:03:45 <frankbrockners> #link draft agenda: https://wiki.opnfv.org/meetings/bgs#may112015
15:03:52 <frankbrockners> anything else we should add to the agenda?
15:04:24 <frankbrockners> does not sound like this is the case
15:05:06 <frankbrockners> so with the Ostack summit coming up next week, just wanted to see who'd be around - and eventually plan for a get together of the BGS team
15:05:19 <narindergupta> #info narindergupta
15:05:19 <lmcdasm> i will be there
15:05:24 <ChrisPriceAB> You mean a f2f at the event?
15:05:32 <ChrisPriceAB> With IRC I hope :)
15:05:36 <frankbrockners> Question: Who'll be in Vancouver? Yes F2F
15:05:42 <arnaud_orange> I'll be
15:05:44 <frankbrockners> We'll do IRC as usual
15:05:50 <lmcdasm> i will be in Van yes
15:06:27 <radez> I'll be there
15:06:31 <fdegir> me as well
15:06:36 <rprakash> I will be there
15:06:45 <ChrisPriceAB> is it worth setting up a bof?
15:06:50 <trozet> #info Tim Rozet
15:06:59 <HKirksey> #info Heather Kirksey
15:07:20 <radez> #info Dan Radez
15:07:28 * dneary wil be in Vancouver
15:07:31 <ulik> I'll be there
15:07:33 <rprakash> chris yes bof will be a good idea
15:07:36 <ulik> #info Uli
15:07:45 <lmcdasm> sorry BOF?
15:07:49 <frankbrockners> info: BGS folks at Ostack Summit in Vancouver include. Daniel Smith, Arnaud, Daniel Radez, Fatih, Prakash
15:07:59 * ChrisPriceAB birds of a feather - meeting
15:08:01 <frankbrockners> #info BGS folks at Ostack Summit in Vancouver include. Daniel Smith, Arnaud, Daniel Radez, Fatih, Prakash
15:08:05 <lmcdasm> <thx>
15:08:21 <frankbrockners> IMHO would be nice to do a gettogether / bar-bof :-)
15:08:28 * ChrisPriceAB flocking, squaking, pooping in concert ;)
15:08:35 <narindergupta> :)
15:08:43 <frankbrockners> I won't be there... - anyone interested in organizing something informal?
15:08:44 <HKirksey> Don’t forget we will be having an OPNFV reception Monday evening
15:08:45 <radez> frankbrockners: +1 on bar-bof
15:08:54 * ChrisPriceAB +1 on the bar....
15:08:58 <fdegir> can't we have just bar?
15:09:07 <HKirksey> There are some pretty big parties at OpenStack, just something to keep in mind….
15:09:26 * ChrisPriceAB sound like it's a go frank. updates.. updates... updates...
15:09:29 <bryan_att> #info Bryan Sullivan
15:09:38 <frankbrockners> anyone up for organizing something?
15:10:14 * ChrisPriceAB action me to do it, bar-bof would be thursday night
15:10:31 <frankbrockners> does not sound like this is the case... so sounds like Daniel Smith, Arnaud, Daniel Radez, Fatih, Prakash would need to find a bar by themselves :-)
15:10:59 <narindergupta> infortunately i won't be avilable
15:11:20 <frankbrockners> #action ChrisPriceAB to schedule a bar-bof for BGS folks in Vancouver next week (target: Thursday)
15:11:26 <trevor_intel> #info Trevor Cooper
15:11:33 <frankbrockners> ok - let's move to the next topic
15:11:39 <lmcdasm> sorry
15:11:44 <lmcdasm> before we move on
15:11:48 <lmcdasm> can we have a clear resolution ?
15:11:55 <lmcdasm> are we meeting or no?
15:11:59 <Gerald_K> #info Gerald Kunzmann (DOCOMO)
15:12:14 <ChrisPriceAB> lmcdasm: yes I have an action to set it up
15:12:17 <lmcdasm> thx
15:12:19 <lmcdasm> wasnt clear
15:12:19 <frankbrockners> lmcdasm: ChrisPriceAB will set something up
15:12:36 <frankbrockners> #topic Functest status update
15:12:40 <frankbrockners> Jose/Morgan?
15:12:45 <jose_lausuch> hi
15:13:08 <jose_lausuch> #info automation script of functest 99% finished
15:13:22 <jose_lausuch> #info it creates external and private neutron networks
15:13:23 <frankbrockners> what is the missing 1%?
15:13:33 <jose_lausuch> possible bug fixes :)
15:13:46 <jose_lausuch> tesnting on LF pod ongoing
15:13:57 <morgan_orange> #link https://build.opnfv.org/ci/view/functest/
15:14:08 <morgan_orange> #info 2 CI jobs created
15:14:24 <morgan_orange> #info wait for POD1 and POD 2 green light (re config this afternoon)
15:14:42 <morgan_orange> #link https://wiki.opnfv.org/opnfv_functional_testing?&#release_1
15:14:47 <morgan_orange> #info link updated
15:15:07 <morgan_orange> #info table to compare status of OPNFV fresh solution added
15:15:23 <morgan_orange> #info link to Tempest results also added (1 pad per POD)
15:15:30 <morgan_orange> #wait for POD to continu
15:15:35 <morgan_orange> #info vIMS testcase removed
15:15:50 <morgan_orange> #info doc to be udated today
15:16:11 <jose_lausuch> I'll update the automation part
15:16:16 <jose_lausuch> what more
15:16:45 <frankbrockners> morgan_orange: once POD1 and POD2 are fully deployed (hopefully later today), can we also start the earlier talked about table of which tests fail and why they fail?
15:17:05 <morgan_orange> yes
15:17:09 <morgan_orange> agree with your mail
15:17:23 <jose_lausuch> I suggest to have a kind of nice formatted table to do that
15:17:27 <frankbrockners> perfect - thanks
15:17:34 <jose_lausuch> etherpad is a bit messy, just plain text
15:17:38 <jose_lausuch> wiki?
15:17:59 <morgan_orange> first results on POD2 showed that the 30 errors corredponded to 4 or 5 errors (mainly linked to network)
15:18:09 <frankbrockners> #info functest team will supply a table on tests that fail - calling out the reasons for failure
15:18:36 <morgan_orange> we have already some proto on the wiki and the etherpad
15:18:38 <frankbrockners> and I have another ask - to prep for the TSC call tomorrow: Can you update https://wiki.opnfv.org/releases/arno/releasereadiness with the most recent info?
15:18:58 <trozet> frankbrockners: I'll update it today
15:19:11 <frankbrockners> thanks trozet.
15:19:25 <frankbrockners> morgan_orange: could you take care of the functest part of the table?
15:19:28 <morgan_orange> yes
15:19:31 <frankbrockners> many thanks
15:19:45 <frankbrockners> ok - anything else on functest?
15:19:47 <jose_lausuch> question
15:19:49 <morgan_orange> #link https://wiki.opnfv.org/list_of_tempest_smoke_tests
15:20:00 <jose_lausuch> since now we have an automation script
15:20:04 <morgan_orange> #link https://etherpad.opnfv.org/p/functest-lfpod2-testresults
15:20:06 <jose_lausuch> or "functest" installation script
15:20:11 <jose_lausuch> shall we include that in JIRA?
15:20:23 <jose_lausuch> I cannot link any TAG when I do commits
15:20:32 <jose_lausuch> I use 2 or 3 TAGs
15:20:41 <jose_lausuch> I think we should add a task in JIRA for automation
15:20:50 <frankbrockners> makes sense
15:20:56 <morgan_orange> Ok I will do
15:20:59 <jose_lausuch> thanks
15:21:27 <jose_lausuch> #info a new user story "functest installation" to be added to JIRA
15:21:41 <frankbrockners> perfect
15:21:49 <frankbrockners> r we done with functest updates?
15:21:54 <morgan_orange> last point pbandzi: what about automation of ODL in CI
15:21:54 <jose_lausuch> yep
15:22:07 <frankbrockners> ah - good point
15:22:16 <jose_lausuch> ah I have another thing
15:22:23 <jose_lausuch> but after you
15:22:41 <pbandzi> morgan_orange: scripts should be done, but last time I had time to test them on lf lab u had issue with some tests
15:22:59 <pbandzi> so I have to clean them up hopefully tomorrow
15:23:50 <jose_lausuch> ok, I shoot now then
15:23:52 <frankbrockners> #info ODL robot tests: tests done. pending test runs on LF hardware. target for completion: tomorrow.
15:23:58 <jose_lausuch> about VPing test
15:24:07 <jose_lausuch> I changed major part of the code
15:24:13 <morgan_orange> ok for ODL on Jenkins I just put the line $HOME/.functest/ODL/start_tests.sh assuming that installation of robot and config is managed by the functest config
15:24:57 <jose_lausuch> now, it does not output anything to the nova console, so what I did is that as soon as 1 VM success pining the other VM, it shuts down, and the vPing script detects that power donw and it concludes that the test worked. Is it ok?
15:25:01 <frankbrockners> #info ok for ODL on Jenkins I just put the line $HOME/.functest/ODL/start_tests.sh assuming that installation of robot and config is managed by the functest config (per morgan_orange)
15:26:04 <frankbrockners> jose_lausuch: Sounds a bit odd to me. But could we discuss this at the end of the meeting - once we're done with all the updates?
15:26:10 <jose_lausuch> yes
15:26:16 <frankbrockners> thanks
15:26:30 <frankbrockners> let's switch topics
15:26:54 <frankbrockners> #topic POD1/POD2 config updates (and re-installation)
15:27:06 <frankbrockners> pbandzi could you give us a brief update on where things are?
15:27:27 <pbandzi> #info POD2 has chganged public IP, wiki is updated
15:27:56 <pbandzi> #info pod1 we had some issue with vlans 1000... 300... but figured out that we used another interface
15:28:22 <pbandzi> #info I think Stefan is deploying fuel now again
15:28:36 <pbandzi> that's all
15:28:50 <frankbrockners> #info most recent info on LF HW is found on https://wiki.opnfv.org/get_started/lflab_hosting (Peter updated this wiki)
15:29:03 <[1]JonasB> #info We can confirm that bootp leakage is gone
15:29:05 <frankbrockners> #info .10.x network is now for POD2 (VLAN412)
15:29:20 <frankbrockners> #info .9.x network is now entirely for POD1 (VLAN411)
15:29:35 <frankbrockners> perfect
15:29:56 <frankbrockners> let's move to individual updates from deployment tools
15:30:01 <morgan_orange> Fuel installation in progress, will Foreman solution be reinstalled?
15:30:14 <morgan_orange> when?
15:30:21 <frankbrockners> #topic Updates on deployment tools and POD1/POD2 installation
15:30:31 <frankbrockners> Anyone interested in going first?
15:30:40 <[1]JonasB> I can go
15:30:50 <frankbrockners> Jonas, please go ahead
15:31:07 <[1]JonasB> #info We have had some environment issues which caused a bad day :-(
15:31:32 <[1]JonasB> #info Now resolved, and a simple autodeploy is going right now
15:32:09 <[1]JonasB> #info Once that deploy is successfully finish we will start the more complex system end-state deployment
15:32:59 <[1]JonasB> #info Leakage is gone, but we see strange ARPs, although not hindering us.
15:33:07 <[1]JonasB> end fuel
15:33:23 <iben_> #info Iben Rodriguez was here… hello everyone!
15:33:54 <frankbrockners> thanks [1]JonasB
15:34:15 <frankbrockners> trozet: Any updates on Foreman and POD2 redeploy?
15:34:50 <trozet> #info fdegir is going to try to redeploy soon
15:35:13 <jose_lausuch> please let us know when the deployment is ready, so morgan and I align to run the tests there
15:35:15 <fdegir> #info Waiting for green light from BGS to start the deployment
15:35:18 <trozet> thanks pbandzi for reconfiguring the POD for us
15:35:24 <trozet> #info install instructions are merged I think.  Will submit a patch with the comments from folks
15:35:55 <frankbrockners> what are we missing to give fdegir green light?
15:36:07 <trozet> #info Need to patch our OPNFV install to create/configure br-ex.  I believe this is why some of the functest cases are failing.  Should have it in a few days.
15:36:50 <trozet> end of status
15:37:33 * fdegir it seems I'm good to go with foreman deployment
15:37:36 <frankbrockners> question: Should functest wait until "create/configure br-ex" is done or start with current setup?
15:38:24 <jose_lausuch> functest needs access to the br-ex to work
15:39:05 <trozet> I'll use intel pod1 to test out my changes then submit a patch to gerrit when its ready
15:39:52 <frankbrockners> trozet: given that functest doesn't yet work on POD2 - how about trying things directly on POD2?
15:39:53 <morgan_orange> due to network config, we could anyway use the solution to validate automation (even if we know that errors will occur)
15:40:19 <trozet> frankbrockners: I can do that
15:40:44 <trozet> ok morgan_orange if you want to continue using the setup thats fine with me
15:40:47 <trozet> I can use intelpod1
15:41:11 <frankbrockners> ok - sounds like a plan
15:41:53 <frankbrockners> one addition from radez on building the ISO for Foreman-based deployment:
15:42:36 <frankbrockners> #info  iso for foreman based deployment: looks like it's missing some resources. the guys from orange are working with it so I'll get some feedback from them and make updates (per radez)
15:42:58 <frankbrockners> any additional status that we missed capturing?
15:43:37 <trozet> i dont think so
15:43:46 <lmcdasm> one question on docs?
15:43:58 <frankbrockners> if not... tomorrow is TSC time again - and in order to give the TSC enough input let's make sure that https://wiki.opnfv.org/releases/arno/releasereadiness is up to date.
15:44:12 <frankbrockners> sure lmcdasm go ahead
15:44:37 <lmcdasm> Iben / Victor - can you give us a status on the updates from the training / help sessions from the past two weeks?
15:44:56 <lmcdasm> we had a number of updates and i havent seen them (i probably missed them) from you and/or David
15:46:54 <lmcdasm> ;) - guess not .
15:47:14 <lmcdasm> anyway - i see Victors stuff submitted, but not approved, so when it gets merged ill look there i suppose... thanks Frank
15:47:17 <frankbrockners> iben_: r u still around?
15:47:20 * bryan_att iben must have stepped away
15:47:30 <iben_> Hi team
15:48:00 <iben_> I haven’t checked with Victor since two weeks ago due to NFV World congress not much work was done from my side
15:48:09 <iben_> But victor has sent some emails to the list
15:48:26 <iben_> i missed anything about training/help
15:48:49 <lmcdasm> great - the edits  and updates from our two session with David and yourself you have passed to Victor to have the II and other stuff updated then if i got you?
15:48:49 <iben_> unless you are asking me about the work we’ve been doing to help the various internal private labs get fuel working on virtual
15:48:51 <iben_> ?
15:48:59 <iben_> ahh
15:49:00 <iben_> yes
15:49:16 <iben_> lmcdasm: you are daniel?
15:49:28 <lmcdasm> yes - Im Daniel
15:49:55 <iben_> so - we need to understand if these “internal” labs are “official” or not
15:50:27 <iben_> it seems there are lots of teams wanting to consume the OPNFV.ISO and try it out on their virtual setup
15:50:29 <lmcdasm> hmm. .good point, i was referring to the doc updates (things missnig, etc you brought up ) you bring up a bigger point of reference topology, etc
15:50:38 <iben_> instead of making these one-off configuraitons we should look to embrace these and crowdsource the docs
15:50:50 <bryan_att> not sure what you mean by "official"
15:51:06 <bryan_att> or "one-off"
15:51:21 <iben_> there have been lots of private emails going around with documents attached that I’d like to bring out to the open and post to the wiki as markup so we can get more eyeballs on them
15:51:38 <bryan_att> sounds good
15:51:41 <iben_> specifically focused on helping DK get the sandbox going
15:52:02 <iben_> so - if we can agree - then those docs can be sent to victor and the documentation team to get posted to the wiki
15:52:21 <bryan_att> the AT&T lab is intended to be "official" in that it will help demonstrate real readiness of the OPNFV platform for development use, and heterogenous environment installk
15:52:28 <lmcdasm> i believe that (with the exception of the docs i did specifically for you and David) the wiki docs are the ones to use
15:52:45 <iben_> as people run through it and find waays to improve the docs and make it easier for a newbie to “get started” with OPNFV.ISO on virtual then we can imrpove this whole process
15:52:53 <lmcdasm> and that is what Victor has takenb.. however the good point to bring up is that we havent said anything about nested enviornments in the docs but that is what David/Iben are doing
15:53:16 <iben_> there has been concern that since OPNFV has not officially endorsed running on virtual nested then we shouldnt’ spend any energy on this
15:53:18 <lmcdasm> so its a bit of a quandry, since in terms of ARNO, the baremetal architecture is setup and documented, but that is not what the ATT lab is using at this point.
15:53:48 <iben_> not just ATT - but many (most?) new labs are running nested virtual environemnts already
15:53:57 <iben_> now they want to know how to run OPNFV on there
15:53:58 <lmcdasm> for my part - since the HW wsa long in coming and I wanted to help David/Iben, i provided the setup that i use for our labs testers, etc.
15:54:08 <lmcdasm> but it wasnt intended to be part of ARNO as i know
15:54:14 <frankbrockners> yup - this is the current priority: document the official bare metal setup first.
15:54:15 <lmcdasm> so.. its a larger question
15:54:18 <bryan_att> Arno will be a blip in the stream... we need to use test environments flexibly and that will for us include VM-based install
15:54:29 <B_Smith> Arno .1
15:54:35 <frankbrockners> nested virtualization deployments - which are important for developers would go second
15:54:51 <lmcdasm> agreed Bryan and im fine with giving it out - it just creates the issue that Iben mentioned in that for what we have now, its not documented
15:54:52 <bryan_att> but we don't want to take anyone off task - so we will live with the degree of support we can get
15:55:09 <bryan_att> but our POR is to use VM-based install environments
15:55:21 <lmcdasm> and only ESXI?
15:55:27 <lmcdasm> or are you using LIBVirt?
15:55:29 <bryan_att> but the approach remains "official" from our perspective
15:56:06 <bryan_att> we have a vSphere managed environment. not too uncommon I think
15:56:21 <lmcdasm> agreed .. the question is a slightly bigger one though
15:56:22 <frankbrockners> folks... this is a very worthwhile discussion - and we should have a virtual environment for OPNFV soon - but after Arno is out
15:56:26 <bryan_att> we will have others as well
15:56:27 <lmcdasm> since Nested can be lots of hypervisors
15:56:59 <lmcdasm> and the amount of documentation and tesing becomes exponetially largers (and with each setup - i.e Signle Switch, distributed switch, linux bridge, etc, etc)
15:57:08 <frankbrockners> and we're not going to solve this here. Has anyone yet started to outline the desired target environment?
15:57:16 <lmcdasm> so there needs to be some format in place to handle cause we cant doc every enviornment i dont think :)
15:57:19 <iben_> I have a meeting in 3 minutes - can’t stay long here but make some action for me and I’ll ask Victor to follow up with docs and status
15:57:35 <lmcdasm> Frank - to answer your question - i provided the planning exercise to Iben/David and team
15:57:42 <lmcdasm> if they can come back with that topology and layout
15:57:46 <dneary> Away...
15:57:47 <frankbrockners> BGS-wise, we're done for today
15:57:47 <lmcdasm> then  we woudl have a starting point
15:58:03 <bryan_att> i would like someone to list the issues that make VM based install different so we can work on the docs
15:58:27 <frankbrockners> lmcdasm: Would be great to have the starting point for a virtual environment documented on a wiki. So that folks  can contribute their needs/requirements
15:58:28 <bryan_att> I don't see why bare metal is special when vmware can emulate it
15:58:45 <iben_> actually - my meeting is in 30 minutes so i can stay
15:58:48 <lmcdasm> Bryan - the issue is not so much the making it nesteed
15:59:05 <iben_> look - when someone asks for help there are three possible responses:
15:59:08 <lmcdasm> but doing the planning work in advance.. since there are some issue depending on what type of vSphere you are running and how you are goin to connect out
15:59:20 * frankbrockners need to run - and will close things here. Feel free to continue the nested virt discussion
15:59:21 <iben_> 1 - it’s officially part of arno lets get this fixed
15:59:38 <frankbrockners> nested virt is not part of Arno.
15:59:39 <iben_> 2 - not supported - not part of arno - will help on the side if I can
15:59:45 <trozet> bryan_att: maybe I missed earlier conversation and I'm out of the loop here, but I added instructions and in the process of adding full VM support
15:59:54 <lmcdasm> anyway - thanks for the discussion im off as well - im happy to help out with the ATT as much as i can, as i said to David/Iben - its best to bring htis up in TSC call
15:59:59 <frankbrockners> #endmeeting