13:58:03 <ChrisPriceAB> #startmeeting OPNFV TSC
13:58:03 <collabot> Meeting started Tue May 26 13:58:03 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:58:03 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:58:03 <collabot> The meeting name has been set to 'opnfv_tsc'
13:58:16 <ChrisPriceAB> #roll call (TSC members announce)
13:58:23 <ChrisPriceAB> #topic roll call (TSC members announce)
13:58:28 <ChrisPriceAB> #info Chris Price
13:58:44 <narindergupta> #info Narinder Gupta
13:58:52 <Gerald_K> #info Gerald Kunzmann (DOCOMO)
13:59:03 <pbandzi> #info Peter Bandzi
13:59:08 <pbandzi> on behalf of Frank
13:59:15 * ChrisPriceAB thanks Peter
13:59:49 <tallgren> #info Tapio Tallgren
13:59:54 <dlenrow> #info dlenrow
14:00:19 * ChrisPriceAB Agenda for today https://wiki.opnfv.org/wiki/tsc
14:00:22 <morgan_orange> #info Morgan Richomme
14:00:33 <bryan_att> #info Bryan Sullivan
14:00:55 <jose_lausuch> #info Jose Lausuch
14:01:12 <Wenjing> #inffo Wenjing
14:01:19 * ChrisPriceAB request on this call is for TSC members only Jose.
14:01:22 <ljlamers> #info Larry Lamers
14:01:23 <Wenjing> #info Wenjing
14:01:32 <jose_lausuch> oups, ok :)
14:01:34 <uli-k> #info Uli Kleber
14:02:47 <ChrisPriceAB> #topic Approval of previous minutes
14:03:13 <ChrisPriceAB> #agree TSC approves the previous minutes of meeting.
14:03:18 <ChrisPriceAB> #topic Agenda Bashing
14:05:20 <rajeev> #info Rajeev Koodli
14:05:42 <ChrisPriceAB> #topic OpenStack summit activity summary
14:05:48 <dneary> Missing first hour of TSC meeting today
14:05:51 <ChrisPriceAB> #chair rpaik
14:05:51 <collabot> Current chairs: ChrisPriceAB rpaik
14:05:55 <ChrisPriceAB> #chair ulik
14:05:55 <collabot> Warning: Nick not in channel: ulik
14:05:55 <collabot> Current chairs: ChrisPriceAB rpaik ulik
14:06:10 <ChrisPriceAB> #chair uli-k
14:06:10 <collabot> Current chairs: ChrisPriceAB rpaik uli-k ulik
14:06:44 <ChrisPriceAB> #info Standing room only at the OpenStack summit OPNFV day.  The morning session was completely full.
14:07:11 <ChrisPriceAB> #info requirements project sessions were well attended overall and well received.
14:07:39 <ChrisPriceAB> #info Steve Gordon from the Telco Working group closed the day, this session was completely full also.
14:08:00 <ChrisPriceAB> #info approximately 270 people showed up to the OPNFV evening reception of the
14:08:12 <dlenrow> Damn! Missed that reception in Vancouver :(
14:08:26 * ChrisPriceAB hehe
14:09:53 <trevor_intel> #info Trevor Cooper
14:10:52 <cdub> #info Chris Wright
14:10:54 <Thinh_> #info Thinh Nguyenphu
14:10:59 <rpaik> #info ChrisPriceAB/HKirksey/Jim Zemlin also attended the OpenStack Board meeting on Sunday prior to the summit
14:11:20 <bryan_att> link to the generic deck on the wiki?
14:11:42 <dku> #info Dirk Kutscher
14:11:59 <dku> sorry, got delayed in another meeting...
14:12:15 <aripie> #info Ari Pietikainen (Ericsson)
14:13:14 <ChrisPriceAB> #link https://www.opnfv.org/sites/opnfv/files/pages/files/opnfv_overview_deck_05112015.pdf generic OPNFV presentation
14:13:25 <bryan_att> thanks
14:13:56 <ChrisPriceAB> #topic OPNFV Board meeting summary
14:15:55 <bryan_att> is there a job description for the release manager? very interested in the set of tasks/roles that Chris mentioned, and how projects are expected to work with the release manager
14:18:36 <rpaik> #info ChrisPriceAB discussed some of the Arno learnings with the board during the meeting but the technical community will have to do a formal post-mortem
14:19:12 <ChrisPriceAB> #topic Project Approvals
14:19:36 <dlenrow> uli-k: can you make your comments via IRC?
14:21:56 <dlenrow> #info BOD will provide oversight on major theme's/capabilities for OPNFV release. Proposal coming in future BOD meeting. Release committee from BOD.
14:23:43 <dlenrow> #info BOD expected to have interactive discussion with TSC on this topic
14:24:54 <dlenrow> #info rajeev adds that working upstream topic got lots of discussion in BOD mtg.
14:25:33 <dlenrow> #info bryan_att describes how doctor is trying to document best practices from their successfl initial upstream work
14:26:00 <ChrisPriceAB> #topic committer and contributor review of the inspector project
14:26:08 <ChrisPriceAB> #link https://wiki.opnfv.org/requirements_projects/inspector updated proposal page
14:27:58 <ChrisPriceAB> #startvote TSC vote to approve the creation of the inspector project? (+1, 0, -1)
14:27:58 <collabot> Begin voting on: TSC vote to approve the creation of the inspector project? Valid vote options are , +1, 0, -1, .
14:27:58 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
14:28:03 <dlenrow> #vote +1
14:28:05 <uli-k> #vote +1
14:28:05 <ChrisPriceAB> #vote +1
14:28:08 <bryan_att> #vote +1
14:28:10 <Gerald_K> #vote +1
14:28:11 <Wenjing> #vote +1
14:28:12 <rajeev> #vote +1
14:28:13 <julien_ZTE> #vote +1
14:28:15 <tallgren> #vote +1
14:28:21 <pbandzi> #vote +1
14:28:22 <cdub> #vote +1
14:28:25 <zhiheng> vote +1
14:28:26 <pbandzi> on behalf of Frank
14:28:33 <jaosorior> yay :D
14:28:34 <ChrisPriceAB> #endvote
14:28:34 <collabot> Voted on "TSC vote to approve the creation of the inspector project?" Results are
14:28:34 <collabot> +1 (11): dlenrow, rajeev, bryan_att, ChrisPriceAB, tallgren, cdub, pbandzi, Gerald_K, uli-k, julien_ZTE, Wenjing
14:28:35 <Gerald_K> on behalf of Ashiq
14:28:42 <zhiheng> #vote +1
14:28:44 <dlenrow> inspector team: Congratulations: Please work closely with Congress team and any audit monitoring they plan.
14:28:55 <ChrisPriceAB> #topic committer and contributor review of the JOID project
14:29:11 <bryan_att> fyi it would be good to summarize on the Inspector project wiki page the existing interaction of openstack and DMTF/CADF e.g. as indicated by the link https://wiki.openstack.org/w/images/e/e1/Introduction_to_Cloud_Auditing_using_CADF_Event_Model_and_Taxonomy_2013-10-22.pdf
14:29:14 <narindergupta> ChrisPriceAB, https://wiki.opnfv.org/project_proposals/joid?&#key_project_facts
14:29:22 <ChrisPriceAB> #link https://wiki.opnfv.org/project_proposals/joid updated wiki
14:30:02 <ChrisPriceAB> #startvote TSC vote to approve the creation of the JOID project? (+1, 0, -1)
14:30:02 <collabot> Begin voting on: TSC vote to approve the creation of the JOID project? Valid vote options are , +1, 0, -1, .
14:30:02 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
14:30:12 <uli-k> #vote +1
14:30:13 <ChrisPriceAB> #vote +1
14:30:14 <TomNadeau> #vote +1
14:30:16 <dlenrow> #vote +1
14:30:18 <julien_ZTE> #vote +1
14:30:19 <dku> #vote +1
14:30:19 <bryan_att> #vote +1
14:30:21 <pbandzi> #vote +1
14:30:22 <cdub> #vote +1
14:30:23 <Wenjing> #vote +1
14:30:25 <rajeev> #vote +1
14:30:28 <zhiheng> #vote +1
14:30:28 <tallgren> #vote +1
14:30:37 <ChrisPriceAB> #endvote
14:30:37 <collabot> Voted on "TSC vote to approve the creation of the JOID project?" Results are
14:30:37 <collabot> +1 (13): dku, dlenrow, TomNadeau, rajeev, bryan_att, zhiheng, ChrisPriceAB, tallgren, cdub, pbandzi, uli-k, julien_ZTE, Wenjing
14:30:41 <aricg> Who is project lead?
14:31:05 <dlenrow> don't committers need to elect a PL?
14:31:19 <dlenrow> oh yeah...
14:31:39 <ChrisPriceAB> #topic Requirements projects and next steps
14:31:46 <dlenrow> congratutlations JOID team
14:32:37 <ChrisPriceAB> #info uli-k reports that requirements projects cannot be seen to be finishd until the requirements are implemented.
14:32:52 <ChrisPriceAB> #info this is not reflected in our lifecycle document today
14:33:31 <ChrisPriceAB> #info proposals have been made on potential changes/amendments to the lifecycle document
14:34:18 <bryan_att> #info I volunteer for that team
14:34:21 <ChrisPriceAB> #info uli-k proposes that we start a sub-team to propose amendments to the lifecycle document or requirements projects
14:35:40 <jaosorior> bryan_att: regarding your comment about inspector. Planned to add the relevant documentation (including something like that) in the gerrit repo, which will be generating sphinx documentation
14:35:41 <bryan_att> there are 11 requirements projects; we likely would not expect all leads to participate
14:36:24 <RayNugent> #link http://www.openstack.org/blog/2015/02/tc-update-project-reform-progress/
14:39:10 <bryan_att> jaosorior, thanks - sounds good. the intent is that we get directly engaged upstream as early as possible. coming out of openstack it was a common feedback to projects like OPNFV - get engaged early, socialize goals, and take feedback in forming blueprints etc - rather than delivering "shrink-wrapped" projects into openstack
14:40:09 <jaosorior> bryan_att: The intent is to have the repo to track the progress done in OpenStack as well as relevant documentation. We will have no code as everything will be done upstream.
14:40:37 <jaosorior> * Not only in OpenStack but in the relevant components we work on
14:41:14 <bryan_att> sounds good
14:41:22 <rpaik> #info ChrisPriceAB also suggests having discussions among testing & integration teams on our learning to-date (parallel to requirements projects)
14:43:13 <dlenrow> uli-k and a small group would be good to draft, subject to review by PLs. of course
14:43:25 <dlenrow> small group, first draft seems good
14:43:58 <ChrisPriceAB> #action uli-k to recruit a team from our requirements project community to further develop the requirement projects development process.
14:44:25 <ChrisPriceAB> #info Ildiko reccommends this be done as a retrospective of what is going well.
14:44:52 <bryan_att> maybe a reason we don't have too much req project lead feedback is that many of the leads are in asia zones and not on this call?
14:44:55 <Gerald_K> I volunteer for that team
14:45:00 <ildikov> #info Ildiko Vancsa
14:46:01 <ChrisPriceAB> #info ildokov, bryan_att and Gerald_K have volunteered to participate in the requirements project process review with uli-k
14:47:06 * ildikov volunteers for requirements projects way of working group
14:47:27 * ChrisPriceAB oops got your nic wrong, sorry
14:48:09 * uli-k Thanks to the volunteers!
14:48:30 <RayNugent> #info suggestion to develop metrics for upstream acceptance of OPNFV proposals (i.e. accepted BPs, projects etc)
14:49:28 <ChrisPriceAB> #topic Arno Project plans & tracking
14:49:52 <ChrisPriceAB> #info Release tagging and maintenance structure
14:51:51 <ChrisPriceAB> #info uli-k mentions that in order to move trunk to the latest upstream versions we would need a maintenance branch
14:52:16 <ChrisPriceAB> #info Jonas describes the question is if we want to do stable releases at all
14:52:49 <ChrisPriceAB> #info bryan_att indicates that we will want to be able to release a stable version for issues.
14:53:03 <ChrisPriceAB> #info uli-k would like to keep the bug-fixing of Arno to a minimum.
14:54:34 <ChrisPriceAB> #info providing some stability to our consumers and standing behind our release is important to our community, and for our credibility.
14:56:59 <bryan_att> agree, my goal is to move to a more stable beta as soon as possible, minimize maintenance overhead, identify who will be addressing maintenance issues (triage, fixing) - we have to support the product but help users move to a more stable release asap
14:57:44 <ChrisPriceAB> #info bryan_att asks how we will provide support for Arno once we do release
14:57:45 <RayNugent> #info suggest a discussion on what "maintenance" of a release means
15:01:32 <ChrisPriceAB> #action ChrisPriceAB start dialog on the lists regarding support structure for Arno.
15:02:06 <dneary> On the call now.
15:02:15 <rprakash> #info EOL for Arno shoukd no be before B-release
15:02:38 <bryan_att> +1 - we expect to maintain Arno and want to optimize the effort to do so
15:03:08 <dlenrow> rprakash: best practice probably continues at least until N + 2 comes out...
15:03:21 <ChrisPriceAB> #agree There is a need to support and potentially provide stable releases on the Arno release with a minimum maintenance effort.
15:03:35 <ChrisPriceAB> #info Release activities - flag raising
15:05:07 <ChrisPriceAB> #info morgan_orange reports that in functional testing we are unable to run a complete sequence.  refactoring is ongoing however issues remain on networking.
15:06:20 <ChrisPriceAB> #info morgan_orange is confident that the full sequence will contain some errors at Arno release however these are able to be explained.
15:07:27 <bryan_att> i'm doing my best to address editing / formatting issues in the release docs. can't add a lot of value with the technical content, but will do what I can. We do need to ensure we have quick turnaround on gerrit reviews for doc edits and merge +1's quickly, so ask that committers to BGS and Pharos watch for reviews. And would like easier +1's for simple
15:07:27 <bryan_att> editorial changes.
15:08:28 <ChrisPriceAB> #action morgan_orange to report to the TSC on next weeks meeting on the status and stability of Arno and the automated test suite.
15:09:41 <rprakash> #info 3 or 4 errors in networking now call it orange flag, meeting of test teams to look st regressions, freez etc.
15:09:59 <morgan_orange> #link https://wiki.opnfv.org/r1_tempest
15:10:12 <morgan_orange> 3 or 4 categories of errors but more errors overall
15:10:14 <dneary> dlenrow, That makes sense for a product, but does it make sense for OPNFV? OpenStack supports old releases to N-1, we're not going to do any better than that, right?
15:10:41 <morgan_orange> #link https://wiki.opnfv.org/r1_rally_bench
15:10:50 <morgan_orange> #link https://wiki.opnfv.org/r1_odl_suite
15:12:17 <dlenrow> dneary: We found that from first release on, this worked well for ODL. This is most recent example of a new OSS infra platform. Experience was lots of people built on Hydrogen and wanted maint for multiple releases
15:12:50 <ChrisPriceAB> #link https://wiki.opnfv.org/documentation/Arno current Arno documentation status
15:13:00 <dneary> dlenrow, N+2 means doing periodic releases of Helium after the release of Lithium - that does not sound feasible or reasonable to me
15:13:31 <dlenrow> dneary: We have different interpretation of N +/- can discuss offline
15:13:33 <dneary> dlenrow, Helium does not have any developer attention any more
15:13:44 <ChrisPriceAB> #topic Release 2 planning
15:13:56 <ChrisPriceAB> #info Working on the development process
15:14:09 <dneary> N: Current release, N+1: Last stable, N+2: Next to last stable.
15:18:29 <ChrisPriceAB> #info bryan_att describes that cross project discussions will be necessary to ensure we have concistency in our activities.
15:19:02 <ChrisPriceAB> #info Prakash indicates that requirements should map to upstream development sources, this could be streamlined in cross project activities.
15:19:05 <RayNugent> #info would this be a OPNFV design summitt?
15:19:22 * ChrisPriceAB thats planned for November I think
15:20:32 <RayNugent> #info That would be a good place to do it. is it on the agenda yet?
15:26:08 <ChrisPriceAB> #info Release dates and upstream dependencies
15:29:55 <TomNadeau> chris, while the Board has asked for releases every 6 months do they have any preference on maint releases?
15:30:00 <TomNadeau> or is that up to us?
15:30:01 <julien_ZTE> #info If we based on openstack Liberty, Liberty itself may not be stable on Nov.
15:30:07 <uli-k> #info There is expectation that B-Release would support Openstack Liberty
15:30:29 <tallgren> So the B-release should be in December, but not too late
15:30:37 <uli-k> #info TSC should decide whether we want to accomodate this expectation.
15:30:55 * ChrisPriceAB TomNadeau: they have not expressed any preferences on maint/stable releases
15:31:44 <ildikov> julien_ZTE: when is an OpenStack release considered to be stable? I mean how long after the official release date?
15:32:14 <rajeev> Mid-December would be a good target for B-release
15:32:38 <julien_ZTE> #info ildikov 2 month at least
15:34:32 <julien_ZTE> #info Liberty target Oct 15. 2015
15:34:44 <julien_ZTE> #link https://wiki.openstack.org/wiki/Releases
15:35:05 <RayNugent> #info OpenStack has 4 release prior to GA in Oct. Liberty will be pretty stable when released
15:36:03 <ildikov> julien_ZTE: hmm, ok
15:38:05 <rprakash> #info june 4 to dec 4,  6-months we can target and define packages and installrs for ci/cd
15:38:29 <rpaik> #info ONOS, OpenContrail, ODL, OpenStack, Open vSwitch as starting points for upstream communties for release 2
15:38:50 <ChrisPriceAB> #action dneary to provide a release map for upstream comunities as input in to the B-Release planning discussion.
15:39:23 <tallgren> Add DPDK
15:39:32 <rprakash> #info would lik to work with dneary on this action item above
15:39:42 <rpaik> #info add DPDK to the list above :-)
15:39:52 <ChrisPriceAB> #agree The TSC agrees thet the accommodation of our current upstream efforts as important when setting a target release date.
15:43:56 <rprakash> #info michael young  expects concerns about sprawl and so answer was that markee features in rel 2 should drive the upstream engagement
15:44:52 <rajeev> +1 to tallgren, rpaik on adding DPDK
15:46:54 <ChrisPriceAB> #info the ETSI NFV has a working group that will be establishing a roadmap of community releases including features.  The idea is to understand the cadence and pipeline of community activity.
15:47:20 <rprakash> #info prakash add me to that
15:47:50 * uli-k EVE working group
15:47:57 <tallgren> The ETSI information can only be shared with ETSI members?
15:48:23 <Thinh_> thinh nguyenphu, EVE WG
15:51:25 <julien_ZTE> #agree using Liberty +1
15:51:26 <ChrisPriceAB> #info uli-k asks if we can refer to the Liberty release of OpenStack for our OPNFV B-Release
15:52:50 * ChrisPriceAB we have larry! https://wiki.opnfv.org/lar-e
15:53:54 <bryan_att> fyi - back on the earlier documentation review topic - I posted a suggested list of guidelines to getting engaged in reviews to the list: lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-May/002875.html
15:54:39 <dneary> rprakash, Happy to sync - my suggestion is to do it in a wiki page (community/release_dates)
15:54:50 <rprakash> * We do have multisite too link  https://wiki.opnfv.org/multisite
15:55:51 <bryan_att> +1 to setting a goal for Liberty as the OpenStack base for our B release
15:56:04 <dneary> ChrisPriceAB, Sure - we'll have something with a table to fill in (but then we'll need to argue relative priorities & important, etc)
15:56:06 <tallgren> +1
15:56:07 <dlenrow> +1 me too
15:56:09 <bryan_att> My goal for Copper is to have BPs for Liberty as the next goal
15:56:24 * dneary thinks that we should choose the B name soon
15:56:27 <ChrisPriceAB> #agree the TSC would like to accomodate the OpenStack liberty release in our B-release planning
15:56:34 <uli-k> THANKS
15:56:40 <rpaik> #info will also review project release map of upstrem communities prior to setting the date for a B-release next week
15:56:59 <dlenrow> If we will have an SR-like thing we need an SR plan yesterday....
15:57:10 <bryan_att> uli-k, let me know if the suggestions on doc review are helpful - see the list note I sent
15:57:38 <uli-k> bryan_att: ok
15:57:43 <ChrisPriceAB> #endmeeting