16:00:16 <frankbrockners> #startmeeting OPNFV BGS daily sync
16:00:16 <collabot> Meeting started Tue Jun  2 16:00:16 2015 UTC.  The chair is frankbrockners. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:16 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:16 <collabot> The meeting name has been set to 'opnfv_bgs_daily_sync'
16:00:24 <frankbrockners> #info Frank Brockners
16:00:28 <jose_lausuch> #info Jose Lausuch
16:00:44 <pbandzi> #info Peter Bandzi
16:02:29 <jonasbjurel> #info Jonas Bjurel
16:03:12 <ChrisPriceAB> #info Chris Price
16:03:27 <frankbrockners> ...am pinging other folks to get a quorum...
16:04:55 <frankbrockners> let's get going - and go through the laundry list.
16:05:20 <frankbrockners> Peter created a nice summary of the meeting yesterday: https://wiki.opnfv.org/meetings/bgs#june12015
16:05:25 <lmcdasm> #info daniel smith
16:05:29 <trozet> #info Tim Rozet
16:05:33 <frankbrockners> let's do 1...5
16:05:48 <frankbrockners> #topic updates on "POD1 auto deploy with ODL and automated testing"
16:05:57 <lmcdasm> ok ill go?
16:06:06 <frankbrockners> jonasbjurel, lmcdasm?
16:06:10 <frankbrockners> sure - go ahead
16:06:16 <jonasbjurel> Dan go!
16:06:21 <lmcdasm> #info so POD1 is deployed in ODL mode now . the automation is coming after test results
16:06:40 <lmcdasm> #info we have hit a snag with the tunnels not talking together this morning (over the wire) so we are looking at that now
16:07:02 <lmcdasm> #info jose started to run functest on it (sine we have the scope of SUT set now) and it failed.. so we are wokring on it.
16:07:21 <lmcdasm> #info we will be able to change to ODL mode after deploying from jenkins
16:07:47 <lmcdasm> #info so - its "in the works" - vmsn and such are up, but i think its a tagging issue / something with OVS version that is not setting up the endpoints
16:07:56 <lmcdasm> #info i illicited some advice from the team and we will continue
16:07:57 <lmcdasm> thats it
16:08:00 <trozet> lmcdasm: I think you need what Michal mentioned in his email
16:10:25 <frankbrockners> let's go through the updates quickly - and then discuss next steps. Per the TSC call: Plan is to tag Arno tomorrow.
16:10:32 <frankbrockners> thanks Dan.
16:10:37 <lmcdasm> you're welcome
16:10:45 <frankbrockners> #topic updates on "bootable ISO for Foreman"
16:10:52 <frankbrockners> trozet: Any news?
16:11:01 <jose_lausuch> I can give some info later about functest on pod2
16:11:36 <trozet> #info radez got passed what was blocking him and got a test run with the ISO working
16:12:46 <trozet> anything else Frank?
16:12:50 <frankbrockners> so http://artifacts.opnfv.org/genesis/foreman/opnfv-2015-06-02_02-47-03.iso deploys?
16:12:52 <trozet> move on to pod2?
16:13:34 <trozet> frankbrockners: it installs, but it doesnt deploy
16:13:55 <trozet> we havent finished a deploy yet
16:14:21 <trozet> radez is sitting next to me telling me what to say cause his laptop died
16:15:37 <frankbrockners> ok - could you elaborate? I just thought I used the wrong wording: I should have said that the "ISO installs" so that a deploy can be triggered
16:15:42 <frankbrockners> what are we missing?
16:16:42 <trozet> yeah radez wanted to try a deploy though
16:16:46 <trozet> just to make sure it all worked
16:17:25 <frankbrockners> ok - so radez hopes that things work but tests are pending... - got it
16:17:44 <trozet> well the installation part works fine
16:17:47 <trozet> like the ISO is good
16:17:56 <frankbrockners> ok - thanks
16:18:08 <frankbrockners> let's switch to the test topics
16:18:26 <frankbrockners> #topic updates on "documentation on failing tests"
16:18:49 <jose_lausuch> well
16:18:52 <jose_lausuch> is that the topic?
16:18:52 <frankbrockners> jose_lausuch, trozet - I think you had some updates here
16:18:55 <jose_lausuch> just documentation?
16:19:00 <jose_lausuch> :)
16:19:02 <frankbrockners> well - updates
16:19:05 <jose_lausuch> ok
16:19:12 <jose_lausuch> I shoot
16:19:16 <jose_lausuch> #info POD2.vPing:
16:19:21 <jose_lausuch> #info DHCP service works out of the box (fresh install) but after running some tempest cases it doesn't, it breaks or something we dont know. Still troubleshooting with trozet.
16:19:24 <frankbrockners> if we can do better then explain why things fail - always perferable
16:19:28 <jose_lausuch> #info Found issue with userdata. A VM created in the vPing script needs metadata service running on nova. Not enabled on nova.conf. A patch to be commited to fix that.
16:19:32 <jose_lausuch> #info POD2.ODL-test:
16:19:36 <jose_lausuch> #info Got better results. 18 critical tests, 15 passed, 3 failed
16:19:39 <jose_lausuch> #info POD2.Tempest:
16:19:44 <jose_lausuch> #info Got better results, but manually. Issue found since Saturday when running with Rally: https://bugs.launchpad.net/rally/+bug/1454648
16:19:48 <jose_lausuch> #info Maybe the bug is realted to a missing router that should be created by default. A patch to be commited to create a router attached to the public network 'provider-network'.
16:19:51 <jose_lausuch> #info POD2.Rally-bench-tests: Same as before. Not in the highes prio now.
16:19:54 <jose_lausuch> done :)
16:20:14 <frankbrockners> jose_lausuch came well prepared :-)
16:20:28 <jose_lausuch> just wrote it minutes ago
16:20:29 <frankbrockners> thanks jose_lausuch
16:20:30 <jose_lausuch> hehehe
16:20:40 <jose_lausuch> y r w :)
16:20:57 <trozet> ill have a patch done today to make the router and turn on the metadata
16:21:08 <jose_lausuch> that sounds awesome :)
16:21:21 <frankbrockners> #topic finalize vPing
16:21:26 <jose_lausuch> #info Morgan started updating the documentation for this issues
16:21:39 <jose_lausuch> to be continued tomorrow when we have a clear picture what things work and what dont
16:21:42 <frankbrockners> #info see above in jose_lausuch update
16:22:12 <frankbrockners> jose_lausuch: Is the plan to move away from static IP addresses for vPing - or do you stay for Arno with static IPs?
16:22:27 <jose_lausuch> well
16:22:36 <jose_lausuch> I did a patch yesterday to hardcode the IPs
16:22:44 <jose_lausuch> but it doesnt prevent from using the DHCP service
16:22:46 <jose_lausuch> meaning
16:22:59 <jose_lausuch> I create a port for the VMs with an specific IP
16:23:08 <jose_lausuch> but the OS is configured to use dhcp
16:23:15 <jose_lausuch> so we neeed dhcp running anyway
16:23:33 <jose_lausuch> (which I would say is essential for any case, vping or whoever wants to spawn a vm)
16:23:45 * frankbrockners agrees
16:23:47 <lmcdasm> note*
16:23:58 <lmcdasm> unless you want to change the VM rom a cirros (or modify the cirros image) to not use DHCP
16:24:00 <lmcdasm> (option)
16:24:26 <frankbrockners> #topic ODL tests ok on both PODs.
16:24:35 <frankbrockners> jose covered most of it already
16:24:46 <frankbrockners> pbandzi - is there anything you'd like to add?
16:24:53 <jose_lausuch> Imcdasm well, thats an ugly hack :)
16:25:05 <pbandzi> just for ODL three tests are expected to fail due to odl bug
16:25:05 <jose_lausuch> but then we need to have 2 differnt images
16:25:16 <jose_lausuch> and cannot use the one from the internet
16:25:24 <trozet> jose_lausuch: lets continue to debug the dhcp problem in #opnfv-bgs
16:25:25 <frankbrockners> pbandzi: let's info that
16:25:30 <jose_lausuch> and hardcoding the ips means having poor flexibility also
16:25:32 <jose_lausuch> ok
16:25:32 <jose_lausuch> yes
16:25:36 <jose_lausuch> agree trozet
16:25:57 <pbandzi> #info ODL suite: three tests are expected to fail due to odl bug
16:26:13 <pbandzi> #link https://wiki.opnfv.org/r1_odl_suite
16:26:16 <jose_lausuch> ya, I forgot to mention "due to an ODL bug" sorry :)
16:26:36 <frankbrockners> thanks... - r we done with status?
16:27:07 <frankbrockners> #topic next steps
16:27:08 <jose_lausuch> from my side yes
16:27:59 <frankbrockners> per the note above: folks want to tag the release tomorrow. tag per tsc decision is arno.2015.1.0 - see also https://wiki.opnfv.org/octopus/releasepipeline
16:28:20 <lmcdasm> question if i may?
16:28:26 <frankbrockners> go ahead
16:29:04 <lmcdasm> looking at this page, (and maybe im flogging a dead horse), but how do we plan on supporting the release? since Tim, Dan, me, Jose, etc cant possibly do it all in a formal/consistent manner
16:29:25 <lmcdasm> (and Fatih* - sorry)
16:30:15 <lmcdasm> i guess - looking ath the page, i would wonder if we have a bullet or note that says "once the release is set - here is the flow" or something like that?
16:30:17 <frankbrockners> lmcdasm: the support question came up on the TSC today - without much of a resolution. We just made sure that there is no such thing as a "support" mailer for now.
16:31:11 <frankbrockners> in theory things should be "community" supported - and there should be no expectation created of something like "you submit an issue and will be helped within 24hrs"
16:31:37 <ChrisPriceAB> :)  We will have a mailing list established for these queries.  Support will be managed by communty, I have an action to request community committment on that.  (does not mean we will solve issues immediately, can be postponed to next release for instance)
16:31:58 <frankbrockners> yup - key thing is to set expectations
16:32:16 <ChrisPriceAB> I have a question also - What actions/resolutions do we feel are needed before we feel ready for labeling?
16:32:28 <lmcdasm> hmm. okies - i think we just need to be cognizant of the fact that (given responses already) there is a learning curve  and if we dont have someone to pick stuff up / give some kind of attention, interest will fade quickly.. thx for the repsonse.
16:32:33 <frankbrockners> that would have been my next question
16:32:45 <fdegir> and I have a question regarding what to release
16:32:46 <ChrisPriceAB> ack lmcdasm
16:32:57 <fdegir> what frankbrockners brought up: releasing the source code
16:33:02 <fdegir> guys might think differently
16:33:43 <frankbrockners> fdegir: Could we first agree on what we tag for Arno?
16:33:51 <fdegir> ok
16:34:44 <frankbrockners> My approach would be that we have one owner per deployment tool to do the tagging: Proposal: trozet for Foreman and jonasbjurel for Fuel
16:34:45 <ChrisPriceAB> what do we see as blockers, and when do we pull the plug on resolving them?
16:34:46 <jonasbjurel> Its not just tagging, it is branching as well?
16:35:02 <fdegir> jonasbjurel: yes, branching is needed
16:35:27 <ChrisPriceAB> described here https://wiki.opnfv.org/octopus/releasepipeline
16:35:36 <frankbrockners> tagging is what we need for Thursday
16:35:38 <fdegir> have a comment there
16:35:43 <trozet> frankbrockners: you mean branch+tag our non-genesis code?
16:35:50 <fdegir> we can only have one tag/branch
16:36:00 <fdegir> so no foreman and fuel specific tags
16:36:13 <fdegir> on genesis repo
16:36:19 <ChrisPriceAB> ack fdegir.  it's the repo we tag&branch
16:36:36 <trozet> so what is frankbrockners asking for?
16:36:42 <frankbrockners> do you want to tag the entire repo or just portions?
16:36:52 <fdegir> there is no portion tagging in git
16:36:58 <fdegir> one tag applies to complete repo
16:37:14 <fdegir> it sticks on certain sha1
16:37:20 <jonasbjurel> fdegir: agree one tag
16:37:22 <fdegir> that points to certain version of the repo
16:37:40 <jonasbjurel> How would we otherwise do it?
16:37:48 <fdegir> so trozet and jonasbjurel need to come up with one sha1
16:38:04 <trozet> its not really a bgs thing
16:38:13 <fdegir> stating that: this is the sha1 where we can build/deploy
16:38:14 <frankbrockners> in which case - forget my question
16:38:30 <fdegir> and functest should say that yes we can test that deployed thing with this functest sha1 version
16:38:36 <fdegir> and it works
16:38:40 <ChrisPriceAB> we decided on arno.2015.1.0 did we not?  Across all projects
16:38:46 <fdegir> yes ChrisPriceAB
16:39:01 <ChrisPriceAB> ok, so when we are ready we will label with that.
16:39:15 <fdegir> so frankbrockners suggestion changes to: trozet and jonasbjurel agree on the version
16:39:29 <fdegir> and then one of them applies the tag & creates the branch
16:39:40 <ChrisPriceAB> I am still not sure what we need to do before we say "we are ready" and label
16:39:44 <jonasbjurel> jonas agrees
16:40:02 <fdegir> ChrisPriceAB: I think we should have one full run - nontouched
16:40:12 <fdegir> where the proposed build/deploy/test jobs run
16:40:18 <fdegir> and results evaluated by functest
16:40:37 <fdegir> and then once bgs + functest can say it is good to release
16:40:46 <fdegir> we find our iso and corresponding sha1s
16:40:59 <frankbrockners> IMHO we should also have the ISO validated
16:41:11 <lmcdasm> question?
16:41:15 <fdegir> meaning?
16:41:16 <frankbrockners> (for Foreman)
16:41:24 <fdegir> ok
16:41:37 <lmcdasm> when we say validated - we mean that for both FUEL and FOREMAN the ISO is installable and deployable
16:41:51 <lmcdasm> and we "know" there may be (documented) test case issues - but that is not criteria for release tag
16:41:54 <lmcdasm> do i have that right?
16:41:55 <frankbrockners> lmcdasm - yes
16:42:18 <frankbrockners> "deploys and kind of works"
16:42:35 <frankbrockners> with "kind of" being described by the test cases
16:42:43 <frankbrockners> and additional release notes
16:42:44 <lmcdasm> well. i think we know that the basic opensack operations work
16:43:03 <lmcdasm> and we know that ODL is "buggy" so we have some competence that it can be used and tinkered with for a first release no?
16:43:09 <lmcdasm> openstack*
16:43:32 * ChrisPriceAB cringes at the thought
16:43:44 <frankbrockners> yes - we know that ODL is buggy - we'll just document it
16:43:53 <frankbrockners> that is the nature of the Arno release
16:44:09 <frankbrockners> so back on Chris' note
16:44:11 <lmcdasm> i know its not perfect Chris - however, we need to look a bit bigger that even if we get ODL with all tests working
16:44:24 <lmcdasm> its a small subset of what you "can" do and there is no way we can really cover all aspectes :)
16:44:37 <jonasbjurel> frankbrockners: Kind of works is a big statement for where we stand.
16:44:39 <lmcdasm> unless you want to set a larger scope and give more time (which is something we dont wanna do i think)
16:46:41 <frankbrockners> so can we agree (per Chris question) for Arno we'll tag things as soon as "build/deploy/test jobs run non-touched - and both ISOs install"?
16:47:07 <trozet> whos pulling the branch and tagging?
16:47:19 <frankbrockners> that is the next question
16:47:22 <trozet> ok
16:47:28 <trozet> yes
16:47:30 <lmcdasm> #agreed - with the caveat being that "test will fail" :)
16:47:51 <frankbrockners> #agreed  for Arno we'll tag things as soon as "build/deploy/test jobs run non-touched - and both ISOs install"
16:48:02 <trozet> and vping passes?
16:48:09 <fdegir> :)
16:48:19 <lmcdasm> i dont think we should qualify with one or the other
16:48:20 <frankbrockners> vping would be part of the "test"
16:48:27 <lmcdasm> i mean - if we are gonna pick one, then why not all :)
16:48:45 <trozet> vping is pretty simple, 2 VMs ping each other
16:48:50 <trozet> i would say for Arno we should at least have that working
16:48:55 <frankbrockners> so next question: Who's pulling the branch and tagging things?
16:48:57 <trozet> and say we can deploy/install and basic ping works
16:49:27 <frankbrockners> trozet: Agreed. The most simple VNF test case should work
16:49:28 <jonasbjurel> I agree, if we dont have vping working, than nothing can be deployed on the infrastructure
16:49:56 <trozet> so once we have vping passing on both deploys
16:49:59 <lmcdasm> semi-agree - since it depends on how we are marketing it
16:49:59 <trozet> and ISO working
16:50:11 <frankbrockners> #agreed "vping" working is a gating factor for Arno
16:50:13 <trozet> we pull, tag and freeze then release
16:50:53 <fdegir> to be clear; we must execute full build/deploy/test runs for foreman and fuel on same sha1s
16:51:31 <lmcdasm> deadline for final commits would be?
16:51:36 <frankbrockners> back on the "who" question: My preference would be that trozet and jonasbjurel agree on "ready" - and then either of the two would tag and pull the branch
16:52:10 <trozet> ok
16:52:19 <frankbrockners> jonasbjurel?
16:53:29 <fdegir> lmcdasm: it could take up to 4 hours to execute full run
16:53:51 <frankbrockners> jonasbjurel - ok?
16:53:58 <jonasbjurel> Sorry
16:54:16 <fdegir> lmcdasm: so each commit you make might require full run
16:54:35 <jonasbjurel> Ok with me, how do I technically do a tag in gerrit?
16:55:00 <fdegir> lmcdasm: I would say tomorrow afternoon CEST in case last minute problems
16:55:07 <fdegir> jonasbjurel: we will send instructions
16:55:30 <frankbrockners> fdegir has a recipe for it
16:55:46 <jonasbjurel> Also howto branch?
16:55:52 <frankbrockners> #info trozet and jonasbjurel agree on "ready" - and then either of the two would tag and pull the branch
16:56:29 <fdegir> jonasbjurel: yes
16:56:36 <frankbrockners> so how about jonasbjurel and trozet just sync tomorrow afternoon CET
16:56:47 <jonasbjurel> Yes
16:56:48 <fdegir> will need to check with aricg to make sure you have all the rights
16:56:52 <frankbrockners> that time I expect everyone else to be on IRC anyway
16:57:17 <frankbrockners> if things don't work out - then we can call our BGS meeting tomorrow "afternoon"
16:57:46 <frankbrockners> so latest would be tomorrow 9am PDT
16:57:48 <frankbrockners> ok?
16:57:58 <trozet> k
16:58:47 <frankbrockners> #info target for tag & branch: tomorrow afternoon CET - latest at/during BGS daily synch at 9am PT
16:58:58 <frankbrockners> anything else?
16:59:44 <jonasbjurel> THanks everyone working days and nights!
16:59:58 <frankbrockners> ok... thanks much everyone - Let's all keep fingers crossed
17:00:03 <bryan_att> yes - many thanks!
17:00:08 <frankbrockners> #endmeeting