08:02:58 <joehuang> #startmeeting Multisite Weekly Meeting 2015.06.11
08:02:59 <collabot> Meeting started Thu Jun 11 08:02:58 2015 UTC.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:02:59 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:02:59 <collabot> The meeting name has been set to 'multisite_weekly_meeting_2015_06_11'
08:03:19 <sorantis_> hello
08:03:24 <joehuang> Hi, good morning or afternoon
08:04:07 <Malla> Hi all
08:04:18 <zhipeng> Hi
08:04:20 <xiaolong> Hi
08:04:25 <joehuang> Hi, all, let's start the meeting
08:04:31 <zhipeng> #topic Roll Call
08:04:35 <zhipeng> #info Malla
08:04:39 <zhipeng> #info zhipeng
08:04:44 <zhipeng> #info xiaolong
08:04:49 <zhipeng> #info joehuang
08:04:56 <joehuang> Dimitri in on etherpad
08:05:06 <sorantis_> that's me
08:05:11 <joehuang> OK
08:05:21 <joehuang> Today agenda:
08:05:21 <zhipeng> #info Dimitri
08:05:31 <zhipeng> #topic agenda bashing
08:05:32 <joehuang> Gap analysis for use case 2, use case 4.1.2, use case 4.1.3
08:06:08 <joehuang> Today Colin is not here, so let's start from use case 4.1.2
08:06:25 <zhipeng> #topic Gap Analysis for use cases
08:06:32 <joehuang> Use case is listed at https://etherpad.opnfv.org/p/multisite_usecase_collection
08:06:47 <zhipeng> #link https://etherpad.opnfv.org/p/multisite_usecase_collection
08:07:20 <sorantis_> So, there's already some means for centralized resource management
08:07:30 <joehuang> Centralized resource management required
08:08:12 <sorantis_> For each endpoint in the Keystone endpoint database there's a region column that identifies an OpenStack site
08:08:25 <joehuang> correct
08:08:31 <sorantis_> this, if more than one, will end up in Horizon as a dropdown list
08:08:48 <sorantis_> there are two options that Horizon supports
08:08:55 <joehuang> You have to select one, and jump to that region
08:09:17 <joehuang> You can only see resource information from one region
08:09:19 <sorantis_> Yes, the point is that each API supports regions concept
08:09:40 <Malla> #info Centralized resource management required for multi-site resource management.
08:09:48 <sorantis_> then it's up to the management layer to output this info in a certain way
08:10:21 <sorantis_> so, first of all, I don't think it's VIM related, second, it largely depends on a use-case
08:10:43 <sorantis_> Some may want to consolidate all resources in one view
08:10:56 <sorantis_> some may want to have a clear separation between regions
08:11:23 <sorantis_> but from a technical perspective the enablers already exist
08:11:36 <joehuang> Which one
08:11:40 <zhipeng> I think this doesn't necessaily means that it is beyond VIM
08:12:22 <Malla> In some sense the celimeter will monitor the resource?
08:12:36 <sorantis_> E.g. for each python-<service>client there's an --os-region parameter
08:13:08 <joehuang> python-<service>client retrieve single region single service information
08:13:57 <sorantis_> yes, but if you write a simple script that invokes a command with --os-region as a variable, you'll get output for all regions :)
08:14:29 <sorantis_> for r in regions: show_resources(r)
08:14:29 <joehuang> Yes. Ceilometer can collection some information like CPU utilization,memory usage resource information for monitoring
08:14:59 <joehuang> You can also use tool to boot a VM in each physical host, but we have OpeNStack to manage many physical hosts to boot VM
08:15:24 <zhipeng> guys we need to put stuff with #info to the minutes :P
08:15:41 <zhipeng> so please use the cmd when you think you want to make a point to be recorded
08:15:59 <zhipeng> Hi David
08:16:12 <zhipeng> #info David_Orange
08:16:26 <joehuang> for resource management, it's similar, you can get resource one by one, and put it together
08:16:43 <joehuang> you can also provide a service layer to help you to do that
08:16:50 <sorantis_> #info Keystone supports regions concept as part of an endpoint. This enables communicating with all the registered regions via corresponding endpoints
08:17:23 <Malla> #info promise project is working on resource management, maybe we can get some information if discuss with promise project folks.
08:17:31 <joehuang> You mean send one request per region, then aggregate the response
08:18:07 <sorantis_> this service layer has already been provided and shown on the example of Horizon
08:18:31 <joehuang> "this service layer" promise?
08:18:35 <sorantis_> This could be one way of doing it
08:20:00 <joehuang> does promise support multi-site?
08:20:08 <xiaolong> to make things cear, let's talk about a concret use case: a user wants to know his total virtual resources (cpu, ram, disk) across multiple regions and multiple openstack instances, how can he do that?
08:20:34 <sorantis_> isn't promise all about resource reservation and capacity planning?
08:20:41 <joehuang> Yes, this is much more clear use case
08:20:56 <xiaolong> is there today an API, a took which allow him to do it without additional work?
08:21:16 <joehuang> the question is "promise support multi-region or not"
08:21:30 <sorantis_> can the user use a "for" loop?
08:21:56 <xiaolong> no, if it needs that the user programs himself, it is a problem
08:22:22 <joehuang> and "for loop" to handle tenant management
08:23:27 <joehuang> You have to be careful for multi-tenancy for this simple" for loop"
08:24:00 <joehuang> Let's come back to these multi-site candidate solutions
08:24:18 <xiaolong> second example: a user wants to be notified by all the logs whose alert level is upper that "warn" of all his virtual machines, how can do that today?
08:24:22 <sorantis_> I think creating another layer of APIs just for the sake for hiding a for loop is overkill
08:24:42 <joehuang> Cells, multi-regions. heat+multi-regions, KeyStone federation, not support the centralized resource view well
08:25:13 <sorantis_> can you elaborate why multi-tenancy is something to be careful with?
08:26:08 <joehuang> Sure, One user can only see total resources and utilization for the project the user has role to access
08:27:06 <sorantis_> isn't it a general case for multi-tenancy?
08:27:28 <sorantis_> even for a single site
08:27:38 <joehuang> "for loop" itself not
08:28:05 <Malla> Even it is also the case for single site as well.
08:29:20 <joehuang> If some other upper layer need the resource view, it should be one service layer with API to provide this functionality
08:30:13 <joehuang> From the gap analysis, currently seems that only cascading provides upper layer with API service and centralized resources view
08:30:25 <Malla> guys, if topic what to include in meeting minutes, pls use info.
08:30:25 <joehuang> Any questions on that
08:31:12 <joehuang> Thanks
08:31:41 <sorantis> I was switching the IRC clients :) sorry, for the delay
08:31:57 <joehuang> we are still here
08:32:14 <joehuang> can you see the log before you quit
08:32:50 <sorantis> So, you’re saying that if an upper layer reqests for a global view of the resources there needs to be a layer for such aggregation
08:33:15 <joehuang> So any questions on the gap analysis for the use case 4.1.2
08:33:22 <sorantis> No, the window crashed, so I had to use another client
08:33:40 <sorantis> yes, that I got
08:34:46 <joehuang> Even for promise to do a reservation, promise need to know the resource view
08:36:05 <joehuang> if we have another management layer to do the resource aggreation, then what's API the management layer provides? should promise change it's interface calling
08:36:35 <tallgren> Sorry I have not followed the discussion earlier, but is the idea in 4.1.2 to find what is the least loaded region to run an application?
08:37:03 <xiaolong> let's think more about the user cases, without talk about the presentation layer, is there any more operation we should do beside the simple "for loop", at least, aggregation (sum), sort, select?
08:37:40 <zhipeng> Malla it is getting out of hands, minutes nightmare lol
08:38:12 <Malla> :)
08:38:28 <joehuang> to tallgre:  to make things cear, let's talk about a concret use case: a user wants to know his total virtual resources (cpu, ram, disk) across multiple regions and multiple openstack instances, how can he do that?
08:39:26 <tallgren> Ok, I see. It is not for Nova scheduler to make decision, it is for the cloud operator
08:40:10 <tallgren> or the project owner
08:40:21 <joehuang> Correct
08:40:34 <joehuang> and in multi-site scenario
08:41:49 <joehuang> Any questions on the gap analysis?
08:42:35 <joehuang> Is there any one want to use Cells with shared Nova,Cinder,Neutron...in multisite?
08:43:25 <sorantis> cells probably are best to use withing a large datacenter
08:44:14 <joehuang> If no other questions, let's have a conclusion:
08:45:09 <joehuang> #agreed:From the gap analysis, currently seems that only cascading provides upper layer with API service and centralized resources view
08:45:37 <joehuang> Sorry, Sorantis, your message coming later
08:45:51 <sorantis> well it seems that you have already agreed
08:46:21 <joehuang> #agreed: cells probably are best to use withing a large datacenter
08:47:07 <joehuang> No. I have asked several times, questions. You can still ask questions, can cancel the agreed
08:47:38 <sorantis> for me the stated use-case easily be addressed with a simple iteration
08:48:02 <sorantis> if we are talking just about a global resource view
08:48:05 <joehuang> Ok, Sorantis, we can continue  to discuss use cases 4.1.2. Your ideas
08:48:40 <sorantis> I have already described my ideas
08:48:47 <joehuang> But if you look at the use case 4.1.4
08:49:23 <joehuang> The resource utilization also should be controlled by quatos
08:50:02 <sorantis> Yes, balancing quotas can be achieved in multisite with the current functionality
08:50:23 <sorantis> so which use case are we discussing?
08:50:38 <joehuang> Can you explain more clear: current functionality
08:51:02 <sorantis> nova’s quota usage works only in one region
08:51:22 <sorantis> however even within a single region quotas usage can get out of sync
08:51:29 <joehuang> In fact, total resource view should be the quato the tenant can have
08:52:01 <joehuang> in multi-site scenario
08:52:50 <sorantis> total resource view is a list allocated resources. It’s the quota. Quota is a limit on the amount of each type of resource
08:53:12 <sorantis> quota usage is total view,yes
08:53:29 <sorantis> and this must be synced
08:53:41 <joehuang> You can apply and you have applied
08:54:45 <joehuang> So use case 4.1.2 is so simply "usage" concept
08:55:11 <joehuang> Sorry, wrong type"So use case 4.1.2 is not simply "usage" concept
08:56:05 <sorantis> how  do you mean?
08:56:36 <joehuang> Total resource view means your total quota in multi-site
08:57:59 <sorantis> if we user the same definitions as in nova, neutron, cinder, etc. then quota is a limit you apply on a resource type. Quota usage is the amount of resources currently in use
08:59:43 <joehuang> When the centralized resource management also implys the management of total resources can be used
09:00:57 <zhipeng> #endmeeting
09:03:22 <joehuang> Hello, we have discuss the use case 4.1.2, let's continue discussion next time.
09:03:35 <joehuang> #endmeeting