#opnfv-meeting: Octopus weekly team meeting

Meeting started by uli-k at 14:00:07 UTC (full logs).

Meeting summary

  1. roll call (uli-k, 14:00:31)
    1. Uli (uli-k, 14:00:55)
    2. Dan Radez (radez, 14:00:58)
    3. Fatih Degirmenci (fdegir, 14:01:16)
    4. Jun Li (MatthewLi, 14:01:19)

  2. agenda bashing (uli-k, 14:02:41)
    1. Tim Rozet (trozet, 14:02:58)
    2. I have: Action item review / Feedback Arno maintenance proposal / Proposal for Releng project / Starting work on B-Release (uli-k, 14:02:58)
    3. zhifeng (zhifeng, 14:03:12)
    4. meimei (meimei1, 14:03:16)

  3. action item review (uli-k, 14:04:15)
    1. Action item: 1. uli-k and vlaza check and improve description how to comment on documents (uli-k, 14:04:37)
    2. Bryan Sullivan (bryan_att, 14:04:46)
    3. I didn't have a chance to talk to vlaza, so we have to carry it on. Very sorry. It is already old. (uli-k, 14:05:07)
    4. ACTION: uli-k and vlaza check and improve description how to comment on documents (uli-k, 14:05:18)
    5. Action item: 2. uli-k to send the link to R2 etherpad to community to trigger feedback (uli-k, 14:05:35)
    6. done. (uli-k, 14:05:41)
    7. Action item: 3. MatthewLi2 to prepare zuul demo (uli-k, 14:08:11)
    8. MatthewLi2, last week you said, we can do it on July 6. (uli-k, 14:08:36)
    9. Action item: 4. trozet to prepare RDO/TripleO demo (uli-k, 14:09:29)
    10. AGREED: next week demo RDO/TripleO (uli-k, 14:11:50)
    11. ACTION: radez and uli-k to send out the invitation to mailing list for the demo. (uli-k, 14:17:05)
    12. etherpad.opnfv.org/p/octopusR2 we collect all R2 stuff. (uli-k, 14:23:42)
    13. https://etherpad.opnfv.org/p/octopusR2 (fdegir, 14:27:07)

  4. Feedback Arno maintenance proposal (uli-k, 14:32:24)
    1. https://wiki.opnfv.org/releases/stablebranch (uli-k, 14:32:35)

  5. Proposal for Releng project (uli-k, 14:40:33)
    1. Release Engineering - Releng project was proposed last week 2015-06-23 and sent for community for feedback (fdegir, 14:41:47)
    2. The purpose with proposing releng is to continue what we've been doing in formal way (fdegir, 14:42:31)
    3. During Arno, releng was the place where all automation, CI, tooling was realized (fdegir, 14:43:01)
    4. By the people who knows what is needed and has the expertise (fdegir, 14:43:23)
    5. So, proposed releng project aims to provide service to OPNFV community to cover automation/tooling needs (fdegir, 14:43:59)
    6. This could be realizing input provided by Octopus and creating CI pipelines (fdegir, 14:44:20)
    7. Realizing analytics needs for testing projects by creating scripts, installing tools, and so on (fdegir, 14:44:39)
    8. or other tooling/autoamation needs which we are not aware as of yet (fdegir, 14:45:11)
    9. Other issues we experienced was not having real world coverage (fdegir, 14:46:05)
    10. Proposed releng project aims to provide this as well by having committers from Asia, Europe, and Americas (fdegir, 14:46:27)
    11. Releng committers also come from 5 projects: Octopus, BGS, Functest, Pharos, Docs, LF (fdegir, 14:46:48)
    12. with broad experience in their own areas and automation who can represent their projects, provide input, and more importantly write code (fdegir, 14:47:19)
    13. Minor details is that all committers belong to different companies so we have very broad coverage (fdegir, 14:47:40)
    14. Octopus will continue providing key information when it comes to CI/CD aspects (fdegir, 14:54:27)
    15. and continue writing real stuff in same way in releng repo (fdegir, 14:54:41)
    16. Few of the exampels are: working with upstream, virtualizing deployments, evaluating/employing CI/CD tools, providing guidance to other projects when it comes to CI/CD (fdegir, 14:55:42)
    17. releng project is about automation/tooling (fdegir, 14:56:41)
    18. you can see it as infra project perhaps (fdegir, 14:56:49)
    19. For Octopus people; there is no change in way of working (fdegir, 14:57:53)
    20. except their patches will be reviewed by mopre people (fdegir, 14:58:05)
    21. and gets deployed faster (fdegir, 14:58:11)
    22. which is a huge improvement (fdegir, 14:58:19)
    23. and the tooling work was done on best effort basis by people from different projects (fdegir, 14:59:57)
    24. releng project puts all these contributors together (fdegir, 15:00:16)
    25. making self forming team a real project (fdegir, 15:00:24)


Meeting ended at 15:01:17 UTC (full logs).

Action items

  1. uli-k and vlaza check and improve description how to comment on documents
  2. radez and uli-k to send out the invitation to mailing list for the demo.


Action items, by person

  1. radez
    1. radez and uli-k to send out the invitation to mailing list for the demo.
  2. uli-k
    1. uli-k and vlaza check and improve description how to comment on documents
    2. radez and uli-k to send out the invitation to mailing list for the demo.


People present (lines said)

  1. fdegir (111)
  2. uli-k (93)
  3. bryan_att (36)
  4. MatthewLi (19)
  5. chenshuai_ (9)
  6. trozet (7)
  7. radez (6)
  8. ChrisPriceAB (3)
  9. collabot (3)
  10. meimei1 (2)
  11. frankbrockners (1)
  12. zhifeng (1)


Generated by MeetBot 0.1.4.