16:00:05 <KLuehrs> #startmeeting LSOAPI
16:00:05 <collabot> Meeting started Thu Aug 27 16:00:05 2015 UTC.  The chair is KLuehrs. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:05 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:05 <collabot> The meeting name has been set to 'lsoapi'
16:00:32 <KLuehrs> #chair KLuehrs
16:00:32 <collabot> Current chairs: KLuehrs
16:04:33 <KLuehrs> #topic Status Update
16:09:58 <KLuehrs> #info CableLabs was asked by MEF to help organize the MEF LSO Hackathon in November in Dallas, TX
16:16:29 <KLuehrs> #info CableLabs shared proposed development road map leading up to the MEF LSO Hackathon
16:18:11 <KLuehrs> #info Lance H suggested for the first phase, implement IP transport network with GRE tunnel overlay for EVC implementation. Currently ability to provide Layer 2 service is not in place in all service provider networks (business services over DOCSIS), leveraging IP makes more sense.
16:21:57 <KLuehrs> #info Group was queried: can anyone provide access to a NetConf enabled MEF compliant device? No response.
16:27:51 <KLuehrs> #info James Kim from CableLabs shared MEF plans for the LSO Hackathon. MEF currently plans two sub-projects during the Hackathon: one based on OPNFV Connectivity Services LSO project work and one based on MEF Service Configuration and Activation project.
16:29:54 <KLuehrs> #action James Kim to send Hesham El Bakoury from Huawei information about the MEF Hackathon
16:36:07 <KLuehrs> #info MEF LSO Hackathon goals (1) Contribute API development back to MEF specifications, (2) Contribute API development back to outside projects including OPNFV Connectivity Services LSO.
16:44:24 <KLuehrs> #info Question: Can another controller be used, e.g., ONOS? James Kim responded that for the Hackathon time is limited for preparation and planning so we need to focus on OpenDaylight for now. Kevin Luehrs added that the APIs being developed within LSOAPI will eventually be able to interface via REST to other controllers
16:44:52 <KLuehrs> #info Kevin Luehrs shared the LSOAPI software architecture documentation wiki page.
16:45:29 <KLuehrs> #info Steve Saunders shared the API documentation being developed using RAML. When complete this will be posted to the LSOAPI /documents wiki page.
16:51:03 <KLuehrs> #topic LSOAPI Requirements
16:56:19 <KLuehrs> #info Concern: How does architecture of the software map to an orchestrator? The APIs northbound to OpenDaylight likely belongs in an orchestrator. The focus is on the APIs and we need to find a home for the APIs, e.g., in OpenStack.
16:57:51 <KLuehrs> #info LSOAPI project seeks people with OpenStack expertise to help define where the northbound APIs belong.
16:58:54 <KLuehrs> #info Comment: While the proof of concept focuses on Ethernet eventually the APIs may need to support other transport.
16:59:46 <KLuehrs> We need to consider how an orchestrator will direct the workflow for creating the EVC between UNIs.
17:01:30 <KLuehrs> #endmeeting