15:02:45 <ChrisPriceAB> #startmeeting OPNFV Brahmaputra release planning meeting
15:02:45 <collabot> Meeting started Tue Sep  1 15:02:45 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:45 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:45 <collabot> The meeting name has been set to 'opnfv_brahmaputra_release_planning_meeting'
15:02:55 <ChrisPriceAB> #chair debrascott
15:02:55 <collabot> Current chairs: ChrisPriceAB debrascott
15:02:57 <[1]JonasB> #info Jonas Bjurel (Fuel)
15:03:01 <bryan_att> #info Bryan Sullivan
15:03:05 <anac1> #info Ana Cunha (Yardstick)
15:03:09 <ChrisPriceAB> #chair bryan_att
15:03:09 <collabot> Current chairs: ChrisPriceAB bryan_att debrascott
15:03:15 <ChrisPriceAB> #chair anac1
15:03:15 <collabot> Current chairs: ChrisPriceAB anac1 bryan_att debrascott
15:03:16 <n0ano> o/
15:03:19 <fdegir> #info Fatih Degirmenci (Releng)
15:03:26 <ChrisPriceAB> #info Chris Price
15:03:26 <ashyoung> #info Ashlee Young (ONOSFW)
15:03:28 <uli-k> #info Uli
15:03:32 <ChrisPriceAB> #chair fdegir
15:03:32 <collabot> Current chairs: ChrisPriceAB anac1 bryan_att debrascott fdegir
15:03:37 <billyoma> #info billyoma (VSPERF)
15:03:38 <bin_> #info Bin Hu
15:03:52 <r-mibu> #info Ryota Mibu (Doctor)
15:04:01 <ChrisPriceAB> #info OPNFV Release IRC Channel == (#opnfv-release) to be used for daily release discussions
15:04:21 <ChrisPriceAB> #topic Brahmaputra schedule overview
15:04:36 <debrascott> #info https://wiki.opnfv.org/releases/brahmaputra/release_plan
15:05:00 <ChrisPriceAB> #undo
15:05:00 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c71e10>
15:05:07 <ChrisPriceAB> #link https://wiki.opnfv.org/releases/brahmaputra/release_plan Brahmaputra release plan
15:07:23 <ChrisPriceAB> #info we are finding a new goto bridge with more places
15:07:27 <HKirksey> What’s the GTM info for this meeting
15:07:30 <HKirksey> I’m having trouble joining
15:07:51 <bryan_att> we are getting a new bridge setup
15:07:55 <n0ano> reached limit on number of phone attendees, might be locked out for today, working on it for future
15:07:57 <bryan_att> not enough ports
15:08:13 <lmcdasm> #info Daniel Smith
15:08:18 <trozet> #info Tim Rozet
15:08:27 <HKirksey> #info Heather Kirksey
15:08:28 <hongbotian> info hongbo tian
15:08:28 <hujie> #info Jie Hu
15:08:31 <spirentbrian> #info Brian Castelli
15:08:34 <ChrisPriceAB> #info please use the TSC goto bridge:  https://global.gotomeeting.com/join/798898261
15:08:37 <hongbotian> #info hongbo tian
15:08:58 <ChrisPriceAB> end your first meeting, then swap over.  can't have 2 running
15:11:00 <dneary> ChrisPriceAB, debrascott: What's the meeting # for B release planning? I used 341-956-909 and have been listening to holding beeps for 10 mins
15:11:13 <ChrisPriceAB> #info Milestone C is due on the 25th of September, requiring each project ot have their plans in Jira
15:11:24 <ChrisPriceAB> dneary https://global.gotomeeting.com/join/798898261
15:12:01 <ChrisPriceAB> #info By milestone C we should have our sprints planned, the timing and scope of the sprints and epic/stories to be addressed.
15:12:16 <rex_lee> #info Rex Lee
15:12:21 <ChrisPriceAB> #info Debra reminds us that we will be running a time-boxed release and will cut scope rather than move the dates.
15:12:31 <dneary> ChrisPriceAB, Thanks - https://wiki.opnfv.org/releases/brahmaputra/release_plan needs updating
15:12:41 <ChrisPriceAB> #info this leads to the project being strict on reaching milestones.
15:13:07 <ChrisPriceAB> dneary, Debra's bridge will be the one we use, it's limited to 26 participants at the moment.  to be resolved.
15:13:15 * dneary is (mostly) disconnected today
15:13:38 <ChrisPriceAB> #info Jonas raises the topic of inter-project dependancies and the importance of having those clear by milestone C
15:14:03 <[1]JonasB> #link https://etherpad.opnfv.org/p/artifact_handling
15:15:44 <ChrisPriceAB> #info Debra outlines that both the incoming and outgoing dependancies need to be addressed as part of the planning phase.
15:15:55 <ChrisPriceAB> #topic status reports
15:16:10 <ChrisPriceAB> #info Debra asks that projects participating provide status reports
15:16:42 <ChrisPriceAB> #info Debra would like to have each project # info in their status during these meetings.  However it would be difficult to address all issues in real time on the calls.
15:17:25 <ChrisPriceAB> #info Debra outlines that having status reporting via the web by Fridays, where these can be checked, will give everyone a chance to review those prior to the project meetings.
15:18:30 <ChrisPriceAB> #info Ray outlines that using Jira for up to date information will allow collaboration across timezones.
15:19:10 <ChrisPriceAB> #info Billy provides the suggestion that we maintain a single brahmaputra release page to keep track of all project information.
15:20:00 <hujie> # info Escalator is working on requirements and we are waiting for othe projects' feedbacks for a questionnarie
15:20:01 <bryan_att> can't we focus all this in Jira?
15:20:09 <hujie> #link https://wiki.opnfv.org/_media/wiki/opnfv_escalator_questionnaire_20150723.pptx
15:20:16 <bryan_att> any red flags could be clear from Jira
15:20:28 <ChrisPriceAB> true Bryan
15:20:33 <fdegir> we can label the R2 backlog items with a common label
15:20:38 <hujie> #link https://docs.google.com/forms/d/11o1mt15zcq0WBtXYK0n6lKF8XuIzQTwvv8ePTjmcoF0/viewform?usp=send_form
15:20:52 <ashyoung> #info ONOSFW status https://wiki.opnfv.org/collaborative_development_projects/onosfw
15:21:02 <fdegir> and then it is a simple query on jira to see what's outstanding
15:21:02 <bryan_att> we can add any details we need to Jira I think
15:21:13 <fdegir> what's completed
15:21:30 <fdegir> dependencies between issues under different projects can also be created on jira
15:22:01 <fdegir> and we need to write good definition of done/acceptance criteria for issues to make sense
15:22:12 <corenova> can anyone share the link to GTM again? thanks
15:22:18 <ChrisPriceAB> https://global.gotomeeting.com/join/798898261
15:23:06 <fdegir> the items in the project backlogs can be prioritized as well
15:23:21 <fdegir> to see the laggong items/risks
15:24:27 <bryan_att> +1 to one tool to rule them all
15:24:28 <ChrisPriceAB> #action fdegir and debra and others to craft a proposal on how we might achieve tracking and logging to present to the community
15:24:35 <ashyoung> bryan_att that sounds good once we get to milestone C and have tasks. But A & B are before that point.
15:24:44 * ChrisPriceAB never underestimates the power of the dark side...
15:24:51 <RayNugent_> Jira is the right place to do this
15:24:51 <ChrisPriceAB> oops wrong movie
15:25:07 <ChrisPriceAB> ash, we have passed A&B  :DS
15:25:24 <ChrisPriceAB> #topic concerns and questions form the community
15:26:19 <ChrisPriceAB> #info ashyoung voices some concerns around infrastructure tools.  ashyoung is having trouble getting code reviews done.
15:26:50 <ChrisPriceAB> #info ashyoung also has concerns on getting developer resources to have hands on access to LF resources.
15:29:10 * ChrisPriceAB is now muted
15:29:32 <ashyoung> ChrisPriceAB yep. I know. I've completed both A & B milestones. I'm in the middle of C, but this is a bit of chicken and egg. We need C completed to report the status of C tasks :)
15:30:15 <ChrisPriceAB> #info fatih comments that we lack resources for CI and releng.  Accessing LF resources is not a solution, an the hope if that Pharos can help facilitate community resource scaling.
15:30:47 <ChrisPriceAB> #info people start beating the pharos team (virtually), we need more pharos resources to help beat back...
15:30:58 <MR_Sandvine> #info Manuel R
15:31:15 <corenova> #info Peter Lee
15:31:38 <lmcdasm> +1 to the question - is there a deliverables list overall?
15:31:39 <corenova> do we have Agile plugin available in Jira? It looks like it is
15:31:39 <corenova> unlicensed for our project
15:32:02 <ChrisPriceAB> #info dneary ask if there is a brahmaputra scope available
15:32:14 <ChrisPriceAB> #info Debra responds that this should be complete at Milestone C
15:35:35 <ChrisPriceAB> #info Debra clarifies that after milestone C, no projects will be able to join the Brahmaputra release
15:40:11 <ChrisPriceAB> #info it is made clear that infrastructure projects need to have requirements on them clear by milestone C.
15:40:15 <ChrisPriceAB> #topic project roll call
15:40:23 <trozet> #info Apex
15:40:25 <ChrisPriceAB> #info Chris Price opnfvdocs
15:40:32 <uli-k> #info Uli Octopus
15:40:39 <billyoma> #info VSPERF (billyoma for Maryam Tahhan)
15:40:40 <trevor_intel> #info pharos
15:40:42 <ashyoung> #info Ashlee Young ONOSFW
15:40:43 <morgan_orange> #info Morgan Functest
15:40:45 <StuartMackie> OpenContrail Virtual Networking
15:40:52 <corenova> #info Peter Promise
15:40:52 <bin_> #info IPv6
15:40:54 <hongbotian> #info hongbo bottlenecks
15:40:58 <[1]JonasB> #info Jonas Bjurel (fuel)
15:41:00 * rex_lee #info Rex Lee on Resource Scheduler
15:41:01 <hujie> #info hujie Escalator
15:41:07 <bryan_att> #info Bryan copper
15:41:08 <r-mibu> #info Ryota Doctor
15:41:11 <fdegir> #info Fatih Degirmenci Releng
15:41:18 <anac1> #info Ana Cunha (Yardstick)
15:41:24 * ChrisPriceAB is happy to see our project leads well represented!!!
15:41:28 <bin_> #info Bin IPv6
15:42:16 <ChrisPriceAB> #topic Project dependancies
15:42:50 <ChrisPriceAB> #info Debra outlines the needs for projects to be very clear on their dependencies by milestone-C, or a pre-milestone checkpoint on dependancies.
15:43:35 <ChrisPriceAB> #info bryan_att states it would be helpful to project leads to know what types of requirements the infra teams need to know about.
15:43:45 <ChrisPriceAB> #undo
15:43:45 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x29d8990>
15:43:51 <ChrisPriceAB> #info bryan_att states it would be helpful to project leads to know what types of requirements the infra and test teams need to know about.
15:44:23 <ChrisPriceAB> #info anac1 outlines the need to know what type of testing needs to be done for each project.  What is the SUT and which project is best suited to work with the project.
15:44:34 <bryan_att> should these requirements be communicated through Jira?
15:44:47 <ChrisPriceAB> I think so!
15:45:00 <VikramDham_> VikramDham -> QTIP project
15:45:08 <ashyoung> But who should we issue a ticket to, as a project lead?
15:45:20 <ChrisPriceAB> #info anac1 outlines that this is best done in Jira to make it clear what requirements are existing between projects.
15:45:23 <bryan_att> similar type of "these are the types of things you can request from us" input is needed from the CI and infra teams
15:46:10 <bryan_att> e.g. I know that we will add Congress to the CI pipeline - but I intend to submit patches myself - not sure what the CI team will need to do, really
15:46:24 <ChrisPriceAB> #info morgan_orange outlines the need to have a test plan ready by september is going to be very hard.
15:46:33 <ChrisPriceAB> #undo
15:46:33 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x29d8150>
15:46:36 <ChrisPriceAB> #info morgan_orange outlines the need to have a test plan ready by september is going to be very hard to achieve.
15:47:11 <bryan_att> for testing, I intend to develop test plans and scripts for configuration through VNFM/NFVO test drivers and policy tests using Congress - but I will submit them, not expect others to develop them...
15:47:36 * ChrisPriceAB cheers for bryan_att
15:48:03 <ChrisPriceAB> #info Debra asks for clarification from the installer infra team on what is required.
15:48:52 <ChrisPriceAB> #info Jonas outlines that Genesis can respond next week as well on the needed requirements.  They will need to know how artifacts will be packaged, package dependancies and versions, and sample manifests that will be delivered.
15:48:56 <fdegir> bryan_att: you at least need someone to review your patches
15:49:16 <fdegir> and we might be useful time to time
15:49:47 <bryan_att> fdegir: yes, there is some minimal expectation on others, but this is part of being in the community... we don't have to say "i expect someone to review my input"... it should just happen
15:50:01 <fdegir> bryan_att: yes
15:50:12 * ChrisPriceAB thinks some Jira and some Gerrit training is needed
15:50:38 <bryan_att> fdegir: and i do appreciate the reviews by anyone who has the time!
15:50:42 <ChrisPriceAB> #link https://etherpad.opnfv.org/p/artifact_handling detailed overview of the dependancies for installers
15:51:00 <fdegir> bryan_att: reviews are good for learning and fun
15:51:11 <VikramDham_> agree with Chris regarding Jira and Gerrit training
15:51:27 <trozet> fdegir: fun eh? I'll add you to more reviews then :)
15:51:35 <corenova> bryan_att: will help on that
15:51:44 <fdegir> trozet: I am already watching genesis
15:51:55 <trozet> fdegir: Apex incoming :)
15:52:15 <hujie> When we can get the training of Jira?
15:58:39 <fdegir> trozet: subscribed to that one as well - I can at least point the whitespaces in worst case
16:01:18 <bryan_att> we are oot...
16:03:54 <ChrisPriceAB> notebook is dying, will wrap up here.  goto will die when my PC does too
16:04:00 <ChrisPriceAB> #endmeeting