15:00:39 <frankbrockners> #startmeeting OPNFV BGS/Genesis weekly meeting
15:00:39 <collabot> Meeting started Mon Sep 14 15:00:39 2015 UTC.  The chair is frankbrockners. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:39 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:39 <collabot> The meeting name has been set to 'opnfv_bgs_genesis_weekly_meeting'
15:01:08 <Jonas2> #info Jonas Bjurel
15:01:10 <morgan_orange> #info Morgan Richomme
15:01:15 <dduffey> #info David Duffey
15:01:32 <trozet> #info Tim Rozet
15:01:45 <frankbrockners> #info Frank Brockners
15:02:01 <bryan_att> #info Bryan Sullivan
15:02:39 <davidmichaelkarr> #info David Karr
15:02:52 <frankbrockners> #info draft agenda for today: https://wiki.opnfv.org/meetings/bgs#sep142015
15:02:53 <chenshuai> #info chenshuai
15:02:54 <ashyoung> #info Ashlee Young
15:03:01 <lmcdasm> #info Daniel Smith (Ericsson)
15:03:05 <fdegir> #info Fatih Degirmenci
15:03:35 <lmcdasm> anyone have the GTM number handy? (i dont have my laptop open).
15:03:51 <dduffey> Long distance
15:03:51 <dduffey> :
15:03:51 <dduffey> +1 (312) 757-3119
15:03:51 <dduffey> Access code
15:03:51 <dduffey> :
15:03:52 <dduffey> 158-935-301
15:03:54 <lmcdasm> thx
15:04:09 <fdegir> isn't it irc only?
15:04:12 <dduffey> sorry for the 6 lines, bad cut-and-paste
15:04:22 <dduffey> I think it is irc only, no presenter/talkers on the call
15:04:25 <morgan_orange> I will be on IRC only
15:04:44 <frankbrockners> thanks.. yes - IRC only
15:04:45 <lmcdasm> thx - i wasnt sure (so  many meetings)
15:04:56 <arturt> #info Artur Tyloch
15:05:00 <frankbrockners> on the agenda: anything else to add?
15:05:07 <debra> #info Debra
15:05:30 <ebrjohn> Hello, Brady here, is this the Genesis meeting? and are you on GoTo?
15:05:31 <bryan_att> agenda - status and process for project dependencies
15:05:33 <lmcdasm> FrankB: - arey ou going to address the link between project-->BGS/GENESIS --> installers via third bullet?
15:05:35 <frankbrockners> as usually we'll have two main topics - BGS and Genesis
15:05:37 <lmcdasm> if not then i think that should be added.
15:05:58 <lmcdasm> Brady - yes - genesis - no GTM
15:06:14 <frankbrockners> lmcdasm: yes - we're going to address this as "how to work with Genesis"
15:06:16 <ebrjohn> lmcdasm: thanks
15:06:19 <lmcdasm> thank you
15:06:26 <frankbrockners> ok - let's get rolling
15:06:32 <bryan_att> frankbrockners:  was that agenda item add clear?
15:06:37 <frankbrockners> #topic BGS - Arno SR1 status
15:06:57 <ebrjohn> frankbrockners: sorry, one additional item, Jonas Bjurel suggested I join to discuss the OPNFV SFC Genesis requirements
15:07:15 <frankbrockners> bryan_att: https://wiki.opnfv.org/meetings/bgs#sep142015 - work procedures bullet
15:07:19 <Jonas2> Welcome ebrjohn
15:07:33 <trozet> #info SR1 development pretty much complete, radez is just updating the build and I need to finish docs, but all other bugs are closed for Foreman
15:07:49 <frankbrockners> ebrjohn: thanks - let's add this
15:08:04 <frankbrockners> thanks trozet
15:08:08 <radez> #info Dan Radez
15:08:21 <morgan_orange> #info for Functest we are not able to test all the scenario (stable/master on foreman/fuel) because auto installation is failing on LF pOD2
15:08:38 <morgan_orange> #info auto reconfig of POD leads to network issue
15:08:47 <Jonas2> #info Fuel SR1 pretty much frozen, remaining items: local repo mirror, docs.
15:09:02 <morgan_orange> #info Jose and Peter spent time testing it on LF POD2
15:09:09 <frankbrockners> Jonas2: what does local repo mirror mean?
15:09:37 <morgan_orange> #link https://build.opnfv.org/ci/computer/opnfv-jump-2/
15:10:19 <Jonas2> frankbrockners: With Fuel 6.1, the repos are not part of the .iso any longer, so we need to have a local package mirror
15:10:47 <trozet> morgan_orange: it looks like foreman is failing because of 172.30.8.75 is still power on, even after clean
15:11:47 <frankbrockners> Jonas2: Does releng provide for that local mirror?
15:12:04 <morgan_orange> trozet: it is a consequence of using only 1 POD for all the installers . The reconfig of the underlay is not fully clean
15:12:18 <Jonas2> frankbrockners: We will provide that through fuel
15:13:02 <frankbrockners> Jonas2: Not sure I fully follow - but let's take this offline
15:13:08 <morgan_orange> at the moment only 1 deploy has been successfull since 48h (last fuel master) all the other attemps failed (fuel stable, foreman stable and master)
15:13:30 <trozet> morgan_orange: ok do we need to get pbandzi to look at the UCS?  I will take a look as well
15:13:50 <morgan_orange> pbandzi is already looking at these issues with Jose
15:13:56 <frankbrockners> pbandzi is out 'till Thursday this week
15:14:44 <Jonas2> frankbrockners: Fuel 6.1 works pretty much as forman did in Arno/SR0, pulls packages from upstream repo while installing. We dont want tha, thats why we build a local package mirror at buildtime, which will be colocated with Fuel.
15:15:39 <bryan_att> that will be much better. otherwise the install is more fragile
15:16:03 <lmcdasm> also - without a frozen local repo
15:16:14 <frankbrockners> so in summary for SR1 status it seems as if (a) both Fuel and Foreman/Quickstack are code development ready; (b) there are test/deployment issues which are pending a resolution of LF lab config fixes
15:16:16 <lmcdasm> you dont know if you are testing what you actually released before / no real "Freeze"
15:16:57 <Jonas2> lmcdasm: Agreed, the old discussion we had back during the Arno/SR0 days:-)
15:17:10 <lmcdasm> never addressed - swept under the carpet
15:17:16 <lmcdasm> we are doing this again in this release and SR1
15:17:27 <lmcdasm> would be good to have a final word from TSC on whether we delivery SW or NOT
15:17:30 <lmcdasm> as a requirement
15:17:36 <lmcdasm> deliver*
15:18:10 <Jonas2> lmcdasm: Actually there is a Genesis Jira issue for the B-release that sais that it must deploy without connectivity.
15:18:18 <lmcdasm> ahh.. thx Jonas
15:18:18 <lmcdasm> :)
15:18:21 <trozet> lmcdasm: what are we missing here?
15:18:48 * trozet can try to look into UCS and figure out the infra problem
15:19:06 <frankbrockners> thanks tim
15:19:06 <lmcdasm> trozet: perhaps nothing - if you and all other installers are meeting that requirement - i/e that all SW is self contained in installer releases and no internet connectivity is required
15:19:20 <lmcdasm> then great! (didnt know about the requirement).
15:19:29 <frankbrockners> #info trozet to look into the LF config issues that the testing team observes
15:19:37 <trozet> lmcdasm: for Arno and SR1 we tag any local repos, so we know its frozen
15:19:38 <ashyoung> I'm glad that requirement is there
15:19:41 <lmcdasm> if we have installers that are still using links to get SW packages during installation - then that needs to be corrected
15:19:47 <lmcdasm> but thats not good enough Tim
15:20:01 <lmcdasm> you have to delivery the SW - you have to assume no one has connectivity outbound
15:20:05 <ashyoung> Does the requirement say how the artifacts should be packaged?
15:20:20 <trozet> lmcdasm: yeah that will be fixed in B release
15:20:23 <chenshuai> lmcdasm: we have this jira ticket
15:20:42 <frankbrockners> let's keep Arno SR1 separated from B-river
15:21:56 <frankbrockners> for Arno SR1 we should follow what we've done for Arno - i.e. install the jumphost from the .iso but assume that the jumphost and all other hosts have internet connectivity
15:22:19 <frankbrockners> *unless* we have consensus here to change this to "no Internet connectivity"
15:23:22 <frankbrockners> trozet, Jonas2: ok?
15:23:37 <Jonas2> frankbrockners: OK
15:23:44 <trozet> frankbrockners: yeah we are not changing that for SR1, that is correct
15:24:49 <frankbrockners> #info Arno SR1 install procedures and requirements will be the same as for Arno, i.e. jumphost installs from a bootable .iso - but further installation of hosts can assume Internet connectivity
15:25:52 <frankbrockners> given that we have quite a few moving pieces towards SR1, the idea was brought up by Morgan and Fatih to have a regular brief synch meetings like we did for Arno
15:26:26 <frankbrockners> in those meetings we'd discuss progress and open issues really briefly - so 15-30min max per day
15:26:30 <Jonas2> frankbrockners: Too many meetings - really!
15:26:57 <frankbrockners> ok - one voice against a regular synch meeting...
15:27:02 <frankbrockners> any other takers?
15:27:05 <trozet> frankbrockners: I like the idea of a daily meeting at this point, its getting close to release time
15:27:12 <trozet> just keep it 30 min or less
15:27:21 <Jonas2> frannkbrockners - not every day at least
15:27:25 <frankbrockners> my target would be 15min
15:27:37 <morgan_orange> if I come back to the CI thread, today we (functest) are not able to test simply because the installations failed on POD2
15:27:44 <frankbrockners> how about Mon/Wed/Fri
15:28:04 <morgan_orange> wxhen installation is fined, functest usually is fine (we have only 1 bug on ODL)
15:28:17 <frankbrockners> morgan_orange - the idea of the synch meetings would be to surface those issues and track them
15:28:22 <morgan_orange> yes
15:28:26 <morgan_orange> 15 minutes is enough
15:28:37 <Jonas2> frankbrockners: Ok, what time?
15:29:00 <frankbrockners> how about 15min at 9am PDT (=4pm UTC) on Mon/Wed/Fri - IRC only
15:29:09 <morgan_orange> 15 minutes as first item of weekly monday BGS meeting?
15:29:20 <frankbrockners> good point
15:29:22 <Jonas2> frankbrockners: OK
15:29:39 <frankbrockners> that means Monday as weekly - plus Wed and Fri
15:30:07 <chenshuai> monday? after this meeting?
15:30:09 <frankbrockners> should we do 8am PDT (3pm UTC) instead
15:30:15 <frankbrockners> then it is always the same time
15:30:19 <frankbrockners> of the day
15:30:31 <frankbrockners> chenshuai - no as part of this meeting
15:30:51 <Jonas2> All: We are now half way into the meeting and we havent started with the b-river. Its there we have the challenges!
15:31:17 <frankbrockners> Jonas2: Ack - but SR1 needs attention as well..
15:31:22 <frankbrockners> so proposal again:
15:31:30 <morgan_orange> 10 minutes 3PM UTC on Mon/Wed/Friday + a wiki page to teack the status (assuming that the goal is to have a CI up& running install/deploy/functest for both installers on both versions
15:31:48 <frankbrockners> thanks morgan_orange
15:32:06 <frankbrockners> ok for everyone?
15:32:38 <Jonas2> frankbrockners: OK
15:32:49 <frankbrockners> #info Arno SR1 status meetings and tracking: 10 minutes 3PM UTC on Mon/Wed/Friday + a wiki page to teack the status (assuming that the goal is to have a CI up& running install/deploy/functest for both installers on both versions
15:33:50 <frankbrockners> #info for status tracking we can use the already existing https://wiki.opnfv.org/releases/arno/stablerelease_1 page
15:34:09 <frankbrockners> per Jonas2 - let's move on to the next topic... Release 2
15:34:31 <frankbrockners> #topic Genesis
15:34:38 <frankbrockners> #topic Genesis - work procedures
15:35:21 <frankbrockners> #info for now, we have two wikis with complementary info https://wiki.opnfv.org/genesis/integration_guidelines and https://wiki.opnfv.org/genesis/genesis_work_procedures
15:35:29 <Jonas2> We have received three integration requests
15:36:01 <frankbrockners> proposal: merge them into one - and require folks to use Jira rather than email to create requests.
15:36:32 <frankbrockners> would that be ok (I can create a merged proposal - unless someone else wants to do that)
15:36:34 <frankbrockners> ?
15:36:47 <trozet> frankbrockners: in a genesis email when you were gone, the consensus we had was that folks didn't want members outside of genesis to create requests in JIRA
15:36:55 <trozet> frankbrockners: in a genesis meeting*
15:36:59 <ashyoung> This going in circles
15:37:01 <Jonas2> frankbrockners: should it be genesis Jira requests?
15:37:02 <lmcdasm> yup
15:37:06 <lmcdasm> +1ash
15:37:18 <ashyoung> your procedure on your wiki says to send email and discuss
15:37:42 <bryan_att> I think all projects should have one member in Genesis - to address the issue of how to get their requirements integrated
15:37:57 <lmcdasm> also - should projects create the JIRA in thier own project, in genesis - or in the installer they want? we are assuming that all installers will pick up all reqs from projects?
15:38:09 <lmcdasm> that seems a bit far  - is it not that projects set a requirement to be installed on ZYX?
15:38:19 <lmcdasm> again - the process from project to genesis to installer is super fuzzy
15:38:34 <bryan_att> it's assumed that it won't be as simple as saying "please integrate this software" - and that it gets done without direct project support in genesis
15:38:51 <lmcdasm> hmm. im super confused then
15:39:02 <lmcdasm> since thats how the three reqs you put from copper came out last week (or the way i read them).
15:39:08 <frankbrockners> https://wiki.opnfv.org/genesis/genesis_work_procedures already states that the logic is bottoms up
15:39:31 <lmcdasm> sigh - thats not a process Frank
15:39:37 <lmcdasm> thats a page of steps on how to create a ticket
15:39:39 <frankbrockners> i.e. if you have something to be integrated, you need to do the work and bring the code
15:39:46 <lmcdasm> im looking for a proces spage that says from Project A wants B on all installers
15:39:57 <Jonas2> frankbrockners: On what project should the Jira request be issued?
15:39:58 <bryan_att> for copper that was the scope of the request - I was following a template suggested - but we are here in this project to make it happen
15:40:02 <lmcdasm> submits to genesis, genesis talks to all installers and they set requirement or something
15:40:22 <lmcdasm> how does it work once the story is created is what im trying to understand
15:40:38 <lmcdasm> thx for the answer bryan..
15:40:42 <ashyoung> I also followed the provided template
15:41:01 <debra> other projects can set a dependency on a genesis task in jira and vsv
15:41:02 <frankbrockners> lmcdasm - that is what I was proposing to flash out in details with merging the two wikis
15:41:12 <lmcdasm> as it is now, i we have project opening JIRAs in genesis that will result in something in an installer Project?  Why the three hops?
15:41:20 <frankbrockners> in essence it would be: (a) I have a new requirement for all installers.
15:41:37 <frankbrockners> if so then (b) I create the integration for all the installers (i.e. create the code)
15:41:56 <debra> no one should enter  a task in Jira for genesis if they are not on the genesis team
15:41:58 <frankbrockners> if done then (c) I raise a request through Jira with the Genesis team
15:42:24 <frankbrockners> (d) Genesis team will review, test, and make sure that the code really works and fits
15:42:29 <debra> you have to keep control of your own project scope
15:42:33 <lmcdasm> ?
15:42:41 <frankbrockners> and vote whether it would be taken on as a general requirement
15:42:45 <lmcdasm> ok - hmm. how will genesis do that verify on all installers
15:42:53 <trozet> +1 debra
15:42:58 <lmcdasm> and what happens to the work the project did when genesis comes back weeks/ later and says no?
15:43:15 <lmcdasm> anyway - thanks for the explanation - would be great to a see a documented flow chart or something with a Process
15:43:28 <lmcdasm> so people know and can ask questions to reference against (maybe im a brokwn record now).
15:43:45 <trozet> lmcdasm: some of your questions have answers on the wiki
15:43:50 <frankbrockners> lmcdasm - I can do this - but this was my understanding so far
15:44:00 <lmcdasm> trozet - im looking at the wiki and i dont see a process flow
15:44:14 <lmcdasm> the gates that show how a project created that req A - the format for getting inclusion into JIRA
15:44:22 <lmcdasm> and i really dont see how the intsallers are invovled
15:44:29 <lmcdasm> since not all installers are part of gensis..
15:44:31 <frankbrockners> so in essence: if you have a common requirement, then you need to also bring the code to provide for the common solution
15:44:41 <lmcdasm> anywa - thanks for the discussion..
15:44:47 <trozet> lmcdasm: https://wiki.opnfv.org/genesis/integration_guidelines <---  If your requirement is not approved, then you may choose to engage in a particular installer to see if you could be part of their installers as non-official Genesis requirement.
15:45:06 <lmcdasm> thx.
15:45:18 <lmcdasm> so this means all intsallers have to be a par of genesis by default
15:45:27 <lmcdasm> or you have genesis making decisions for other projects without input
15:45:53 <lmcdasm> anyway - seems like everyone by Ash and i understand the process.
15:46:14 <lmcdasm> so please continue and i will continute to read and ask questions to Debra and othersin the mail thread
15:46:50 <frankbrockners> so back on the earlier question: Should I take a stab at integrating the two wikis - or trozet, do you want to take a stab?
15:47:36 <Jonas2> franbrockners: Who doesnt matter to me.
15:47:37 <trozet> frankbrockners: I think my process is better, but everyone may not agree.  If you want to combine them please go ahead
15:48:13 <Jonas2> So what is the deadline for the integration requests? Sep 21?
15:48:24 <frankbrockners> trozet - ok - let's do this jointly
15:49:24 <frankbrockners> Milestone C is Setp/25
15:49:43 <frankbrockners> so in theory, other projects should have their requests in by Sept/25
15:50:20 <Jonas2> frankbrockners: If I should have a plan Sep 25, I need to know what is comming into fuel before that.
15:50:37 <debra> frankbrockners they need to have their request to you with enough time for you to process before Sep 25
15:50:59 <ebrjohn> +1 debra
15:51:07 <lmcdasm> Debra - a question - two weeks ago i brought this up to you in your project meeting
15:51:21 <ashyoung> So, does this mean you want our projects to issue Jira tickets to you?
15:51:24 <lmcdasm> have you ap lan to deal with the gap between projects and into installer so isntallers can handle their own stuff + the stuff from projects?
15:51:29 <lmcdasm> have you a plan*
15:51:30 <ebrjohn> #info ebrjohn Brady Johnson
15:51:49 * ebrjohn info'd in just in case... now you know who I am :)
15:51:50 <frankbrockners> debra - you won't be able to process a request until folks also show you the integration code for all installers
15:52:10 <frankbrockners> IMHO we should first gather the tickets and then decide which ones to pick up
15:52:21 <ashyoung> This crazy!!!!
15:52:35 <frankbrockners> and I don't expect that integration code will be there by Sep/25
15:52:39 <ashyoung> I love not getting a response to a question
15:53:02 <frankbrockners> ashyoung: Sorry - could you repeat the question?
15:53:04 <ashyoung> You guys can't even agree on email request vs Jira
15:53:14 <debra> lmcdasm, ashyoung, we may need to set offsets in the milestones of too many projects are later. We don't want to set them yet as we want to push as many as possible to actually meet the deadlines
15:53:16 <ashyoung> Do we issue a jira ticket to your project
15:53:32 <ashyoung> so how do we get requests to you?
15:53:38 <lmcdasm> ok - when can we start to see some solid plans for the relase?
15:53:51 <ashyoung> I am simply trying to figure out what do I need to do
15:53:56 <lmcdasm> its been 4 weeks i have brought some stuff up and no answers.. we are talking about a release in 10 days from today
15:53:59 <frankbrockners> ah - I believe trozet clarified this earlier: Email request first, which is then transformed into a Jira ticket
15:54:06 <debra> frankbrockners- intent to join and being successful at joining are 2 different things. They should give you intent now so you have them planned in your scope.
15:54:13 <ashyoung> ok
15:54:13 <lmcdasm> but there is no mention of how to dela with the gap brought up - not input from Frank or Debra on the emails or ask questions popped up
15:54:15 <ashyoung> thanks!
15:54:27 <lmcdasm> and each meeting we are talking about tickets and JIRA - when the way this is coming together for the people doing the coding is not clear
15:54:36 <Jonas2> debra: +1
15:54:47 <bryan_att> frankbrockners:  we are mote than happy to create the Jira ticket ourselves - is that what you want?
15:55:37 <frankbrockners> bryan_att: trozet said that there was a different process agreed - trozet, could you just restate the consensus?
15:56:00 * bryan_att ok sorry perhaps distracted
15:56:29 <ebrjohn> Looks like we wont get to the SFC Genesis requirements today
15:56:42 <trozet> frankbrockners: Well I think Jonas +1 the integration guidelines I proposed, if no one else disagrees then...
15:57:00 <trozet> frankbrockners: which is email format liek others have done, then we discuss your requirement in a meeting to form a JIRA requirest
15:57:02 <frankbrockners> trozet: thanks - which means email first
15:57:02 <trozet> request*
15:57:25 <trozet> sorry to those who joined from their respective requirements and we are not getting to that discussion
15:57:28 <Jonas2> And what is the deadline?
15:57:55 <lmcdasm> sorry - i cant +1 cause i dont see how it will work - who picks up the first ticket, how does the genesis decision making happen for requiremensts (just a argument in IRC / is there a method) - how will this flow from Gen to projects (will another ticket in the JIRA for that installer project be created)..
15:58:00 <Jonas2> In last weeks meeting we proposed Sep 21
15:58:17 <ebrjohn> trozet: thanks for that, just let us know what else we need to do to get our requirements in
15:58:30 <debra> after the milestone C use a change management  process in your project as needed. i.e. exception process for those coming late. This means you have control over whether they can join late or not.
15:58:50 <frankbrockners> Jonas2: Let's do Sep/21 then - to have folks articulate their "desire"
15:58:55 <trozet> ebrjohn: will do
15:59:23 <Jonas2> #info Deadline for integration requests is Sep 21
15:59:28 <debra> frankbrockners +1
15:59:56 <frankbrockners> ebrjohn - specifically on SFC - the key thing would be to articulate that you expect to create the integration / code for the different installers (or better: supply a pointer if the code is already available)
16:00:02 <Jonas2> frankbrockners: Will you let TSC know the deadline?
16:00:24 <frankbrockners> Jonas2: I can ask Chris for 2 min on the TSC call tomorrow
16:00:30 <frankbrockners> and get the word out
16:00:54 <frankbrockners> Let's also send email
16:00:55 <trozet> frankbrockners: I suggest we have a gtm to discuss requirements with each installers with real voice :)
16:00:57 <debra> frankbrockners communicate this in as many channels as possible
16:01:01 <lmcdasm> 4 business days for all projects to get that stuff in - a little short huh?
16:01:13 <ebrjohn> frankbrockners: ok, then Genesis will at some point later accept or reject it, right? What happens if its rejected?
16:01:22 <ebrjohn> Do we throw the code away?
16:01:23 <frankbrockners> Sep/21 is one week from now
16:01:27 <ashyoung> At the beginning of the call, it was stated that you had several requests now. Can you confirm what projects you have received them from?
16:01:43 <frankbrockners> ebrjohn - installers can still pick the code up
16:01:45 <lmcdasm> ebrjohn +10 your question - asked a couple times
16:01:47 <debra> ebrjohn, if rejected it could be postponed until next sr release
16:01:52 <trozet> ashyoung: Copper, SFC, ONOSFW, let me check if there are others
16:02:18 <lmcdasm> frank - can you elaborate on what you mean - "installers can pick up the code"
16:02:20 <Jonas2> I have seen SFC, OVS, Copper (Im unsure if I also saw ONOS).
16:02:22 <ashyoung> Cool! Thanks1
16:02:24 <lmcdasm> if Gensisi said no - how would that work?
16:02:27 <debra> or next possible release
16:02:36 <frankbrockners> trozet: Did you discuss how to track the email requests in the last meeting?
16:02:41 <ebrjohn> debra: Until next release, and in the meantime, the project cant install :(
16:02:41 <bryan_att> I assume that projects can always publish post-install customizations if genesis does not accept it, or it's too late
16:02:44 <ashyoung> ONOS isn't a project. It's ONOSFW
16:02:46 <debra> lmcdasm, they may just say no for this release, not "no" forever
16:02:52 <trozet> frankbrockners: no we should add them to a wiki though
16:02:58 <ashyoung> I've asked for that Jira ticket to be fixed
16:03:00 <bryan_att> as artifacts of the B release
16:03:38 <lmcdasm> great - do we have the criteria and method that all installers will analyze requirements - dispute resolution (2 installers say yes, one says no - what dod we do?).
16:03:47 <debra> bryan_att +1
16:03:49 <trozet> lmcdasm: its majority rules
16:03:56 <lmcdasm> HAHA
16:04:18 <frankbrockners> lmcdasm - https://wiki.opnfv.org/genesis/governance
16:04:50 <trozet> lmcdasm: and that is clearly stated on the wiki^
16:04:51 <lmcdasm> ok - but that is to the genesis repo - we are talking about project requirements that pass through genesis to an installer project
16:05:00 <lmcdasm> ok - very good..
16:05:08 <frankbrockners> ok - prior to closing - in past Genesis meetings, there were already a couple of AIs on specific requirements
16:05:18 <frankbrockners> http://ircbot.wl.linuxfoundation.org/meetings/opnfv-meeting/2015/opnfv-meeting.2015-08-31-15.00.html
16:05:24 <lmcdasm> thanks for the clarity on code commits to genesis.. if i get it.. a requirement will be approved.. then genesis will take the installer code and do the deliveyr.. great!!
16:05:27 <bryan_att> I suggest we have a TSC vote on certification of any genesis objection to incorporating requirements  - this should be an exception and the reasons eg. logistics/feasibility are important for the community to understand and agree to
16:05:50 <frankbrockners> have we taken GENESIS-7 to a patch in Gerrit?
16:05:56 <Jonas2> frankbrockners: in your genesis repo structure proposal you have one file covering all Jira requests, to better accomodate for voting - wouldnt it be better to have one file per Jira?
16:06:02 <bryan_att> for community cohesiveness at least
16:06:19 <frankbrockners> Jonas2
16:06:31 <trozet> frankbrockners: we need to take some of the basic requirements to a vote in gerrit.  I have not taken any into Gerrit yet
16:06:35 <frankbrockners> Jonas2: Agreed - single file per Jira might be even better
16:06:53 <frankbrockners> trozet: Let's get this started
16:07:13 <frankbrockners> that way we can also see whether the process works or whether we need to tweak it
16:07:30 <trozet> yup
16:07:36 <bryan_att> all - any feedback on  my last suggestion for TSC oversight on objections?
16:07:56 <trozet> frankbrockners: Want me to create a wiki to track the email requests? we can also update with the meeting we plan to discuss them with the respective projects
16:08:23 <trozet> bryan_att: TSC always votes +1
16:08:25 <trozet> ;)
16:08:26 <Jonas2> bryan_att: TSC will not do any coding :-)
16:08:28 <frankbrockners> bryan_att: Not sure about any TSC involvement here. Genesis is just requirements consolidation across installers that participate
16:09:06 <frankbrockners> and the TSC cannot mandate any work to be done by any group
16:09:23 <frankbrockners> all Genesis does is coordinate and provide visibility
16:09:26 <bryan_att> I think it's important for projects to understand the limitations that genesis may encounter - elevating issues to the TSC will help address or bring to the table issues with the installer support communities, e.g. indications of need for better cross-installer alignment
16:10:00 <bryan_att> this is an important "gate" for the community
16:10:09 <frankbrockners> bryan_att - if we encounter any issues that we as the Genesis team believes the TSC could solve, we can of course bring them up with the TSC
16:10:24 <frankbrockners> but back on the actual task
16:10:26 <bryan_att> we have to understand as a community, why some projects may not be able to pass it
16:11:04 <ebrjohn> bryan_att: sounds very reasonable to me what you're suggesting
16:11:28 <ebrjohn> bryan_att: shouldnt it be voted on in Genesis before having to escalate to the TSC?
16:11:37 <frankbrockners> there are a couple of things we need to get done asap: i.e. create a set of "sample" committs for existing Jira tickets - and use our process
16:11:40 <bryan_att> , ok, move on - we will followup as needed
16:11:46 <bryan_att> ebrjohn: yes
16:12:26 <frankbrockners> any volunteers - I could create a few - trozet, Jonas2 - do you want to do the same?
16:12:39 <trozet> frankbrockners: yes
16:13:06 <trozet> frankbrockners: just do the basic ones
16:13:18 <Jonas2> frankbrockners: I can do some.
16:13:31 <frankbrockners> #action frankbrockners, trozet - create a set of commits associated to Jira tickets (start with simple ones)  - to test out the process
16:13:35 <Jonas2> I need to create a Jira for that ;-)
16:13:47 <ashyoung> lol
16:13:47 <trozet> Jonas2 LOL
16:13:50 <frankbrockners> #action Jonas2 - to help create a set of commits as well
16:14:14 <Jonas2> I can work from the top of the stack.
16:14:50 <frankbrockners> ok - cool
16:15:00 <trozet> lets just communicate with each other
16:15:04 <trozet> which ones we create, to avoid duplicate
16:15:21 <frankbrockners> in addition to that we need to start to track requests that come in via email
16:15:29 <Jonas2> trozet: Work from the bottom
16:15:32 <frankbrockners> trozet - let's do this offline
16:15:42 <trozet> yeah
16:15:58 <frankbrockners> trozet - could you start a wiki for the requests which came in so far?
16:16:13 <trozet> frankbrockners: yup will do
16:16:17 <frankbrockners> thanks
16:16:27 <frankbrockners> ... we're way over time already
16:16:39 <frankbrockners> but is there anything else we should cover really quickly
16:16:46 <frankbrockners> is the SFC team still here?
16:17:12 <trozet> ebrjohn: ping?
16:17:17 <ebrjohn> hello, sorry
16:17:22 <ebrjohn> im back
16:17:26 <ebrjohn> reading
16:17:40 <frankbrockners> ebrjohn - how can we help?
16:17:42 <ebrjohn> Ok, SFC team is still hear, and ready
16:18:01 <ebrjohn> Well, I submit an email per you wiki, and it was suggested I come to this meeting
16:18:16 <ebrjohn> The requirements were a patched version of OVS, and Tacker
16:18:43 <ebrjohn> I understand now that we cant include TAcker in OPNFV deliverables, and will have to handle it via a post-install or something similar
16:19:08 <trozet> frankbrockners: I think SFC request is to include an OVS  install option with NSH support
16:19:10 <ebrjohn> One other requirement I was considering is that we need ODL Beryllium, but Im not sure if that's necessary to specify
16:19:21 <ebrjohn> So, what else do I need to do for now?
16:19:31 <ebrjohn> trozet: correct, thanks
16:19:42 <trozet> ebrjohn: why does SFC need Beryllium?
16:20:32 <ebrjohn> trozet: because we need the latest ODL SFC has to offer
16:20:46 <ebrjohn> This was discussed early on in one of our weekly calls
16:20:53 <trozet> ebrjohn: the current genesis proposal is https://jira.opnfv.org/browse/GENESIS-6
16:21:10 <ebrjohn> We will definitely find bugs, and need new features from ODL SFC, and the best way to handle that will be to use SFC Be
16:21:42 <frankbrockners> ebrjohn - ODL Be will barely be out by Feb/2
16:21:45 <trozet> ebrjohn: I think the Beryllium release date is too close
16:22:20 <trozet> formal release date is 2/4 for Beryllium, RC0 is 1/7
16:22:29 <trozet> OPNFV is 2/2
16:23:15 <Jonas2> Guys - need to leave now.
16:23:17 <ebrjohn> there's a month between the 2 releases, right? and ODL releases first
16:23:47 <ebrjohn> trozet: what's tjat jira link for? Its an empty jira page, should I enter something there?
16:24:15 <trozet> ebrjohn: Requirement: OpenDaylight Lithium release support
16:24:25 <ebrjohn> Ahh, its all in the title
16:24:34 <trozet> ebrjohn: I don't think Beryllium is an option
16:24:43 <ebrjohn> Would that then exclude OPNFV SFC from Genesis?
16:25:00 <trozet> ebrjohn: so since Tacker is not allowed as part of an installer, i dont think that is a valid requirement either
16:25:11 <trozet> ebrjohn: no it doesn't, just that requirement
16:25:30 <ebrjohn> Well, we're going to need ODL SFC Be.
16:25:38 <trozet> ebrjohn: we could still do the requirement for OVS with NSH, if no one on the genesis team is against that proposal?
16:25:44 * ebrjohn Be => Beryllium
16:26:14 <trozet> ebrjohn: well in that case then yeah I don't think we will ship B-release with Be
16:26:22 <ebrjohn> Ok, I dont understand how that would work... Would we use Genesis for part of the installation, and something else for the rest of it???
16:26:31 <ebrjohn> Seems kind-of strange to me
16:27:03 <trozet> ebrjohn: genesis creates requirements that installers would have to support
16:27:11 <trozet> ebrjohn: so by default installers would have to install Lithium
16:27:32 <trozet> ebrjohn: perhaps you can engage with a specific installer to install Be as an option, but I don't think the Genesis team will make that a requirement
16:27:43 <trozet> frankbrockners, Jonas2: do you agree?
16:27:52 <ebrjohn> I thinkn Jonas had to leave
16:28:09 <ebrjohn> BTW, I have to leave now, too
16:28:12 <frankbrockners> trozet: Yes - for now support of Be in Brahmaputra is unlikely
16:28:21 <trozet> yeah we are far past the end of meeting time
16:28:31 <trozet> ebrjohn: lets bring this up in another meeting
16:29:01 <frankbrockners> ok - which brings us to the end of the agenda for today..
16:29:08 <frankbrockners> thank you everyone!
16:29:09 <ebrjohn> ok, thanks, and we'll talk to you later then
16:29:17 <frankbrockners> #endmeeting