13:58:46 <ChrisPriceAB> #startmeeting OPNFV TSC
13:58:46 <collabot> Meeting started Tue Sep 29 13:58:46 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:58:46 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:58:46 <collabot> The meeting name has been set to 'opnfv_tsc'
13:58:52 <ChrisPriceAB> #topic roll call
13:59:01 <ChrisPriceAB> #info Chris Price
13:59:13 <ChrisPriceAB> #chair rpaik
13:59:13 <collabot> Current chairs: ChrisPriceAB rpaik
13:59:41 <uli-k> #info Uli Kleber
13:59:44 <dlenrow> #info dlenrow
13:59:45 <bertys_> #info Bertrand Souville (Proxy for Ashiq)
14:00:10 <tallgren> #info Tapio Tallgren
14:01:32 <frankbrockners> #info Frank Brockners
14:01:49 <bryan_att> #info Bryan Sullivan
14:01:57 <ChrisPriceAB> #topic Agenda Bashing
14:02:02 <chenshuai1> #info chenshuai
14:02:07 <morgan_orange> #info Morgan Richomme
14:02:08 <ChrisPriceAB> #link https://wiki.opnfv.org/wiki/tsc TSC agenda
14:02:33 <dku> #info Dirk Kutscher
14:03:03 <rprakash> #info rprakash
14:03:53 <ChrisPriceAB> #info The topic for PTL stand-in's for vacation and or other out-of-office reasons has been raised.
14:04:01 <dneary> #info dneary (representing cdub)
14:04:14 <Parviz> # info Parviz Yegani
14:04:15 <rpaik> #agree on previous minutes due to lack of commnets/objections
14:04:33 <Parviz> #info Parviz Yegani
14:04:49 <rpaik> now have quorum
14:04:54 <ChrisPriceAB> #topic OPNFV release artifacts discussion
14:04:59 <frankbrockners> #link https://wiki.opnfv.org/releases/brahmaputra/release_artifacts_discussion
14:05:27 <ChrisPriceAB> #info The above link summarises the discussion thus far around what we release as OPNFV at a release date.
14:06:50 <ChrisPriceAB> #info The feedback from the community is that the current approach requires significant effort and there is a desire to simplify our release engineering effort
14:07:16 <ChrisPriceAB> #optins are covered in the WiKi with a range of approaches as described as options for Brahmaputra
14:07:37 <ChrisPriceAB> #info options are covered in the WiKi with a range of approaches as described as options for Brahmaputra
14:07:38 <mbeierl> #info Mark Beierl
14:10:14 <ChrisPriceAB> #info frankbrockners asks for TSC votes on preferences for release vehicles in Brahmaputra
14:11:03 <dneary> frankbrockners, Are you asking for a final vote, or are you looking for a straw poll to evaluate where TSC members stand?
14:13:11 <Susana_> isn't this something the board needs to discuss? I mean maintenance of prior releases
14:17:05 <bryan_att> IMO, the install script is the most flexible approach. I have found issues trying to use the ISO.  I don
14:17:23 <bryan_att> t think the ISO is actually used in our PODS, right?
14:18:07 <bryan_att> Installers *have* to provide the script, and the ISO should be optional.
14:18:19 <dneary> ChrisPriceAB, cdub has joined - he has the Red Hat now
14:18:30 <dlenrow> Create Web poll. Do offline?
14:19:03 <RayNugent_> #info this seems like an important decision, perhaps we need more discussion?
14:19:05 <ChrisPriceAB> #info the following vote will be based on the presented order of options on the wiki page https://wiki.opnfv.org/releases/brahmaputra/release_artifacts_discussion
14:19:10 <fdegir> ISO could be good if the PODs don't have access to the internet
14:19:15 <bryan_att> are we ready to vote right now, or do we need any wider discussion? I'm not sure all aspects/implications of these options have been fully discussed
14:19:37 <bryan_att> from a user perspective...
14:19:41 <dneary> dlenrow: #vote 1a, 1b, 1c, 2a, 2b, 2c
14:20:14 <RayNugent_> #agree with Brian, need more discussion on this
14:20:40 * bryan_att is sorry to for not reviewing this before - didn't know or recall that it had been out there so long...
14:21:26 <dneary> ChrisPriceAB, You can have options other than +1, 0, -1 in a vote - 1a to 2c should work
14:21:44 <bryan_att> can we vote for only one one option - everything else is optional?
14:22:23 <bryan_att> the script can leverage a local repo as well
14:22:27 <aricg-> even the iso will need internet, afaik
14:22:39 <s_berg> aricg-:
14:22:49 <bryan_att> a local repo has been under discussion as a solution for those with internet access issues
14:22:50 <s_berg> aricg-: Not for Fuel at the current point in time at least.
14:22:54 <ChrisPriceAB> #startvote What is the TSC's preference for release artifacts in Brahmaputra? (1a, 1b, 1c, 2a, 2b, 2c, 0)
14:22:54 <collabot> Begin voting on: What is the TSC's preference for release artifacts in Brahmaputra? Valid vote options are , 1a, 1b, 1c, 2a, 2b, 2c, 0, .
14:22:54 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
14:23:00 <dlenrow> Why is this a TSC meeting vote? It's a community info poll. TSC vote is to make a specific decision.
14:23:07 <lmcdasm> no
14:23:14 <lmcdasm> you need an ISO for internetless installs of FUEL
14:23:25 <KLuehrs> #info Kevin Luehrs (LSOAPI)
14:23:28 <lmcdasm> and even with scripted installs, you need to have the media (and ISO) being produced
14:23:43 <ChrisPriceAB> #endvote
14:23:43 <collabot> Voted on "What is the TSC's preference for release artifacts in Brahmaputra?" Results are
14:24:10 <ChrisPriceAB> #action Chris will start the vote on the TSC mailing list for TSC members to provide preferences in an e-mail vote.
14:24:13 <TomNadeau> Lets move this thing forward.  As Frank said its been in play for 3 weeks.
14:24:18 <TomNadeau> what are we really waiting for?
14:24:47 <ChrisPriceAB> #info the vote will end EoB (PST) this Friday.
14:26:29 <ChrisPriceAB> #topic Arno SR1 status
14:26:54 <ChrisPriceAB> #info The SR1 activity is ongoing with regular check-in's.
14:27:00 <uli-k> Please clarify any questions before the vote closes.
14:27:02 <frankbrockners> #link https://wiki.opnfv.org/releases/arno/stablerelease_1
14:27:46 <ChrisPriceAB> #info There are remaining issues with the overall pipeline.  The installers work however there are issues with the sequencing of events through the CI pipeline.
14:28:18 <ChrisPriceAB> #info we will not be able to release SR1 today given the current status of the overall system.
14:28:22 <bryan_att> I would be useful to get the opinion of the BGS members / main contributors on the options... note them on the wiki. The rest of us are less aware of how hard each option is to do/maintain. We can chime in from a user perspective but actually maintaining these things is another matter.
14:29:51 <bryan_att> +1 to following the recommendation of BGS
14:29:53 <fdegir> we are trying to improve reproducibility/repeatability of deploys and tests to improve overall reliability
14:30:17 <ChrisPriceAB> #info the recommendation from the SR1 team is to allow a few more days to stabilize the pipeline.
14:30:35 <ChrisPriceAB> #agree The TSC agrees to the delay in order to secure stability for SR1.
14:30:53 <ChrisPriceAB> #topic Brahmaputra Milestone C decision
14:31:24 <ChrisPriceAB> #info Debra reports that as of this morning 38 projects have reported, one project has pulled out of Brahmaputra, and one project pending a report.
14:32:09 <ChrisPriceAB> #link https://wiki.opnfv.org/releases/brahmaputra/release_plan Milestone C report and Brahmaputra plan
14:32:40 <ChrisPriceAB> #info no projects are reporting Red.  Some concerns around resourcing or dependencies that are seen to be non-blocking
14:33:30 <ChrisPriceAB> #info Debra recommends that given the status of the Milestone C input the TSC votes to pass Milestone C.
14:34:26 <ChrisPriceAB> #agree The TSC agrees by consensus to pass Milestone C.
14:35:57 <ChrisPriceAB> #topic Election processes and improvement opportunities
14:36:22 <ChrisPriceAB> #link https://wiki.opnfv.org/election_proposal wiki proposing ideas to improve our election process
14:36:49 <ChrisPriceAB> #info dneary outlines some of the feedback received after our previous round of community voting.
14:43:29 <bryan_att> the key question is what is the bar for "active" - if we were using the committer role as typical then we would not be having this problem of having to expand the voter pool
14:43:57 <bryan_att> we need to apply more discipline to the committer lists
14:49:34 <bryan_att> can someone publish stats on how many "inactive" committers voted? (needs a strawman criteria for "active")? This would help address the concern that the active community was not accurately represented.
14:51:43 <TomNadeau> I like the proposal.
14:52:01 * frankbrockners likes the proposal as well
14:52:33 <TomNadeau> I like the inclusion of the full anonymized results for voting.  there is no reason I can think of why we should hide these details
14:53:08 <TomNadeau> Voter pool should also be listed somewhere - on a wiki or something - with their statement of why they are on the ticket
14:53:28 <ChrisPriceAB> #action dneary to lead a community discussion on what an Active Technical Contributor means prior to the TSC voting on a bylaw changes in this area.
14:55:05 <frankbrockners> could we do a quick time check?
14:55:11 <frankbrockners> 5 more min left
14:55:14 * dneary is done
14:55:51 <ChrisPriceAB> Brian states he will remain silent for the rest of the call :D
14:56:03 <TomNadeau> 8)
14:56:40 * bryan_att sorry for belaboring the point - but correcting our use of the process is easier than changing the process (bylaws)
14:56:45 <dlenrow> By some definition of active, more than half of current candidates are not active
14:57:52 <ChrisPriceAB> #action dneary to construct a concrete proposal for runnign future elections for the TSC to vote on next week.
14:58:39 <ChrisPriceAB> #topic Upcoming "meet-ups" - openflow world congress
14:58:46 <frankbrockners> what happend to the committer removal topic?
14:58:58 * ChrisPriceAB next week sorry...
14:59:16 <ChrisPriceAB> I will take it to the lists this week in any case.
15:00:24 <ChrisPriceAB> #info heather proposes we schedule a dinner at the dusseldorf mini-summit in lieu of having a venue for a meet-up.
15:01:04 <dneary> ChrisPriceAB, Proposals broken out now - looking OK? https://wiki.opnfv.org/election_proposal
15:01:53 <dneary> #info Dave has updated the election proposal to break out individual proposals
15:01:58 <dneary> #link https://wiki.opnfv.org/election_proposal
15:02:16 <ChrisPriceAB> Thanks Dave!!!  Let's get feedback on that and conclude next week
15:02:42 <ChrisPriceAB> #action rpaik to send a request for a vote to the TSC mailing list around the change of the wiki tool.
15:02:45 <ChrisPriceAB> #endmeeting