15:02:55 <ChrisPriceAB> #startmeeting Brahmaputra weekly project meeting
15:02:55 <collabot> Meeting started Tue Sep 29 15:02:55 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:55 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:55 <collabot> The meeting name has been set to 'brahmaputra_weekly_project_meeting'
15:03:01 <ChrisPriceAB> #chair debra
15:03:01 <collabot> Current chairs: ChrisPriceAB debra
15:03:08 <ChrisPriceAB> #chair debrascott
15:03:08 <collabot> Current chairs: ChrisPriceAB debra debrascott
15:03:12 <ChrisPriceAB> #chair rpaik
15:03:12 <collabot> Current chairs: ChrisPriceAB debra debrascott rpaik
15:03:18 <ChrisPriceAB> #topic roll call
15:03:26 <uli-k> #info Uli Kleber (Octopus)
15:03:26 <ChrisPriceAB> #info Chris Price
15:03:27 <anac1> #info Ana Cunha (Yardstick)
15:03:38 <trozet> #info Tim Rozet (Apex)
15:03:53 <KLuehrs> #info Kevin Luehrs (LSOAPI)
15:03:53 <chenshuai1> #info chenshuai (Compass4nfv)
15:03:55 <fdegir> #info Fatih Degirmenci (Releng)
15:04:01 <mbeierl> #info Mark Beierl (StorPerf)
15:04:16 <rprakash> #info rprakash
15:04:28 <StuartMackie> #info Stuart Mackie (OpenContrail Virtual Networking)
15:04:45 <bryan_att> #info Bryan Sullivan
15:05:00 <debrascott> #topic Agenda Bashing
15:05:07 <debrascott> #link https://wiki.opnfv.org/releases/brahmaputra/minutes
15:05:30 <bin_> #info Bin  Hu (IPv6)
15:05:40 <maryamtahhan> #info Maryam Tahhan
15:06:15 <ashyoung> #info Ashlee Young (onosfw)
15:06:39 <frankbrockners> #info Frank Brockners
15:06:41 <debrascott> #topic Milestone C process retrospective
15:06:53 <n0ano> #info n0ano
15:06:57 <VikramDham> #info Vikram Dham (QTIP)
15:07:17 <r-mibu> #info Ryota Mibu (Doctor)
15:07:37 <morgan_orange> #info Morgan Richomme (Functest)
15:07:57 <ljlamers> #info Larry Lamers
15:08:10 <debrascott> #link https://wiki.opnfv.org/releases/brahmaputra/minutes
15:09:12 <debrascott> #action Debra make link to Brahmaputra release very visible from front of WIKI
15:09:27 <frankbrockners> #link https://wiki.opnfv.org/releases/brahmaputra/release_plan
15:09:40 * ChrisPriceAB is only on IRC for this call unfortunately (take minutes please :)
15:10:22 <debrascott> #info process a little difficult to get into for new projects but otherwise went well
15:12:38 <ChrisPriceAB> #chair frankbrockners
15:12:38 <collabot> Current chairs: ChrisPriceAB debra debrascott frankbrockners rpaik
15:12:45 <debrascott> #topic Jira issues
15:12:47 <ildikov> #info for Milestone D we do not expect this amount of reporting efforts
15:13:03 <ildikov> #info Milestone E is where we would need to have this checkpoint again
15:14:59 <debrascott> #info using Sprint functionality- need to create a board first then drag tasks into the board
15:15:49 <debrascott> #info need administrator rights to create a board
15:16:29 <debrascott> #info look under projects tab, if you have administration rights you’ll see an “administer” tab
15:17:35 <debrascott> #info project leads should have administrative rights
15:18:35 <debrascott> #info project leads can then delegate additional administrators
15:18:52 <maryamtahhan> Yep, just tried it out there :)
15:20:30 <debrascott> #info under administration tab is a “permissions” tab where delegates can be added
15:21:32 <mbeierl> #info under Projects -> Your project name
15:21:48 <mbeierl> #info Will be "Overview" and "Administration"
15:24:00 <debrascott> #action Debra add administration tasks to list of Jira training to be created
15:27:25 <debrascott> #action Mark Beierl to check with Aric on how to make administrator group visible to users
15:28:02 <billyoma> cd
15:29:27 <mbeierl> #info Under "Roles" there is a table of "Project Roles | Users |  Groups" with rows "Administrators, Developers, Users"  Click in the cell at the intersection of "Administrators+Users" and you can enter the name of additional project administrators that you want to create/start/stop sprints
15:30:09 <mbeierl> #info I incorrectly identified this as "permissions", it is actually the "roles" page
15:30:48 <anac1> there will be a discussion next week on TSC about committer removal
15:32:27 <debrascott> #info Do we need to ever remove people from Jira? A: no because that also removes all their cases
15:33:03 <debrascott> #info you can deactivate users in Jira if necessary
15:33:52 <debrascott> #topic future topics, key to staying on track toward next milestone
15:35:51 <debrascott> #info Frank brings up project interdependencies, make sure they get closed before Milestone D
15:38:05 <debrascott> #action Debra to create a dependency graph
15:38:31 <RayNugent_> #info good to track dependencies but we should avoid adding additional gates
15:40:54 <morgan_orange> FYI we initiated something on the wiki to see the links between Test and Feature projects https://wiki.opnfv.org/feature_test_project_matrix
15:43:57 <morgan_orange> we suggested a first approach with the pad description https://etherpad.opnfv.org/p/testing_requests_for_b_release
15:47:21 <ChrisPriceAB> #chair mbeierl
15:47:21 <collabot> Current chairs: ChrisPriceAB debra debrascott frankbrockners mbeierl rpaik
15:49:41 <debrascott> #Ryota asks how to manage test projects dependencies which may require additonal configuration provisions versus what is required for test?
15:50:08 <debrascott> #info Ryota asks how to manage test projects dependencies which may require additonal configuration provisions versus what is required for test?
15:51:24 <morgan_orange> #link https://wiki.opnfv.org/testing/
15:52:07 <debrascott> #info Morgan clarifies that feature projects will need to provide additional things for configuration of tests and because of this there are additional milestones needed for test projects.
15:52:57 <debrascott> #info test projects will not write feature project tests, they will help you with it
15:53:12 <anac1> morgan_orange: if the feature project has a specific requirement (e.g. component version), it should be the feature project to add the requirment to the installers?
15:53:54 <morgan_orange> for me yes
15:54:00 <anac1> for me too
15:54:24 <morgan_orange> only the feature projects knows what it needs
15:55:06 <anac1> and the test projects, we fix our own requirments, or?
15:55:33 <frankbrockners> i think the question Ryota is asking is the following: Assume you need O/S Heat and O/S Tacker for your project to be tested.
15:55:37 <morgan_orange> if we have our own test suites that require tuning in the config, yes
15:55:50 <frankbrockners> Who would install Heat and Tacker for that project.
15:56:05 <anac1> morgan_orange: agree
15:56:20 <frankbrockners> And I believe the answer given here is that the project that requires Heat and Tacker would install it prior to their e.g. Tempest tests to run
15:56:29 <frankbrockners> question is whether this is always feasible
15:57:05 <morgan_orange> Heat was already included in Arno
15:57:31 <morgan_orange> if we take the example of Tacker, would it be a requirement for genesis => need for tacker
15:57:36 <KLuehrs> Need to drop - have another call to start. Thanks all.
15:57:59 <morgan_orange> then feature project shall create the tacker config/scenario and discuss with a Test project for integration in CI pipeline
15:58:00 <frankbrockners> we even have Tacker as an ask - but Tacker is out of scope for OPNFV
15:58:13 <frankbrockners> this was the answer given so far
15:58:23 <morgan_orange> and heat was not :)
15:58:43 <frankbrockners> luckily noone asked the scope question on Heat
15:59:04 <morgan_orange> but right this is a valid question. the vIMS testcase include the deployment of a Cloudify solution to manage the deployment of the vIMS
15:59:24 <morgan_orange> it is managed by the functest project as it is a test case of Functest
15:59:50 <morgan_orange> and it works manually on Arno
16:00:11 <anac1> same for the virtual traffic classifier in yardstick
16:00:27 <frankbrockners> Could we do a timecheck on this meeting? we're at the top of the hr..
16:01:03 <frankbrockners> debrascott: Arno SR1 synch meeting is waiting to use this channel..
16:01:42 <frankbrockners> thanks debrascott
16:01:45 <debrascott> #endmeeting