15:00:46 <ChrisPriceAB> #startmeeting OPNFV TSC
15:00:46 <collabot> Meeting started Tue Nov 10 15:00:46 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:46 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:46 <collabot> The meeting name has been set to 'opnfv_tsc'
15:00:50 <ChrisPriceAB> #topic roll call
15:00:56 <edgarstp> #info Edgar StPierre
15:00:57 <ChrisPriceAB> #info Chris Price
15:01:02 <ChrisPriceAB> #chair rpaik
15:01:02 <collabot> Current chairs: ChrisPriceAB rpaik
15:01:08 <dlenrow> #info dlenrow
15:01:14 <bryan_att> #info Bryan Sullivan
15:01:19 <ChrisPriceAB> #chair dlenrow
15:01:19 <collabot> Current chairs: ChrisPriceAB dlenrow rpaik
15:01:47 <ChrisPriceAB> Dave, you coming to the event today?
15:01:47 <frankbrockners> #info Frank Brockners
15:02:00 <ChrisPriceAB> #chair frankbrockners
15:02:00 <collabot> Current chairs: ChrisPriceAB dlenrow frankbrockners rpaik
15:04:06 <ChrisPriceAB> #topic Previous minutes of meeting.
15:04:20 <ChrisPriceAB> #info Previous minutes if meeting approved, no comments.
15:04:26 <ChrisPriceAB> #topic Agenda Bashing
15:04:47 <Ashiq> #info Ashiq Khan
15:05:20 <frankbrockners> #info additional agenda topic: Genesis timelines
15:05:48 <Parviz> #info Parviz Yegani
15:06:11 <ChrisPriceAB> #topic Latest from the Design Summit & OPNFV Summit
15:06:15 <uli-k> #info Uli Kleber
15:09:04 <ChrisPriceAB> #info the design summit has been very effective and well attended.
15:09:53 <ChrisPriceAB> #info feedback thus far includes improvements in size of rooms, whiteboards, and video streaming could be improvements.
15:10:31 <ChrisPriceAB> #info also, video dongles for computers to plug into faster
15:10:32 <rpaik> #info A reminder on a design summit wrap-up session at 4:30pm PT in Regency B-C
15:10:41 <cdub> #info Chris Wright
15:11:26 <ChrisPriceAB> #info Ashiq adds that room reservations have been an issue, using etherpad, wiki, and/or sched has made it a little confusing.
15:12:14 <ChrisPriceAB> #topic OPNFV Software License
15:12:56 <Wenjing> #info Wenjing Chu
15:13:15 <ChrisPriceAB> #info Scott, director of strategic programs for the linux foundation, introduces himself
15:13:34 <dku> #info Dirk Kutscher
15:13:51 <ChrisPriceAB> #info Scott would like to help with our process development to institute best practices heading into our Brahmaputra release.
15:14:31 <ChrisPriceAB> #info Scott mentions the licence file is a good practice and should continue
15:15:10 <ChrisPriceAB> #info The information around the contributor per file should also contain the license information as a best practice.
15:16:02 <ChrisPriceAB> #link https://wiki.opnfv.org/developer/contribution_guidelines coding guidelines including file header templates.
15:18:21 <ChrisPriceAB> #info dneary asks if this is a reccomendation, or a requirement.
15:18:36 <ChrisPriceAB> #info Scott answers this is a requirement for contribution.
15:20:08 <Tapio_T> #info Tapio Tallgren
15:21:58 <rpaik> #info a question was raised on gif, jpeg, etc.
15:23:34 <rpaik> #info plus how do you handle binaries
15:23:51 <ChrisPriceAB> #action rpaik to set up a follow up discussion around binary files with Scott and Frank and other interested parties.
15:26:52 <ChrisPriceAB> #info Scott is also part of a working group in the LF that is looking to simplify the process of adding license information to files.  This is due to be ready around March.
15:27:42 <bryan_att> are all patches required to carry the copyright and license info of the contributor?
15:29:29 <ChrisPriceAB> #info byran_att asks if all patches are required to carry the copyright and license info of the contributor?
15:33:46 <ChrisPriceAB> #info The OPNFV team discuss the methods in place, where we track contributors in our GIT logs which do not require us to update the header for each patch.
15:35:57 <bryan_att> so we need to clarify that contributors do not have to identify the specific things they have changed in the changed file itself, rather the git system itself provides the history of changes in the case that this becomes important
15:36:09 <ChrisPriceAB> #action The TSC shall invest some time working on clarifying the roles and expectations on contributors and the reviewing committers.
15:37:51 <ChrisPriceAB> #topic Brahmaputra artifact governance and expectations
15:40:24 <dneary> #info dneary (joining IRC late, on phone earlier)
15:41:29 <dneary> bryan_att, A link on the topic of names and attribution in source files: http://producingoss.com/en/managing-volunteers.html#territoriality
15:41:36 <dneary> #link http://producingoss.com/en/managing-volunteers.html#territoriality
15:58:13 <ChrisPriceAB> #action frankbrockners and chrispriceab to put a concrete proposal together on release contents based on this discussion for review.
15:58:44 <ChrisPriceAB> #info dneary explicitly states that he wants brahmaputra to be based on at a minimum patches that are accepted upstream.
15:59:07 <ChrisPriceAB> #info frankbrockners explains this may not always be possible due to the large cross project dependencies in OPNFV.
16:01:19 <ChrisPriceAB> #info frankbrockners adds that the install teams are geting nervous about the amount of last minute work that might come up.  Frinday 13th is the end-date for requesting work from the installer teams.
16:01:36 <ChrisPriceAB> #action all PTL's makse sure your requirements are into the genesis requirements.
16:01:59 <ChrisPriceAB> #endmeeting