15:00:21 <uli-k> #startmeeting Octopus weekly meeting
15:00:21 <collabot> Meeting started Mon Nov 23 15:00:21 2015 UTC.  The chair is uli-k. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:21 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:21 <collabot> The meeting name has been set to 'octopus_weekly_meeting'
15:00:42 <uli-k> Hi, welcome to octopus meeting!
15:00:55 <uli-k> #topic roll call
15:01:17 <uli-k> #info Octopus participants, please type #info
15:01:37 <zhifeng> #info zhifeng
15:02:05 <uli-k> Hi, let's hope we have some more people joining......
15:04:27 <trozet> #info Tim Rozet
15:04:32 <uli-k> fdegir, Thanks for the email reminder! I guess you are hiding somewhere in IRC :D
15:04:46 <fdegir> sorry
15:04:54 <fdegir> having trouble with my compute
15:04:55 <fdegir> r
15:05:01 <fdegir> #info Fatih Degirmenci
15:05:19 <uli-k> Hi! No problem! Happy you guys are here.
15:05:25 <fdegir> it sends reminders itself
15:05:33 <uli-k> #chair fdegir, trozet
15:05:33 <collabot> Current chairs: fdegir trozet uli-k
15:05:55 <uli-k> #topic Agenda bashing
15:06:15 <uli-k> #info I put as sole topic the Milestone preparation.
15:06:44 <trozet> uli-k: what needs to be done to reach next milestone?
15:07:55 <uli-k> I think we should know what we need to do the over-all pipeline and the final release testing.
15:08:22 <uli-k> At the moment I still need to get answer from TSC, how to do the final testing.
15:08:49 <dduffey> #info David Duffey
15:08:50 <uli-k> I waited with my email to put it on agenda tomorrow, until this meeting.
15:09:16 <uli-k> fdegir, do you agree?
15:09:22 <ChrisPriceAB> ???  What will the TSC say about how to run tests?
15:09:39 <uli-k> Hi, ChrisPriceAB!
15:09:46 <fdegir> running tests on a community lab you mean?
15:09:47 <ChrisPriceAB> allo
15:10:42 <uli-k> I mean where do execute release tests for Brahmaputra
15:11:10 <uli-k> If there is nothing else, let's start with that.
15:11:10 <ChrisPriceAB> Where the deployment is done, we run the tests to see if it was a success.
15:11:22 <uli-k> #topic Release testing Brahmaputra
15:11:51 <uli-k> In SFO in the breakout we said, we want to do release testing for each installer on a dedicated lab.
15:12:25 <uli-k> I got feedback from TSC chair, that this would be a step back, since in Arno SR1, we were able to release both installers on the same lab.
15:12:34 <ChrisPriceAB> So, our target is that our CI pipeline deploys Brahmaputra and runs the test suites.
15:13:08 <ChrisPriceAB> While we are in R&D phase we likely need to do work in community labs, but to release the deployment needs to be portable across infrastructures.
15:13:23 <ChrisPriceAB> not tied to a specific lab and configuration.
15:13:40 <uli-k> The question is: Do we need to run the CI pipeline then for All installers on All community labs?
15:14:01 <uli-k> We would need maybe a week of execution time.....
15:15:10 <uli-k> Just to give a different example:
15:15:27 <ChrisPriceAB> As a minimum expectation we should be able to run the genesis deploys of all installers on the LF lab infra as part of a release candidacy activity.
15:15:49 <uli-k> We could run deploy by every installer on three different labs. Then run the full test suite on one installer on all labs.
15:16:05 <fdegir> there has been some discussion regarding separating installer build/deploy from testing
15:16:06 <uli-k> What is a Genesis deploy?
15:16:16 <fdegir> installers can do build/deploy wherever they want
15:16:36 <ChrisPriceAB> We should also be looking at "feature deploys" of the platform as needing to be done between RC0 and RC3 with code freeze.
15:16:39 <fdegir> and the stable/working version of the installer then gets deployed to "somewhere" (could be LF) and then the testing runs on it
15:16:49 <trozet> ChrisPriceAB: so I guess we need to have confidence that they can run anywhere (including LF infra) then for release it just needs to pass on one of the labs?
15:16:52 <fdegir> no unstable/undeployable versions will be run
15:17:21 <fdegir> to limit the potential issues that could be caused by latest changes in installer codebase
15:17:31 <fdegir> and to help test projects to test relatively stable version
15:17:40 <ChrisPriceAB> trozet, we should expect they could run anywhere.
15:18:04 <trozet> ChrisPriceAB: agreed.  But does that also mean the final cut needs to run on LF infra to be releasable?
15:18:11 <ChrisPriceAB> (feature deploys) may not but that should be captured in the feature documentation as a limitation.
15:18:26 <ChrisPriceAB> trozet, I would think it makes sense to do the final runs on the LF infra.
15:18:37 <trozet> ChrisPriceAB: fine with me
15:18:43 <ChrisPriceAB> for the "genesis deploys" <- for want of a better term...
15:19:03 <uli-k> :D
15:19:24 <ChrisPriceAB> I guess we as of yet do not have a list of the "feature deploy" options that come with the various projects
15:19:28 <uli-k> But what's the difference between the Genesis deploy and a feature deploy?
15:19:46 <ChrisPriceAB> https://wiki.opnfv.org/releases/brahmaputra
15:20:15 <ChrisPriceAB> "From the Brahmaputra release onwards, a user can choose the features to be installed for a particular installation. Feature selection and the associated configuration of the features is done via a set of configuration files"
15:20:42 <ChrisPriceAB> whereas genesis will provide us with a Brahmpautra common deploy that is supported across all deploy tools.  (The genesis deploy)
15:20:52 <ChrisPriceAB> fwoabt
15:21:25 <uli-k> So the format of that set of configuration files is then an API that should be fixed by Milestone D?
15:22:10 <ChrisPriceAB> As of yet the feature deploy validation is not clear to me, we should be practical and look to ensure we have validated them post freeze.  (incl bugfixes and regression as much as possible)
15:22:17 <ChrisPriceAB> this will be a bumpy ride...
15:22:49 <ChrisPriceAB> Milestone D is a good expectation, but it may not be 100% clear until code freeze.  (bumpy)
15:23:24 <uli-k> At least we need to know which features are "optional" - besides the installer and controller options.
15:23:24 <ChrisPriceAB> As long as the CI is in place for deploy/test it should not cause us too much overall issue.  stability will be the challenge to achieve.
15:24:12 <uli-k> My fear for CI is how many release pipelines we need to run.
15:24:30 <ChrisPriceAB> trozet, how many variations are there in a "genesis deploy"?  2 controllers or three?
15:24:57 <uli-k> Sorry my fault. three.
15:25:04 <trozet> ChrisPriceAB: OPNFV defines 3 controllers, so we use 3.  You can optionally deploy non-ha, but its not required for release
15:25:22 <uli-k> agree
15:25:28 <ChrisPriceAB> Ok, cool.  So 4 deploy tools, and 3 controllers for each.  The basic regression is 12 runs.
15:25:34 <ChrisPriceAB> :D
15:25:38 <uli-k> :D
15:25:43 <uli-k> All on LF lab?
15:25:43 <fdegir> + fature projects
15:25:43 <fdegir> feature
15:25:57 <ChrisPriceAB> 6 runs on each pod.  should be OK, it's 6-8 hours for each
15:26:04 <ChrisPriceAB> we have a week for RC activity
15:26:18 <uli-k> And we will have no bugs.
15:26:26 <ChrisPriceAB> yeah feature projects will be tough to schedule...  will likely need to be one off after code freeze.
15:26:45 <ChrisPriceAB> uli-k that's why we do RC for a month.
15:27:51 <uli-k> When we do the release deployment on LF lab, that doesn't tell us that it runs on all community labs.
15:28:03 <ChrisPriceAB> fdegir, I assume we can't schedule FP testing on the LF infra for each RC.  So we will likely need to use community infra for that...
15:28:30 <fdegir> yes, we need community labs
15:28:59 <ChrisPriceAB> agree uli-k.  but we have to expect the community is trying things outr there during R&D.  We can't increase our realese testing cost to 12X(the number of labs)
15:30:32 <uli-k> Yes. That's why I need some guidance from TSC, how much release testing in community labs (maybe in addition to the 12 deploys on LF)
15:30:48 <ChrisPriceAB> I would suggest based on what I see that:
15:31:03 <ChrisPriceAB> All "genesis deploys" run on LF infra during each RC cycle.
15:31:26 <ChrisPriceAB> All "feature deploys" need to be run on a CI enabled infra post code freeze.
15:31:55 <uli-k> on one CI enabled infra? or on two CI enabled infra?
15:32:02 <ChrisPriceAB> we can take this to the TSC, but the TSC is going to turn around to releng & CI and ask "what is possible?"
15:32:07 <uli-k> feature deploys also must be portable.
15:32:14 <ChrisPriceAB> two is better than one if possible.
15:32:49 <ChrisPriceAB> I suggest making a proposal here and having it agreed by the TSC
15:33:28 <uli-k> OK.Our releng & CI proposal from SFO breakout was different......
15:33:37 <uli-k> But not liked by some...
15:34:32 <uli-k> I think what we need from the SFO proposal is that we run the full test suite on all 12 deploys.
15:36:22 <uli-k> Can we use community labs for that?
15:37:56 <ChrisPriceAB> ?  the test suites should follow the deploy.  always.
15:38:45 <uli-k> Then we get some timing issues on the LF lab. That's why we proposed to distribute it to community labs.
15:42:28 <uli-k> fdegir, do you think we can provide TSC with a proposal, that includes the 12 deploys, the feature options (as far as we know them), and an estimate of the total runtime if we use the LF PODs only (for the final run)?
15:43:11 <fdegir> uli-k: yes we can
15:43:20 <uli-k> OK.
15:43:40 <uli-k> #action uli-k, fdegir, provide TSC with a proposal, that includes the 12 deploys, the feature options (as far as we know them), and an estimate of the total runtime if we use the LF PODs only (for the final run)?
15:44:09 <fdegir> #link https://etherpad.opnfv.org/p/brahmaputra_release_testing
15:44:09 <uli-k> Other concerns we need to resolve before Milestone D?
15:46:15 <uli-k> I think we can close the meeting then and we prepare the proposal on etherpad.
15:47:05 <uli-k> Thanks everybody for joining and especially ChrisPriceAB for the inputs!
15:47:20 <uli-k> fdegir, something for releng?
15:47:29 <fdegir> nope
15:47:47 <uli-k> Great! See you next time!
15:47:50 <uli-k> #endmeeting