15:04:45 <iben> #startmeeting OPNFV B Release CI Planning Pharos Test and Perf
15:04:45 <collabot> Meeting started Thu Dec  3 15:04:45 2015 UTC.  The chair is iben. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:45 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:04:45 <collabot> The meeting name has been set to 'opnfv_b_release_ci_planning_pharos_test_and_perf'
15:04:57 <[1]JonasB> #info Jonas Bjurel
15:04:58 <morgan_orange> #info Morgan Richomme
15:04:59 <anac1> #info Ana Cunha
15:05:04 <fdegir> #info Fatih Degirmenci
15:05:12 <iben> #info Iben Rodriguez
15:05:25 <iben> this is an audio meeting - join here - https://global.gotomeeting.com/join/305553637
15:05:37 <iben> who can help me chair this?
15:05:55 <morgan_orange> iben: I can
15:06:05 <iben> #chair trevor_intel morgan_orange fdegir [1]JonasB
15:06:05 <collabot> Current chairs: [1]JonasB fdegir iben morgan_orange trevor_intel
15:06:15 <[1]JonasB> Thx Iben:-)
15:06:19 <morgan_orange> #info agenda https://wiki.opnfv.org/meetings/test
15:06:20 <s_berg> #info Stefan Berg
15:06:23 <iben> no - thank you!
15:06:49 <iben> I’m getting the kids ready for school so will be on audio mostly
15:06:58 <trevor_intel> #info trevor_intel (Pharos)
15:06:58 <iben> #topic Logistics and Weekly Agenda: https://wiki.opnfv.org/meetings/test
15:07:06 <bin_> #info Bin Hu (IPv6)
15:07:10 <narindergupta> #info Narinder Gupta
15:07:28 <morgan_orange> #info discussion on possible combinations for B-Release
15:07:34 <iben> Agenda - December 3rd, 2015 (55 min)
15:07:35 <iben> This meeting slot will be used for discussion on release plan for build/deploy/test
15:07:36 <iben> CI needs to know which configuration to run and which tests to execute
15:07:38 <iben> Need common configuration files for …
15:07:39 <iben> Build config
15:07:41 <iben> Deploy config
15:07:42 <iben> POD config
15:07:44 <iben> Test config
15:07:45 <iben> Question 0: what are the combinations of installers/controllers/other sw component versions (compatibility matrix)?
15:07:46 <iben> Question 1: how many deploy/test environments are needed?
15:07:47 <iben> Question 2: what community labs will volunteer to provide needed resources?
15:08:01 <iben> #topic CI needs to know which configuration to run and which tests to execute
15:08:50 <iben> #info Need common configuration files for build, deploy, pod, test setup, test execution, test data collection
15:10:25 <morgan_orange> #info list of projects that declared testcases:
15:10:27 <morgan_orange> #link http://213.77.62.197/test_projects
15:11:37 <morgan_orange> #info 88 testcases have been declared
15:13:06 <fdegir> #info This is the page propose for keeping track of combinations
15:13:08 <fdegir> #link https://etherpad.opnfv.org/p/brahmaputra_release_testing
15:15:43 <fdegir> trevor_intel: please refres the page
15:16:23 <trevor_intel> which one?
15:16:33 <fdegir> the wiki - showing the table
15:16:38 <fdegir> the labs table
15:17:09 <fdegir> the previous page - we put intel pod8 for compass
15:17:09 <trevor_intel> showing it now
15:17:46 <trevor_intel> just had to refresh :)
15:18:43 <fdegir> we tried to capture times to make estimation regarding how many pods we need
15:18:56 <fdegir> so opencontrail should be included in combinations
15:19:29 <[1]JonasB> Is now the place to discuss the exact testcase combinations, or should we discuss the structure/framework?
15:19:59 <[1]JonasB> We need to start coding towards a commonly agreed structure/framework.
15:21:02 <fdegir> that table is based on what Uli and me guessed
15:21:05 <trozet> morgan_orange: why are we testing without a controller?
15:21:27 <fdegir> so no guarantee that we will have all the combinations
15:21:41 <morgan_orange> trozet: that is what we have today on LF POD 2, it is not necessarily the target
15:21:56 <trozet> morgan_orange: imo thats a waste of time, and shoudl be removed
15:22:32 <trozet> openstack liberty testing already happens upstream, no point in testing it again in opnfv
15:22:43 <fdegir> trozet: please add your comment directly on etherpad
15:22:44 <s_berg> An installer will not be able to install an arbitrary version of a function!
15:22:48 <fdegir> under that table
15:24:59 <morgan_orange> trozet: we do perform our tests on what is delivered today..and the current solution deployed on POD2 does not include the controller, we are not making specific tests for a configuration without controller...even if it could make sense (SDNVPN has an implementation based on Neutron)
15:25:53 <fdegir> morgan_orange: question
15:26:34 <fdegir> morgan_orange: do we have ability to deploy those configurations which you have test cases declared for?
15:27:02 <fdegir> morgan_orange: which one of those combinations can be deployed?
15:27:11 <morgan_orange> you mean deduce a config from the declaration of the testcases?
15:27:40 <fdegir> the point I want to make is that
15:27:47 <fdegir> having declaration does not mean they work
15:28:17 <fdegir> +1 to default configuration
15:28:32 <fdegir> and start from there, adding controller/features that become available while we move on
15:32:29 <morgan_orange> #link https://wiki.opnfv.org/brahmaputra_testing_page
15:34:21 <frankbrockners> #link https://wiki.opnfv.org/genesis/configuration-files-discussion
15:35:08 <anac1> #link https://git.opnfv.org/cgit/yardstick/tree/etc/yardstick/nodes/pod.yaml.sample
15:37:33 <morgan_orange> https://wiki.opnfv.org/brahmaputra_testing_page
15:41:15 <iben> .
15:45:32 <morgan_orange> #info yardstick, functest ,..must be agnostic towards the installers...
15:46:10 <morgan_orange> #info but we were not able to run against all the labs
15:47:47 <morgan_orange> #info first run functest & yardstick with all the installers (on the 4 identified labs) then integrate feature projects tests, generalize test framework in any lab
15:53:52 <fdegir> #info all pods listed on Morgan's page must be connected to Jenkins
15:53:58 <fdegir> #info all installers must come to jenkins and then automatic installations must be enabled
15:54:18 <fdegir> #info once the automatic installations work fine, testing must be enabled
15:54:55 <fdegir> only joid is not visible on jenkins
15:55:05 <fdegir> apex, compass, and fuel are on jenkins
15:55:29 <fdegir> with differences in which tests are executed against them
15:56:23 <fdegir> for these 3 installers, what we currently run is the deployments with latest versions of installers
15:58:45 <morgan_orange> #action morgan_orange create a matrix: installer feature supported, possible to deploy through jenkins
15:58:58 <morgan_orange> #info add information on what can be deployed today
15:59:17 <morgan_orange> #info what is possible, on which lab is it possible
15:59:54 <fdegir> narindergupta: asked trevor_intel and rest of intel guys to get access to intel PODs
16:00:19 <fdegir> narindergupta: once I get access, I'll connect your intel PODs: POD5 and POD6
16:00:36 <fdegir> and then will start working on deploying joid from jenkins automatically
16:00:43 <morgan_orange> fdegir: David_Orange1 coudl help he started working on jnekins job
16:02:27 <iben_> We already have JIRA for davidmichaelkarr to access interested joid pods
16:02:29 <narindergupta> fdegir: iben_: should able to help and he is helping to get the access of intel labs. I would suggest to start with pod5 and pod6 i am using for dev purpose
16:02:36 <iben_> Intel
16:02:36 <trevor_intel> fdegir: I'll get you lab access ASAp
16:02:52 <iben_> We sent email to Jack
16:03:01 <fdegir> I already sent mail
16:03:06 <narindergupta> iben_: thanks
16:03:17 <trevor_intel> fdegir: I'll prod :)
16:03:21 <fdegir> to Jack, Trevor, and Michael
16:03:30 <trevor_intel> fdegir: I see it
16:03:38 <fdegir> thx trevor_intel
16:04:21 <iben_> fdegir: please work with davidmichaelkarr
16:04:39 <fdegir> he can subscribe to the gerrit releng project
16:04:46 <fdegir> and get automatic mails and review stuff
16:06:16 <morgan_orange> #info needs synchro meetings on this topic => reuse existing meetings release meeting (Tuesday) test (Thursday)
16:07:03 <morgan_orange> #endmeeting