#opnfv-meeting: Brahmaputra Release

Meeting started by debrascott at 16:01:56 UTC (full logs).

Meeting summary

    1. agenda today is to continue CI pipeline and lab resources for development discussion (debrascott, 16:03:15)
    2. Ashlee Young (onosfw) (ashyoung, 16:04:01)
    3. Chris Price (opnfvdocs) (ChrisPriceAB, 16:04:10)
    4. Frank Brockners (genesis) (frankbrockners, 16:04:26)
    5. Stuart Mackie - OpenContrail (StuartMackie, 16:04:27)
    6. #info Uli (octopus) (uli-k_, 16:04:34)
    7. Mark Gray (ovsnfv) (mdgray, 16:04:40)
    8. Ana Cunha (Yardstick) (anac1_, 16:05:02)
    9. Branch prerequisite is to have environment that would support test & dev, 8 pods ideally but minimum 5 pods (debrascott, 16:06:25)
    10. Larry Lamers (ljlamers, 16:07:26)
    11. plan B proposal reduce test scope (what we do on master branch) after branching (debrascott, 16:08:39)
    12. impact reducing verification activities based on resources = stable is less stable, less (debrascott, 16:10:03)
    13. other option is to not branch which creates significant risk of breaking release so not desired (debrascott, 16:12:10)
    14. concept is to do as much verification on master as possible, depending on lab resources, if more resources become available then increase verification (debrascott, 16:13:28)
    15. it is critical that we know what scenarios to run; need projects to submit scenarios they want to see (debrascott, 16:14:20)
    16. by scenario we mean deployed set of components in a certain configurations (hardware, installer, os, etc) (debrascott, 16:15:27)
    17. need this scenario information from every feature project that intends to be part of the CI/CD test pipeline (debrascott, 16:17:14)
    18. https://wiki.opnfv.org/brahmaputra_testing_page#test_scenarios_for_brahmaputra deployment scenario list (ChrisPriceAB, 16:18:59)
    19. ACTION: : resend communication to all project leads to add scenarios for their projects to the link above (debrascott, 16:20:55)
    20. which projects have not deployed on Pharos yet? which can use Jenkins now to deploy? (debrascott, 16:23:03)
    21. OVSNFV can deploy on Pharos. However there are some issues. We aren't using Jenkins yet. (mdgray, 16:24:08)
    22. ACTION: on test scenario page add a status for each project on deploying with Pharos in which scenarios (debrascott, 16:24:31)
    23. need visibility on status of test case coding (debrascott, 16:25:16)
    24. many of the test cases in the repo are skeleton frameworks without details, especially difficult for those that are not in Jenkins (debrascott, 16:26:25)
    25. looks like we should be targetting Jenkins integration for projects by Milestone D (c+release) for tracking leading up to code freeze. (ChrisPriceAB, 16:28:34)
    26. projects need to create put scripts into a CI folder in Jenkins job (debrascott, 16:28:47)
    27. https://build.opnfv.org/ci/view/Brahmaputra%20CI/ (fdegir, 16:29:06)
    28. In order for projects to run specific Jenkins jobs for the project, they must create what script they want to execute via Jenkins in their repo under ci folder (fdegir, 16:33:55)
    29. Iben Rodriguez (ibenrodriguez, 16:35:00)
    30. Jack Morgan at Intel is contact for jump host issues, time for having the labs up and running is unknown at this time. Was supposed to be ready last week (debrascott, 16:36:53)
    31. One the projects create scripts in <project_repo_root>/ci folder, corresponding jenkins jobs will be created or updated if already exist (fdegir, 16:38:05)
    32. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-December/006893.html (fdegir, 16:39:48)
    33. https://git.opnfv.org/cgit/?s=idle (frankbrockners, 16:40:02)
    34. ACTION: why is everything idle on projects repo for 2 weeks? Are they working in private repo or doing other work? Debra to check on status (debrascott, 16:42:21)
    35. The status for installers on CI (fdegir, 16:45:55)
    36. Apex virtual deploys work fine on Jenkins, bare metal work is ongoing (fdegir, 16:46:16)
    37. Compass bare metal deploys work on Jenkins and some functest execution done manually against it (fdegir, 16:46:49)
    38. Fuel bare metal and virtual deploys work on Jenkins, functest and yardstick work (fdegir, 16:47:04)
    39. Joid bare metal work on Jenkins but due to lack of jumphost on Intel POD5, only 3 controllers and 1 compute deployed, functest runs as well but fails (fdegir, 16:47:50)
    40. https://build.opnfv.org/ci/view/Brahmaputra%20CI/job/fuel-nosdn-opnfv-jump-2-daily-master/ (fdegir, 16:48:15)
    41. https://build.opnfv.org/ci/view/Brahmaputra%20CI/job/joid-odl-intel-pod5-daily-master/ (fdegir, 16:48:25)
    42. https://build.opnfv.org/ci/view/Brahmaputra%20CI/job/apex-daily-master/ (fdegir, 16:48:42)
    43. https://build.opnfv.org/ci/view/Brahmaputra%20CI/job/compass-daily-master/ (fdegir, 16:48:52)
    44. Frank reiterates that projects will not be excluded simply because they “miss” having something finished in the milestone E report. Milestone E is primarily reporting. We are trying to include everyone as best we can in the release. Milestone E gives us a chance to see where there are gaps and to know what must be documented. Exlusion from the release would be based on having critical issues such as can’t build (debrascott, 16:52:10)

  1. Documentation (debrascott, 16:52:48)
    1. focusing on central docs right now (debrascott, 16:53:05)
    2. patches are being pushed for templates now (debrascott, 16:53:24)
    3. documentaition processes are updated on the wiki (debrascott, 16:53:42)
    4. https://wiki.opnfv.org/documentation documentation overview (ChrisPriceAB, 16:53:59)
    5. https://wiki.opnfv.org/documentation/configguide configuration guide instructions (ChrisPriceAB, 16:54:20)
    6. need to finalize the scenarioäs in order to close the document structures fully. (ChrisPriceAB, 16:56:25)
    7. ACTION: IRC standup reporting to begin after Milestone E (debrascott, 17:02:37)


Meeting ended at 17:04:10 UTC (full logs).

Action items

  1. : resend communication to all project leads to add scenarios for their projects to the link above
  2. on test scenario page add a status for each project on deploying with Pharos in which scenarios
  3. why is everything idle on projects repo for 2 weeks? Are they working in private repo or doing other work? Debra to check on status
  4. IRC standup reporting to begin after Milestone E


People present (lines said)

  1. fdegir (35)
  2. ashyoung (30)
  3. debrascott (27)
  4. ChrisPriceAB (6)
  5. mdgray (5)
  6. ibenrodriguez (5)
  7. frankbrockners (4)
  8. anac1_ (4)
  9. collabot` (3)
  10. uli-k_ (1)
  11. ljlamers (1)
  12. StuartMackie (1)
  13. billyoma (1)


Generated by MeetBot 0.1.4.