08:08:06 <joehuang> #startmeeting multisite
08:08:06 <collabot> Meeting started Thu Jan 21 08:08:06 2016 UTC.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:08:06 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:08:06 <collabot> The meeting name has been set to 'multisite'
08:08:19 <joehuang> #topic rollcall
08:08:21 <SAshish> #info Ashish
08:08:26 <joehuang> #info joehuang
08:08:29 <sorantis> #info dimitri
08:08:31 <zhiyuan> #info zhiyuan
08:08:47 <joehuang> Zhipeng, you have a good message for multisite
08:08:55 <joehuang> could you share with us
08:09:09 <zhipeng> yes, dear multisiters
08:09:26 <zhipeng> Openstack foundation just published its very first NFV report today
08:09:47 <zhipeng> and in it, Multisite is one of the two projects that is mentioned
08:09:54 <zhipeng> in a dedicated section
08:10:04 <sorantis> fantastic!
08:10:04 <zhipeng> our work have been detailed described
08:10:21 <SAshish> Awesome guys. Congrats al
08:10:22 <zhipeng> the editor actually talked to me during last year's opnfv summit
08:10:23 <SAshish> all
08:10:29 <joehuang> yes, our work has be recognized in the whitepaper
08:10:34 <zhipeng> i guess the talk pay up quite nicely :P
08:10:37 <joehuang> #link http://www.openstack.org/assets/telecoms-and-nfv/OpenStack-Foundation-NFV-Report.pdf
08:10:57 <joehuang> I also found the link in OpenStack.org homepage
08:11:11 <sorantis> this is great recognition of our work!
08:11:34 <zhipeng> yep !
08:11:41 <joehuang> page13, a dedicated chapter!
08:11:47 <zhipeng> and I will definitely make that f**ing Tshirt this year
08:11:47 <joehuang> yes
08:11:50 <zhipeng> for you guys
08:12:02 <zhipeng> no, for us
08:12:03 <zhipeng> :P
08:12:07 <sorantis> :)
08:12:24 <joehuang> yes, it's great value to do multisite work
08:12:30 <sorantis> that’s a great way to start a day
08:13:01 <joehuang> and mention global and per-site quota management
08:13:02 <zhipeng> yes , and we sure have more for them in C and D release
08:13:03 <SAshish> :)
08:13:39 <joehuang> shall we collect in OPNFV for other multisite use cases?
08:14:02 <zhipeng> I think usecase 4 and 5 should be a mouthful for us in C and D
08:14:02 <joehuang> after one release, may other teams will raise some requirement on multisite
08:14:17 <zhipeng> but we should welcome thoughts if anyone got any
08:14:21 <sorantis> that’as right
08:14:32 <zhipeng> but implentation wise I don't think we have the volume for C and D
08:14:36 <joehuang> yes, we need to listen others'
08:14:43 <joehuang> agree
08:15:05 <joehuang> if we have more requirements, may more people join
08:15:20 <joehuang> but for us, limited volume left
08:15:27 <zhipeng> yes indeed
08:16:59 <sorantis> action: have be beer :)
08:17:07 <SAshish> hahahah
08:17:12 <joehuang> haha
08:17:13 <zhipeng> no
08:17:19 <zhipeng> #action have beer
08:17:23 <joehuang> I'll send a mail for inquiry to other teams, but at the same time we mainly focus on current use cases
08:17:34 <sorantis> +1
08:17:53 <zhipeng> yes i heard HA team might still have some thoughts on Multisite, let's see what idea could we have
08:18:06 <joehuang> #action send a mail for inquiry to other teams for multisite requirements,  but at the same time we mainly focus on current use cases
08:19:32 <joehuang> let's a short talk on the kingbird design
08:19:41 <joehuang> #topic kingbird design
08:19:42 <SAshish> sure.
08:20:00 <joehuang> We have JobDaemon and Jobworker
08:20:24 <joehuang> Can we only have JobWorker or previous Dimitri's engine
08:20:46 <sorantis> any particular reason for it?
08:21:06 <joehuang> that means one process to send out 20 request to 20 regions to query the quota
08:21:17 <joehuang> using eventlets
08:21:31 <SAshish> with threads
08:21:54 <joehuang> or jobdaemon send to multiple jobworker, and each job workers send several requests to regarding regions?
08:22:13 <sorantis> I actually welcome this idea, as it will simplify our design
08:22:34 <SAshish> currently, during my implementation I felt, we have jobdeamon unnecesarry.
08:22:44 <joehuang> which one will have better experience
08:22:45 <SAshish> I have a quotamanager controller
08:23:18 <SAshish> then It can spawn jobworkers for each region
08:23:33 <SAshish> rpc call from jobdeamon and its manager can be removed
08:24:05 <joehuang> where the quotamaneger controller locates, API or jobworker?
08:24:14 <SAshish> API
08:24:37 <SAshish> then it spwans jobworkers
08:24:55 <SAshish> if there is any DB call, it directly access DB without JW
08:25:05 <SAshish> calls related to only DB
08:25:05 <joehuang> jobworkers also in API?
08:25:09 <SAshish> no
08:25:28 <SAshish> only QM will be in API as controllers.
08:25:42 <SAshish> then QM will make a rpc call to JW
08:25:49 <joehuang> so QM will send one msg or multiple msg to JW
08:26:32 <SAshish> yes.. depending on how many regions it has to query. but for that also we need to use eventlet
08:27:03 <SAshish> if cast then no issues, but for call we have to do parallel calls to JWs
08:27:14 <sorantis> what happens what we have multiple controllers?
08:27:34 <sorantis> say one for QM, one for some other sync activity?
08:27:37 <SAshish> each controller is for each usecase.
08:27:41 <joehuang> how about one call to JW, and JW will send multiple requests in parallel
08:28:14 <SAshish> QM => one controller, multisite image replication = another controller
08:28:18 <SAshish> like this
08:28:24 <joehuang> it's stateless restful API, each one is no related to another one "what happens what we have multiple controllers?"
08:28:43 <SAshish> network management => another controller
08:28:58 <SAshish> yes. one will not have effect on others
08:29:04 <joehuang> agree, it's different restful resource, and different controller
08:29:06 <SAshish> Am I making sense?
08:29:22 <SAshish> controllers => solve each usecase
08:29:44 <joehuang> only wonder to know QM will send one message for all regions or per region base
08:29:46 <SAshish> usecases = QM, image replication, network management
08:29:46 <sorantis> got it. I was more thinking that since we can also run in autonomous mode, then controllers will be invoked no via API, but on a scheduled timer
08:30:03 <SAshish> controllers are MVC controllers
08:30:19 <sorantis> oh, ok
08:30:40 <SAshish> it has to be multiple messages to mulitple regions
08:30:45 <SAshish> parallely
08:31:11 <joehuang> or directly send multiple quota rest request directly from API?
08:31:49 <SAshish> from API to JW?
08:32:06 <joehuang> from API directly to other regions
08:32:39 <SAshish> I dnt support, we have to break the design
08:32:46 <SAshish> then It will be only APIs
08:33:44 <joehuang> but from your ideas, API QM has to wait and collect and calculate results from other regions
08:34:43 <joehuang> if send one call rpc to JW, and JW to spawn multiple request eventlet to other regions, then the collection and report will be done in JW single location
08:34:45 <SAshish> quota syncing will be a cast
08:35:40 <joehuang> CAST is async. operation
08:35:43 <SAshish> remaning QM API calls are there. Update/delete/list can be rpc call
08:36:09 <SAshish> then in this case there will be only one JW.
08:37:12 <joehuang> make sense
08:37:25 <SAshish> which one?
08:37:31 <joehuang> the last one
08:38:21 <SAshish> can we have eventlet in controller each spawning JW threads for each region.
08:38:50 <SAshish> so there will be 'n' JWs for 'n' regions
08:39:35 <joehuang> yes, this is my concerns on the comparation of these two ways
08:40:17 <joehuang> " eventlet in controller each spawning JW threads for each region" then we have to put the quota collection function in API
08:40:20 <sorantis> guys, unfortunately I have to leave the meeting now
08:40:32 <joehuang> ok, see you next time
08:40:42 <SAshish> sure.. bye
08:40:42 <joehuang> thanks Dimitri
08:40:45 <sorantis> thanks for the great news!
08:40:56 <joehuang> Have a cup of beer
08:41:00 <sorantis> Multisite is awesome :)
08:41:03 <zhipeng> talk to you later sorantis
08:41:09 <SAshish> barrel of beer
08:41:22 <sorantis> ocean :)
08:41:24 <zhipeng> multi site of barrels of beer
08:41:31 <SAshish> lol
08:41:37 <SAshish> multiregion beer bashes
08:41:40 <sorantis> you all want my death, huh? :)
08:41:49 <joehuang> hahahs
08:41:52 <SAshish> hahahah
08:42:03 <sorantis> cheers guys! talk soon!
08:42:03 <SAshish> have multiple JWs with you
08:42:06 <SAshish> I will become one
08:42:08 <SAshish> JW for u
08:42:19 <joehuang> So Ashish, could you  have a short summary of different idea and comparation, so we can have more discussion and thinking in next meeting?
08:42:31 <joehuang> cheer
08:42:33 <SAshish> sure.. Joe
08:43:00 <joehuang> #action  summary of different idea and comparation of quota management implementation
08:43:07 <zhipeng> another thing is that we need to arrange for Multisite C release earlier
08:43:29 <joehuang> yes, next time.... Have beer first
08:43:41 <SAshish> hahah...
08:43:48 <zhipeng> haha okey i 'll stop typing
08:43:50 <joehuang> ok. thanks attending for today's meeting
08:43:56 <joehuang> see you next time
08:43:58 <SAshish> thanks guys :)
08:44:03 <zhipeng> see ya
08:44:07 <joehuang> #endmeeing
08:44:12 <SAshish> sure.. Take care. bye
08:44:19 <joehuang> #endmeeting